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1 RT-Druid and Erika Enterprise tutorial for dsPIC
(R) DSC

This small tutorial describes a set of steps needed to compile a simple application that
shows the main features of Erika Enterprise and RT-Druid for the dsPIC (R) DSC platform.

This tutorial has been tested on a FLEX board produced by Evidence and Embedded
Solutions and on a Microchip Explorer 16 development board from Microchip.

We suppose the reader is familiar with the MPLAB IDE debug environment provided
by Microchip.
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2 Installing Erika Enterprise and RT-Druid on

Microsoft Windows

This chapter will guide the developer to the installation procedure of Erika Enterprise
and RT-Druid for the dsPIC (R) DSC platform.

Warning: The Cygwin install pathname, the Erika Enterprise Basic install path-
name, and the pathname of RT-Druid workspaces where the user projects reside,
MUST NOT contain any blank space, otherwise Erika Enterprise Basic may not work
properly.

E.g., C:\MyApplications\Evidence\ and C:\MyApplications\Cygwin\ are accept-
able, while C:\My Applications\Evidence\ or C:\My Applications\Cygwin\ MUST
be avoided.

This is a known issue that will soon be fixed.

The installation of Erika Enterprise and RT-Druid is composed by the following pack-
ages:

• The Eclipse development environment, which is used by RT-Druid to provide the
basic development environment for Erika Enterprise applications.

• The Eclipse environment is based on the Java platform, so that a working Java
Runtime Environment must be present for using RT-Druid.

• The RT-Druid plugins, which provide the code generation for Erika Enterprise and
Erika Enterprise Basic for Eclipse.

• The Erika Enterprise or Erika Enterprise Basic source code.

• The Microchip MPLAB IDE.

• The Microchip C30 Compiler.

• A version of the Microchip C30 compiler recompiled from the GCC sources, which
enables basic C language compilation without the need to buy the full fledged
Microchip C30 Compiler.

• A set of examples for the dsPIC (R) DSC Platform, which can be used to compile
a first set of running examples for the Evidence/Embedded Solutions FLEX board,
the Microchip Explorer 16 board, and others. These applications are organized in
“templates”, available at project creation.
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2 Installing Erika Enterprise and RT-Druid on Microsoft Windows

• A subset of the Cygwin environment [1], including a set of utilities like make, gawk,
and few others, which are used during the compilation process of an Erika Enterprise
application.

To install the software, execute the following steps:

1. Install your favourite Java runtime environment, which is needed to run RT-Druid;
in fact, RT-Druid is a plugin of the Eclipse editor, which requires Java to be
executed.

2. Install the latest version of the Microchip MPLAB IDE; you can use the default
install directory. At the end of the install process, accept the system reboot.

3. Install the Microchip C30 Compiler, available from the Microchip web site. Even
in this case, you can use the default install directory. When it is asked to change
the default environment, please do accept.

4. Run the Erika Enterprise and RT-Druid installer.

5. The installer will prompt a list of packages which can be installed. Select all the
packages you wish to install and continue the installation procedure (see Figure
2.1).

Figure 2.1: This screenshot shows the dialog box with the available install packages.

Note: The Erika Enterprise install package provides a version of the Microchip C30
compiler recompiled from the GCC sources made available from Microchip. Although
that compiler is able to compile Erika Enterprise applications, it does not include
Microchip include files and libraries which are only distributed with the Microchip
package.
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2 Installing Erika Enterprise and RT-Druid on Microsoft Windows

6. At this point, please check the first line of the file evidencedir\bin\mymake_cygwin.bat
(where evidencedir is the directory you chose during the installation). For exam-
ple, if Cygwin is installed inside C:\cygwin, then the first line of the file should
look like the following one:

@set EE_BASH_PATH=C:\ cygwin\bin\bash

...that is, the line contains the correct path to the bash.exe file in your Cygwin
installation. If you accepted the default settings, the correct pathname should be
C:\cygwin\bin\bash as specified in the example before.

Note: We ask to perform this check because it seems that on some Windows ma-
chines the Cygwin installer does not correctly set the registry keys used by the Erika
Enterprise installer.

The rest of this tutorial supposes that the Microchip MPLAB IDE is installed within
the C:\Programmi\Microchip directory and that, consequently, the GNU Assembler for
dsPIC (R) DSC is installed within C:\Programmi\Microchip\MPLAB ASM30\ Suite\bin.
Please note that these values may be different from the settings you have chosen on your
machine.
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3 First RT-Druid startup and configuration

After all the required packages have been installed, you are ready to start RT-Druid for
the first time.

Please follow the next steps:

1. As the first step, run the Eclipse IDE from the Evidence menu inside the Start
menu of your Windows machine, choosing Start/Programs/Evidence/RT-Druid.

2. A dialog box will appear, asking to choose the right workspace (see Figure 3.1).
Leave the default workpackage directory as it is, and proceed by pressing “OK”.

Figure 3.1: This screenshot shows the dialog box for the choice of the current workspace
directory.

Warning: The workspace pathname MUST NOT contain any blank space, other-
wise Erika Enterprise Basic and RT-Druid may not work properly.

3. The Eclipse Welcome screen appears, like in Figure 3.2.

4. Before being able to correctly build your application, you should set the path to
the Microchip C30 compiler and the MPLAB ASM30 assembler programs. For
doing so, please go to the “Preference” menu, as shown in Figure 3.3, and find
the “RT-Druid/Oil/PIC30 Configurator” form as depicted in Figure 3.4. The first
textbox, labeled Gcc path, refers to the installation directory of the Microchip C30
compiler. The second textbox, labeled Asm path, refers to the installation directory
of the ASM30 assembler provided with the MPLAB IDE.
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3 First RT-Druid startup and configuration

Figure 3.2: The Eclipse Welcome screen.

Warning: The install directories specified in the two textboxes of Figure 3.4 does
not include the bin directory!

That is, c:\Programmi\Microchip\MPLAB C30 is correct, wheras
c:\Programmi\Microchip\MPLAB C30\bin is not.

Warning: The install directory of the assembler refers to the assembler provided
with MPLAB IDE and not the assembler provided with the C30 compiler. The reason
is that the directory is used to call the assembler and also to copy the crt0.s file,
which has a different position in the two assemblers distributions made by Microchip.

5. Before creating and building your application, please deselect the “Build Auto-
matically” flag inside the “Project” menu, as shown in Figure 3.5.
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3 First RT-Druid startup and configuration

Figure 3.3: Go to the “Preference” menu.

Figure 3.4: Select paths for compiler and assembler.

Figure 3.5: Deselect the “Build Automatically” flag in the “Project” menu.
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4 Compiling your first Erika Enterprise demo for

dsPIC (R) DSC

You are now ready to compile your first Erika Enterprise demo. Please execute the
following steps:

1. Please select “New Project”, then “RT-Druid Oil and c/c++ Project” from the
“File menu”, as in Figure 4.1.

Figure 4.1: Select “New project” from the “File” menu.

2. A Dialog box appear. Please select a template for the new project, as in Figure
4.2.

3. Press “Next”.

4. Insert the name of the new project. Please type myProject (you can choose other
names of course). Please see Figure 4.3. Press the “Finish” button.

5. We are now ready to build the demo. Right click on the project name in the
Eclipse navigation bar, and choose “Build Project”1 (see Figure 4.4).

1“Build Project” only appears if the “Build Automatically” flag is not selected in the “Project” menu.
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4 Compiling your first Erika Enterprise demo for dsPIC (R) DSC

Figure 4.2: Select “RT-Druid Oil and c/c++ Project”.

Figure 4.3: Type a name for the new project.

6. Then, the compilation process starts as depicted in Figure 4.5.

Note: If the error depicted in Figure 4.6 appears (meaning that mymake_cygwin.bat
is unable to find a file), then please follow the instructions at the last point of Chapter
2.

7. At the end of the compiling process you will be able to find a file named ‘pic30.elf
inside the Debug directory inside the project, as shown in Figure 4.7.

8. You are now ready to import the produced ELF file inside Microchip MPLAB
IDE. To do that, open MPLAB IDE as in Figure 4.8.

9. Choose “Import...” from the “File” menu, as in Figure 4.9.
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4 Compiling your first Erika Enterprise demo for dsPIC (R) DSC

Figure 4.4: We are now able to build the project.

10. A dialog box appear. Please select the pic30.elf file that has been produced by the
compilation process in Eclipse, as shown in Figure 4.10. You can find that file inside
the Eclipse workspace you selected at the beginning in Figure 3.1. In this example,
the file is stored inside the directory c:\Programmi\Evidence\eclipse\workspace\

pic30_oo_mono\Debug.

11. You have now imported the ELF file inside MPLAB IDE. There is no need to
create a MPLAB IDE Project, because the compilation process is handled by
Eclipse. Figure 4.11 shows the “Disassembly Listing” and the “Program Memory”
window. Please note that MPLAB IDE correctly recognizes the debug symbols of
the source code produced inside Eclipse.

12. You can now start debugging the demo application using MPLAB IDE.

Figure 4.12 shows the Explorer 16 board with the running pic30\explorer16\Devices Demo

demo application, which uses the Explorer 16 onboard devices to monitor and display
the environment temeperature.
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4 Compiling your first Erika Enterprise demo for dsPIC (R) DSC

Figure 4.5: The compilation process.

Figure 4.6: An error that shows up on some Windows machines. Please check the
mymake_cygwin.bat file as explained in the last point of Chapter 2.
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4 Compiling your first Erika Enterprise demo for dsPIC (R) DSC

Figure 4.7: The output file is ready to be programmed on the target board.

Figure 4.8: The Microchip MPLAB IDE.
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4 Compiling your first Erika Enterprise demo for dsPIC (R) DSC

Figure 4.9: Choose “Import...” from the “File” menu to import the elf file produced in
Eclipse.

Figure 4.10: Select the ELF file you want to import.
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4 Compiling your first Erika Enterprise demo for dsPIC (R) DSC

Figure 4.11: Debug symbols are correctly recognized.

Figure 4.12: The Explorer 16 board with the running demo program.
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5 History

Version Comment

1.0.0 Initial revision.
1.1.0 Updated with information and screenshots about

Erika Enterprise version 1.4.
1.1.3 Updated with new screenshots about configuration;

added warnings about blanks in pathnames.
1.1.4 Added some changes to the install instructions from

comments by Simone Mannori.
1.1.5 Added Cygwin error workaround when the installer

can not find the cygwin registry value.
1.1.6 Typos found when translating the document in ital-

ian.
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