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Preface 

This preface introduces the Embest Integrated Development Environment (Embe
stIDE) and its documentation. It contains the following sections: 

• About this book 

• Related Publications 

• Typographical convention 

• Feedback 

About this book 

This book is user manual for Embest IDE for ARM. It describes the major featur
es of EmbestIDE, installing Embest IDE for ARM, graphical user interface component
s of EmbestIDE, and provides information on debugging applications with EmbestID
E. 

This book is organized into the following chapters: 

Chapter 1 Overview 

 Read this chapter for an introduction to EmbestIDE. 

Chapter 2 Installing Embest IDE for ARM 

 Details for installing EmbestIDE, registering, files and folder structur
es of EmbestIDE. 

Chapter 3 Project examples 

 Give some examples to lead users to start with EmbestIDE quickly 

Chapter 4 Editor 

 Read this chapter for details about how to use EmbestIDE built-in te
xt editor. It describes the basic functionality of the editor.  

Chapter 5 Project management 

 Read this chapter for details about how to use project files to organi
ze your project source files. 

Chapter 6 Project build 

 Details about specify the output from compiling and linking your sou
rce. This chapter gives details about how to configure compile option
s and link options of a project.  

Chapter 7 Software debug 

 Introduce the debugger of EmbestIDE, details about how to debug a
rm-based application with EmbestIDE. 



Chapter 8 Customization and Options 

 Read this chapter for details about customizes EmbestIDE. 

Appendix A JTAG Emulator Hardware Reference 

Appendix B Debug Output Reference 

Appendix C Debug Command List 

Appendix D Memory Map File 

Appendix E Command Script Reference 

Appendix F Additional Software Tools of Embest IDE 

Appendix G Common questions 

  

Further Reading 

This book describes all the details about Embest IDE. Refer to the following boo
ks for information on other components of developing embedded application base o
n ARM processors: 

 ARM Architectural Reference Manual (ARM DUI 0100) 

 ARM Reference Peripheral Specification (ARM DDI 0062) 

 ARM Target Development System User Guide (ARM DUI 0061) 

     — you can get these papers from: www.arm.com 

 Program reference of Embest IDE  

Typographical Convention 

The following typographical convention are used in this book: 

Menu quote Use > to separate the main menu and submenu 

Commands Highlights important notes 

Notes Italic denotative arguments with lines above and below 

Notes: this is an important note, and please pay attention to it. 
 

 

Feed Back on This Book 

If you have any problems with this book, please send email to press@embedinf
o.com giving: 

 the document title 



 the page number(s) to which your comments apply 

 a concise explanation of the problem. 

General suggestions for additions and improvements are also welcome.  



I. Overview 

This chapter introduces the Embest IDE. It contains the following sections: 

 About the Embest IDE 

 main characteristic of Embest IDE 

 User Interface Basics 

1.1 About Embest IDE 

Embest IDE is an Integrated Development Environment for software cross-devel
opment. The EmbestIDE is an application that provides a simple and versatile graph
ical user interface and tools for developing embedded software. It is an Integrated 
Development Environment (IDE) that facilitates managing and building projects, est
ablishing and managing host-target communication, running and debugging applicati
ons. It provides an efficient way for developing embedded applications. EmbestIDE 
comprises the following elements (Figure 1-1): 

 An integrated source-code editor. 

 A project management facility. 

 Integrated C and ASM compilers and linker. 

 a source-level debugger. 

 an integrated development environment. 

 an ARM simulator 

 

Figure 1-1: EmbestIDE Tools 

EmbestIDE uses host-target cross model for developing embedded applications. E
mbestIDE runs on a host computer. Your target board is connected to the host com
puter through debug device (BDM/JTAG Emulator). You can edit and build your proj
ects on the host, and create a target executable file with EmbestIDE. Download the
 target file to the target, and then use EmbestIDE debugger to debug it through the



 communication of debug device connected between the host computer and the targ
et board. Figure1-2 illustrates the host-target cross model with EmbestIDE. 

When you use Embest IDE for ARM, a debug device—Embest JTAG Emulator is p
rovided. See Appendix A “JTAG Emulator Connection” for detail describe about Emb
est JTAG emulators. 

 

Figure 1-2 the Host-target Cross Model with Embest IDE  

1.2 Major Features of Embest IDE 

EmbestIDE runs under Windows 95 above and Windows NT 4.0 above. EmbestI
DE supports target microprocessors debugging on the ARM-core microprocessor fam
ilies, 68K, PowerPC, and Coldfire microprocessor families.  EmbestIDE provides a si
mple, versatile and graphical user interface for managing your software developmen
t projects. You can use Embest IDE for ARM to develop C and ARM assembly langua
ge code targeted at ARM and Thumb processors. It speeds up your development cy
cle by providing: 

 Comprehensive project management capabilities 

 Code navigation routines to help you locate routines quickly. 

EmbestIDE enables you to organize source code files, library files, other files, a
nd configuration settings into a project. Each project enables you to create and man
age multiple configurations of build target settings.  

Major features of EmbestIDE: 

 Support development language: ANSI C, ARM assembly language. 

 User interface: consists of an integrated set of windows, tools, menus, toolbars,
 directories, and other elements that allow you to create, test, and refine your a
pplication. It is just like Microsoft Visual Studio’s user interface.  

 Source code Editor: Standard text manipulation capabilities; C and ASM syntax
-element color highlight; Debugger integration, the editor window tracks code ex



ecution; Compiler integration, the project management utility links compiler war
nings and errors directly to the affected source in the editor window. Support fil
e print; Capable of search and replace, and performs batch searches in multiple 
files. 

 Project Management: The EmbestIDE project facility simplifies organizing, conf
iguring, and building embedded applications. It includes graphical configuration o
f the build environment (including compiler flags).  

 Compiler: includes the GNU compiler, as well as a collection of supporting tools 
that provide a complete development tool chain: cpp, C preprocessor; gcc, C co
mpiler; make, program building automation tool; ld, programmable static linker;
 as, portable assembler; binary utilities. EmbestIDE supports commercial version
s of the leading-edge GNU tools originally developed by the Free Software Found
ation (FSF). Users of the GNU tools benefit from the innovative FSF development
 environment as well as from testing and support by Embest Info&Tech Co., LTD.
 Among other features, the EmbestIDE project facility provides a GUI for the GN
U tools that is powerful and easy to use. 

 EmbestIDE debugger: a powerful graphical debugger that enables program loa
ding, executing, running control, and monitoring; a source-level debugger, view 
your application code as C, as assembly-level code, or in a mixed mode that sho
ws both; full-featured debugging, provides an exhaustive set of debugging featur
es, designed to make it easy to find and fix bugs; set a breakpoint or clear a br
eakpoint by single click, supports conditional and command breakpoints; single s
tepping, "step into" traces execution of every individual instruction even when fu
nctions are called, "step over" does not trace into the called function, "step out "
 brings execution back to the calling function; supports register and variables val
ue display and modify, supports function stack display and memory display, seve
ral specialized windows display these debugging information. Figure 7-1 shows t
hese debugging information display windows, when you are debugging, you can 
access these windows using the "View" menu; EmbestIDE supports graphical deb
ug and command-line debug. For complex or unpredictable debugging needs, the
 command-line interface gives you full access to a wealth of specialized debuggi
ng commands.  

1.3 User Interface of EmbestIDE 

The user interface is the portion of the environment where display information a
nd specify action. These topics describe user interface’s basic structure of EmbestID
E. 

To step into EmbestIDE, just run EmbestiDE.exe. EmbestIDE user interface cons
ists of an integrated set of windows, tools, menus, toolbars, directories, and other e
lements that allow you to create, test, and refine your application. Figure 1-3 shows
 the main GUI of EmbestIDE. The user interface uses standard Windows interface fu
nctionality along with a few additional features to make your development environm



ent easy to use. The basic features that you use most often are windows and docu
ment views, toolbars, menus, directories, and keyboard shortcuts. 

 

Figure 1-3  Embest IDE Main GUI 

Title column displays current opening file name. Menus column and tool bar colu
mn are below title column. The menu bar is a special toolbar at the top of the scre
en that contains menus such as File, Edit, and Build. The standard tool bar appears 
just below the menu bar. You can move the toolbars to different locations to suit yo
ur needs. Workspace window shows file information about current opening projects.
 Source code window is the usual used window witch you edit and browse your cod
e in. You can open several source code file windows at one time. Output window dis
plays build information, debug information, file search output information and comm
and-line debug input and output. Status column displays detail information about m
enus and tool bars, it also displays the current line number and column number of t
he cursor in source code window.  

  



II. Installation 

2.1 System Requirement 

Host: A PC with a Pentium or higher processor 

Memory: More than 64M 

Disk Space: 150M 

Monitor: VGA or Super VGA color monitor  

Operation System: Microsoft Windows 98, Windows NT with Service Pack 3 or later, 

Windows 2000, Windows Me, Windows XP 

Others: Mouse, Parallel Port, CD-ROM 

 

2.2 Install and remove Embest IDE  

2.2.1 Install main programs 

Step1: It is strongly recommended that you exit all programs under Win32;  

Step2: Place Embest IDE setup CD in CD-Rom, run the setup program (if operating 
system allows CD-Rom to run it automatically, a setup interface will popup when CD-Rom 
reads disc), user can also install setup program by running Setup.exe from CD; 

 

Figure 2-1 Welcome dialog box 

Step3: click Next button in Welcome dialog box;  



 

Figure 2-2 License dialog box of setup program. 

Step4: License dialog box lists the agreement of Embest IDE system user, click Yes 
to agree the agreement, the system goes to the next step; 

 

Figure 2-3 Input Register User dialog box 

Step5: Enter user information in the dialog box, click next to continue; 



 

Figure 2-4 Destination Location dialog box 

Step6: Select the destination folder of Embest IDE system in Destination Dialog Box, 
the default folder is C:\EmbestIDE, if user selects the default folder, click Next to 
continue; if users needs select another folder, click Browse button, a Choose 
FolderDialog Box will pop up, user can select another folder to install Embest IDE. 

 

Figure 2-5 Choose Folder Dialog Box 

 

Notices: To ensure normal operation of cross the installation path of Embest 
IDE should not contain space so as to ensure normal operation of cross 
compiler; this caution also apply to the undermentioned name of folders and 
source file. 

 



Step7:  Enter the name of program group in Program FolderDialog Box, choose Next 
to continue;  

 

Figure 2-6 Information Dialog Box 

Step8: Information Dialog Box contains current setup information and system 
information, if you are satisfied with the settings, click Next to begin copying files;  

 

Figure 2-7 Copying files of setup program 

Step9: when the copying is finished, the system indicates users to restart the 
computer, user must restart the computer after the setup is finished, and obtain legal 
License file, then Embest IDE can run normally.  



 

Figure 2-8 Setup finished  

2.2.2 Remove Embest IDE 

Embest IDE can be removed by running setup program (it is highly recommended), 
or  by clicking “Add/Delete Program” button under “Control Panel”. 

 

 (a) Remove Embest IDE by running setup program (recommended) 



 

 (b) Remove Embest IDE using “Add/Delete Program”  

Figure 2-9 Development environment of Removing Embest IDE 

Notices: if user modifies installation folder or files, or adds new folders or files 
during using Embest IDE, they will not be removed together with the 
program. 

 

2.2.3 Setup of compiler tool  

Embest IDE development environment can use GNU GCC compiler toolchain of 
different versions, toolchain of different versions can be installed in Build folder under 
Embest IDE installation folder. 

User can choose setup link of cross compiler in the setup wizard of Embest IDE 
software, or directly run setup wizard of compiler toolkit in the CD. Compiler toolchain of 
all versions provide a setup file like xgcc-arm-elf-xxx.exe (xxx is version No.) 

When setup wizard of compiler toolkit is run, the welcome interface below will popup. 



 

Figure 2-10 welcome interface of setup wizard of compiler toolkit.  

Click Next, select the install directory of compiler toolkit, the setup program will 
create the folder Build\xgcc-arm-elf-xxx under the install directory. 

 

Figure 2-11 Select install directory for compiler toolkit.  

Then click Next, setup program will copy compiler toolkit, STL (Standard Template 
Library) and GCC support library to designated folder. 



 

Figure 2-12 Copy program files to install directory 

2.2.2 Remove compiler toolkit 

User can use “Add/Delete Program” under control panel to remove the installed 
toolkit (recommended), or remove it by directly deleting the install folder. 

 

Figure 2-13 remove compiler toolkit using “Add/Delete Program”. 

Notices: if user modifies the name or content of installation folder or files, or 
adds name or contents of new folders or files, they will not be removed 
together with the program. 

 



2.3 Directories & Files 

 

2.3.1 Directories & Files 

The files of Embest IDE release are copied to a directory and its subfolders, wh
en the installation steps finished. For example, if the destination location is C:\Emb
estIDE, several sub-directories will be created on it, and the files will be copied acc
ording their functions (show as Table 2-3-1-1). 

Table 2-3-1-1 

Folder/File Description 

Bin Folder with main application, DLL files and DLL folders 

Build Folder created when GNU GCC Cross-Compiler for ARM installed. Recommend 

installation any version of GNU GCC Cross-Compiler and library here. Every 

subdirectory includes one type of GCC tools. For example, 

C:\EmbestIDE\Build\xgcc-arm-elf-3.0.2 is the GCC Cross Compiler for ARM v3.0.2, 

include the Compiler/Assembler/Linker, and new-libc library in it. 

Doc Folder with documents 

Examples Folder with samples 

ide.ini Configuration files of Embest IDE, it shows the folder of the modules and other 

settings in running. 

Licenses Folder with license files 

Peripheral The information library of the peripheral registers of the processors set by the system 

Target Folder with BSP files 

License.txt License file 

Readme.Txt Readme file 

Tools Folder with the tools in system application include Flash Programmer, elf2bin etc. 

Description of directory C:\EmbestIDE\Bin show at Table 2-3-1-2. 

Table 2-3-1-2 

Folder/File   Description 

Build Folder with cross-compiler interface files 



CPU Folder with CPU interface files 

Device Folder with device interface files 

File Folder with file modules 

Description of directory C:\EmbestIDE\Examples Table 2-3-1-3 

Table 2-3-1-3 

Folder/File    Description 

ARM Command examples for ARM include particular assemble examples  

SDT&ADS ADS 1.2 and SDT 2.51 Projects, can open and debug under Embest IDE 

 

2.3.2 File Types 

Table 2-3-2-1 

Name Description 

*.ews Workspace file of EmbestIDE 

*.pjf Project file of EmbestIDE 

*.opt Workspace status file 

*.ini Config file of EmbestIDE 

*.c C source file 

*.C C++ source file 

*.cc C++ source file 

*.cp C++ source file 

*.cxx C++ source file 

*.c++ C++ source file 

*.cpp C++ source file 

*.s Assemble source file 

*.asm Assemble source file 

*.h C/C++ header file 

*.inc Assemble include file 

*.mac Macro file 

*.map Memory map file 



*.cs Command script file 

*.ld Link script file 

*.o Object file 

*.a Library file 

 

2.4 Product registration 

From Embest IDE Pro for ARM 2005, EMBEST INFO&TECH CORPORATION grants each 
Embest IDE software a 30-day full-function license (Evaluate), within these days (maximum 30 days) 
user can normally use all debug functions under Embest IDE development environment. 

If user does not register the software before expiry (maximum 30 days), the software will not be 
operable unless with official license software, when the Evaluate expiries, the register notice below 
will popup every time Embest IDE is run. 

 

2-4-1 Register notice window 

 

Notices: 

1. Users please do not attempt to modify system time of your computer, to 
prevent fault of Embest IDE during Evaluate period. 

2. During the Evaluate period, the software or hardware of Embest IDE has full 
software and hardware functions of official versions. 

 

The registration of authorized users include two steps: 1. generate registration information file; 2. 
Submit registration information file, obtain license file. 

Official license includes personal PC binding version and floating version. The license for 
personal PC binding version requires submission of a registration application file key.dat generated 
in local machine; while the license for floating version can be acquired as long as there is one 
officially licensed server in one LAN. 

 

 



2.4.1 Generate registration information file 

Every time you run EmbestIDE.exe, a dialog box will popup, user can choose 
“Evaluate” to use Embest IDE or choose “Register” to apply for official license. 

When users chooses “Register”, first a user information dialog box will popup, please 
complete your information accurately, then click “Generate Key.dat”, registration 
application file key.dat will be generated in Licenses folder under install directory of 
Embest IDE, see the register interface below: 

 

2-10 Register information dialog box 

1 User Name 
Compulsory field. Used to provide services and technical 
support. 

2 Company Name 
Compulsory field. Used to provide services and technical 
support. 

3 Phone Number 
Compulsory field. Used to contact users or notify users of 
services and upgrade 

4 Fax Number 
Compulsory field. Used to contact users or notify users of 
services and upgrade 

5 Contact E-mail 
Compulsory field. Used to contact users or notify users of 
services and upgrade 

6 Emulator Number 
Compulsory field. The necessary content for license 
generation and premise for license grant. 

7 Licenses Type 

User must first choose a PC Licenses, then he can enter the 
above data. 

When choosing Floating Licenses, he must enter Server IP 
of LAN. 

 



1. Apply for license for personal PC binding version 

Single user please choose PC License in the column License Type, then complete your 
accurate information as an end user: 

 

Figure 2-11 Use PC Licenses registration dialog box 

2. Apply for license for floating version 

For Embest IDE users, if you have registered Embest Floating Licenses Server in the 
same LAN, you can enter the legal IP address of the PC which is installed and licensed 
Embest Floating Licenses Server when you choose Floating Licenses, see the figure 
below:  

 



Figure 2-12 Use Floating Licenses registration dialog box 

Notices: 

1. Unlike PC Licenses, for Floating Licenses computer does not have to 
generate license file (but the server should first be registered in the same 
way with that of PC Licenses). 

2. Please refer to User’s Manual of Embest Floating Licenses Server for 
registration of floating version server. 

 
 

2.4.2 Acquire runtime license file 

Complete user information accurately, and submit the generated registration file key.dat 
to EMBEST INFO&TECH CORPORATION in one of the following ways: 
1. Email it to Licenses@embedinfo.com (it is strongly recommended you zip it first to 
avoid transmission error); or 
2. print it and fax it to (+86)0755-25616057; or 
3. save it in floppy disk and send it to EMBEST INFO&TECH  CORPORATION by courier. 
Then user will receive the License.dat from EMBEST INFO&TECH  CORPORATION by 
Email, fax or a floppy disk containing the file, user need copy the file to the directory 
Embest Floating Licenses Server, then the registration is finished. 

 

Notices: 

1. Please do not modify the generated key.dat file; 

2. If users applies for Licenses file by email, generally they will receive the reply 
within 24 hours; 

3.Any attempt to modify Embest IDE file or modify the content of officially granted 
License file may result in software runtime error. 

4. Unless you replace computer HD or mainboard, the officially granted can be reused 
normally, so please backup Licenses file. 

5. If user has trouble acquiring license file, please feel free to contact our Market 
Department, so as to prevent any delay. 

 

2.5 Connecting the Emulator Hardware 

Embest Emulator is a JTAG-based debugging channel for ARM microprocessors. It 
provides an interface between Embest IDE and an ARM microprocessor deeply 
embedded. 



Embest Emulator
DB25 to PC IDC14/20 to JTAG 

 

A standard male-to-female 25-way parallel cable connects the Embest Emulator 
to the PC’s parallel port. 

The connection to the target board is made by a 20-way (or 14 - way) female I
DC header cable (BT224 type) with all pins connected straight through (1-1, 2-2, ...
 20-20). 

 

Note: Connecting cable dose not provide hot swap 

 

For further pin-out details, refer to Embest IDE JTAG interface connections on p
age A-2. 

 



III. Quick Start  

3.1 Simple Example 

This section shows users step by step how to create, compile and debug a simpl
e project. The project described below is to create a random number.  

The project demo locates at \Examples\arm\explasm under EmbestIDE installing
 directory. The files to be used are: 

Random.s Assemble file of random number function 

Randtest.c Main program file 

 

Note:  

1. Only source files above are used. The project can only be run an
d debugged by simulator under EmbestIDE.  

2. The project doesn’t link to any function library and doesn’t use Li
nker scripts. The program created by the project doesn’t have a fun
ction to initiate any circuit board. Therefore, it can’t run itself when 
it is programmed into FALSH. 

 

3.1.1 Create a Project 

1) Creating Project 

Select File > New Workspace menu, Give a project name and specify project 
directory as shown in Figure 3-1: 

 

Figure 3-1 Create a New Project Dialog box 

Rantest has been used as a project name, and project directory has been specif
ied manually as D:\EmbestIDE\Example\arm\explasm\, D:\EmbestIDE is supposed i
nstalling directory of EmbestIDE unless noted. 

After clicking OK, two files will be created in the project directory: 



Rantest.ews Workspace file (one or more project files.) 

Randtest.pjf Project file 

 

Note:  

1. It is normally generate both workspace and project files with
 the same project name under the location. 

2. Workspace and project files are maintained by EmbestIDE sy
stem itself. Users cannot edit these files manually.  

After the project has been created, files pane will appear in EmbestIDE workspa
ce window as shown in Figure 3-2. 

 

Figure 3-2 Workspace Window 

The Figure 3-2 shows current workspace is rantest which contains a project na
med rantest. Boldface indicates that rantest is an active project.  

 2) Add Source Files 

Choose Project Source Files folder in rantest workspace window. Click Project
 > Add To Project > Files to add source files. You can also right click Project S
ource Files folder to add source files, See Figure 3-3: 



 

Figure 3-3 Add Source Files In Workspace Window 

You can add the source files in the pop up dialog box. To select source files, pr
ess CTRL key and hold, click source files of random.s and randtest.c in Project direc
tory, See Figure 3-4. 

 

Figure 3-4 File Open Window 

After the source files added, workspace window is shown as Figure 3-5. 



 

Figure 3-5 Workspace Window 

 

3.1.2 Project Settings 

After creating a project, you need to configure the project. The project settings 
include CPU settings, emulator settings, debug settings, directory settings, compiler 
settings, assembler settings and linker settings. The project settings is a critical ste
p to entire software development. 

Click Project > Settings, Project Settings dialog box pops up, then Choose ran
dtest files in the dialog. 

1. CPU Settings 

Select Processor pane from Project Settings dialog box. Define CPU module as 
ARM7, CPU family and CPU member as ARM7 too. Switch Endian to little endian. 
Build tools are GNU tools for ARM. Figure 3-5 is a Project Settings dialog. 



 

Figure 3-5 Processor pane of Project Settings Dialog 

After build tool has been set, Project Settings dialog will show the pane of this 
build tool. 

2. Emulator Settings 

Select Remote pane from Project Settings dialog. Define Remote Device as jtaga
rm7. Because of Embest Emulator for ARM does not support to change the working 
speed, don’t worry about the setting of Speed item. When using Embest PowerICE f
or ARM, select the valid work speed: Full Speed(120Kbyte/s), High Speed, Medium 
Speed, Low Speed. Communication port with remote device is PARALLEL. Communic
ation channel is LPT1 as shown on Figure 3-6. 



 

figure 3-6 Remote Pane of Project Settings Dialog 

Device Module Description 

JtagARM7  ----- Embest Emulator for ARM debug ARM7-series CPU 

JtagARM9  ----- Embest Emulator for ARM debug ARM9-series CPU 

PowerICEARM7 ----- Embest PowerICE for ARM debug ARM7-series CPU 

PowerICEARM9 ----- Embest PowerICE for ARM debug ARM9-series CPU 

UnetICE  ----- Embest UnetICE for ARM debug ARM7/9-series CPU 

simARM7  ----- Embest IDE for ARM simulator (only for ARM7-series CPU) 

 

 

3. Debug Settings 

Select Debug pane from Project Settings dialog. Select General from Category, 
Set symbol file as ./debug/rantest.elf and Action after connected as None. See 
Figure 3-7. 



 

figure3-7 Debug General Options of Project Settings Dialog 

Select Download from Category. Set Download file as ./debug/rantest.elf. set 
Download Verify option on. Set Download file to address 0x2000000. Execute pro
gram starting from download address. See Figure 3-8. 

 

figure 3-8 Debug Download Options of Project Settings Dialog 



Note: 

1. Flat Binary format can be used for download files. The tool ELF2BIN pr
ovided by IDE can transfer ELF files to the files with flat binary format. 

2. Please change download address according to the project linker options
 setting. 

3. You must manual input the strings in the box “symbol file” and “downl
oad file” before project build, since there is no output *.elf file exist befor
e project build command executively. 

Set Memory Map to No map file. See Figure 3-9. 

 

Figure 3-9 Debug Memory Maps Options of Project Settings 

4. Compiler Settings 

Select Compiler pane from Project Settings dialog. Set Object Files Location a
s ./debug and others as default. See Figure 3-10. 



 

Figure 3-10 Compiler Pane of Project Settings Dialog 

5. Assembler Settings 

Select Assembler pane from Project Settings Dialog. Set Object Files Location
 as ./debug and other as default. See Figure 3-11. 

 

Figure 3-11 Assembler Pane of Project Settings Dialog 

6. Linker Settings 



Select Linker pane from Project Settings Dialog. Select General from Category. 
The Output file name is the default setting as ./debug/<project_name>.elf (somet
imes copy it to the Symbol file and Download file of Debug setting); Modify Linke 
Options input command line: add new option before –o as: 

-Ttext 0x2000000 (take care of the SPACE between other options, means that
 address of entire executive program code will start from 0x2000000.) 

Keep others as default. See Figure 3-12. 

 

Figuer 3-12 Linker General Options of Project Settings 

Note: 

1.-T is one of the linker options to set the start address of the text seg
ment. For example, –Ttext 0x2000000 will re-locate the text address s
tart 0x2000000, the Download address should be set as 0x2000000 in t
he Debugg settings; If not use –T option, linker will link the text with d
efault start address 0x8000, and the Download address should be set as
 0x8000. If not, the program cannot be downloaded to run correctly. 

2. You also can change the default text address by a linker script file, i
nput it’s name and path in “Linker script file”. The text address will set 
in the first ‘.=addr’ constant of the linker script file, and the Download a
ddress use the same addr. 

 

Select Image Entry Options from Category. Set Select Entry File as rantest.o. 
Select entry point as Main. See Figure 3-13. 



 

Figure 3-13 Linker Image Entry Optios of Project Settings Dialog 

Entry File ‘Rantest.o’ means that executive code compiled and linked  ‘rantest.
c’ will locate at starting point of entire executive program. 

Entry Point means that executive code will run starting from this label address
. 

 

Note: The step described above can be skipped if users open works
pace file explasm.ews created under the directory. 

 

3.1.3 Compile and Link 

Click Build > Build rantest to complete entire project building. You can view t
he output in the output window, the following messages show as Figure 3-14. 

 

Figure 3-14 Build Output Window 

The message shown in the window indicates that this project building has been 
success. 



 

3.1.4 Debug 

1. Create Executive File 

Click Tools > Elf to Bin to automatically transfer the project output file called 
“project name +.elf” under ‘debug’ sub-directory to executive file. The executive file
 has flat binary file format. The final file will be named as “project name +.bin” and
 saved in ‘debug’ sub-directory under project directory. 

You can also complete file transfer by running elf2bin.exe located in Bin sub-dir
ectory under install directory. 

Note: This step can be skipped if you have make a choice of downlo
ading ELF format file directly. 

2. Active connection  

Click Debug > Remote Connect to active the connection with the target boar
d through Embest JTAG emulator. The target board will be one of the two kinds of 
status: 

 Running status: When the target board is in this status, debug output windo
w shows messages as “Info: target running, all breakpoints disabled.” as shown in F
igure 3-15. 

 

Figure 3-15 Debug Output Window 

In this case, Embest IDE Disassemble window shows nothing. 

 Stop status (This happens when you stopped the activing connection with the
 target board previously, you stopped running target board prior). When the target 
board is in this status, debug output window shows message as “Info: CPU was in d
ebug state before connect! Current values may be incorrect!” as shown in Figure 3-
16. 

 

Figure 3-16 Debug Output Window 



In this case, Embest IDE Disassemble window shows assemble instruction, with 
the instruction currently PC is pointing to beginning. See Figure 3-17. 

 

Figure 3-17 Disassemble Window 

 

Note: In general, disassemble window which you see is not as
 same as above. 

3. Download File 

Click Debug > Stop to stop running target board if current target board is on r
unning status. Click Debug > Download to download file if current target board is 
on stopping status. Downloading parameters were set through Debug pane in Projec
t Settings dialog. When downloading files, status bar will show “Download File” with
 progress bar to indicate download progress. Status bar will show “Download Compl
eted” when the downloading finished. 

When download is completed, program pointer will automatically return to progr
am starting point. Disassemble window will appear as shown in Figure 3-18.  



 

Figure3-18 Disassemble Window 

At the same time, rantest.c source file window will appear as well as shown in F
igure 3-19. 

 

Figure 3-19 Source File Window 

4. Debug 

Click Debug > StepOver to run program to this line: 

random = randomnumber(); 



Click View > Debug Windows > Variables menu to show the Variable windo
w. Continuous to click Debug > StepOver to view the changes of function variable
s as shown in Figure 3-20.  

 

Figure 3-20 Variables Window 

 

3.2 A Complete Example 

This section shows you step by step to create, compile and debug a complete p
roject. The project demonstrates communication between PC and AT91EB40 evaluati
on board through parallel port. This is a complete embedded application. 

The example project locates at \Examples\AT91\ATEB40x\EB4008\ under Embes
t IDE installed directory after installed the examples for ATEB40x board1. The files t
o be used are: 

1. We have provided an accessory CD-ROM with contained software installation package. 

term.c Terminal Test Main Program File 

Terminal_irq.s Assemble Interrupt Handle Program File 

Cstartup.s Startup Program File for evaluation board. The file locat
es at the following sub-directory under installed directo
ry ATEB40x\Targets\EB40008\. 

The differences between the project described in this section and the project de
scribed in the previous section are: 

 The project of this section contains complete target board startup codes. Afte
r the program is debugged successfully, you can change AT91_DEBUG_ICE=1 define
d by project settings to AT91_DEBUG_NONE=1, replace the linker script file as flas
h_eb40x.ld (for flash image) and then rebuild it, and this can be downloaded to FL
ASH to run itself. 

 The project of this section uses individual linker scripts. The file is 

ram_ice_extern.ld Linker Script file for RAM Debugging, locate the tex
t area start address in extern SRAM. 



sram_ice.ld_inner.ld locate the text area start address in inner SRAM. 

flash_eb40x.ld Linker Script file for Flash Running, use to build the
 image file to program into Flash. 

Flash_ram_run.ld Linker Script file for RAM Running, use to build the
 image file to program into Flash, but copy itself to
 inner SRAM to run.  

 The project of this section links to standard C function library. The file of func
tion library supports arm interwork format. 

Libc.a(-lc) Standard C function library, the file is located at \build\
xgcc-arm-elf\arm-elf\lib\arm-inter. 

Libgcc.a(-lgcc) Support base of GCC library, the file is located at \build
\xgcc-arm-elf-xxx\lib\gcc-lib\arm-elf\x.x.x\arm-inter. 

 

 The project of this section connects to peripheral driver function library and d
evice function library of AT91 series CPU provided by ATMEL. They include:  

Lib_drv_32.lib Peripheral Driver Function Library,The file is located a
t AT91Lib\drivers\lib_drv\arm-inter\ under installed 
directory. The project file creating the library is locat
ed at the directory one level up. It can create THUMB
 instruction library or ARM Interwork library by chang
ing project settings. The example shown here uses A
RM Interwork function library. 

R40008_lib32.lib Device Function Library. The file is located at AT91Lib
\parts\r40008\arm-inter\ under installed directory. T
he project file creating the library is located at the di
rectory one level up. It can create THUMB instruction 
library or ARM Interwork library by changing project 
settings. The example shown here uses ARM Interwor
k function library. 

 
 

Note 1: Before using the project, if could not found the libraries Lib_drv_3
2.lib and r40008_lib32.lib: 

1. Install the software package for the ATMEL AT91 CPUs. 

2. Open workspace file lib_drv_32.ews, which located at AT91Lib\drivers\lib
_drv\ directory to build peripheral driver function library named lib_drv_32.l
ib, and open workspace file r40807_lib32.ews, which located at AT91Lib\par
ts\r40008\ to build device function library named r40008_lib32.lib. 

Note 2:If you don’t want to use ARM Interwork, you can create function li



brary, which support ARM only. And don’t choose to support ARM interwor
k in project compiler and assembler settings. 

 

3.2.1 Create Project 

The project called EB40008UART can be created and related source files can be 
added by following the same procedure described in the previous section at \Exampl
es\AT91\ATEB40x\EB4008\ under installed directory. Final workspace window will be
appeared as shown in the Figure 3-21. 

 

(a) add files in project directly (only t
he project source files) 

 

(b) after modify the folder names and ad
d all files (not necessary) 

 

(c) right click the folder name and modify the folder properties 

Figure 3-21 Workspace Window 



3.2.2 Project Settings 

The processor settings and remote settings can be done by following the same 
procedure described in Section 3.1.2 previously. Please refer to it. You can indicate 
the CPU to use by the Peripheral1 item, select the Maker as ATMEL and Chip as A
T91R40807 (the same as AT91R40008). 

1. If could not find the chip or compatible chip want to debug, leave it empty and well. 

 

Figure 3-22 Processor options of Project Settings Dialog 

1. Debug Settings 

Select Debug pane from Project Settings dialog. Set Symbol file settings as .\
debug\EB40008.elf. Set Action after connected option to Command script an
d input the file ..\Targets\boot_EB40x.cs. See Figure 3-22. 



 

Figure 3-22 Debug General Options of Project Settings Dialog 

Select Download from Category. Set download file to .\debug\EB40008.el
f. Set Download Verify option on. Set download address for download file as 0x
0100 (). Execute program starting from download address as shown in Figure 3-23. 

 

Figure 3-23 Debug Download Options of Project Settings Dialog 

Memory Maps Settings is the same as the first section. Please refer to it. 

2. Directory Settings 



Select Directory pane from Project Settings Dialog. Set additional source file 
directory as ..\AT91Lib and ..\Targets. If you want to track the program in driver f
unction library or device function library, you can add more source file directories h
ere as shown in Figure 3-24. 

 

Figure 3-24 Directory Pane of Project Settings Dialog 

3. Compiler Settings 

Select Compiler pane from Project Settings Dialog. Select General from Catego
ry. Set Object files location as .\debug and add two include directories: ..\..\AT9
1Lib, ..\..\AT91Lib\parts\r40008 and ..\Targets\EB40008. Select Target Specific O
ptions from category. Set Instruction Sets as ARM interworking and others as d
efault. See Figure 3-25. 

 



Figure 3-25 Compiler General Options of Project Settings Dialog 

4. Assembler Settings  

Select Assembler pane from Project Settings dialog. Select general from categ
ory. Set Object file location as .\debug. Add three include directories: ..\..\AT91L
ib, ..\..\AT91Lib\parts\r40008 and ..\Targets\EB40008.  Add three predefines: ATEB
40x=1,AT91R40008=1,AT91_DEBUG_ICE=1. Select Target Specific Options from 
category. Make the assembled code as supporting interworking and others as defa
ult. See Figure below. 

 

Figure 3-26 Assembler Pane of Project Settings Dialog  

5. Linker Settings 

Select Linker pane from Project Settings dialog. Select general from category.
 Set Output file name as .\debug\<Project_name>..elf and linker script file as ..
\Targets\ram_ice_inner.ld as shown in Figure 3-27. 



 

Figure 3-27 Linker General Options of Project Settings Dialog 

Select Image Entry Options from category. Make entry file as cstartup.o as s
hown in Figure 3-28. 

 

Figure 3-28 Linker Image Entry Options of Project Settings Dialog 

Select Add Library Searching Path from category. Add the library files path:
 D:\EmbestIDE\Build\xgcc-arm-elf\arm-elf\lib\arm-inter (use the ARM interwork for
mat library file libc.a) and D:\EmbestIDE\Build\xgcc-arm-elf\lib\gcc-lib\arm-elf\3.0.2
\arm-inter (use the ARM interwork format library file libgcc.a). 



Select Include Object and Library Modules from category. Add three library
 files:  

..\..\AT91Lib\drivers\lib_drv\arm-inter\lib_drv_32.lib 

..\..\AT91Lib\parts\r40008\arm-inter\r40008_lib32.lib 

-lc 

-lgcc 

See Figure below. 

 

Figure 3-29 Linker Include Object Options of Project Settings Dialog 

 

Note: The step above can be skipped if you directly open worksp
ace file term.ews created in the directory. 

 

3.2.3 Compile and Link 

Click Build > Build term to complete compiling, assembling and linking the ent
ire project. When “Command(s) successfully executed” appears at build window of o
utput window, it means the project has been successfully built. 

 

3.2.4 Debug 

1. Terminal Program Settings 

Connect Serial A on ATEB40x board to COM port of PC by using a standard seri
es port wire. Run Terminal program of windows. Click Setting > Communication 
and set communication parameters as shown in Figure 3-30. 



 

Figure 3-30 Terminal Program Communication Settings Dialog 

Select port according to COM port of PC connected. Figure 3-30 above is set to 
COM1 Port. 

2. Debug 

Create executive file, active the connection with target board through Embest JT
AG emulator, and then download the executive file. Disassemble window will pop ou
t after downloading file. Disassemble window will show assemble code starting from
 address 0x0100. Source file window relating with instruction address 0x0100 will p
op out then. You can open file of Term.c and set breakpoint at the beginning of mai
n() function. Click Debug > Go and execute program up to this line as shown in Fi
gure below. 

 



Figure 3-27 Source File Window 

Click Debug > Go again. The program starts running. Terminal program shows 
message of “AT91 TERMINAL TEST:” as shown in Figure below. 

 

Figure 3-27 Terminal Program Window 

Input “Hello, Embest”. Terminal program will show “AT91: Hello, Embest”. 

 

3.3 Example Project of S3C4510B 

The example program introduced in this part is a complete program based on S
3C4510, which may be debugged in RAM, and solidification may be normally conduc
ted in ROM. Led will be lit at interval during normal operation period, and press the
 button to light another led.  

For the convenience of users to rapidly understand S3C4510 programming and 
application, the whole software includes only two program source files:  

 starting assembling file: init.s 

 C source program file: ledint.c 

All macro definitions are included in the source files, and no other header files a
re used.  

The example program has integrally demonstrated the starting process of S3C4
510 processor, including configuration of memory area, stack setting and interrupt v
ector setting, and has demonstrated the control to IO port after completion of starti
ng and function processing of interrupt. The example program is the minimum prog
ram framework of S3C4510, and users can extend their own application on this bas
e.  

The example program is based on EV4510 EVM board of Embest Corporation, a
nd the basic configuration includes 2M of Flash area, 16M of DRAM area, IO port P1
6 connected to LED1, IO port P17 connected to LED2, and IO port P9 connected to 



the button. If developing personnel want to apply the program to the PCB designed
 by themselves, they only need to modify the value of the system configuration regi
ster and the setting value of the memory area register in the starting file, meanwhil
e, modify the value of the relevant register of IO port in C-file according to actual I
O port connection.  

3.3.1 Interpretation of Source Program  

 starting assembling file 

Starting assembling file “init.s”; starting assembling file will complete in turn: se
tting of interrupt vector, setting of system configuration register, configuration of m
emory area, copy of data segment used in program to RAM area, initialization of sta
ck space, and entering into C language program entry. 

What shall be paid attention to includes: 

1) if software is debugged in RAM, the configuration of memory area will be completed 
by integration environment through command  script file, therefore, it is 
unnecessary to use memory area configuration code in program, which can be 
completed through switching to ROM symbol definition; 

2) when debugging is made in RAM, it is unnecessary to copy the content of data 
segment, which will be automatically selected in program through judgment 
whether the addresses of read only area and read-write area are overlapped;  

3) no handing to primary exception vector such as failure of prefetch has been made 
in the code, perfect program shall handle any of primary vectors, including saving 
the implementing state before entering into primary exception vector for reference 
and returning to implement the program after removing possible mistake. 

The source code and the detailed interpretation of “Init.s” are as follows: 

/**************************************************** 
*  file name: init.s 
*  description: S3C4510 starting program 
****************************************************/ 
 

#=================================================== 
# programming register bit definition  
#=================================================== 

.EQU    LOCKOUT,   0xC0    @ forbid all interrupts  

.EQU    MODE_MASK,   0x1F    @ processor mode bit 

.EQU    UDF_MODE,   0x1B    @ undefined mode UDF 

.EQU    ABT_MODE,   0x17    @ abnormal mode ABT 

.EQU    SUP_MODE,   0x13    @ superuser mode SVC 

.EQU    IRQ_MODE,   0x12    @ interrupt mode IRQ 

.EQU    FIQ_MODE,   0x11    @ fast interrupt mode FIQ 

.EQU    USR_MODE,   0x10    @ user mode USR 



#==================================================== 
# set interrupt and primary exception vector 
#==================================================== 

ENTRY: 
B       Reset_Handler   @ implement from here after S3C4510 reset 
B       SystemUndefinedHandler 

    B       SystemSwiHandler 
    B       SystemPrefetchHandler 
    B       SystemAbortHandler 
    B  SystemReserv      
    B       SystemIrqHandler 
    B       SystemFiqHandler 
 

#=================================================== 
# reset entry point 
#=================================================== 

    .global Reset_Handler 
Reset_Handler:                      @ reset entry point 
  
 #================================================== 
 # set system configuration register  
 #================================================== 
 LDR r0, =0x3FF0000     @ address of system configuration register: 
0x3FF00000 
 LDR r1, =0x83FFFF90      @ value of register is set as 0x83FFFF90 
 STR r1, [r0]       @ significance of register: to use synchronical 

DRAM, peripheral register base value 0x3FF0000, which can cache 
      

#================================================== 
 # configuration of memory area, not define ROM when debugging the program in 
RAM, and define when solidified   
 #================================================== 
.ifdef ROM 
 LDR     r0, =SystemInitDataSDRAM @ load the setting value of memory area 
register to save address 
 LDMIA   r0, {r1-r12}    @ load 12 setting values 
 LDR r0, =0x3FF0000 + 0x3010   @ load the address of memory area 
register 
 STMIA   r0, {r1-r12}    @ set memory area register 
.endif  
 
 #================================================== 
 # introduce external symbol, symbol definition is in link script file 

#==================================================



 .extern  Image_RO_Limit    @ size of read only area 
    .extern  Image_RW_Base     @ initial address of read-write memory area 
    .extern  Image_ZI_Base     @ initial address of clear area, the area of the 
uninitialized variable .bss segment in code 

    .extern  Image_ZI_Limit    @ size of clear area 

 #================================================== 
 # memory area needed to use to initialize C code 
 #================================================== 
 LDR  r0, =Image_RO_Limit   @ obtain the size of read only area 
 LDR  r1, =Image_RW_Base    @ obtain the initial address of read-write memory 
area 
 LDR  r3, =Image_ZI_Base    @ obtain the initial address of clear area 
 CMP     r0, r1                @ compare whether the read only area and the 
read-write area are overlapped  
 BEQ     LOOP1 
LOOP0: 
 CMP     r1, r3                @ copy the content of “.data” data segment in 
program to the read-write area 
    LDRCC   r2, [r0], #4 
    STRCC   r2, [r1], #4 
    BCC     LOOP0 
LOOP1: 
    LDR     r1, =Image_ZI_Limit  @ commence from the top of the clear area 
    MOV     r2, #0 
LOOP2: 
   CMP     r3, r1                @ clear 
 STRCC   r2, [r3], #4 
 BCC     LOOP2 
 
 #================================================= 
 # initialize stack space 
 #================================================= 
INITIALIZE_STACK: 
 MRS r0, cpsr 
 BIC r0, r0, #LOCKOUT | MODE_MASK 

 ORR r2, r0, #USR_MODE 

 ORR r1, r0, #LOCKOUT | FIQ_MODE 
 MSR cpsr_cf, r1 
 MSR spsr_cf, r2  
 LDR sp, =FIQ_STACK    @ set fast interrupt stack space 
 
 ORR r1, r0, #LOCKOUT | IRQ_MODE 

MSR cpsr cf r1



 MSR spsr_cf, r2 
 LDR sp, =IRQ_STACK   @ set interrupt stack space 

ORR r1, r0, #LOCKOUT | ABT_MODE  
 MSR cpsr_cf, r1 
 MSR spsr_cf, r2 
 LDR sp, =ABT_STACK   @ set abnormal stack space 
 
 ORR r1, r0, #LOCKOUT | UDF_MODE  
 MSR cpsr_cf, r1 
 MSR spsr_cf, r2 
 LDR sp, =UDF_STACK    @ set undefined abnormal stack space 
 
 
 ORR r1, r0, #LOCKOUT | SUP_MODE  
 MSR cpsr_cf, r1 
 MSR spsr_cf, r2 
 LDR sp, =SUP_STACK      @ set superuser stack space 
  
 #================================================= 
 # switch to user mode and set user stack space 
 #================================================= 
 MRS r0, cpsr 
 BIC r0, r0, #LOCKOUT | MODE_MASK 
 ORR r1, r0, #USR_MODE 
 MSR cpsr_cf, r0 
 LDR sp, =USR_STACK 
 
 #================================================= 
 # enter into C language program entry 
 #================================================= 
    .extern __main 
    BL      __main 
 

#================================================= 
 #definition of vector function, definition of internal function in C program 
 #================================================= 
SystemUndefinedHandler: B SystemUndefinedHandler 
SystemSwiHandler:  B SystemSwiHandler 
MakeSVC:    B MakeSVC 
SystemPrefetchHandler: B SystemPrefetchHandler 
SystemAbortHandler:  B SystemAbortHandler 
SystemReserv:   B SystemReserv 
 
SystemIrqHandler: @ interrupt vector



 .extern ISR_IrqHandler 
 STMFD sp!, {r0-r12, lr} @ interrupt stack saving 
 BL ISR_IrqHandler   @ interrupt C manipulation function 
 LDMFD sp!, {r0-r12, lr} @ recover interrupt stack 
 SUBS pc, lr, #4   @ return to the program index before interrupt  
 
SystemFiqHandler:    @ fast interrupt vector  
 .extern ISR_FiqHandler 
 STMFD sp!, {r0-r7, lr} @ fast interrupt stack saving 
 BL ISR_FiqHandler   @ fast interrupt C manipulation function 
 LDMFD sp!, {r0-r7, lr} @ fast recover interrupt stack 
 SUBS pc, lr, #4   @ return to the program index before fast interrupt 
 

#=============================================== 
# memory area register setting value 
#=============================================== 

SystemInitDataSDRAM: 
 .long 0x00003E02   @ EXTDBWTH setting value 
 .long 0x02000060   @ ROMCOON0 setting value, 0~0x200000 
 .long 0x00000060 
    .long 0x00000060 
 .long 0x00000060 
 .long 0x00000060 
 .long 0x00000060 
 .long 0x14010301   @ DRAMCON0 setting value, 0x400000~0x1400000 
 .long 0x00000000 
 .long 0x00000000 
 .long 0x00000000 
 .long 0x9C298360    @ REFEXTCOM setting value 
 

#=============================================== 
# stack space definition interval 
#=============================================== 

.data 
      .SPACE    1024 
USR_STACK:  .SPACE    512 
UDF_STACK:  .SPACE    512 
ABT_STACK:  .SPACE    512 
IRQ_STACK:  .SPACE    512 
FIQ_STACK:  .SPACE    512 
SUP_STACK: 
 
  

 



 C master program file 

C master program file “led_int.c” completes the initialization of IO port and inter
rupt, realization of interrupt function, and handling to the uncompleted fast interrup
t in the program, and remain an empty function of fast interrupt handling for the n
eed of link. 

The source code and detailed interpretation of “Led_int.c” are as follows: 

/*********************************************************** 
* file name:  led_int.c  
* description  S3C4510 control IO and interrupt demonstration program   */ 
*    P16/TOUT0 connected to LED1 
*   P17/TOUT1 connected to LED2  

*    P9/XIRQ1  connected to button 

************************************************************/ 
#define VPint     *(volatile unsigned int *) 
 
#define Base_Addr 0x3ff0000    // register base address 
 
#define IOPMOD (VPint(Base_Addr+0x5000)) // IO mode register 
#define IOPCON   (VPint(Base_Addr+0x5004)) // IO control register 
#define IOPDATA  (VPint(Base_Addr+0x5008)) // IO data register 
 
#define INTMOD    (VPint(Base_Addr+0x4000)) // interrupt mode register 
#define INTPEND   (VPint(Base_Addr+0x4004)) // interrupt pending register 
#define INTMASK   (VPint(Base_Addr+0x4008))// interrupt mask register 
#define INTOFFSET (VPint(Base_Addr+0x4024)) // interrupt shift register 
 
void ISR_IrqHandler(void); 
void ISR_FiqHandler(void); 
 
/**************************************************** 
* name: __main  
* function: C language entry master function  
******************************************************/ 
void __main(void) 
{ 
 int i, j; 



 { 
  IOPDATA = 0x00010000; // light LED1 
     for(i=0; i < 65000; i++) ; // simple delay 
  IOPDATA = 0;    // put out LED1 

     for(i=0; i < 65000; i++) ; 
 } 
} 
 
/**************************************************** 
* name: ISR_IrqHandler  
* function:  interrupt handling function  

******************************************************/ 

void ISR_IrqHandler(void) 
{ 
 unsigned int  IntOffSet; 
 
 IntOffSet = (unsigned int)INTOFFSET;// obtain interrupt source 
 INTPEND = 1<<(IntOffSet>>2);  // remove interrupt pending symbol 
 IOPDATA = 0x00020000;   // light LED2 
} 
 
/**************************************************** 
* name: ISR_FiqHandler  
* function: fast interrupt handling function  
******************************************************/ 
void ISR_FiqHandler(void) 
{ 

} 

 
 

 

 

3.3.2 Creation of Project  

Select menu File > New Workspace, the system will pop up project creation dial
og, as shown in Fig 3-35: 



 

Fig 3-35 project creation dialog 

Input the project name of the newly-created project “led_int” in the edit box of 
project name, and input the directory path “C:\EmbestIDE\Examples\Samsung\ledin
t in the edit box” for storing the project in the edit box of project location. 

Select button OK to create new project ledint, and the integration environment 
will create the workspace and project with the same name as the project. 

Select the right key menu to create source file folder in the window of workspac
e and add relevant source file, at last, the workspace is shown as Fig 3-36:  

 

Fig 3-36 window of workspace 

3.3.3 Configuration of Project  

The processor configuration and emulator configuration in the project is the sam
e as in the example described in Part 1 of this chapter, what needs to pay attention
 to is that, during the course of processor configuration, for Maker in Peripheral Reg
ister, select S3C4510B, for Chip, select S3C4510B, because the example is based o
n S3C4510B chip of Samsung Corporation, as shown in Fig 3-37, and the please set
 other configurations according to the following steps.  



 

Fig 3-37  project configuration processor page layout 

 Debugging equipment configuration  

Select project configuration dialog box to debug equipment debug page layout, 
as shown in Fig 3-38: 

 Select General option in Category 

 set debugging symbol file as./debug/ledint.elf; 

 if debugged in RAM, set “Action after connected” of emulator as comma
nd script, then select the command script file to implement as “net-start.cs”; 

 if debugged in ROM, set “Action after connected” of emulator as “none”; 

command script file is a serial commands for integration environment to implem
ent, which will usually complete the initialization work needed by processor, includin
g reset, memory area configuration, and disable interrupt, etc, users shall use com
mand script file to map RAM area to O address when debugging in RAM in this exa
mple, which is the same with the address of Flash to be solidified to finally, so that 
the users download program to O address to debug whether the phenomenon is co
nsistent to the actual operation; the command script “net-start.cs” used in this exa
mple and the interpretation is as follows:  

reset        ; reset processor  
stop         ; stop processor operation  
memwrite 0x3ff4008 0xffffffff  ; remove all interrupts  
memwrite 0x3ff4004 0xffffffff  ; mask all interrupts  
memwrite 0x3ff0000 0x83FFFF90 ; config. System register 
memwrite 0x3ff3010 0x00003e02 ; config. Access width register 
memwrite 0x3ff3014 0x1a060040 ; config.ROM0 (0x1800000-0x1a00000) 
memwrite 0x3ff302C 0x10000301 ; config.RAM0 from 0x0 to 0x1000000 
memwrite 0x3ff303C 0x9c298360 ; config. DRAM brush parameter register 



  

 

Fig 3-38 general option of project configuration debugging page layout 

 select Download option in Category, as shown in Fig 3-39: 

 set download file as ./debug/ledint.elf; 

 set download address as 0x0; 

 other default settings used; 

 

Fig 3-39 download option of project configuration debugging configuration page 
layout 



 select debugging option Memory Maps in Category, as shown in Fig 3-40: 

 Set Memory Map as No map file; 

 

Fig 3-40 memory mapping option of project configuration debugging page layout 

Memory mapping file “.map” file is used for debugging in integration environme
nt. During the process of software debugging, it will produce abnormities in some p
rocessors to access illegal memory area, if the abnormities fail to be handled, they 
will cause the software debugging process not able to continue; to use memory are
a mapping file (*.map) may prevent the above problems and adjust emulator acces
s speed to reach the moderate level.   

 compiling configuration  

select project configuration dialog box compiling configuration (Compiler) page l
ayout, as shown in Fig 3-41: 

 select General option in Category 

 set object files location as .\debug; 

 other default settings used; 



 

Fig 3-41  general option of project configuration compiling page layout 

 assembly configuration  

select project configuration dialog box assembly configuration (Assembler) page 
layout, as shown in Fig 3-42: 

 select General option in Category 

 Set object files location as .\debug: 

 Set predefine as ROM=1 if it needed to build binary image and debug in
 ROM; do not set any predefine for debugging in RAM. 

 other default settings used; 

 



Fig 3-42  general option of project configuration assembly configuration page 

 link configuration  

select project configuration dialog box link configuration (Linker) page layout, as
 shown in Fig 3-43:  

 select General option in Category 

 set linker script file as flash.ld when solidifying program or debugging in
 ROM; 

 set linker script file as ram_ice.ld when debugging program in RAM; 

 set output file name as .\debug\ledint.elf; 

 other default settings used; 

 

Fig 3-43  general option of project configuration link page layout 

link location file shall be used in embed development of system level, and th
e file describes the relevant information of code link location, including code seg
ment, data segment address, etc, the linker shall use the file to make correct lo
cation to the codes of the whole system. The link location files used for RAM de
bugging and solidification are different, and the following are the link location fil
es used for solidification:  

 

SECTIONS    

{ 

. = 0x000000; 

.text : { *(.text) }; 

.rodata : { *(.rodata) }; 

 

Image_RO_Limit = .; 

 

 

set the current address as 0. 

code segment, symbol lay program code here from 0.  

read only data segment, the fixed values such as static globa

l variable in program is laid in this segment. 

read only area length, the symbol used in starting program. 



 

. = 0x0400000; 

Image_RW_Base = .; 

 

.data : { *(.data) }; 

 

Image_ZI_Base = .; 

 

.bss : { *(.bss) }; 

 

Image_ZI_Limit = .; 

end = .; 

 

set the current address as 0x400000. 

read and write area base address, the symbol used in startin

g program. 

data segment, the initialized global variable in program is lai

d in this segment. 

clear area base address, the symbol used in starting progra

m. 

contain uninitialized globally useable data, such as uninitialize

d global variable. 

clear area length, the symbol used in starting program. 

end address. 

 

.debug_info 0 : { *(.debug_info)  }; debugging information output segment. 

.debug_line   0 : { *(.debug_line)  }     

.debug_abbrev  0 : { *(.debug_abbrev)}    

.debug_frame  0 : { *(.debug_frame) }    

} 

 

 
the link location file used for debugging in RAM: 

SECTIONS    

{ 

. = 0x000000; 

.text : { *(.text) }; 

.rodata : { *(.rodata) }; 

 

Image_RO_Limit = .; 

 

Image_RW_Base = .; 

 

.data : { *(.data) }; 

 

Image_ZI_Base = .; 

 

.bss : { *(.bss) }; 

 

Image_ZI_Limit = .; 

end = .; 

 

 

 

set the current address as 0. 

code segment, symbol lay program code here from 0.  

read only data segment, the fixed values such as static globa

l variable in program is laid in this segment. 

read only area length, the symbol used in starting program. 

read and write area base address, the symbol used in startin

g program. 

data segment, the initialized global variable in program is lai

d in this segment. 

clear area base address, the symbol used in starting progra

m. 

contain uninitialized globally useable data, such as uninitialize

d global variable. 

clear area length, the symbol used in starting program. 

end address. 

 

.debug_info 0 : { *(.debug_info)  }; debugging information output segment. 

.debug_line   0 : { *(.debug_line)  }     

.debug_abbrev  0 : { *(.debug_abbrev)}    

.debug_frame  0 : { *(.debug_frame) }    

} 



 

3.3.4 Debugging of Program in RAM 

Debugging of software may be completed in ROM area or RAM area, because it 
is convenient to read and write in RAM area and the access speed is high, all the d
ebugging during the process of software development shall be completed in RAM ar
ea if only the hardware condition allows. 

The following steps shall be completed before debugging of software: compile li
nk project, to connect emulator and target board, and download program. 

 compile link project  

Users select Build menu, compile corresponding file or project, and output relev
ant compiling and link information at the Build subwindow of the Output window. Ac
cording to link configuration, led_int.elf file will be built under .\led_int\debug\ direc
tory after passing of program compiling, and the file contains the execution file of d
ebugging information.  

 connect emulator and target board 

    Select Remote Connect submenu on Debug menu, and the debugger in integrati
on environment will be connected to the target system through emulator.   

 download program 

After connection of target system, if automatic download option is set in the de
bugging configuration option, the debugger will automatically download software; or
 it will select Download submenu download program of the menu Debug. Now, the 
debugger will download binary system instruction file to the location designated by t
he target board memory area after removing the debugging information in led_int.el
f, meanwhile, will display the download progress on the status bar. In this example,
 the download address set is 0x0, and the address is the initial address of RAM me
mory area through command script mapping. After download successfully, the statu
s bar will display “Download Completed” in blue, or the information of “Download Fa
iled” will be displayed in red status bar.  

The debugging interface of Embest IDE after download of program is shown in F
ig 3-44, and now the debugging of program may be started. 



 

Fig 3-44  Embest IDE debugging interface 

Embest IDE will display the corresponding assembly instruction at the current d
ownload address after download of program, and to select “Go to source” submenu 
on the right key menu may switch to the window of the source file. 

Now it may, through setting breakpoint at the window of anti-assembly file or s
ource file, implement the operation such as single step run to debug program and a
nalyze the problems in program, as shown in Fig 3-45.  

 

Fig 3-45  set breakpoint in source program 



3.3.5 Download onto the Flash ROM 

The program passed through debugging in RAM is different from the program fi
nally programmed into Flash space, and users shall change the project settings:  

 Set ROM=1 in the predefine option of assembly, the initialization code of th
e startup file will be included to compile. In this case, build the project to g
enerate binary image. After programming the binary image into Flash and r
unning, the startup file will copy the image to RAM to run.  

 Select the link file flash.ld in Linker, and the link file and starting file will co
mbine to complete the handling job of data segment downloaded onto Flash
 originally. 

After completion of the above modification, compile program again. Then use Elf
 to Bin tool to change ledint.elf file into binary format file ledint.bin. 

At last, use Embest Flash Programmer to download ledint.bin to the Flash ROM, 
as show in Fig 3-46. 

 

Fig 3-46 Flash programmer interface program page layout 

Please reference to Embest online Flash Programmer for ARM online user’s man
ual for more about the usage. 

 

3.3.6 Debugging of Program in Flash 

When target board limited by software resources, such as the space of RAM are
a is less than the space of program code, which causes that debugging can not be 
made in RAM area, or it is needed to observe the actual operation situation of progr



am in Flash, it may select to debug program after completing the solidification work
s described in the previous part. 

The project configuration for debugging of program in Flash is different from tha
t of the debugging in RAM: 

 it is unnecessary to implement script file in debugging option, the work is c
ompleted during the course of starting file, and it is needed to change the o
ption “Action after connected” into “None”; 

And the debugging processes are different too; 

 after connecting to emulator, it unnecessary to implement Download progra
m operation  

 if it is to commence debugging program at the entry of starting program, re
set command shall be implemented, and now the program will stop at the z
ero address; 

 two hardware breakpoints may be set at most when program is debugged i
n Flash. 

3.3.7 Startup Program Design of S3C44B0X 

S3C44B0 starting program design is different from the starting program of S3C4
510 as we describe in the above example, the major reason lies in that S3C44B0 h
as no memory mapping function, all the addresses of memory area are fixed, in ad
dition, S3C44B0 provides vector interrupt function and reduces interrupt delay. Ther
efore, in the starting program of S3C44B0, the appearance of vector interrupt functi
on leads to extension of vector table, meanwhile, for the convenience of design of p
rogram and the debugging in RAM, interrupt entry is shifted to the tip end of RAM t
hrough address definition mode. 

The starting program of S3C4510 represents the starting flow of processor chips
 of most integrate ARM, and S3C44B0 represents the rest, to understand the startin
g program of these two processors is helpful to the starting design of other process
ors.  

The following codes are the source codes and the interpretation of the starting 
program of S3C44B0, in order to effectively apply the space, some similar interrupt 
entry definitions and function macro definitions are omitted, and the omitted parts i
s replaced by “……” and notes are given, if users want to use the following source c
odes as starting programs, they shall add the omitted parts by themselves.  

# ***************************************************** 

# file name: 44binit.s 

# description: S3c44b0x starting file 

# ***************************************************** 

 

#========================================== 

# register definition and bit definition  

#========================================== 



.equ  INTMSK,    0x01e0000c 

.equ  WTCON,    0x01d30000   

 

.equ  CLKCON,   0x01d80004 

.equ  LOCKTIME,  0x01d8000c 

 

.equ  FIQMODE,  0x11 

.equ  IRQMODE,  0x12 

.equ  SVCMODE,  0x13 

.equ  ABORTMODE,     0x17 

.equ  UNDEFMODE,     0x1b 

.equ  MODEMASK,      0x1f 

.equ  NOINT,   0xc0 

#=========================================== 

# interrupt handling macro  

#=========================================== 

    .macro HANDLER HandleLabel 

    sub     sp, sp, #4   @ stack space degression save jump address 

    stmfd     sp!, {r0}   @ save work register r0 to stack 

    ldr     r0, =\HandleLabel  @ load interrupt entry address location to r0 

    ldr     r0, [r0]      @ load interrupt entry address to r0 

    str     r0, [sp,#4]   @ save interrupt entry address to stack 

    ldmfd     sp!, {r0,pc}      @ recover work register and jump to interrupt function 

    .endm 

 

#========================================== 

#  set ARM7 interrupt and primary exception vector 

#========================================== 

ENTRY: 

    b  ResetHandler   @ implement from here after S3C4510 reset 

    b  HandlerUndef   @ undefined primary exception vector 

    b  HandlerSWI   @ soft interrupt vector 

    b  HandlerPabort   @ obtain fetch primary exception vector 

    b  HandlerDabort   @ obtain data primary exception vector 

    b  .      @ keep  

    b  HandlerIRQ    @ interrupt vector  

    b  HandlerFIQ   @ fast interrupt vector  

 

#========================================== 

# set 44B0 interrupt vector table  

#========================================== 

VECTOR_BRANCH: 

    ldr pc,=HandlerEINT0      @ mGA H/W interrupt vector table 

    ldr pc,=HandlerEINT1      @  



    ……      @ omit 

    ldr pc,=HandlerADC   @ mGKB 

    ……      @ omit 

    b . 

#========================================== 

# interrupt vector handling macro 

#========================================== 

HandlerFIQ:  HANDLER HandleFIQ 

HandlerIRQ:  HANDLER HandleIRQ 

HandlerUndef:    HANDLER HandleUndef 

HandlerSWI:  HANDLER HandleSWI 

HandlerDabort:   HANDLER HandleDabort 

HandlerPabort:   HANDLER HandlePabort 

 

HandlerADC:  HANDLER HandleADC 

 ……      @ omit 

HandlerEINT1: HANDLER HandleEINT1 

HandlerEINT0: HANDLER HandleEINT0 

#========================================== 

# interrupt vector handling macro 

#========================================== 

ResetHandler: 

    ldr     r0,=WTCON     @ watchdog forbidden  

    ldr     r1,=0x0    

    str     r1,[r0] 

 

    ldr     r0,=INTMSK 

    ldr     r1,=0x07ffffff       @ all interrupts forbidden 

    str     r1,[r0] 

 

 #=========================================== 

 # set clock control controller  

 #=========================================== 

    ldr  r0, =LOCKTIME 

    ldr  r1, =0xfff 

    str  r1, [r0] 

 

    ldr     r0, =CLKCON 

    ldr     r1, =0x7ff8   @ clock of all modules unlocked  

    str     r1, [r0] 

 

 #=========================================== 

 # set memory area controller  



 # If build the binary image to program into flash, and want to copy the code to RAM to run, 

 # please set EXEC_FROM_RAM=1 in the predefine option of assembly 

 #=========================================== 

    ldr     r0, =SMRDATA 

.ifdef EXEC_FROM_RAM   @ if need to calculate the offset address SMRDATA 

    ldr      r1, =Image_RO_Base 

    sub      r0, r0, r1   @ yes, subtract to the RAM start address. 

.endif 

    ldmia     r0, {r1-r13} 

    ldr     r0, =0x01c80000 

    stmia     r0, {r1-r13} 

 

.ifdef      EXEC_FROM_RAM  @ if need to copy code segment to RAM 

    mov    r0, #0    @ copy from ROM start address 

    ldr    r1, =Image_RO_Base @ store to real space 

    ldr    r3, =Image_ZI_Limit @ until ZI segment end address. 

LoopRw: 

    cmp    r1, r3 

    ldrcc     r2, [r0], #4 

    strcc    r2, [r1], #4 

    bcc    LoopRw 

 

    ldr    pc, =Jump  @ jump to the new address in RAM. 

Jump: 

    nop 

    nop 

    nop 

.endif 

 #=========================================== 

 # initialize stack space 

 #=========================================== 

    ldr     sp, =SVCStack  @ switch to supervise stack space  

    bl     InitStacks 

 

 #=========================================== 

 # introduce external symbol, symbol definition is in link script file 

 #=========================================== 

 .extern  Image_RO_Limit   @ end address of read only area 

    .extern  Image_RW_Base  @ start address of readable-writeable memory area 

    .extern  Image_ZI_Base  @ start address of clear area 

    .extern  Image_ZI_Limit  @ end address of clear area  

 

 #=========================================== 

 # initialize the memory area needed to use by C code 



 #=========================================== 

    LDR  r0, =Image_RO_Limit  @ obtain the end address of read only area 

    LDR  r1, =Image_RW_Base  @ obtain the start address of readable- writable memory area 

    LDR  r3, =Image_ZI_Base   @ obtain the start address of clear area 

    CMP     r0, r1    @ compare whether the read only area and the readable-writable area are overlapped 

    BEQ     LOOP1 

LOOP0: 

    CMP     r1, r3    @ copy the content of “.data” data segment in program to the readable-writable area 

    LDRCC   r2, [r0], #4 

    STRCC   r2, [r1], #4 

    BCC     LOOP0 

LOOP1: 

    LDR     r1, =Image_ZI_Limit @ commence from the top of the clear area 

    MOV     r2, #0 

LOOP2: 

    CMP     r3, r1             @ clear 

    STRCC   r2, [r3], #4 

    BCC     LOOP2 

 

 #=========================== 

 # enter into C language program entry 

 #=========================== 

    MRS    r0, CPSR 

    BIC     r0, r0, #NOINT /* enable interrupt */ 

    MSR    CPSR_cxsf, r0 

    /* jump to main() */ 

    .extern   Main 

    bl       Main 

    b        . 

 

#========================================== 

# initialize the function of stack space  

#========================================== 

InitStacks: 

    mrs     r0, cpsr 

    bic     r0, r0, #MODEMASK 

    orr     r1, r0, #UNDEFMODE | NOINT 

    msr     cpsr_cxsf, r1    

    ldr     sp, =UndefStack  @ set undefined abnormal stack space 

  

    orr     r1, r0, #ABORTMODE|NOINT 

    msr     cpsr_cxsf, r1         

    ldr     sp, =AbortStack  @ set abnormal stack space 

 



    orr     r1, r0, #IRQMODE|NOINT 

msr     cpsr_cxsf, r1        

    ldr     sp, =IRQStack  @ set interrupt stack space 

  

    orr     r1, r0, #FIQMODE|NOINT 

    msr     cpsr_cxsf, r1        

    ldr     sp, =FIQStack  @ set fast interrupt stack space 

 

    bic     r0, r0, #MODEMASK|NOINT 

    orr     r1, r0, #SVCMODE 

    msr     cpsr_cxsf, r1 

    ldr     sp, =SVCStack  @ set superuser stack space 

 

    mov     pc,lr     @ function return 

     

#========================================== 

# setting value of relevant register of memory area  

#========================================== 

SMRDATA: 

 .long 0x11110101   @ memory area access width control register 

 .long 0x00000600   @ BANK0 control register 

 .long 0x00007FFC   @ BANK1 control register 

 .long 0x00007FFC   @ BANK2 control register 

 .long 0x00007FFC   @ BANK3 control register 

 .long 0x00007FFC   @ BANK4 control register 

 .long 0x00007FFC   @ BANK5 control register 

 .long 0x00018000   @ BANK6 control register 

 .long 0x00018000   @ BANK7 control register 

 .long 0x00860459   @ SDRAM brush control register 

 .long 0x10     @ SDRAM memory area size  

 .long 0x20     @ BANK6 SDRAM mode register 

 .long 0x20     @ BANK7 SDRAM mode register 

 

 

.equ STARTADDRESS, 0xc7fff00 

#========================================== 

# stack space definition  

#========================================== 

.equ UserStack,  STARTADDRESS-0x500      @ c1(c7)ffa00 

.equ SVCStack,  STARTADDRESS-0x500+256  @ c1(c7)ffb00 

.equ UndefStack,  STARTADDRESS-0x500+256*2 @ c1(c7)ffc00 

.equ AbortStack,  STARTADDRESS-0x500+256*3 @ c1(c7)ffd00 

.equ IRQStack,  STARTADDRESS-0x500+256*4 @ c1(c7)ffe00 

.equ FIQStack,  STARTADDRESS-0x500+256*5 @ c1(c7)fff00 



#========================================== 

# ARM interrupt vector entry definition  

#========================================== 

.equ HandleReset,  STARTADDRESS 

.equ HandleUndef,  STARTADDRESS+4 

.equ HandleSWI,  STARTADDRESS+4*2 

.equ HandlePabort,  STARTADDRESS+4*3 

.equ HandleDabort,  STARTADDRESS+4*4 

.equ HandleReserved, STARTADDRESS+4*5 

.equ HandleIRQ,  STARTADDRESS+4*6 

.equ HandleFIQ,  STARTADDRESS+4*7 

 

#========================================== 

# S3C44B0 interrupt vector entry definition 

#========================================== 

.equ HandleADC,     STARTADDRESS+4*8 

……        @ omit 

.equ HandleEINT4567, STARTADDRESS+4*29 

.equ HandleEINT3, STARTADDRESS+4*30 

.equ HandleEINT2, STARTADDRESS+4*31 

.equ HandleEINT1, STARTADDRESS+4*32 

.equ HandleEINT0, STARTADDRESS+4*33 @ 0xc1(c7)fff84 

 

 



IV. Editor 

 Embest development environment includes an integrated Text editor to manage,
 edit, and print source files.  

4.1 Editor Overview 

The EmbestIDE source code editor includes standard text manipulation capabiliti
es, as well as the following specialized features: 

◊ C and assembly syntax color highlighting. 

◊ Debugger integration: the editor window tracks code execution. 

◊ Compiler integration: compiler messages links to the editor window. 

The EmbestIDE editor also provides features tailored to the program environme
nt. Editor display program syntactic elements such as C keywords, preprocessor dire
ctives, and comments in color. Because the editor is integrated with the debugger, t
he editor also keeps pace automatically with program execution during debugging s
ession. 

You can work on as many files simultaneously as your computer's memory allo
ws. This is convenient for you are working with more than one module, or want to 
edit both a source and header file at the same time. 

Typically, developers use the EmbestIDE editor to work with source files and he
ader files. However, because it is a text editor, it can also be used on any text file. 
For example, you can view a bug report, or save a note in a text file. 

The EmbestIDE editor uses standard Windows editing commands and convention
s. Most of the procedures for using the editor should seem familiar if you have used
 other Windows-based text editors. With the Text editor, you can:  

◊ Perform advanced find and replace operations in a single file or multiple files,
 including using regular expressions and incremental searching. 

◊ Use Bookmarks to mark frequently accessed lines in your source file. 

◊ Customize the Text editor with the selection margin, indent, and drag and dr
op. 

◊ Select lines, multiple lines, or columns. 

◊ Use drag-and-drop editing within one editor window, between editor windows,
 and between the Text editor and the debugger. 

◊ Manage the source window.  

While using the Text editor, in many instances you can right-click mouse  to dis
play a shortcut menu of frequently used commands. The commands available depen
d on what the mouse pointer is pointing to. 

   



4.2 The Standard Toolbar 

The Standard toolbar has buttons for frequently used editing commands that are 
also available in the File and Edit menus. Figure 4-1 shows the Standard toolbar. 

When you first start EmbestIDE in its default configuration, the Standard toolbar 
appears just below. You can click View>Toolbars>Standard to show and hide the st
andard tool bar. 

 

Figure4-1 Standard Tool Bar 

The following are summary descriptions of each buttons and the equivalent menu
 option.  

Table 4-1 Standard Tool Bar Buttons Description 

button menu description 

 File>New Create a new file 

 File>Open Open an existing file  

 File>Save Save current file  

 File>Save All Save all opening files 

 File>Print Print current file 

 Edit>Cut 
Delete the selection and place it into the 
clipboard 

 Edit>Copy Copy the selection to the clipboard 

 Edit>Paste Insert the clipboard text at the insertion point 

 Edit>Undo Undo the previous operation 

 Edit>Redo Redo the previous operation 

 View>Workspace View or hide the workspace window 

 View>output View or hide the output window 

 Edit>Find in Files Search strings in multiple files 



 Edit>Find Next 
Search for another instance of the same string 
in the same search direction 

 Edit>Find Previous Repeat the search, but in the opposite direction

 Edit>Replace 
Specify both a string to find and a replacement 
for it 

 
Edit>More Bookmarks>Toggle 
Bookmark 

Toggles an unnamed bookmark for the current 
line 

 
Edit>More Bookmarks>Next 
Bookmark 

Moves to the line containing the next bookmark

 
Edit>More Bookmarks 
>Previous Bookmark 

Moves to the line containing the previous 
bookmark 

 
Edit>More Bookmarks>Clear All 
Bookmarks 

Clears all bookmarks in the window 

  

4.3 File Management 

The following sections describe file management commands.  

  

4.3.1 Create a file 

Table 4-2  Operation of Create a New File  

Button Shortcut File menu 

 Ctrl+N File > New 

 

To create a new file, click File> New, an empty window appears, ready for input
 text. 

  

 

4.3.2 Open a File 

Table 4-3  Operation of Open a File 

Button Shortcut File menu  

 Ctrl+O File > Open 

 

To open an existing file, click File>Open. A standard Windows file browser allow
s you to select which file to be open. 



Recent files of the File menu (File > Recent Files) lists the most recently opened
 files. You can choose one of these without navigating through the open dialog box. 

  

4.3.3 Save and Close a File 

Table 4-4  Save and Close File Button 

Button Shortcut File menu 

 Ctrl+S File > Save 

N/a  File > Save As 

  File > Save All 

N/a Ctrl+F4 File > Close 

 

To save current file, click File>Save. If need specify a new name (or path) for c
urrent file, click Save As instead. (Save is disabled until you modify current file.) 

If you open multiple files, you can also click File>save all  to save the modificati
on of all opening files. 

Click Close to dismiss the editor window for current file. If the file has changed 
since you last saved, a confirmation dialog box offers you the opportunity to save t
he file before closing it. 

  

4.3.4 Print 

Table 4-5 Print Buttons 

Button Shortcut File menu 

 Ctrl+P File > Print 

N/a  File > Print Preview 

N/a  File > Page Setup 

N/a  File > Print Setup 

 

To print current edit window, click File>Print. A standard print dialog box (Figur
e 4-2) appears. 



 

Figure 4-2  Print Dialog Box 

Click File > Print Preview, to preview the page will be printed. Click File > Page 
Setup to change the margin size of each page in printout. 

  

4.4 Typing and Editing 

Only one edit window in EmbestIDE is active at any time. The active window co
ntains a text cursor, a blinking vertical line also called an insertion point. Whatever 
you type appears at the text location indicated by the text cursor. 

The editor is designed for edit source files. As such, it does not provide the "wo
rd wrap" feature found in many word edit software. You must press ENTER to start 
a new line. If a line is too long for the current width of the edit window, the text sc
rolls horizontally as necessary to display the text you are editing. 

There are two edit modes in EmbestIDE: overtype mode, which replaces the exi
sting text under the cursor as you type, and insert mode (the default), which displa
ces text to the right while adding the characters you type. Use the INSERT key on 
your keyboard to toggle between these two modes. The edit mode does not change
 when you switch edit windows; the last mode you selected continues to apply, eve
n if you switch to a window that you last edited with the other edit mode. 

NOTE: If you cannot type inside an editor window, check for a READ indicator on the status 
bar at the bottom of EmbestIDE window. If that indicator appears, the editor is displaying as a 
read-only file. To enable type in that window, click Edit>Read Only menu to turn off the 
read-only file attribute. 

 
  



4.4.1 Edit Text 

Table 4-6  Edit Button 

Button Shortcut Edit menu 

 Ctrl+Z Edit > Undo Typing 

 Ctrl+Z Edit > Redo 

 Ctrl+X Edit > Cut 

 Ctrl+C Edit > Copy 

 Ctrl+V Edit > Paste 

 Del Edit > Delete 

 Ctrl+A Edit > Select All 

 

The edit menu supports the Windows standard edit functions: Undo, Cut, Copy, 
Paste, Delete, and Select All, with standard shortcuts. With the text editor, you can 
cut, copy, and paste selected text using menu commands or drag-and-drop operatio
n. You can also undo and redo selected edit actions. 

The editor uses the standard Windows keys and mouse actions for moving throu
ghout the file. For example, the following specialized keys have the standard effect
s: 

Table 4-7  The Standard Windows Edit Keys 

Page Up Display the previous portion of text. 

Page Down Display the next portion of text. 

End Move the cursor to the end of the line. 

Ctrl+End Display the end of the document. 

Home Move the cursor to the beginning of the line. 

Ctrl+Home Display the start of the document. 

← ↑ ↓ → Move the cursor into the direction of the arrow, one character 

or line at a time. 

Ctrl + ← 

Ctrl + → 

Move the cursor one word at a time, in the direction of the 

arrow. 



Ctrl + ↑ 

Ctrl + ↓ 

Scroll the window by one line, in the direction of the arrow, 

without changing cursor position. 

You can set bookmarks to mark source lines that need frequently access in your
 source file. Once a bookmark is set, you can use menu or keyboard commands to 
move to it. You can remove a bookmark when you no longer need it. 

   

4.4.2 Find and Replace Text 

Table 4-8 Find and Replace Button 

Button Shortcut Menu 

N/a Ctrl+F Edit > Find 

 F3 Edit > Find Next 

 Shift+F3 Edit > Find Previous 

  Edit > Find in Files 

 Ctrl+H Edit > Replace 

 

The text editor supports string searching. You can search text in a single source
 file or in multiple files.  

Click Edit>Find to search for a string in the current active file window. Figure 4-
4 shows the Find dialog box. Enter the string you are looking for, set the options, a
nd click find next. The option buttons under Direction determine whether the editor 
searches back (Up) from the cursor position, or forwards (Down). The option of mat
ch whole word only means Matches all occurrences of a text string not preceded or 
followed by an alphanumeric character or the underscore (_). The option of match c
ase means Searches for text that matches the capitalization of the text string. If th
e text is not found, the editor displays an error message; the Find dialog box remai
ns open, in case you need to correct the search string. To continue your search, us
e the Find Next or Find Previous shortcut keys, or the equivalent toolbar buttons on
 the standard toolbar. The default shortcut key for Find Next is F3; the default key 
combination for Find Previous is SHIFT+F3. 



 

Figure 4-4 Find Dialog Box 

Click Edit > Replace to specify both a string to find and a replacement for it. Fi
gure 4-5 shows the Replace dialog box. The buttons in the Replace dialog box allow
 you to replace all occurrences of a string, or examine each individual occurrence b
efore decide whether or not to replace it. 

 

Figure 4-5 Replace Dialog Box 

You can also find text in multiple files. Just click Edit > Find in Files to do this s
earch. The Find in Files command supports two output panes. This allows you to co
nduct a second search through multiple files without losing the results from your fir
st search. Figure 4-6 shows the Find in Files dialog box. In the Find what box, type 
the search text. In the In files/file types box, select the file types you want to searc
h. You can use the drop-down list to select from common file types or to type text 
specifying other file types. In the In folder box, select the primary folder that you w
ant to search. Click the Browse button to display the Choose Directory dialog box if 
you want to change drivers and directories. If necessary, select one or more of the 
Find options. If you want to direct the search output to a second Find in Files pane,
 select the Output to pane 2 check box. Click the Find button to begin the search. 

The Output window displays the list of file locations where the text string appea
rs. Each occurrence lists the fully qualified filename, followed by the line number of 
the occurrence and the line containing the match. To open a file that contains a ma
tch, double-click the entry in the Output window. 



An editor window contains the file opens with the line contain the match selecte
d. You can jump to other occurrences of the text string by double-clicking the specif
ic entries in the Output window. 

When you jump to a found string location specified in the Output window, the c
orresponding source file is loaded if it is not already open in the editor. 

 

Figure 4-6 Find in Files Dialog Box 

  

4.4.3 Hex file Editor 

Embest IDE Hex file editor can open the HEX or  Bin format files, and read, mo
dify and save.  

Open file: when you open file with the menu File Open, drop down file type se
lect box and select Hex Files (*.hex,*.bin) to open the file.  

 

Fig. 4-7 Open Hex file dialog box 



Edit file: after open Hex file, the display in Source Program Window is shown i
n fig. 4-8. The user can directly modify the content of file in left Hex area. The edit
or will automatically identify ASCII characters and display in the right. As the same,
 the user can also directly input ASCII code in right ASCII area.   

 

Fig. 4-8 Hex file Editor in Source Program Window 

4.4.4 Find in Hex file 

Hex file editor supports the forward and back finding of ASCII character string a
nd Hex code. The user highlights Find in menu option to activate Find Dialog Box wi
th right key of mouse in Source Program Window, or activates it through Find optio
n in Edit menu:  

 

 

Fig. 4-9 Hex file finding interface 

The user can input Hex code while finding:  



 

Fig. 4-10 Hex file finding input dialog box 

The user can also input ASCII code while finding, and highlight Find ASCII optio
n:  

 

Fig. 4-11 Hex binary file finding input dialog box 

Hex file editor also supports copy, stick, cancel, print and print interview so that
 the user is easy to view Hex file.  

4.5 Function List Window of Source Program 

When users open C language or C ++ source file in editing window, source file f
unction listing window will dynamically display the function contained in the current 
source file, and user can select the display format of function through menu.  

Users can self-define the display mode of function in list: 

 display detailed information of function 

 only display function name 

 do not display function return style 

 do not display function call parameter 

4.5.1 Introduction 

Click the menu Tools > Options, select Extra Function Prototype in the ejected d
ialog box; the window Func can be found in workspace window; the function list cur
rently opening C/C++ program is shown in the window; double click the position of 
function name fast positioning function in source program. As shown in fig. 4-12. 



 

Fig 4-12  Dynamic list window of source program function 

Click right key in list window to select the display style of function. The ejected righ
t key menu is shown in fig. 4-13.  

 

Fig 4-13  Right key menu in dynamic list window of functions 

Introduction to main options of right key menu in dynamic list window of functions 

Whole Prototype: display all information concerning definition of function, incl
uding return type, function name, and parameter 

Func Name Only: Only display function name 

No Return Type: display function name, parameter of function definition 

No Parameters: display return type, function name of function definition 



V. Project Management  

5.1 Introduction 

The project facility is a key element of EmbestIDE. It provides graphical and aut
omated mechanisms for create applications that can be downloaded to target. A pro
ject consists of the source code files, build settings, and binary codes that are used
 to create a downloadable application. The project facility provides a simple means f
or define, modify, and maintain a variety of build options for each project. Each pro
ject requires its own directory. 

In EmbestIDE, the Project Workspace is a container for your development proje
cts. When you create a new project, a workspace is created at the same time. You 
can use the Project Workspace window to view and access the various elements of 
your projects. After you have created a project workspace, you can add new project
s, including independent projects.  

The workspace directory is the root directory for the project workspace. The pro
jects you add to the project workspace can be located on other paths, even on a dif
ferent drive. 

The project facility provides mechanisms for: 

◊ Organize the files that make up of a project. A project is a collection of sourc
e files, library files, and other input files. You can organize the files in a project in v
arious ways to provide a logical structure to your source files.  

◊ Group related projects into a workspace. 

◊ Define varied sets of build options. The project facility provides a simpler mea
n for configuration and building, a project settings dialog box enable you define targ
et processor, debug device, debug information, output file, compiling option, assem
ble option, linker option, and so an. 

◊ Build applications. A build toolbar is provided, which provides access to all th
e major build commands.  

◊ Download application objects to the target. 

This chapter describes many of the basic tasks involving projects, such as: 

◊ create projects 

◊ open projects 

◊ add files to projects 

◊ save projects 

◊ move files in the project window 

◊ configure projects    



5.2 GUI 

Figure 5-1 and figure 5-2 shows the operation menu about project management
 in file menu and project menu of EmbestIDE. 

          

Figure 5-1 File Menu                  Figure 5-2 Project Menu 

Operation about project management in file menu describes below: 

Table 5-1 Project Management in File Menu 

File menu Describe 

New Workspace… Create a new project, a workspace 

Open Workspace… Open a workspace and the projects in the workspace  

Save Workspace Save workspace and the projects in the workspace 

Close Workspace Close a workspace and the projects in the workspace 

Recent Workspace Open a recently used project workspace 

Table 5-2 describes the project menu. 

Table 5-2 Project Menus 

Project menu Describe 



Set Active Project Active a project 

Add To Project Insert file or folder into a project  

Settings… Configure the active project  

Workspace window is the project management window, click View>Workspace 
(shortcut: Alt+0) to hide or show workspace window. The workspace window shows
 information about the projects and the files in that project. The workspace window 
provides an outline view of project categories. The workspace Window is modeled af
ter the Microsoft Windows Explorer, it shows the relationships among the files includ
ed in the project workspace. The relationships in the project workspace are logical o
nes, not physical ones. It does not reflect the organization of files on your hard disk.
  

You can highlight every level folder in the Workspace window then right-click to
 invoke its pop-up menu. We will describe these menus following. 

To navigate the workspace window, use the vertical scroll bar on the right side 
of the window, or the Up and Down Arrow keys on your keyboard. If the workspace
 window contains many files, use the Home key to scroll to the top of the list, or us
e the End key to scroll to the end of the list. Use the Page Up and Page Down keys
 to scroll one page up or one page down the workspace window. 

Workspace directory is the root directory of project workspace. Every project co
nsists of several relative folders such as C Source Files, Assembly Source files, Link 
Files, Include Files. You can create new folder in the project. To do this, highlight th
e project file then choose Create New Folder from the shortcut menu, in the pop up
 new folder dialog box fill in the folder name you want to create. To delete the fold
er you created or the files you added just press Delete key.  

5.3 Operations  

5.3.1 Create a New Project 

When you first create a new project, a workspace is created at the same time. 

1) Click File>New Workspace, a dialog box pops up. 

 

Figure 5-3 Create a New Project 



2) Enter the new Project name and its path, and click  to browse the path. 

3) Click Ok button, a new project will be created, and a same name workspace
 will be created too. 

You can insert a new project into an existing project workspace too: 

1) Open the project workspace that you want to add a new project to. 

2) Highlight the root directory of the project workspace, right-click to invoke its
 pop-up menu, then Click “Add New Project to Workspace…”. 

3) Enter a new project name and its path on the dialog box.  

4) Click ok button. 

The new project that you just created becomes the default active project in the 
workspace. 

Notes: when a new workspace and project is created, two files with the same main file 
name and .ews and .pjf extend file name is created in the project saved path. The file 
with .ews extend file name is the workspace file. This file saved the workspace information. 
The file with .pjf extend file name is the project file, which saved the information about this 
project. You can’t edit these two files with manual method. 

  

5.3.2 Open a Project 

To open an existing project workspace: 

1) On the File menu, click Open Workspace. 

2) Select the driver and directory that contain the project workspace that you 
want to open. 

3) Select the .ews or .prj file for the project workspace from the File Name list
 and click OK.  

 

Figure 5-4 Opening a Project 

To reopen a recently used project workspace: 



On the File menu, click recent workspaces, and then click the name of the rece
ntly used workspace.  

5.3.3 Workspace Operation  

Workspace window displays and manages the files and projects in workspace wi
ndow. All source files in projects and all projects in workspace can be browsed intui
tively in workspace window. The top level catalogue of workspace displays current 
workspace name and project numbers in this workspace, the second level catalogue
 displays each project name, the third level catalogue displays source file name or s
ource file group name, the fourth level catalogue displays source file name. Source 
files can be divided into many groups according to file type. Default groups have ‘Pr
oject Source Files’ and ‘Project Header Files’. Group is a logic concept, not accordin
g to actual file directory, create group just for explicit manage source files.  

Each catalogue in workspace corresponds to different right mouse menu. 

The top level catalogue’s right mouse menu is workspace right mouse menu, sh
ow as follows figure:  

 

Figure5-5 Workspace Right Mouse Menu 

The operation of workspace right mouse menu is:  

Table5-3 Operation of The Top Level Catalogue’s Right Mouse Menu 

Menu Item Operation 

Add New Project to workspace… Create a new project into current workspace  

Insert Project into Workspace… Insert a existent project into current workspace  

Docking View Switch display mode of workspace window 

Hide Hide workspace window  

Properties Popup workspace’s property dialog box  

The second level catalogue’s right mouse menu is project right mouse menu, sh
ow as follows figure: 



 

Figure5-6 Project Right Mouse Menu 

The operation of project right mouse menu is: 

Table5-4 Operation of The Second Level Catalogue’s Right Mouse Menu 

Menu Item Operation 

Build Compile current active project 

New Folder… Create a new group into current project 

Add Files to Project… Add a file into current project  

Set as Active Project Set current project as active project  

Setting… Project setting management, detail see sect 3.3 

Docking View Switch display mode of workspace window 

Hide Hide workspace window 

Properties Popup workspace’s property dialog box 
 

The third level catalogue’s right mouse menu is file group right mouse menu, sh
ow as follows figure: 

 

 



Figure5-7 File Group Right Mouse Menu 

The operation of file group right mouse menu is: 

Table5-5 Operation of The Third Level Catalogue’s Right Mouse Menu 

Menu Item Operation 

Add Files to Folder… Add a file into current file group 

Docking View Switch display mode of workspace window 

Hide Hide workspace window 

Properties Popup workspace’s property dialog box 
 

The fourth level catalogue’s right mouse menu is file right mouse menu, show a
s follows figure: 

 

Figure5-8 File Right Mouse Menu 

 

The operation of file right mouse menu is: 

Table5-6 Operation Of The Fourth Level Catalogue’s Right Mouse Menu 

Menu Item Operation 

Open Open current file 

Compile Compile current file 

Docking View Switch display mode of workspace window 

Hide Hide workspace window 

Properties Popup workspace’s property dialog box 

User can convenient manage projects in workspace and files in projects through
 all level catalogue’s right mouse menu. If need delete something, just select that o
bject (such as workspace, file group, file etc), push 'Del' key. 



 

5.3.4 Save and Close Workspace  

If user want to save the change of workspace, just click menu 'File > Save Wor
kspace'. Save a workspace or project is not save concrete files in project or worksp
ace, it saves correlative file management information.  

Click menu 'File > Close Workspace' can close current workspace, EmbestIDE wi
ll auto check whether or not exist change after last workspace saves when closing 
workspace, if exist change, EmbestIDE will popup a hint dialog box to hint user whe
ther save change or not.  

 
Notes:When close workspace, just hide workspace window, not actual close 
workspace window.  

 

5.3.5 Set Active Project 

One workspace can contain several projects, but only one project can be active 
project, only active project can be build and debug. The active project’s icon will be
 in colorful. Show as in figure 5-9. 

 

Figure 5-9  right key set as current active project and it’s colorful icon 

If want to set a project as active project, select that project, right click mouse a
nd click 'Save as Active Project' in popup menu, show as in figure 5-9; or click men
u 'Project > Set Active Project', then select the project want to set active, show as i
n figure 5-10. 



 

Figure 5-10  set as current active project from menu bar 

5.4 Project Basic Configuration 

5.4.1 Processor Configuration  

Select menu 'Project > Settings…' will popup project setting dialog box. In projec
t setting dialog box, select ‘Processor’ property page, and user can configure CPU 
on target board. The dialog box show as following figure:  

 

Figure5-11 Processor Configuration Dialog Box 

CPU Module: select current CPU module, different CPU module will sustain differ
ent CPU series. Embest IDE has supported the core of ARM7 and ARM9 series proc
essor. 

CPU Family: select CPU series which user’s CPU belong to.  



CPU Member: select detail CPU type.  

Endian: set memory area byte order of user’s CPU is big endian or little endian.
  

Peripheral Maker: select the Maker of processor on the target board. 

Peripheral Chip: select the processor name on the target board. 

Build Tools: set compiler and linker which according to user’s CPU. 

5.4.2 Configure Emulator  

Select menu 'Project>Settings…' will popup project setting dialog box. In project
 setting dialog box, by select 'Remote' property page, user can figure emulator conn
ect setting. The dialog box show as following figure: 

 

Figure5-12 Emulator Configuration Dialog Box 

Remote device: select debug device, Embest Emulator for ARM is according to
 'jtagarm7', and Embest PowerICE for ARM is according to 'PowerICEARM7'. Series o
f ARM9 CPU, Embest Emulator for ARM is according to 'jtagarm9', and Embest Powe
rICE for ARM is according to 'PowerICEARM9'. Embest Simulator for ARM7 is accordi
ng to 'simarm7'. The information of current device will display on the pane. 

Speed: setting the Emulator work speed. Embest Emulator for ARM was worked
 at constant speed 25Kbyte per second, and Embest PowerICE for ARM was support
 to change the working speed valid: Full Speed(120Kbyte/s), High Speed, Medium S
peed, Low Speed. The valid work speed of Embest PowerICE for ARM show as follo
wing figure 5-13: 



 

Figure 5-13 Embest PowerICE for ARM work speed 

Communication type: select connect communication type which emulator conn
ect to host machine, such as Embest Emulator for ARM use parallel port connect, so
 select ‘PARALLEL’. 

Parallel Port: set according to actual connect. 

Note:Usually, Embest Emulator for ARM use parallel port mode, would be set 
EPP(0x278/0x378). 

 

5.5 ARM SDT and ADS project operation  

5.5.1 SDT software project opening 

Click menu item File > Open Workspace, and a dialog box will pop up for openi
ng workspace. Select file type ARM SDT Project, with the suffix for the software pro
ject file of SDT as apj, as shown in the following figure. 



 

Fig. 5-13 Open SDT project 

Select the SDT project file to be opened, press the open button to open the pro
ject. At the same time opening the SDT project, the integrated environment will aut
omatically generate the Embest IDE workspace and project file corresponding to the
 project, in which the name and number of the project files correspond to the varia
nt in the SDT project, as shown in the following figure.  

 

Fig. 5-14  Automatic generation of Embest IDE workspace and project file  

When the user opens the SDT project for the second time, the integrated enviro
nment will present a dialog box as shown in the following figure: 

 

Fig. 5-15  Prompt dialog box for the second time of opening the SDT project 



The user can select “Yes” to directly open the Embest IDE workspace that was a
utomatically generated during the first time of opening the SDT project. Or, he can 
select “No” to regenerate and open the Embest IDE workspace and project.  

Note: In opening the SDT project of Embest IDE, the user is in fa
ct finally opening the automatically generated Embest IDE worksp
ace after conversion. The follow-up configurations of the user will 
be directly saved in  the Embest IDE workspace and project. Ther
efore, if the user has performed new configuration and modificatio
n after opening the SDT project, Embest IDE workspace will be dir
ectly opened during the follow-up development process.  

The project interface opened by the ARM SDT software is illustrated in the follo
wing figure: 

 

Fig. 5-16  Project interface opened by the ARM SDT 

After conversion, the workspace interface of the project opened by the Embest I
DE is illustrated in the following figure: 



 

Fig. 5-17  Project interface opened by the ARM SDT 

During opening, the Embest IDE automatically deletes file folders that do not co
ntain any files in the SDT project. 

5.5.2 ADS software project opening  

Click menu item File > Open Workspace, and a dialog box will pop up for openi
ng workspace. Select file opening type ARM ADS Project, with the suffix for the soft
ware project file of ADS as mcp, as shown in the following figure. 

 

Fig. 5-18 Open ADS project 

Select the ADS project file to be opened, press the open button to open the pro
ject. At the same time opening the ADS project, the integrated environment will aut



omatically generate the Embest IDE workspace and project file corresponding to the
 project, in which the name and number of the project files correspond to the Targe
t in the SDT project, as shown in the following figure. 

 

Fig. 5-19  Automatic generation of Embest IDE workspace and project file 

When the user opens the ADS project for the second time, the integrated enviro
nment will present a dialog box as shown in the following figure: 

 

Fig. 5-20  Prompt dialog box for the second time of opening the ADS project 

The user can select “Yes” to directly open the Embest IDE workspace that was a
utomatically generated during the first time of opening the ADS project. Or, he can 
select “No” to regenerate and open the Embest IDE workspace and project. 

Note: In opening the ADS project of Embest IDE, the user is in fact fin
ally opening the automatically generated Embest IDE workspace after c
onversion. The follow-up configurations of the user will be directly save
d in the Embest IDE workspace and project. Therefore, if the user has 
performed new configuration and modification after opening the ADS pr
oject, Embest IDE workspace will be directly opened during the follow-u
p development process. 

The project interface opened under the ARM ADS software is illustrated in the fo
llowing figure: 



 

Fig. 5-21  Project interface opened by ARM ADS 

The workspace interface opened by the Embest IDE after conversion is illustrate
d in the following figure: 

 

Fig. 5-22  ADS project interface opened by Embest IDE 

5.5.3 Configuration after opening SDT or ADS project  

Default setting is applied to the processor and debugging equipment after the A
RM SDT or ADS project is opened by the Embest IDE, and users have to perform a
djustment according to the specific conditions.  

Adjusting processor configuration  

Select menu item Project > Settings… or use shortcut key Alt+F7, and a dialog 
box for project setting will pop up. Select processor setting dialog box in the project
 setting dialog box as shown in the following figure, and perform adjustment on the
 options in the blue elliptical box according to specific conditions. 



 

Fig. 5-23  Adjusting processor configuration in project setting dialog box  

Adjusting emulator configuration 
Select menu item Project > Settings…, and a dialog box for project setting will 

pop up. Select Remote setting dialog box in the project setting dialog box as shown
 in the following figure, and perform adjustment on the options in the blue elliptical
 box according to specific conditions. 

 

 

Fig. 5-24  Adjusting emulator configuration in project setting dialog box 

Library file path setting  

After the Embest IDE opens the SDT or ADS project, the default complier will b
e ARM complier. If the user links library files in the software project, he has to man
ually set the library file path.  



Select menu item Project>Settings…, and a dialog box for project setting will po
p up. In the dialog box for project setting, select Linker setting dialog box, select th
e Information Options, and search the path for setting library files according to spec
ific conditions, as shown in the following figure. 

 

Fig. 5-25 Setting searching path for object file 



VI. Project Configuring & Building  

6.1 Build Tools Introduction(by Embest IDE) 

The build module is a visual interface to conFigure  a project and build the targe
t program. The following Project Settings dialog box handles settings that affect h
ow the EmbestIDE builds a specific target file within a project. 

Because several cross-compilers can integrate with the plug-in technique, you m
ust select a compiler for each project before build the target. Show as Figure  6-1,
 in the Processor page of Project Settings dialog box, the Build Tools should be sel
ected before the further conFigure . 

Build Tools that Embest IDE project sets up selects and includes GNU Tools for
 ARM or ARM Build Tools, namely can compatible GNU compiling Tools and AR
M compiling Tools. 

 

Figure  6-1-1 Project Settings Dialog 

Figure  6-1-1 shows an example of project settings. The selected Build Tools for
 project led_swing is GNU Tools for ARM.  

Note:If the Build Tools is not conFigure d for a project, its property pages of compiler, 
assembler and linker will not be displayed. And the prompt information—“No build 
configuration for project: xxxx” —will be displayed in the build pane, as you build it at 
this moment. 

 



6.2 GNU Tools for ARM  

It is one that GNU Tools for ARM compiles and selects the compiling device is set 

up GCC cross-compiler of ARM processor specially; GNU Tools for ARM is the free 

software; GNU Tools for ARM is a dedicative cross-compiler for ARM processor, created 

from GNU source code. It mainly includes C/C++ compiler, assembler, linker, 

standard libraries for embedded system and other tools.  

6.2.1 Files Type and Compiler 

Which application of the cross-compiler will be invoked by EmbestIDE to handle 
a source file lies on its postfix. Table 6-2-1 shows each postfix and its relevant appl
ication. 

Table 6-2-1 

Postfix Application of Cross-Compiler 

*.c C Compiler 

*.C, *.S C++ Compiler 

*.cpp C++ Compiler 

*.cc C++ Compiler 

*.cp C++ Compiler 

*.c++ C++ Compiler 

*.cxx C++ Compiler 

*.s Assembler 

*.asm Assembler 

Files type of GNU tools chain shows as Table 6-2-2. 

Table 6-2-2 

Files  Files Type 

file.stuf source files of GNU  

file.h/.inc/.a head file 

file.o ELF formation target file 

file.elf ELF formation debugging file 

  



stuf stand for *.c/C, *.cpp/C++, *.s/asm, are the source files which can compil
ing or assembling by GNU tools chain(Note: it is permitted that there is the blank 
within the filename or directory.) 

 

 

6.2.2 Options for Compiler 

The Compiler property page, as in the Figure  6-3, is used to conFigure  the co
mpile options for C/C++ compiler of GNU Tools for ARM cross-compiler, All the opti
ons user selected are displayed in the Compile Options edit box with the following f
ormat: 

[Opt-1] [Opt-2] … $(SOURCE_FILE) … [Opt-n] … -o[Path]$(OBJ_FILE) 

 
Note: You can input or modify the options manually in the edit box, but the blank character 

between each option must be reserved, and the macros $(SOURCE_FILE), $(OBJ_FILE) 
should not be deleted or modified. $(SOURCE_FILE) means the source file to be compiled, 
$(OBJ_FILE) means the output of the compiling. There will be replaced with the actual file 
name by the EmbestIDE at the time of building. 

 
Note: When you conFigure a project setting, you should consider that the location of the project 
file (*.pjf) is the current directory. 

 

 

Figure  6-2-1 Compiler General Settings 

Show in Figure  6-3, compiler options are divided into five Categories: 

• General 



• Warning Options 

• Debug/Optimization 

• Target Specific Options 

• Code Generation Options 

  

Note: All this compiler options are also compiled in the document “Program Reference”, and 
explained more detailed. 

 

General  Cluster Description 

Include Directories Add <dir> to the end of the main include paths 

Object file location The location of the compile outcome will be placed, and no 

blank character can be included. 

If not exist, EmbestIDE create it automatically.  

Preprocessor Definitions Define macros, each macro separated by comma and with blank 

character. 

 

1. Warning Options 

 

Figure  6-2-2 Compiler Warning Options 



Warning Options  Cluster Description 

Suppress Warnings -w, Inhibit warning messages 

A variable is unused -Wunused, Warn when a variable is unused 

Unqualified pointer cast -Wcast-qual, Warn about cast which discard 

qualifiers 

Incompatible func cast -Wbad-function-cast, Warn about casting 

functions to incompatible types 

Confusing type conversions -Wconversion, Warn about possibly confusing 

type conversions  

Inlined function cannot be inlined -Winline, Warn when an inlined function cannot 

be inlined 

One local variable shadows another -Wshadow, Warn when one local variable 

shadows another 

Automatic variables are uninitialized -Wuninitialized, Warn about uninitialized 

automatic variables 

Alignment increased when pointer cast -Wcast-align, Warn about pointer casts which 

increase alignment 

Trigraphs encountered -Wtrigraphs, Warn when trigraphs are 

encountered 

Missing Declarations -Wmissing-declarations, Warn about global 

functions without previous declarations 

ANSI C extension -pedantic, Issue warnings needed by strict 

compliance to ANSI C 

 



2. Debug/Optimization 

 

Figure  6-2-3 Compiler Debug/Optimization 

Debug/Optimization  Cluster Description 

Generate default debug format output -g 

Generate DWARF-1 format debug output -gdwarf  

Generate DWARF-2 debug output -gdwarf-2 

Generate extended DWARF-1 format debug output -gdwarf+ 

Optimization Options -O[number]/-Os, Set Optimization level 

to [number]/Optimize for space rather 

than speed 

 



3. Target Specific Options 

 

Figure  6-2-4 Compiler Target Specific Options 

Target Specific Options  Cluster  Description 

ARM only(Default) Generate ARM instructions 

ARM interworking -mthumb-interwork, Generate ARM 

instructions supporting calls between 

THUMB and ARM instructions sets 

Thumb only -mthumb, Generate THUMB Instructions 

Thumb interwork -mthumb –mthumb-interwork, Generate 

THUMB instructions supporting calls 

between THUMB and ARM instructions 

Little endian mode(Default) -mlittle-endian, Assume target CPU is 

conFigure d as little endian 

Big endian mode -mbig-endian, Assume target CPU is 

conFigure d as big endian 

Hardware FP instructions -mhard-float, Use hardware floating point 

instructions 



Lib call for FP operations -msoft-float, Use library calls to perform 

FP operations 

Use the 26bit version of APCS -mapcs-26, Use the 26bit version of APCS

Generate APCS conformant stack frames -mapcs-frame, Generate APCS 

conformant stack frames 

Specify the name of the target CPU Specify the name of the target CPU 

 

4. Code Generation Options 

 

Figure  6-2-5 Compiler Code Generation Options 

Code Generation Options  Cluster Description 

Compile just for ANSI C -ansi, Compile just for ANSI C 

Use the same size for double as for float -fshort-double, Use the same size for 

double as for float 

Use the smallist fitting integer to hold enums -fshort-enums, Use the smallest fitting 

integer to hold enums 

Pretend that host and target use the same FP format -fpretend-float, Pretend that host and 

target use the same FP format 



Do not recognize any built-in functions -fno-builtin, Do not recognize any built 

in functions 

Do not search the system include directories -nostdinc, Do not search the system 

include directories 

Do not put uninitialized globals in the common section -fcommon, Do not put uninitialised 

globals in the common section 

 

6.2.3 Options for Assembler 

The Assembler property page, as in the Figure  6-8, is used to conFigure  the a
ssembling options for assembler of GNU Tools for ARM cross-compiler, All the option
s user select are displayed in the Assemble Options edit box with the following form
at: 

 [Opt-1] [Opt-2] … $(SOURCE_FILE) … [Opt-n] … –o[Path]$(OBJ_FILE) 

 
Note: You can input or modify the options manually in the edit box, but the blank 

character between each option must be reserved, and the macros $(SOURCE_FILE), 
$(OBJ_FILE) should not be deleted or modified. $(SOURCE_FILE) means the 
source file to be compiled, $(OBJ_FILE) means the output of the assembling. There 
will be replaced with the actual file name by the Embest IDE at the time of building. 

 

 

Figure  6-2-6 Assembler General Settings 

Show in Figure  6-2-6, assembler options are divided into four Categories: 



• General 

• Code Generation 

• Target Specific Options 

• Warning Options 

 

Note: All this assembler options are also compiled in the document “Program 
Reference”, and explained more detailed. 

 

General  Cluster Description 

Include Directories -I<dir>, Add dir to search list for include directories 

Object file location The location of the assembling outcome will be placed, and 

no blank character can be included. 

If not exist, Embest IDE create it automatically. 

Preprocessor Definitions Define macros, each macro separated by comma and with 

blank character. 

 
1. Code Generation Options 

 

Figure  6-2-7 Assembler Code Generation Options 

 



Code Generation  Cluster Description 

Generate DWARF-2 debugging information -gdwarf2 

Generate listing file -a 

Keep local symbols -L 

Assemble in MRI compatibility -M 

Strip local absolute symbols --strip-local-absolute 

 
2. Target Specific Options 

 

Figure  6-2-8 Assembler Target Specific Options 

 

Target Specific Options  Cluster  Description 

Allow any instruction(Default) -mall 

Only allow thumb instructions -mthumb 

Make the assembled code as support interworking -mthumb-interwork 

Little endian mode(Default) -EL, Assemble code for a little endian cpu 

Big endian mode -EB, Assemble code for a big endian CPU 

Use the 32bit APCS -mapcs-32 

Use the 26bit APCS -mapcs-26 



Fpa10 FP architecture -mfpa10 

Fpa11 FP architecture -mfpa11  

No FP multiple instructions -mfpe-old 

No FP instructions -mno-fpu 

The code is position independent or reentrant -mapcs-reentrant 

3. Warning Options 

 

Figure  6-2-9 Assembler Warning Options 

 

Warning Options  Cluster Description 

Suppress Warnings -W 

Do not warn about signed overflow -J 

Warn when differences altered for long 

displacements 

-K 

 
 
 

6.2.4 Options for Linker 

The linker property page, as in the Figure 6-12, is used to configure the link opt
ions for linker of GNU Tools for ARM cross-compiler, All the options user select are 



displayed in the Link Options edit box with the following format as the output file is
 executable: 

 [Opt-1] … –o[Path]$(TARGET_NAME) $(OBJ_FILES) [Lib-1] … 

The $(TARGET_NAME) is a macro for executable file name, $(OBJ_FILES) is also 
a macro for the collection of all object files to be linked. 

As the target file is a library, the format of the options is: 

[Opt-1] … $(TARGET_NAME) $(OBJ_FILES) [Lib-1] … 

The $(TARGET_NAME) is a macro for library name. 

 

Note: You can input or modify the options manually in the edit box, but the blank character 
between each option must be reserved, and the macros $(TARGET_NAME), $(OBJ_FILES) 
should not be deleted or modified. There will be replaced with the actual file name by the 
Embest IDE at the time of building.  
 
Note: $(TARGET_NAME) will be replaced with the default that consists of project name and 
postfix, elf or lib. 
 
Note:Macro $(<entry.o>OBJ_FILES), for example, means that the file entry.o is the first 
object file in the collection of all object files to be linked. 

 

Show in Figure  6-2-10, linker options are divided into five Categories: 

• General 

• Image Entry Options 

• Code Generation Options 

• Include Object and Library Modules 

• Add Library Searching Path 

 



1. Linker General Settings 

 

Figure  6-2-10 Linker General Settings 

General  Cluster Description 

Executable file The output file is an executable file 

Library The output file is a library 

Linker script file The link script file 

Output file name The file name of output file 

 
2. Image Entry Options 

 



Figure  6-2-11 Linker Image Entry Options 

Image Entry Options  Cluster  Description 

Select entry file The collection of all object files to be linked is displayed in a list 

box, and you can select one as the first object file to be linked. 

Image entry point -e<address/symbol>, The entry point of the executable target. 

 
Note: Image Entry Options  Cluster can be set while the output file is executable. 

 
 
 

3. Code Generation Options 

 

Figure  6-2-12  Linker Code Generation Options 

Code Generation Options  Cluster Description 

Generate relocateable output -r, Generate relocateable output 

Optimize output file -O1, Optimize output file 

Do not link against shared libraries -static, Do not link against shared libraries 

Output lots of information during link -verbose, Output lots of information during link 

Warn about common symbols --warn-common, Warn about duplicate common symbols 

Warn only once per undefined symbol --warn-once, Warn only once per undefined symbol 

Link little-endian object -EL, Link little-endian objects 



Link big-endian object -EB, Link big-endian objects 

Strip all symbols -s 

Strip debugging symbols -S  

Discard all local symbols -x 

 
Note: Code Generation Options  Cluster can be set while the output file is executable. 

4. Include Object and Library Modules 

 

Figure  6-2-13  Linker Include Object and Library Modules 

Include Object and Library Modules Description 

Library or Object Modules The libraries that should be linked against 

 

5. Add Library Searching Path 



 

Figure  6-2-14 Linker Add Library Searching Path 

Add Library Searching Path  Description 

Library Searching Directories -L<Directory>, Add directory to library search path 

 
Note: Add Library Searching Path can be set while the output file is executable. 

 
 
 
 
 
 

Note: The detailed descriptions of all the options of GNU Tools for ARM cross-compiler can 
be found in <<Embest IDE Program Reference>> 

 
 

6.3 ARM Build Tools  

ARM Build Tools is a dedicative cross-compiler for ARM processor, created from 
ARM source code. It mainly includes C/C++ compiler, assembler, linker, standard li
braries for embedded system and other tools. 



Compiling device supported in Embest IDE compatible SDT 2.51 edition at present, 

this edition compiles and chains tools including ARM C/C ++ compiling device 

Abbreviated as ARMCC , ARM collecting device ( abbreviated as ARMASM ) and ARM 

chaining device(abbreviate as ARMLINK). 

6.3.1 ARM Build Tools and Files 

Which application of the cross-compiler will be invoked by EmbestIDE to handle 
a source file lies on its postfix. Table 6-3-1 shows each postfix and its relevant ap
plication. 

Table 6-3-1 

Postfix Application of Cross-Compiler 

*.c C Compiler 

*.C C++ Compiler 

*.cpp C++ Compiler 

*.cc C++ Compiler 

*.cp C++ Compiler 

*.c++ C++ Compiler 

*.cxx C++ Compiler 

*.s Assembler 

*.asm Assembler 

Files type of ARM tools chain shows as Table 6-3-2. 

Table 6-3-2 

Files  Files Type 

file.stuf source files of ARM  

file.h/.inc/.alf head file 

file.o ELF formation target file 

file.elf ELF formation debugging file 

  

stuf stand for *.c/C, *.cpp/C++, *.s/asm, are the source files which can compil
ing or assembling by ARM tools chain(Note: it is permitted that there is the blank 
within the filename or directory.) 

 



6.3.2 ARM Complier options setting  

The complier attribute tab of the ARM Build Tools complier is illustrated in Fig. 6
-3. There are altogether 7 categories of list (namely, setting option), namely, Gener
al, Target Specific, Warning Options, Error Handling, Debug & Optimization, Code G
eneration and Include Paths. The various configuration options are used for ARMCC 
complier. All the settings of the user will be displayed in the Compile Option edit bo
x in the form of command line switch options. When it is the first time for a new pr
oject to select ARM Build Tools, the system will provide the complier’s default settin
g. 

 

Fig. 6-3-1  Project complier setting and category options list 



General 

 

Figure 6-3-2   settings of General 

shows as Figure 6-3-1, in the Compiler dialog window, click the Category drawin
g menu, select the option in the Source dialog window, the definition as following: 

General  Cluster Description 

Compiler instruction format of the Target file 

ARM      supports ARM code 

Thumb  supports Thumb code 

Source source fiiles type   

Portable C compiler C -pcc, Compiles (BSD 4.2) Portable C compiler C. This 

dialect is based on the 

original Kernighan and Ritchie definition of C, and is 

the one used to build UNIX systems. The -pcc option 

alters the language accepted by the compiler, however 

the built-in ANSI C headers are still used. See also, the 

-zc option in Controlling code generation.The -pcc 

option alters the language accepted by the compilers in 

the following ways: 



 char is signed 

 sizeof is signed 

 an approximation of early UNIX-style C 

preprocessing is used. 

Strict Portable C compiler 

C[BSD4.2] 

-pcc –strict, is extra strict about enforcing conformance 

to the ANSI C standard, Draft C++ standard, or PCC 

conventions. For example, in C++ mode the following 

code gives an error when compiled with -strict and a 

warning without:  

static struct T {int i; }; 

Because no object is declared, the static is spurious. In a 

strict reading of the C++ Draft Standard, it is illegal. 

ANSI/ISO standard C -ansi, Compiles ANSI standard C. This is the default for 

armcc 

Strict ANSI/ISO standard C[ANSI 

X3.159] 

-ansi –strict 

Object file locations settings the directory to store object file(s)  

Preprocessor Definitions Defines symbol as a preprocessor macro, as if the 

following line were at 

the head of the source file: #define symbol [value] This 

option can be repeated. 



 

Target Specific 

 

Figure 6-3-3  settings of Target Specific 

shows as Figure 6-3-1, in the Compiler dialog window, click the Category drawin
g menu, select Target Specific, the definition of compile as following: 

Target Specific Cluster Description 

Little Endian -li, instructs suitable for Little Endian ARM 

Big Endian -bi, instructs suitable for Big Endian ARM 

Processor instruction code support by processor  

Architecture -arch, sets the target architecture. Some 

processor-specific instructions produce either errors or 

warnings if assembled for the wrong target 

architecture. See also the -unsafe assembler option. 

Valid values for architecture 

are 3, 3m, 4, 4T, 4TxM. 

Float point processor -fpu, select the target FPU, where name is one of: 

none  No FPU. Use software floating point library. 

This option implies /softfp. 



fpa  Floating Point Accelerator. This option implies 

/hardfp. 

Software stack check -apcs /swst, specifies that the code in inputfile carries 

out software 

stack checking. 

Frame pointer -apcs /fp, specifies that the code in inputfile uses a 

frame pointer. 

This option is obsolete and is provided for backwards 

compatibility only. 

FP arguments passed in FP register (selected) specifies that the code in inputfile does not 

use a frame pointer. This is the default. 

ARM/Thumb interworking -apcs /inter, specifies that the code is suitable for 

ARM/Thumb interworking. This option has the same 

effect as specifying the INTERWORK attribute for all 

code areas in the source files to be assembled. Refer to 

the ARM Software Development Toolkit User Guide 

for more information on ARM/Thumb interworking. 



 

Warning Options 

 

Figure 6-3-4  settings of Warning Options 

shows as Figure 6-3-1, in the Compiler dialog windows, click the Category drawi
ng menu to set the warning information of the compile. 

The compiler issues warnings to indicate potential portability problems or other 
hazards. The compiler options described below allow you to turn specific warnings o
ff. 

For example, you may wish to turn warnings off if you are in the early stages o
f porting a program written in old-style C. The options are on by default, unless spe
cified otherwise. See also Specifying additional checks on page 2-32 for descriptions
 of additional warning messages. 

The general form of the -W compiler option is: 

-W[ options][+][ options] 

where options are one or more characters. 

If the + character is included in the characters following the -W, the warnings c
orresponding to any following letters are enabled rather than suppressed. 

You can specify multiple options. For example: 

-Wad+fg 

turns off the warning messages specified by a, d, and turns on the warning mes
sage specified by f and g. 

Following description for the Warning Options shows in Figure  6-3-4: 



Warning Options  Cluster Description 

No Warnings -W, suppresses all warnings. If one or more letters follow 

the option, only the warnings controlled by those letters 

are suppressed. 

Implicit narrowing cast -W+n Suppresses the warning message: 

implicit narrow cast 

This warning is issued when the compiler detects the 

implicit narrowing of a long expression in an int or char 

context, or the implicit narrowing of a floating-point 

expression in an integer or narrower floating-point context. 

Such implicit narrowing casts are almost always a source 

of problems when moving code that has been developed 

on a fully 32-bit system (such as ARM C++) to a system in 

which integers occupy 16 bits and longs occupy 32 bits. 

This is suppressed by default. 

Header file not guarded -W+g, Suppresses the warning given if an unguarded 

header file is #included. 

This warning is off by default. It can be enabled with 

-W+g. An unguarded header file is a header file not 

wrapped in a declaration such as: 

#ifdef foo_h 

#define foo_h 

/* body of include file */ 

#endif 

Non-ANSI header -W+p, Suppresses the warning message: 

non-ANSI #include <…> 

The ANSI C standard requires that you use #include <…> 

for ANSI C 

headers only. However, it is useful to disable this warning 

when compiling code not conforming to this aspect of the 



standard. This option is suppressed by default, unless the 

-fussy option is specified. 

C++ incompatibility -W+u, For C code, suppresses warnings about future 

compatibility with C++ for both armcpp and tcpp. This 

option is off by default. It can be enabled with -W+u. 

Char/short bitfields -Wb, Suppresses the warning message: 

ANSI C forbids bit field type ’type’ where ’type’ is 

char or short. 

Lower precision in wider content -W+l, Lower precision in wider context. This warning 

arises in cases like: 

long x; int y, z; x = y*z 

where the multiplication yields an int result that is then 

widened to long. This warns in cases where the destination 

is long long, or where the target system defines 16-bit 

integers or 64-bit longs. This option is off by default. It can 

be enabled with -W+l.  

Padding inserted in struct -Ws, Warns when the compiler inserts padding in a 

struct. This warning is off by default. It can be enabled 

with -W+s. 

‘=’ in condition -Wa, Suppresses the warning message: 

Use of the assignment operator in a condition context 

This warning is given when the compiler encounters a 

statement such as: 

if (a = b) {... 

where it is possible that: 

if ((a = b) != 0) {... 

was intended, or that: 

if (a == b) {... 

was intended. This warning is suppressed by default in 

PCC mode. 



Multiple character read as int -Wm 

Unused declaration -Wx, Disables not used warnings such as: 

Warning: function ‘foo’ declared but not used 

 

Note: User can input the warning switch(s) directly in  Compiler options 

 

Error Handling 

 

Figure 6-3-5  settings of Error Handling 

shows as Figure 6-3-1, in the Compiler dialog window, click the Category drawin
g menu, select Error Handling, the definition of close and down lever in the compile
 error information compiler as following: 

The compiler issues errors to indicate that serious problems exist in the code it 
is attempting to compile. 

The compiler options described below allow you to: 

 turn specific recoverable errors off 

 downgrade specific errors to warnings. 

The general form of the -e compiler option is: 

-e[ options][+][ options] 

where options are one or more of the letters described below. 



If the + character is included in the characters following the -e, the errors corre
sponding to any following letters are enabled rather than suppressed. 

You can specify multiple options. For example: 

-eac 

turns off the error messages specified by a and c 

Following description for the Warning Options shows in Figure 6-3-5: 

Error Handling Cluster Description 

Junk at end of #end/#else/#undef -Ep, Suppresses the error that occurs if there are extraneous 

characters at the 

end of a preprocessor line. This error is suppressed by default in 

PCC mode. 

Implicit pointer cast -Ec, Suppresses all implicit cast errors, such as implicit casts of 

a non-zero 

int to pointer. 

Other doblous cast -Ef, Suppresses errors for unclean casts, such as short to pointer.

Linkage conflict -El, Suppresses errors about linkage disagreements where 

functions are 

implicitly declared extern and later defined as static. This option 

applies to C++ only. 

Zero-length array -Ez, Suppresses the error that occurs if a zero-length array is 

used. 

Access control violation -E+a, This option applies to C++ only. Downgrades access 

control errors to 

warnings. For example: 

class A { void f() {}; }; // private member A a; 

void g() { a.f(); } // erroneous access 

Implicit “int” type -E+I, Downgrades constructs of the following kind from errors 

to warnings. 

For example: 

const i; 

Error: declaration lacks type/storage-class (assuming ‘int’): ’i’



This option applies to C++ only. 

 

Debug & Optimization 

 

Figure 6-3-6    settings of Debug & Optimization 

shows as Figure 6-3-1, in the Compiler dialog window, click the Category drawin
g menu, select Debug * Optimization, the definition as following: 

Debug & Optimization Cluster Description 

dwarf 1 -dwarf1, Use DWARF1 debug table format. This option is not 

recommended for C++. 

If DWARF1 debug tables are generated and a procedure call 

standard that does not use a frame-pointer register is used (always 

the case with Thumb, and the default with ARM), local variables 

that have been allocated to the stack cannot be displayed by the 

debugger. In addition, stack backtrace is not possible. 

dwarf 2 -dwarf2, to select DWARF2 debug tables. This is the default and is 

selected if -g with no dwarf option is specified. This is the default. 

asd (obsolete) -asd, Use ASD debug table format. This option is obsolete and is 

provided for 



backwards compatibility only. 

Enable debug table generation -g, instructs the assembler to generate debug tables. Use the 

following command-line options to control the behavior of -g: 

-dwarf to select DWARF1 debug tables. This option is obsolete. 

Use 

-dwarf2 or -dwarf1. 

-dwarf1 to select DWARF1 debug tables. This option is not 

recommended for C++. 

-dwarf2 to select DWARF2 debug tables. This is the default and is 

selected if -g with no dwarf option is specified. 

Include preprocessor symbol Not use 

Default balance If neither -Otime or -Ospace is specified, the compiler uses a 

balance between the two. You can compile time-critical parts of your 

code with -Otime, and the rest with -Ospace. You should not specify 

both –Otime and -Ospace at the same time. 

For space -Ospace, Optimize to reduce image size at the expense of increased 

execution time. 

For example, large structure copies are done by out-of-line function 

calls 

instead of inline code. 

For time None  -Otime, Optimize to reduce execution time at the expense of a larger 

image. For 

example, compile: 

while ( expression) body…; 

as: 

if ( expression) { 

do body…; 

while ( expression); 

} 

None(best debug view) -O0, Turn off all optimization, except some simple source 



transformations. This is the default optimization level if debug 

tables are generated with -g+. It gives the best debug view and the 

lowest level of optimization. 

Most (good debug view good code) -O1, Turn off the following optimizations: 

 structure splitting 

 range splitting 

 cross-jumping 

 conditional execution. 

If this option is specified and debug tables are generated with -g+ it 

gives a satisfactory debug view with good code density. 

All (poor debug view best code) -O2, Generate fully optimized code. If used with -g+, this option 

produces fully optimized code that is acceptable to the 

debugger, though the mapping of object code to source code is 

not always clear. 

This is the default optimization level if debug tables are not 

generated. 

 

Code Generation 

 



Figure 6-3-7  settings of Code Generation 

shows as Figure 6-3-1, in the Compiler dialog window, click the Category drawin
g menu, select Code Generation, the definition of the compiler output target files as
 following: 

Code Generation Cluster Description 

Read-only literal string -fw, Allows string literals to be writable, as expected by some UNIX 

code, by allocating them in the program data area rather than the 

notionally read-only code area. This also stops the compiler reusing 

a multiply occurring string literal. 

Play char always signed -zc, Make char signed. It is normally unsigned in C++ and ANSI C 

modes, 

and signed in PCC mode. The sign of char is set by the last option 

specified that would normally affect it. For example, if you specify 

both 

the -ansic and -zc options and you want to make char signed in 

ANSI 

C mode, you must specify the -zc option after the -ansic option. 

One AOF area per function -zo, Generates one AOF area for each function. This can result in 

increased 

code size. Normally the compiler generates one AOF function for 

each C 

compilation unit, and at least one AOF function for each C++ 

compilation unit. 

This option enables the linker to remove unused functions when the 

-remove linker option is specified. 

Enum container always int -fy, Treats enumerations as signed integers. This option is off by 

default (no forced integers). 

Inline SWIs may overwrite the Link -fz, Instructs the compiler that an inline SWI may overwrite the 

contents of the link register. This option is usually used for modules 

that run in 



Supervisor mode, and that contain inline SWIs. You must use this 

option 

when compiling code that contains inline SWIs. 

Access word only from word aligned -za0/1, Specifies whether LDR may only access word-aligned 

addresses. Valid values are: 

-za0  LDR is not restricted to accessing word-aligned addresses. 

This 

is the default. 

-za1 LDR may only access word-aligned addresses. 

Max integer load -zi2, The compiler selects a value for the maximum number of 

instructions allowed to generate an integer literal inline before using 

LDR rx,= value on the basis of the -Otime, -Ospace, and -processor 

options. 

You can alter this behavior by setting Number to an integer between 

1 and 

4. Lower numbers generate less code at the possible expense of 

speed, depending on your memory system. The effect of altering 

this value is small, and is usually not significant. 

Max LDM regs -zr16, Limits the number of register values transferred by load 

multiple and 

store multiple instructions generated by the compiler to Number. 

Valid values for Number are 3 to 16 inclusively. The default value is 

16. 

You can use this option to reduce interrupt latency. Note that the 

inline 

assembler is not subject to the limit imposed by the -zr option. 

The Thumb compiler does not support this option.  

Top-level static object -zat4, Specifies the minimum byte alignment for top-level static 

objects, suchas global variables. Valid values for Number are:1, 2, 

4, 8  



The default is 4 for the ARM compilers and 1 for the Thumb 

compilers. 

Min. struct -zas4, Specifies the minimum byte alignment for structures. Valid 

values for Number are: 1, 2, 4, 8 

The default is 4 for both ARM and Thumb compilers. This allows 

structure copying to be implemented more efficiently by copying in 

units of words, rather than bytes. Setting a lower value reduces the 

amount of padding required, at the expense of the speed of structure 

copying. 

Pointer to structs aligned to minimum 

struct alignment 

Specifies whether pointers to structures are assumed to be aligned 

on at least the minimum byte alignment boundaries, as set by the 

-zas option. Valid values are: 

-zap1 Pointers to structures are assumed to be aligned on at least the 

minimum byte alignment boundaries set by -zas. This is the default. 

-zap0  Pointers to structures are not assumed to be aligned on at 

least the minimum byte alignment boundaries set by -zas. Casting 

short[ ] to struct {short, short,...} does not cause a problem. 

 
Include Paths 

 



Figure 6-3-8  settings of Include Paths 

shows as Figure 6-3-1, in the Compiler dialog window, click the Category drawin
g menu, set the search folder of the user define head files and the ANSI lib head f
iles compiler, definition as following: 

Include Paths Cluster Description 

Include Directories -i<dir> , adds directories to the source file search path so 

that arguments to GET/INCLUDE directives do not need 

to be fully qualified.  

ANSI Header -j,  Adds the specified comma-separated list of directories 

to the end of the search path, after all directories specified 

by -I options. Use -j- to search the in-memory file system. 

 

 

Compile Options Window 

The Compiler property page, as in the figure 6-3-1, is used to configure the co
mpile options for C/C++ compiler of ARM Build Tools cross-compiler, All the options
 user selected are displayed in the Compile Options edit box with the following form
at: 

[Opt-1] [Opt-2] …–o[Path]$(OBJ_FILE) … [Opt-n] …$(SOURCE_FILE) 

Note: You can input or modify the options manually in the edit box, but the blank 
character between each option must be reserved, and the macros $(SOURCE_FILE), 
$(OBJ_FILE) should not be deleted or modified. $(SOURCE_FILE) means the 
source file to be compiled, $(OBJ_FILE) means the output of the compiling. There 
will be replaced with the actual file name by the EmbestIDE at the time of building. 

 
Note: When you configure a project setting, you should consider that the location of the 
project file (*.pjf) is the current directory. 

 

shows as Figure 6-3-1, the Switch and meaning of the command in the Compile
 Options Window: 

Switch Description 

-O0 Turn off all optimization, except some simple source 

transformations.  

-dwarf1 Compile output file by dwarf1 format 

-g+ The target file include debug information figure(Function as 



–g) 

-l..\common\ Use the common file folder which in the project base forward 

folder as the search catalog of head files 

-o .\Debug\$(OBJ_FILE) Compile output target file to the Debug folder 

-c Only compile C language program without link 

$(SOURCE_FILE) Compile all source files of the active project  

 

 

6.3.3 ARM Assembler options setting 

The Assembler attribute tab of the ARM Build Tools complier is illustrated in Fig.
 6-3-9. There are altogether 6 categories of list (namely, setting option), namely, G
eneral, Target Specific, Call Standard Options, Debug Options, Predefines and Listin
g Options. The various configuration options are used for ARMASM complier. All the 
settings of the user will be displayed in the Assemble Options edit box in the form 
of command line switch options. When it is the first time for a new project to select
 ARM Build Tools, the system will provide the complier’s default setting. 

 

Fig. 6-3-9  Project complier setting and category options list 



General 

 

Figure 6-3-10 settings of General 

shows as Figure 6-3-9, In the Assembler dialog window, click the Category  dra
wing menu, choose General, the search and assembler output file folder of  the hea
d source files, definition as following: 

General  Cluster Description 

Include Directories -i<dir> , adds directories to the source file search path 

so that arguments to GET/INCLUDE directives do not 

need to be fully qualified. 

Object files location settings the directory to store object file(s) 

 



 

Target Specific 

 

Figure 6-3-11 settings of Target Specific 

shows as Figure 6-3-9, In the Assembler dialog window, click the Category  dra
wing menu, choose Target Specific, the definition  of the assembler target file, defin
ition as following: 

Target Specific Cluster Description 

Little Endian -li, instructs suitable for Little Endian ARM 

Big Endian -bi, instructs suitable for Big Endian ARM 

Processor instruction code support by processor  

Architecture -arch, sets the target architecture. Some processor-specific 

instructions produce either errors or warnings if assembled 

for the wrong target architecture. See also the -unsafe 

assembler option. Valid values for architecture 

are 3, 3m, 4, 4T, 4TxM. 

Float point processor -fpu, select the target FPU, where name is one of: 

none  No FPU. Use software floating point library. This 

option implies /softfp. 



fpa  Floating Point Accelerator. This option implies 

/hardfp. 

Initial State instruction format of the Target file 

ARM      supports ARM code 

Thumb  supports Thumb code 

 

Call standard Options 

 

Figure 6-3-12 settings of Call standard Options 

shows as Figure 6-3-9, In the Assembler dialog window, click the Category  dra
wing menu, choose Call Standard Options, the attributes of  the procedure calling in
 cross compile ,definition as following: 

Call Standard Options  Cluster Description 

Call Standard -apcs none/3, specifies whether you are using the 

ARM Procedure Call Standard or not, and may 

specify some attributes of code areas. User Guide 

for more information. 

none specifies that inputfile does not use APCS. 

APCS registers 



are not set up. Qualifiers are not allowed. 

3 specifies that inputfile uses APCS version 3. 

APCS registers are set up. This is the default. 

Predeclared Register Names APCS register name in the rule: 

PCS   --   PCS rule 

None --   no rule 

Software stack check -apcs /swst, specifies that the code in inputfile 

carries out software 

stack checking. 

Frame pointer -apcs /fp, specifies that the code in inputfile uses a 

frame pointer. 

This option is obsolete and is provided for 

backwards 

compatibility only. 

FP arguments passed in FP register (selected) specifies that the code in inputfile does 

not use a frame pointer. This is the default. 

ARM/Thumb interworking -apcs /inter, specifies that the code is suitable for 

ARM/Thumb interworking. This option has the 

same effect as specifying the INTERWORK 

attribute for all code areas in the source files to be 

assembled. Refer to the ARM Software 

Development Toolkit User Guide for more 

information on ARM/Thumb interworking. 



 

Debug Options 

 

Figure 6-3-13 settings of Debug Options 

shows as Figure 6-3-9, In the Assembler dialog window, click the Category  dra
wing menu, choose Debug Options, the attributes of  assemble output target files ,d
efinition as following: 

Debug Options Cluster Description 

dwarf 1 -dwarf1, Use DWARF1 debug table format. This option is 

not recommended for C++. 

If DWARF1 debug tables are generated and a procedure 

call standard that does not use a frame-pointer register is 

used (always the case with Thumb, and the default with 

ARM), local variables that have been allocated to the stack 

cannot be displayed by the debugger. In addition, stack 

backtrace is not possible. 

dwarf 2 -dwarf2, to select DWARF2 debug tables. This is the 

default and is selected if -g with no dwarf option is 

specified. This is the default. 



asd (obsolete) -asd, Use ASD debug table format. This option is obsolete 

and is provided for 

backwards compatibility only. 

Check register lists -checkreglist, instructs the assembler to check RLIST, 

LDM, and STM register lists to ensure that all registers are 

provided in increasing register number order. 

If this is not the case, a warning is given. 

No warnings -nowarn, turns off warning messages. 

Source line debug -g, instructs the assembler to generate debug tables. Use the 

following command-line options to control the behavior of 

-g: 

-dwarf to select DWARF1 debug tables. This option is 

obsolete. Use -dwarf2 or -dwarf1. 

-dwarf1 to select DWARF1 debug tables. This option is not 

recommended for C++. 

-dwarf2 to select DWARF2 debug tables. This is the 

default and is selected if -g with no dwarf option is 

specified. 

Keep symbols -keep, instructs the assembler to keep local labels in the 

symbol table of the object file, for use by the debugger. 



 

Predefines 

 

Figure 6-3-14 settings of Predefines 

shows as Figure 6-3-9, In the Assembler dialog window, click the Category  dra
wing menu, choose Predefines, the attributes of  predefined macro, definition as foll
owing: 

Predefines  Cluster Description 

Listing of predefines The list of the active predefined  

Variable, Directive, Value -PD, instructs the assembler to pre-execute one of the 

SET directives. You must 

enclose directive in double quotes. See: 

 SETA directive on page 5-82. 

 SETL directive on page 5-83. 

 SETS directive on page 5-84. 

The assembler executes a corresponding GBLL, GBLS, 

or GBLA directive 

to define the variable before setting its value. Arguments 

to SETS must be 



enclosed in escaped double quotation marks, for 

example: 

-pd "Version SETS \"beta-4\"" 

-pd "VersionNum SETA 4" 

 

Listing Options  

 

Figure 6-3-15 settings of symbol list file 

shows as Figure 6-3-9, In the Assembler dialog window, click the Category  dra
wing menu, choose Listing Options, the attributes of  the assemble output files, defi
nition as following: 

Listing Options  Cluster Description 

Listing on -liston, list generation is on. 

Terse -noterse, turns the terse flag off. When this option is on, 

lines skipped due to conditional assembly do not appear in 

the listing. If the terse option is off, these lines do appear in 

the listing. The default is on. 

XRef -xref, instructs the assembler to list cross-referencing 

information on symbols, including where they were 



defined and where they were used, both inside and outside 

macros. The default is off. 

Page width -width, sets the listing page width. The default is 79 

characters. 

Page length -length n(>0), sets the listing page length. Length zero 

means an unpaged listing. The default is 66 lines. 

Continuous page This a synonym for -length 0. 

 

Assemble Options Window 

The Assembler property page, as in the figure 6-8, is used to configure the asse
mbling options for assembler of ARM Build Tools cross-compiler, All the options user
 select are displayed in the Assemble Options edit box with the following format: 

[Opt-1] [Opt-2] …–o[Path]$(OBJ_FILE) … [Opt-n] …$(SOURCE_FILE) 

Note: You can input or modify the options manually in the edit box, but the blank 
character between each option must be reserved, and the macros $(SOURCE_FILE), 
$(OBJ_FILE) should not be deleted or modified. $(SOURCE_FILE) means the 
source file to be compiled, $(OBJ_FILE) means the output of the assembling. There 
will be replaced with the actual file name by the Embest IDE at the time of building. 

 

shows as Figure 6-3-9, Assemble Options Window indicates: 

Switch Description 

-dwarf 1 -dwarf1, Use DWARF1 debug table format.  

-g Include debug information. 

-l..\common\ Use the common folder which in the project last layer catalog 

as the head files search folder. 

-o .\Debug\$(OBJ_FILE) Set the assemble target files output to Debug folder. 

$(SOURCE_FILE) Assemble all the source files in the project. 

 

6.3.4 ARM Linker options setting  

The linker attribute tab of the ARM Build Tools linker is illustrated in Fig.  6-3-1
6-16. If the various option configurations in the figure are used for the linker, all th
e settings of the user will be displayed in the Link Options edit box in the form of c
ommand line. When a new project selects the corresponding Build Tools, the target 
file output by the linker will be an execution file.  



In the Linker attribute tab, change the pull-down window of the Category, and r
espectively set the various category options for the ARM Build Tools linker. 

 

Figure 6-3-16  settings of General 

General 

 

Figure 6-3-17  settings of General 



shows as Figure 6-3-16, In the Linker dialog window, click the Category  drawin
g menu, choose General, the attributes of  ARM linker definition as following: 

General  Cluster Description 

Executable file The output file is an executable file 

Library The output file is a library 

Output formats select  linker output file formation 

-elf generates the image in ELF format. This is the default. Future 

versions of the ARM linker will output images in ELF file format only. 

You can use the fromELF utility to convert an ELF 

file to another format. 

-aof generates the consolidated object in AOF. Because AOF can only 

be used to represent an object, this option is interpreted by the 

linker as a request for partial linking of the input objects into a 

consolidated object. 

-aif generates the image in executable AIF format. Because -aif will not 

be supported in future releases, you are recommended to use 

-elf to produce the output file, then run the fromELF utility to convert to 

AIF format. 

-aif –bin generates the image in non-executable AIF format. Because 

–aif -bin will not be supported in future releases, you are 

recommended to use -elf to produce the output file, then run the 

fromELF utility to convert to AIF BIN. 

-bin generates the image in plain binary format. Because -bin will not be 

supported in future releases, you are recommended to use –elf to 

produce the output file, then run the fromELF utility to convert to BIN. 

Output file -o, The file name of output file (with the project file name and the 

stuff .elf or .lib/.alf ) 

 



Information Options 

 

Figure 6-3-18 settings of Information Options 

shows as Figure 6-3-16, In the Linker dialog window, click the Category  drawin
g menu, choose Information Options, the definition of  the ARM linker debug target 
files as following: 

Information Options Cluster Description 

Include debugging infomation -nodebug, turns off the inclusion of debug information in the 

output file. The image is then smaller, but you cannot debug it 

at source level. 

Give progress information while -verbose, prints messages indicating progress of the link 

operation. 

Search standard library -noscanlib, prevents the scanning of default libraries in a link 

step. This is the opposite of -scanlib. (See also -libpath above).

Give information on  -info < topic >, prints information about specified topics, 

where topic-list is a comma-separated list of topic keywords. A 

topic keyword may be one of the following: 

Totals reports the total code and data sizes in the 

image. The totals are broken down into 



separate totals for object and library files. 

Sizes gives a detailed breakdown of the code and data sizes for 

each input object and interworking veneers. Interwork is 

ignored in this release of the linker. 

Unused lists all unused areas, when used with the -remove 

option. 

Note that spaces are not allowed between keywords in a list. 

For example, you can enter: 

-info sizes,totals but not: 

-info sizes, totals 

Search path for libraries -libpath, specifies a path that is used to search for libraries. 

This path overrides the path specified by the ARMLIB 

environment variable. 

If you do not specify a path using -libpath, the linker searches 

in the path specified by ARMLIB, else searches the libraries 

defined in the file Lib$$Request$$library$$ variant. 

 

Listings Options 

 



Figure 6-3-19 settings of Listings Options 

shows as Figure 6-3-16, In the Linker dialog window, click the Category  drawin
g menu, choose Listings Options, the setting of the listing file attributes , definition 
as following: 

Listings Options Cluster Description 

Produce a list of symbol definition -symb, lists each symbol used in the link step (including 

linker-generated 

symbols) and its value, in the named file. A filename of 

minus (-) names the standard output stream instead of a file. 

Produce an area map  -map, creates an image map listing the base and size of each 

constituent 

area. 

Produce an area xref -xref, lists cross-references between input areas. 

List file -list, redirects the standard output stream to file. This is 

useful in conjunction with -map, -xref, and -symbols. 

 

Entry Point & Image Base 

 

Figure 6-3-20 settings of Entry Point & Image Base 



shows as Figure 6-3-16, In the Linker dialog window, click the Category  drawin
g menu, choose Entry Point & Image Base, definition as following: 

Entry Point & Image Base Cluster Description 

Entry Point -entry, specifies the entry point of the image. The 

entrypoint may be given as either. 

Base of image -ro-base, instructs the linker to place the Read-Only section 

at exec_address (for example, the address of the first 

location in ROM), set in  Read-Only 

-rw-base, instructs the linker to place the Read-Write 

section at exec_address, set in  Read-Write 

 

 

Image Layout 

 

Figure 6-3-21 settings of Image Layout 

shows as Figure 6-3-16, In the Linker dialog window, click the Category  drawin
g menu, choose Image Layout, definition of the start image and end image in the A
RM linker target files as following: 

Image Layout Cluster Description 

Place at beginning of image -first, places area from object first in the RO section of the 



image if it is a non ZI area. If it is a ZI area, it is placed first in 

the ZI section. This can be used to force an area that maps low 

addresses to be placed first (typically the reset and interrupt 

vector addresses). There must be no space between object and 

the following open parenthesis. 

When using scatter loading, use +FIRST instead. 

Object file  assemble object files 

Area Name a certain Area name 

Place at end of image -last, places area from object last in the RW or RO section of 

the 

image if it is a non-ZI area. If it is a ZI area, it is placed last in 

the ZI section. For example, this can be used to force an area 

that contains a checksum to be placed last in the RW section. 

There must be no space between object and the following 

open parenthesis. 

When using scatter loading, use +LAST instead. 

Object file  assemble object files 

Area Name a certain Area name 

 
Note: Object file must include Area Name in it. 

 



Areas Options 

 

Figure 6-3-22 settings of Areas Options 

shows as Figure 6-3-16, In the Linker dialog window, click the Category  drawin
g menu, choose Areas Options, definition of the label  segment in the ARM linker ta
rget files as following: 

Areas Options Cluster Description 

Unrearch Areas -remove, removes unused areas from the image. An area is 

considered to be used if it contains the image entry point, or if 

it is referred to from a used area. You must take care not to 

remove interrupt handlers when using -remove. 

Don’t remove  do not remove 

Remove all  remove unused areas 

Ignore case for symbol matching -case, uses case-sensitive symbol name matching. This is the 

default. 

Allow duplicate symbols -dupok, allows duplicate symbols so that an area can be 

included more than once in the image. However, if -noremove 

is also specified, the image must not contain multiple copies of 

the area. 



Refer unresolved -unresolved, matches each reference to an undefined symbol 

to the global 

definition of symbol. Note that symbol must be both defined 

and global, otherwise it will appear in the list of undefined 

symbols, and the link step will fail. This option is particularly 

useful during top-down development, when it may be possible 

to test a partially-implemented system (where the lower levels 

of code are missing) by connecting each reference to a missing 

function to a dummy function that does nothing. This option 

does not display warnings. 

 

 

 

6.4 Project Settings & Folder Settings 

More than one source file is included in a single project at the most time, and e
ach file maybe has its own compile options different from the others. Thus, we used
 to add the files that have the same compile options into a folder of the project, an
d set options for the folder instead of each source file.  

Show as Figure  6-2-1, GNU Tools for ARM, project led_swing has three folders 
--- C Source, ASM Source and Link Script. The files in folder C Source have their o
wn compile options different from the project settings. 

There is the same settings while selecting the ARM Build Tools which SDT or AD
S project folds. 

Note:For example, a project for ARM based application includes a list  source files, 
part of them should be compiled to generate thumb  object files, and the others 
should result with arm object files. Here, the source files can be divided into two 
parts, and added to two folders separately with relevant option settings. 

 



 

Figure  6-4-1 Folder Settings Dialog 

Show as Figure  6-4-1, select Always Use Custom Compile Options check box, t
he relevant Compiler property page will displayed, in this property page, you can se
t the compile options for the folder. Otherwise, the folder has the same compile set
tings with the project settings. 

If select Always Use Custom assemble Options check box, the relevant assembl
er property page will displayed, in this property page, you can set the assemble opt
ions for the folder. Otherwise, the folder has the same assemble settings with the p
roject. 

Click Reset buttons, valid when the matched check box is selected, to reshuffle 
the relevant settings to be as same as the project. 

6.5 Project Building 

Do one of the following to build project: 

1. Click on Build button on Build toolbar. 

2. Click on Build item on Project menu. 

3. Click on Rebuild All item on Project menu to rebuild the project. 

If build succeeds, a target file will be generated in the output directory specified
 in the Project Settings dialog.  

The output information is displayed in the following build pane. If any error occ
urs, the building operation will be terminated, and the error(s) will be displayed in t
he build pane.  



 

Figure  6-5-1 Build Menu and Toolbar 

 

6.5.1 Project File Compiling and Assembling 

Do one of the following to compile or assemble file: 

1. Click on Compile button on Build toolbar. 

2. Click on Compile item on Project menu. 

3. Click on Compile item on Workspace popup menu (show as Figure  6-18). 

The compiler can handle what kind of file or assembler that is described in File t
ype chapter. 

Menu Item Description 

  Compile Before compile or assemble the active document, Em
bestIDE will check several dependence relationship, if th
e following assumptions are true, the active document wi
ll not be handled:  

1.the object file are more up-to-the-minute than the 
source file; 

2.the object file are more up-to-the-minute than the 
all dependence files of the source file; 

3.No compiling or assembling options are modified, s
ince the last building or rebuilding all operation. 

 



 

Figure  6-5-2 Compiling Menu Item  

 

6.5.2 Project Build 

The menu items----Build, Rebuild All, Batch build, Clean and Stop Build----are al
l used to handle the active project: 

 

Menu Item Description 

  Build 
Compile all the source files that need to be compiled (as the 

description in Files type chapter), and link the object files to 

generate the target file. 

Before build the active project, EmbestIDE will check several 

dependence relationship, if the following assumptions are true, the 

active project will not be handled:  

1.No source file need to be compiled; 

2.The target file are more up-to-the-minute than the 

dependence files of linking operation; 

3.No linking options are modified, since the last building or 

rebuilding all operation. 

 

  Rebuild All 
EmbestIDE deletes the existing object files and target file first and 

then generates them again, suggest use this operation if there more 



than one project in current workspace.  

Batch Build 
Batch Build the Projects and order the building sequence in current 

workspace. 

  Clean 
Delete all the intermediate files include the object files and target 

files 

  Stop Build 
Stop the building or rebuilding all operation 

 

 

Figure  6-5-3  Build Pop Menu in Workspace Pane 

 

6.5.3 Projects batch build 

The user can simultaneously carry out batch build upon several projects in curre
nt workspace. Click the menu Build > Batch Build to pop out the dialogue box as sh
own in fig. 6-5-4.  



 

Fig 6-5-4  Batch Build operating window 

Introduction to options of Batch Build operating window: 

Project Name: select the project to be built by the user; the project not be sel
ected will not be built.  

Move Up: move the highlighted project up a step.  

Move Down: move the highlighted project down a step. 

Select All: select all projects in workspace.  

Build: Build the selected projects in the workspace. The regulated rule of buildi
ng is same as the definition of Build menu of the system.  

Rebuild All: Re-build the selected projects in the workspace. The regulated rul
e of building is same as the definition of Build menu of the system. 

Clean: completely delete the files produced in building.  

Note: for several projects, if it is set that the file folder with sam
e name store building output result, it is suggested using the ope
ration of Rebuild All so that it may not occur any error while buil
ding and connecting files with same name.   

 

6.6 Building Information in Output window 

At the beginning of compiling or building operation, the build pane will be set ac
tive to display the output information. In the Figure  6-21, the first line in this wind
ow prompt you which project or file is handled now. 



If all the command execute successfully, EmbestIDE will print line ---Command
(s) successfully executed, otherwise, line---Error executing above command. 

If fail to complete the compiling operation, error will displayed in build pane. To
 locate to the corresponding source quickly for those syntax errors, simply double cl
ick on the line or press key F4 (shift + F4). 

Building output information shows as Figure  6-5-5 to Figure  6-5-8: 

 

Figure  6-5-5 Build Pane 

 

(a) not use list file output 



 

(b) use list file output 

Figure  6-5-6 GNU Tools for ARM (success) 

 

Figure  6-5-7 GNU Tools for ARM (failure) 

 

Figure  6-5-8 ARM Build Tools (failure) 

 
 



VII. Program Debugging 

7.1 Overview 

The Embest IDE debugger combines the best features of graphical debug and co
mmand-line debug, provides multifarious debug ways.  

The most common debugging activities, such as setting breakpoints and controll
ing program execution, are available through convenient point-and-click interfaces. 
Similarly, program listings and data-inspection windows provide an immediate visual
 context for the crucial portions of your application. For complex or unpredictable de
bugging needs, the command-line interface gives you full access to a wealth of spec
ialized debugging commands.  

Embest IDE provides much advanced features as follows: 

 Supports assemble language debugging and source code debugging; support
s many program windows (include source program window, disassemble pro
gram window and mix-mode window). 

 Many emulational debug methods: Go, Reset, Stop, Step, Step into, Step ov
er, Step out, Goto Cursor, Goto Source and Goto Address etc. 

 Supports Unconditional Breakpoint, Conditional Breakpoint and Watchpoint. 

 Register value display and modification. 

 Memory content according can be desplayed with byte, half-word or word le
ngth and Hexdecimal or Ascii mode.  

 Supports global and local variables display and modification, and also suppo
rts expression value compute.  

 When value-change occurs in memory, variables, registers , corresponding i
nterface content will be displayed with red color.  

 Supports function stack display. 

 Saves debugging environment information with each project. 

7.2 Debugger GUI 

Figure 7-1 illustrates the GUI elements you can use to interact with Embest IDE
 debugger. 



 

Figure 7-1  Embest IDE debugger interface 

The Debug menu provides a complete list of Embest IDE GUI debugger comman
ds, as well as their keyboard shortcuts. 

The Debug toolbar provides buttons for the most common debugger commands,
 as well as for opening and closing all kind of windows and program compile and lin
k etc. 

The Debug status bar displays system status and detail explanations of menu’s 
and toolbar’s role. 

7.2.1 Debugger Toolbar, Buttons, Menu and Shortcut 

The debug toolbar has many buttons for the most common debugging command
s, as well as display auxiliary debugger windows. The toolbar shown as a floating p
alette interface as figure 7-2. 

 



 

Figure7-2  debugger toolbar 

The commands in the debug menu include alternatives to the buttons in the de
bug toolbar, as well as additional debugger functions. Keyboard shortcuts are also a
vailable for all graphical debugger commands. 

The debugger buttons and menu commands are described in following table 7-
1. 

Table 7-1  debug button and menu command 

Button Menu Command Description 

 Connect/ 

Disconnect 

Connect or Disconnect target system 

 Download Download debug file to target system  

 
Restart Restart the program from entry point 

 
Go Run debug file on the target under debugger cont

rol 

 
Stop Stop target system 

 
Reset Reset target system 



 
Step into Step to the next line of code, in order of executio

n (not necessarily the next line displayed in the e
ditor) 

 
Step over Step to the next line displayed on the screen. If t

here is a subroutine call on the current line, the 
button executes that subroutine in its entirety, th
en stops at the line after the subroutine call 

 
Step out Finish the current subroutine. Execution continues

 until the current subroutine returns to its caller. 

 
Run to Cursor Run to the line where cursor staying 

 
Show Next Statement Show next code line which will be execute  

 
Toggle Breakpoint Set or remove a task-level breakpoint on the curr

ent line of the editor window 

 Enable All Breakpoints Enable all breakpoints 

 Disable All Breakpoints Disable all breakpoints 

 
Delete All Breakpoints Delete all breakpoints 

 Breakpoint type There are three choices of Type of breakpoint: 

Auto: the default and recommendation breakpo
int type. If choosing this breakpoint type, Embest
 debugger will automatically treat it as software b
reakpoint or hardware breakpoint;  

Hardware: change the default breakpoint type a
nd set it as hardware breakpoint;  

Software: change the default breakpoint type an
d set it as software breakpoint.  

 Breakpoints… Show the breakpoints management dialog 

 
Watch Open or close the Watch window, which displays

 the values of specified variables throughout the 
execution of the program 

 
Variables Open or close the Variables window, which displ

ays the values of local and global variables 

 
Registers Open or close the Registers window, which displ

ays values of the target registers 

 
Memory Open or close the Memory window, which displa

ys target memory information 



 
Call Stack Open or close the Call Trace window, which disp

lays stack information 

 
Disassembly Open or close the Disassembly window, which d

isplays disassemble code 

 

7.3 Debug Setting 

Debug setting window, which is used to configure debug software, locates at th
e setting dialog window of project. The configurations is divided to three categories:
  

• General 

• Download 

• Memory Maps 

General debug setting page interface show as following figure7-3: 

 

Figure7-3  General Debug Setting Page 

Symbol file column specifies the debug symbol file name and directory, debug 
symbol file contains debug information for debugger, usually symbol file has Elf-for
mat or Coff-format. 

Auto Download option item is used for whether or not auto download file afte
r the target system is resetted or debugger connects target. If be selected, debugg
er will finish the download operation automaticly. 



Command Script option item specifies the command script file, if selected, th
e debugger will auto execute the commands listed in this file after system connects 
target board. 

Download debug setting page interface show as following figure7-4: 

 

Figure7-4  Download Setting Page 

Download file column specifies the executable file to be downloaded, this  file 
is the program which will run on a target system. 

Download Verift option item is used for whether or not auto checksum downlo
ad file. If selected, debugger will auto compare the target memory file with the dow
nload file. 

Download address column specifies the start memory address of download file,
 the download file will ordinally be stored from this address. 

Execute until column specifies a symbol to which program will run, after it is d
ownloaded. 

Download address option item means debugger will auto set PC’s value with t
he download start address after file downloaded. 

Program entry point option item means debugger will auto set PC’s value wit
h the entry-point address of the excutable file after it is downloaded  

Memory maps setting page interface show as following figure7-5: 



 

Figure7-5  Memory Maps Setting Page 

Use map file option item means the range of memory access should be specifie
d when users debug program, and the range is descripted in the memory map file
 assigned in the following editbox. 

7.4 Start to Debug the program 

When a project is compiled and linked successfully, and you have correctly filled
 debug setting dialog, you can debug the project now with the following steps --- 1,
 connect debug emulator device; 2, download program. 

7.4.1 Connect Emulator 

Before connect emulator device, please read Appendix A JTAG Emulator Connec
t. 

Connect computer’s parallel port and the Embest Emulator’s DB25 interface thro
ugh standard DB25 male-to-female parallel cable. Embest Emulator connect target b
oard through a header which mates which IDC sockets mounted on a straight throu
gh ribbon cable. And then, with the target board powered, hardware connection is e
stablished. 

Click Debug menu, select ‘Remote Connect’ menu item(show as figure7-6), or p
ush F8 key, debugger will connects target system through emulator device. 

 



Figure7-6  Debug Menu before Connection 

If connection is failed to set up, debugger will show possible reason in debug pa
ne of the Output Window. Please refer to Appendix A, and check whether power an
d cable connection are correct or not. If the connection established successfully, De
bug menu will show as following figure7-7: 

 

Figure7-7  Debug Menu after Remote Connect 

7.4.2 Program download 

After connection between host and target system set up, we can download exec
utable file to target system now. If Auto Download option is set in Debug Setting Di
alog, debugger will auto progress this step. If not, please click Debug menu, and se
lect Download item. Target file will be downloaded to the predeterminate address o
n target system.  The rate of download process will displayed on the status bar, sh
ow as following figure 7-8: 

 

Figure 7-8  Status Bar as Program Downloading 

If download succeed, status bar displays “Download Completed” in blue, otherwi
se, “Download Failed” in red. Show as following Figure 7-9 and Figure 7-10. 

 

Figure 7-9  Status Bar as Program Download completed 

 

Figure 7-10  Status Bar as Program Download failed 

7.5 Control Program Executing 

Debuger can control target program as it execute, and disassemble binary code 
in the target system, and also can control target program by set breakpoint to help
 user faster debugging program. 

7.5.1 Program Running 

Executing program state includes run-state, stop-state, reset-state mainly. Run-
state expresses program is executing according to code order; Stop-state expresses



 it is stopped at certain code and waiting for debugger to read needed information; 
Reset-state expresses target system is staying at system entry point, all system inf
ormation keeps at the initially state. 

Click ‘Debug’ menu and select ‘Go’ menu item, or push ‘F5’ key, or click ‘Go’ bu
tton on debug toolbar, program will run from the stopped position, and mouse shap
e will change to funnelform shape, program running interface is shown as following 
figure7-11: 

 

Figure 7-11  Program Running Interface 

Click ‘Debug’ menu and select ‘Stop’ menu item, or push Shift+F5 key, or click 
‘Stop’ button on debug toolbar, can make program stop, and mouse shape will chan
ge to primary shape, program stop interface is shown as following Figure7-12: 



 

Figure 7-12  Program Stop Interface 

When program stoped, if stop at certain source code, corresponding source code
 line will be highlight, and set a current-line flag in front of the line ( current-line fl
ag is yellow rightward arrow), source code interface is shown as following figure7-1
3: 

 

Fgure 7-13  Program Stop Interface with Source Code 

Click ‘Debug’ menu and select ‘Reset’ menu item, or push Ctrl+R key, or click 
‘Reset’ button on debug toolbar, program will stop and system will transfer to initial
 state, and mouse shape will change to primary shape, program reset interface is s
hown as following figure 7-14: 



 

Figure 7-14  Program Reset Interface 

Source program also can be executed step by step. Step execute include Step I
nto, Step Over and Step Out mode. 

1.Step Into mode: If there is a subroutine call in the current line, Step Into take
s program to the first line of that subroutine, not to the next line currently displaye
d on your screen. 

2.Step Over mode: Step Over steps program to the next line display on the scre
en. 

3.Step Out mode: program execution continues until the current subroutine com
pletes, then the debugger regains control in the calling statement. 

An example for step execute is shown as follows figure 7-15:( suppose system r
un into the position as the following figure, current subroutine is OSTaskCreate) 

 



Figure 7-15  Step Execute Start Position 

If execute Step into, because the source line have a subroutine call, so system 
will run into the first line of OSTaskCreateHook subroutine, source window interface 
will changed as the following figure 7-16: 

 

Figure 7-16  Source Code Window Interface after Step Into 

If execute Step over, system will stop at next line displayed on the screen, sour
ce code window will changed as the figure 7-17: 

 

Figure7-17  Source Code Window Interface after Step Over 

If execute Step out, system will continues until the current subroutine complete
s, and stop at calling statement, source code window will changed as the following f
igure 7-18: 



 

Figure 7-18  Source Code Window Interface after Step Out 

7.5.2 Disassemble Window 

Disassemble window provides display of assemble code disassembled from binar
y machine code, and provides blend display between assemble code, source code, a
nd binary code. Disassemble window can set and clear assemble breakpoint, and als
o can disassemble binary code in accoding with ARM or THUMB binary machine mod
e. 

The buttons, shortcuts and menu commands, correlative with disassemble windo
w, are described in following table. 

Table 7-2  Buttons, Shortcuts and Menu Commands 

Button Shortcut Key Menu command 

 ALT+8 View > Debug Windows > Call Stack 

Disassemble window is shown as following figure 7-19: 



 

Figure 7-19  Disassemble Window Interface 

Disassemble window blend source code and assemble code as the following figu
re 7-20: 

 

Figure 7-20  Disassemble Window Interface 

Disassemble window blend binary code and assemble code as the following figur
e 7-21: 



 

Figure 7-21  Disassemble Window Interface 

The right mouse menu of disassemble window is shown as following figure 7-2
2. 

 

Figure 7-22 Disassemble Window Right Menu 

Go To Source: show the source code line which in according with current asse
mble line, if the source line exists, debugger will show the source code window. 

Go To Address: set start address of assemble code, and start disassembling bi
nary code from that address. 

Show Next Statement: show assemble code which will execute next step. 

Insert Breakpoint: set a breakpoint at current assemble code line. 



Enable Breakpoint: enable the breakpoint at current assemble code line. 

Disable Breakpoint: disable the breakpoint at current assemble code line. 

Delete Breakpoint: delete the breakpoint at current assemble code line. 

Run to Cursor: run program to the line where the cursor is staying. 

Set Next Statement: set the assemble code line, where the cursor is staying, 
as the line which will execute by system next. 

Disassembly Mode: set disassemble mode ---- ARM or THUMB mode. 

Source Annotation: display assemble code blend with source code. 

Code Byte: display assemble code blend with binary code. 

Close: close the disassembe window. 

 

7.5.3 Breakpoint 

The buttons.shortcut keys and menu items which relate with breakpoint is show
n as following table 7-3: 

Table7-3  Buttons.Shortcut keys and Menu items 

Button 
Shortcut 

Key 
Debug menu command Right mouse menu 

 F9 
Toggle Breakpoints Insert Breakpoint/ 

Delete Breakpoint 
n/a n/a Enable All Breakpoints  
n/a n/a  Enable Breakpoint 
n/a n/a Disable All Breakpoints  
n/a n/a  Disable Breakpoint 

 n/a 
Delete All Breakpoints  

n/a n/a Breakpoints…  
 

Before setting a breakpoint, symbol file must has been fiiled in debug setting di
alog. Embest IDE debugger can set and clear breakpoints in source code window.as
semble window.disassemble window and code blend display window. 

Several way, hereinafter, to set breakpoint: 

1. Moving mouse to left grey margin of the source code window, mouse will cha
nge to hand shape, then click the left mouse button, a red-circle breakpoint flag will
 displays in the left grey margin and a yellow backgrounf bar will be shown at corre
sponding line. 

2. Set cursor to the line which need a breakpoint, and then press ‘F9’ . 

3. Set cursor to the line which need a breakpoint, then click ‘Debug’ menu and s
elect ‘Toggle Breakpoint’ menu item.  



The breakpoint, which is set first time, is a enable breakpoint, shown as followin
g figure 7-23. The flag which is around by cyan circle is a enable breakpoint flag: 

 

Figure 7-23  a Disable Breakpoint Flag 

In a source code window, if a breakpoint is set at a invalid source line, Embest 
IDE will have none response. 

Breakpoint state includes enable state and disable state, program will not auto s
top at the disable breakpoints. Shown as the following figure 7-24, the flag around 
by cyan circle is a disable breakpoint flag: 

 

Figure 7-24  Disable Breakpoint Flag 

When running into a enable breakpoint line, program will stop at the breakpoint,
 shown as the following figure 7-25: 

 

Figure 7-25  Program Stop at Breakpoint 

Right click the flag of Breakpoint, the dialog box below will popup, through this 
dialog box you can disable or enable breakpoint, define the properties of breakpoin
t. 

User can query all breakpoint information and state through breakpoint list. Clic
k ‘Debug’ menu, and select ‘Breakpoint…’ menu item, the breakpoints list dialog will
 pop-up, shown as the following figure 7-26: 



 

Figure 7-26  Breakpoints List Dialog 

Double click left mouse button at a line of the breakpoint list or click Modify but
ton, user can modify the breakpoint information in a dialog, shown as the following 
figure 7-27: 

 

Figure 7-27  Breakpoint Modify Dialog 

As figure 7-27 shows, there are three choices of Type of breakpoint, please che
ck one: 

Auto: the default type. If choosing this breakpoint type, Embest debugger will a
utomatically treat it as software breakpoint or hardware breakpoint. 

Hardware: set current breakpoint as hardware breakpoint; hardware breakpoin
t can be set in RAM area or ROM area; the number of hardware breakpoints is limit
ed by CPU hardware resources, e,g. maximum 2 hardware can be set breakpoints A
RM7TDMI kernel. 



Software: set current breakpoint as software breakpoint. Software breakpoint c
an only be set in RAM area; so when debugging the programs in Flash, only hardwa
re breakpoint can be chosen; theoretically, any number of software breakpoints are 
allowed. 

 

Notices: 
1. Setup of Breakpoint Type through Debug menu can change the default 
breakpoint type, see section 7.2.1; 
2. Setup of Breakpoint Type through breakpoint information window is valid to 
current breakpoint. 

 

Count: set times of breakpoint trigger. 

If want to set a conditional breakpoint, click ‘Advanced’ button which on breakp
oint modify dialog, dialog will append a subdialog below the dialog, shown as the fol
lowing figure 7-28, the ‘When’ editbox displays conditional express, the ’Command’ 
editbox displays the command which will be auto executed as system reach the bre
akpoint. 

 

Figure 7-28  Conditional Breakpoint Modify Dialog 

Enter “5” in the column “Count” in the above figure 7-28, it means: current bre
akpoint will not be valid until triggering 5 times; when breaking point arrives at 0x0
200012c, provided stk=15, breakpoint is triggered once, and Command is executed;



 when triggering for the 5th time, the program will stop at the breakpoint 0x020001
2c. 

 

 

7.6 Debug Information 

When users want to debug a program, they need much debug information to m
ake sure the correctness of program and data, so can faster find the origin of  error
s. Embest IDE has visual debug information windows to display and modify debug i
nformation when user debug a target program, these windows include register wind
ow, memory window, watch window, variables window and call stack window. 

7.6.1 Register Window  

Register window can display and modify values of processor core registers and 
peripheral chip registers on the target system. Registers name and num depend on 
the type of target system processor, when debug different target system, the conte
nt of the register window also differ. Registers values can display on hexadecimal or
 decimal or binary format, and can auto refresh values or refresh by hand. Register
s divide into register group, each group can set different display mode.  

The buttons, shortcut and menu commands which is correlative  with register wi
ndow are described in following table7-4. 

table7-4  register window’s buttons, shortcut and menu commands 

Button Shortcut Key Menu command 

 ALT+5 View > Debug Windows > Register 

Register window show as following figure 7-29: 

 

Figure7-29  register window interface 



Click one register, the name and value of the register will display in input colum
n which is on top of register window. User can modify the value in input column, th
e input column show as following figure7-30: 

 

Figure 7-30  register value modify column 

When register value modified, register window will show the value in red color, 
the interface of register window show as following figure7-31: 

 

Figure 7-31  Register Window interface 

Right click mouse on register window will show the register window menu, the r
egister window menu show as following figure7-32, the meanings of menu item is: 

 



Figure 7-32  Register Window Popup Menu 

Refresh: handly refresh registers value to keep consistent with target system. 

Auto Refresh: auto refresh option, if be set, register group name will in deep 
green, and register window will auto refresh registers value base on every operation
 of user to keep consistent with target system. 

Hex Format: display registers value base on hexadecimal format. 

Binary Format: display registers value base on binary mode. 

Decimal Format: display registers value base on decimal format. 

Expand …: expand all register groups(…=All) or appointed register group(…=re
gister group name). 

Collapse …: collpase all register groups(…=All) or appointed register group(…=
register group name). 

Docking View: window auto arrange option, if set, window will auto keep to th
e side and ordinal arrange. 

Hide: hide register window. 

Note: Setting the data display format, please attention by following: 

1) right key on the register name, settings will effect on the appointed r
egister. 

2) right key on the register group name, settings will effect on the appoi
nted register group. 

3) right key on the blank of the register window, settings will effect on t
he all register group and registers. 

 

7.6.2 Peripheral register window 

Peripheral register window provides status display and operation of peripheral re
gister of target processor. It can view and amend the content of peripheral register 
in this window. The relevant buttons, shortcut keys and menu commands of periphe
ral register window are shown in form 7-5.  

Form 7-5 Buttons, shortcut keys and menu commands in storage area window 

Button Shortcut key Menu command 

 
ALT+5 View > Debug Windows > Registers 



 

Fig. 7-33 Peripheral register window 

As shown in the above figure, peripheral register window shows the peripheral r
egister groups of current target processor with a list. The register group can be sep
arately carried out refresh setting, data display format setting. Click  to view the l
ist of peripheral registers of peripheral register group, and the user can amend the 
content of appointed register.  

1. View peripheral register 

Click  to view the list of peripheral registers of register group in peripheral reg
ister window. The display format of peripheral register is:  

Name of register: current content or property of register 

The readable register will directly display the current content; for write-only regi
ster, it will display the character string WriteOnly in the back of register.   

When the mouse stops above register, the screen will prompt the description of r
egister that the mouse currently points out, and the meanings of each part are:  

Name of register (register mapping address): register description (accessing propert
y) 

As shown in Fig. 7-34:  



 

Fig. 7-34 Value display of peripheral register 

2. Operation of peripheral register 

In name of register group, click  or click right key of mouse to select Expand
 … to expand register group. Click a register, the name and value of this register wi
ll display in the input column in the upper part of register’s window. In input colum
n, it can change the value of this register. The input column is shown in fig. 7-35:  

 

Fig. 7-35 Amendment and input column of register’s value 

The value of register will be shown in red after being amended, as shown in fig.
 7-36:  



 

Fig. 7-36 Show corresponding register in red after the value of register is amended 

While clicking right key in the window of peripheral register, it will pop out the 
menu as shown in fig. 7-37.  

 

Fig. 7-37 Right key menu in window of peripheral register  

Menu  Function 

Refresh … Manually refresh all value of registered groups (…=All)or value 

of appointed register groups(…=group name) so as to keep 

consistent with target system 

Auto Refresh Set automatic refresh. While setting, the window of register will 

automatically keep consistent with target system according to the 

operation of user in each step. While using this setting, the 

corresponding all names of register groups (All) or appointed 



register groups (name of group) will be shown in deep green.  

Properties Display detailed window of peripheral register 

Hex Format Display register’s value according to hex format 

Binary Format Display register’s value according to binary format 

Decimal Format Display register’s value according to decimal format 

Expand … Expand all register groups(…=All) or appointed register groups 

(…=group name)  

Collapse … Collapse all register groups(…=All) or appointed register groups 

(…=group name) 

Docking View Whether the window is automatically arranged to the side. When 

selection, the window will be automatically arranged to the side. 

Hide Hide register window 

 

When the user uses the setting Auto Refresh to all register groups, the system 
will automatically pop out dialog box as shown in fig. 7-38. When the user executes
 a debugging operation, the integrated environment must read all values of peripher
al registers, therefore the debugging speed may be affected in some content. It is s
uggested that the user should selectively use the function of Auto Refresh, and only
 set automatic refresh of some groups, use manual refresh to other register groups 
if necessary.  

 

Fig. 7-38 Prompt when peripheral registers use the setting Auto Refresh 

Notes:  

 While using refresh and automatic refresh of right key menu, it shall pay atte
ntion to the position where the mouse points: 

1) The setting that is carried out with right key above name of special register gr
oup is effective against this register group;  

2) The setting that is carried out with right key in other blank of register is effect
ive against all register groups.  

 While using data display format of right key menu, it shall pay attention to th



e position where the mouse points: 

1) The setting that is carried out with right key above name of special register gr
oup is effective against this register group; 

2) The setting that is carried out with right key in special register group is effecti
ve against this register group; 

3) The setting that is carried out with right key in other blank of register is effect
ive against all register groups. 

The user shall be careful when he uses right key to operate.  

 
3. Detailed dialog box of peripheral register  

The dialog box of peripheral register provides for user the visual viewing measu
res of peripheral register of detailed register and flexible and convenient amendmen
t methods to the value of peripheral register. 

The detailed dialog box provides for user the detailed information about periphe
ral register, including the actual meaning of content, address and bit; the user can 
amend the value of peripheral register through directly inputting hex value or binar
y value, and can also amend the selected register area.    

After selecting register, select sub-menu Properties in right key menu of mouse,
 or double click left key of mouse in register to pop out detailed dialog box of regist
er as shown in fig. 7-39:  

 



Fig. 7-39 Detailed dialog box of peripheral register 

The detailed dialog box of register includes the following:  

Heading of dialog box: display the name of register. 

Blue letterform above dialog box: display the full description of current regi
ster.  

Hex edit box(HEX Value): Display hex value of register, can also be used for
 amending the value of register.  

Binary edit box(Binary Value): Display binary value of register, can also be 
used for amending the value of register. 

Register Field: 

Select drop-down box(Select Option):Selectable value and the meaning 
that the register field currently selected is corresponding.  

Bit: The bit group of register. 

Name of field(Name): Short name of bit group of register. 

Binary value of field(Bin):Binary value of bit group of register. 

Description of field(Desc): Description character string of current set of bi
t group of register.  

Screen prompt: display short name of bit group of register, full name of bit gr
oup of register,all selectable values that the bit group of register is corresponding t
o, and the meaning when the value is set. The value of the bit group of register cur
rently set and its meaning are shown in red.  

If the user wants to amend the content of peripheral register, he can directly a
mend in hex and binary edit box, or amend the value in this field in Select Option o
r Edit Box after selection of register field. The drop-down select box of detailed win
dow of peripheral register is shown in fig. 7-40.  



 

Fig. 7-40 Drop-down select box of detailed window of peripheral register 

7.6.3 Memory Window 

Memory window can display and modify memory content of target system. Mem
ory window show memory content from the address which can be input by user, co
ntent length auto match the size of memory window. Memory content can display o
n byte:half-word or word length mode, and have hexadecimal digit format part and 
ASCII char format part which can respective display in accordance with memory con
tent. When some memory content change, memory window will show these content
 on red color. Embest IDE provides two of the memory window named Memory Win
dow1 and Memory Window2. 

The buttons,shortcut,and menu commands which is correlative  with memory wi
ndow are described in following table7-5. 

Table 7-5  memory window’s buttons, shortcut and menu commands 

Button Shortcut key Menu command 

 ALT+6 View > Debug Windows > Memory 

Memory window display base on byte length mode show as following figure 7-4
1: 



 

Figure 7-41  Memory Window Base on Byte Length Mode 

User can modify original address of memory content in the input column which i
s on top of memory window. Ten of the user’s input will remain in the list of the in
put column. If modified original address, memory window will immediately auto sho
w new memory content. The input column show as following figure 7-42: 

 

Figure 7-42  Original Memory Address Input Column 

If need modify memory content, user can directly modify the content on hexade
cimal digit part or ASCII char part, and new content will immediately write into corr
esponding memory, and show new content on red color. The interface which memor
y content modified show as following figure7-43: 

 



Figure 7-43  Memory Window with content change 

Right click mouse on memory window will show the memory window menu, the 
memory window menu show as following figure7-44, the meanings of menu item is: 

 

Figure 7-44  Memory Window Popup Menu 

Menu Description 

Refresh 
handly refresh memory content to keep consistent with target 

system.  

Auto Refresh 

auto refresh option, if be set, memory window will auto 

memory content base on every operation of user to keep 

consistent with target system.  

Byte Format display memory content base on byte length mode. 

Short Hex Format display memory content base on half-word length mode. 

Long Hex Format display memory content base on word length mode. 

Memory Access Size Set the access size of memory 

Byte      ---- by byte 

Half Word ---- by half word  

Word     ---- by word 

Docking View 
window auto arrange option, if set, window will auto keep to 

the side and ordinal arrange. 

Hide hide memory window. 

 

Note: with Memory Window1for illustration above, so as Memory 
Window2 can be able to operate. But their options are independe
ncy. 



 

7.6.4 Watch Window 

Watch window can display variables value or compute expression result which u
ser input for watch, user can add a new watch data or delete a watch data. Watch 
data value can display base on hexadecimal or decimal format. With every operatio
n of user, watch window will auto compute and update watch data value. Watch win
dow have two page: “Watch 1” and “Watch 2”, each page can separate input differe
nt data. Watch data name will auto save follow project save or close, when open sa
me project next time, watch window will auto load last watch data.  

The buttons,shortcut,and menu commands which is correlative  with watch wind
ow are described in following table7-6. 

Table7-6  watch windows’s buttons,shortcut,and menu commands 

Button Shortcut key Menu command 

 ALT+3 View > Debug Windows > Watch 

Watch window default display base on hexadecimal format, window interface sh
ow as following figure7-45: 

 

Figure 7-45  Watch Window Base on Hex Format 

Watch window interface base on decimal format show as following figure 7-46: 



 

Figure 7-46  Watch Window Base on Decimal Format 

User can use two kinds of ways to add new watch data:  

1.Double click the name column of the blank line in watch window,then will put 
a input box into the line, user can input new data in that box, carriage return or cli
ck other line, watch window will auto compute data value and show it on correspon
ding value column. The interface show as following figure 7-47: 

 

Figure 7-47  Watch Data Input Column 



2.Right click on watch window, select ‘Add’ menu item, then will show a data in
put dialog, enter data, push ‘OK’ button, watch window will compute data value and
 add it at the end of watch window. The input dialog show as following figure 7-48: 

 

Figure 7-48 Watch Data Input Dialog 

User can look over detail data property, select corresponding column, right click
 mouse, select ‘ Properties’ menu item, will show data property dialog, interface sho
w as following figure 7-49: 

 

Figure 7-49 Watch Data Properties Dialog 

Right click mouse on watch window will show the watch window menu, the watc
h window menu show as following figure7-50, the meanings of menu item is: 

 

Figure 7-50  Watch Window Popup Menu 

Add: add a new watch data. 

Delete: delete current selected watch data. 

Hexadecimal Display: data value format option, if set will show data value on
 hexadecimal format, if not set will show data value on decimal format. 



Docking View: window auto arrange option, if set, window will auto keep to th
e side and ordinal arrange. 

Hide: hide watch window. 

Properties: current selected watch data property. 

 

7.6.5 Variables Window  

Variables window can display global and local variables information, and can mo
dify variables’s value. Variables window have two page: ‘Global’ and ‘Local’, respecti
ve display global variables and local variables. Variables value can display base on 
hexadecimal or decimal format. With every operation of user, watch window will aut
o create variables list and compute variables value. If one variable’s value changed,
 variables window will display the value on red color.  

The buttons,shortcut,and menu commands which is correlative  with variables w
indow are described in following table 7-7. 

Table 7-7  variables windows’s buttons,shortcut and menu commands 

Button Shortcut key Menu command 

 ALT+4 View > Debug Windows > Variables 

Variables window default display base on hexadecimal format, window interface 
show as following figure 7-51: 

 

Figure 7-51 Variables Window Base on Hex Format 

Variables window interface base on decimal format show as following figure 7-5
2: 



 

Figure 7-52 Variables Window Base on Adecimal Format 

User can look over detail variables property include variable name,variable value
 and variable type, right click on variables window, select ‘Properties’ menu item, wi
ll show variables property dialog, interface show as following figure 7-53: 

 

Figure 7-53 Variables Property Dialog 

User can modify variable value. The way is double click the value column of the
 variable which need to be modified, and input new value in input box, interface sh
ow as following figure 7-54: 



 

Figure 7-54 Variables modify  

When new variable value is legal, watch window will immediately change variabl
e’s value on target system, and display new value on red color, interface show as f
ollowing figure 7-55: 

 

Figure 7-55 Variables Window after a variable value change 

Right click mouse on variables window will show the variables window menu, th
e variables window menu show as following figure 7-56, the meanings of menu ite
m is: 



 

Figure 7-56 Variables Window Popup Menu 

Hexadecimal Display: variable value format option, if set will show variable v
alue on hexadecimal format, if not set will show variable value on decimal format. 

Docking View: window auto arrange option, if set, window will auto keep to th
e side and ordinal arrange. 

Hide: hide variables window. 

Properties: current selected variable property. 

 

7.6.6 Call Stack Window  

Call stack window can display runtime relation of functions which be calling and 
called. Function parameter value can display base on hexadecimal or decimal format.
 The last called function(current running function) display on top line of the window,
 and arrange down base on function call relation, start function display on end line 
of the window.  

The buttons, shortcut and menu commands which is correlative  with call stack 
window are described in following table7-8. 

Table7-8  call stack window’s buttons,shortcut,and menu commands 

Button Shortcut key Menu command 

 ALT+7 View > Debug Windows > Call Stack 

Call stack window interface show as following figure 7-57 (have been set all fun
ction parameter display property): 

 



Figure7-57  Call Stack Window 

Function Parameter’s name or type or value can be set to display whether or no
t individual. Call stack window interface show as following figure7-58 (Close function
 parameter value display property) 

 

Figure 7-58 Call Stack Window with Function Parameter value 

If close all function parameter display property will only show function name an
d its return type. Call stack window interface show as following figure 7-59 (Close a
ll function parameter display property) 

 

Figure7-59 Call Stack Window without Function Parameter 

Double click one function line of call stack window, source window will show nex
t code to be execute after the code which the function call above function, and put 
a blue rightward arrow on front of the source line, call stack window will also show 
the function line highlight. The interface show as following figure 7-60: 



 

Figure 7-60 Debugger Interface as Double-Click Function Line 

Right click mouse on call stack window will show the call stack window menu, t
he call stack window menu show as following figure, the meanings of menu item is: 

 

Figure 7-61  Call Stack Window Popup Menu 

Parameter Values: parameter values display option, if set will show parameter
 values.  

Parameter Types: parameter types display option, if set will show parameter t
ypes. 

Parameter Names: parameter names display option, if set will show paramete
r names. 

Hexadecimal Display: parameter values format option, if set will show parame
ter values on hexadecimal format, if not set will show parameter values on decimal 
format. 



Docking View: window auto arrange option, if set, window will auto keep to th
e side and ordinal arrange. 

Hide: hide call stack window. 

 



VIII. Customization and Options 

8.1 Introduction 

Embest IDE not only allows you to customize the appearance of the display to 
match your preferences, but it also allows you to add menu entries for other tools y
ou may wish to use. The Options entry in the Tools menu displays commands that 
change the editor settings, and plugin directory for Embest IDE. The Customize entr
y in the Tools menu opens a dialog box for adding menu items. 

Table 8-1 Customization and Options Menu 

Butt
on 

Menu Description 

 Customiz
e… 

Open the Customize dialog box 

 Options… Open the Option dialog box 

 

8.2 Tools Menu Customization 

Select Tools > Customize… menu, open the Customize dialog box: 

 

Figure 8-1 Tools Menu Customize Dialog Box 



Menu Contents List Box lists commands you have added to the Tools menu. 
To add a command, click the New button above the Menu Contents list, type the te
xt for the menu item in the box at the end of the Menu Contents list, and provide t
he necessary information in the boxes below. To modify a command, select it in the
Menu Contents list and change the information specified in the boxes below. To dele
te a command, select it and click the delete button above the Menu COntents list. T
o move a command up or down on the Tools menu, select the command in the Men
u Contents list and click one of the arrows above list. 

Command Edit Box displays the path and filename of the tool currently select
ed in the Menu Contents list. Click the button at the right of the edit box opens a di
alog box where you can browse and select a file. 

Arguments Edit Box Specifies additional arguments for the tool each time you
 start it. You can use several macros in custom menu commands, see 8.4 Use Macr
os for explanations of these macros. 

Workiing directory Edit Box specifies where (in what directory) to run the cu
stom command. You can edit the directory name in place, or click the button at the
 right of this field to bring up a directory browser where you can search for the righ
t directory. 

Prompt for arguments Checked Box When selected, displays a dialog box w
hich prompts for command-line arguments each time you run the tool. You can spe
cify additional arguments for each particular instance of the tool. 

OK Button Applies your changes to the Tools menu. 

CANCEL Button Discards your changes without modifying the Tools menu. 

 

8.3 IDE Options 

8.3.1 Editor Preferences 

Select Tools > Options… menu, then click the Editor tab to adapt the editor to y
our preferences. The Editor page is shown in Figure 8-2: 



 

Figure 8-2 Editor Page 

The following choices are available on the Editor Settings:  

Disable backspace at start of line, prevents joining of lines by using the BA
CKSPACE key. 

Disable drag-and-drop text editing, select this checkbox to disable drag-and
-drop text editing so you can not move or copy selected text with the mouse.. 

Disable show selection margin, select this checkbox to disable display a mar
gin to the left of each line of text. This margin display information about source line
s, including breakpoints, instruction points, and tag pointers. 

Disable automatic indent, select this checkbox to disable indent source code 
automatically. 

Reload last workspace at startup, when selected, automatically loads the wo
rkspace you last worked on. 

Tab Size, provides a place for you to specify the number of space characters th
at equal one tab character. The defaults is four space characters.. 

The following choices are available on the Window Settings:  

Reset the positions of all docking bars & remove all recent info, all docki
ng windows display at same position and size as you lase worked on. When select,
 all docking windows display with the deault position provided by the IDE and all h
istory information reserved by IDE will be cleared.  

Set the main menu and edit popup menus without icons, when selected, 
disable display icons corresponding with menu items. This function suits some opera
tion system which limited GUI resources, such as WINDOWS 98. 

 



8.3.2 Directory Options 

Select Tools > Options… menu, then click the Directories tab. The Directories pa
ge is shown in Figure 8-3: 

 

Figure 8-3 Directories Page 

Plug_in Module Directory: 

Table 8-2 is a description of the Embest IDE Plug_in Module Directories. 

Table 8-2 Directory Description 

Function Default Directory 

CPU Support $(EMBEST_IDE)\bin\cpu 

Debug Device Support $(EMBEST_IDE)\bin\device 

File Support $(EMBEST_IDE)\bin\file 

Build Tools Support $(EMBEST_IDE)\bin\build 

Driver $(EMBEST_IDE)\bin\driver 

In the Show Directories For list box, user select the type of module for the dire
ctory, then the edit box below the list box display directory for modules. You can ed
it the directory or click the button at the right of the edit box opens a dialog box w
here you can browse and select a directory. 

Note:Plug_in Module Directories Use Default, general user do no



t change it. 

Build Executable Files Directory: 

IDE support some different compiler at the same time. You can setting Build E
xecutable Files Directory corresponding with compiler. In the Show Directories Fo
r list box, user select compiler, then directory corresponding with compiler is display
ed in the edit box. User can edit the directory or click the button at the right of the
 edit box opens a dialog box where you can browse and select a directory.  

Note:The default directory specilized by IDE, general user do not c
hange it. 

 

8.4 Use Macro 

You can use argument macros to specify arguments for a Tools menu command.
 Embest IDE provides the argument macros shown in the following table: 

Table 8-3 Macro Description 

No. Macro Name Expands to a string containing Examples 

1 
$(DOWNLOAD_PAT
HFILE) 

The directory and Name of symbo
l file(.elf) 

D:\test\debug\test.elf 

2 $(EMBEST_IDE) 
Installation directory of The Embe
st IDE. 

D:\EmbestIDE 

3 $(LINK_FILE) Name of the output file(.elf) test.elf 

4 $(LINK_DIR) 
The directory of the output file(.el
f) 

D:\test\debug\ 

5 $(LINK_PATHFILE) 
The directory and Name of output
 file(.elf) 

D:\test\debug\test.elf 

6 $(PROJECT_PATH) 
The directory of the current proje
ct. 

D:\test\ 

7 $(PROJECT_NAME) The name of the current project. test 

8 
$(SYMBOL_PATHFI
LE) 

The directory and Name of Symb
ol file(.elf) 

D:\test\debug\test.elf 

To click menu Tools>Options, there is the template to use Macro. 



IX. Customer Service 

Get support on demand. Connect Customer Service for more information on ho
w to use the Embest’s products. 

• Web Site 

Get the latest information and docs about Embest’s products from the web site: 
http://www.embedinfo.com 

You may have noticed some trouble issues at the support forums. In the meanti
me, you can get help by subscribing to the following forum: 

http://www.embedinfo.com/cforum/login.asp 

• E-Mail 

If you have any question, comments, feedback or suggestions as to how our pr
oducts could be improved, let us know at support@embedinfo.com 

• Telephone Number 

You can also call 86-755-25635626 with the extension to the Customer Service 
Center. 

• Fax Number 

Our fax number is 86-755-25616057. 



Appendix A: Hardware Reference of Embest JTAG 

Emulator 

Embest JTAG Emulator contents two types of product: Standard JTAG Emulator 
(Embest Emulator for ARM), and Enhanced JTAG Emulator (Embest PowerICE for AR
M). 

Standard Emulator (Embest Emulator for ARM) was the standard JTAG emulator
 for development series of ARM core CPU, early product of Embest Info&Tech Co., LT
D. It works at 25Kbyte per second by transmission, and capability stabilization. 

Enhanced Emulator (Embest PowerICE for ARM) was the New-generation of JTA
G emulator. It’s feature power supply can be provided by internal or external input,
 and works at highest speed 120Kbyte per second by transmission. 

Embest JTAG Emulator has a Parallel port connecting to the Computer’s parallel 
port, and a JTAG interface connecting to the target system.  

There are 3 LEDs on the panel, indicating the Emulator’s working state. 
 

Note: Cable connection must not hot swap! 

 

A.1 Embest PowerICE for ARM 

1. JTAG Interface Connections 

A standard male-to-female 25-way parallel cable connects the Embest PowerICE
 for ARM to the PC's parallel port. The connection to the target board is made by a 
20-way (or 14 - way) female IDC header cable with all pins connected straight thro
ugh (1-1, 2-2, ... 20-20). There are two types of IDC interface cable: 14pin and 20
 pins. JTAG pin connections is described as figure A-1-1 and A-1-2. 

 

 

(b) 14 Pin JTAG Connections 



(a) 20 Pin JTAG Connections 

Figure A-1-1 JTAG Connection 

 

Note: All GND pins should be connected to 0V on the target board. 

 

The following table shows the JTAG pinouts. 

Signal I/O Description 

Vref Input This is the target reference voltage. It indicates that target has power and also 
controls the output logic levels to the target. It is normally fed from Vdd on target 
board. 

Vsupply Input This is the supply voltage to Embest PowerICE for ARM. It draws its supply 
current from this pin via a step-up voltage convertor. This is normally fed by the 
target Vdd. Valid power supply voltage is form 2.7V to 5.5V. 

GND - Ground. 
TDI Output Test Data In signal from Embest PowerICE for ARM to the target JTAG port. It is 

recommended that this pin be pulled to a defined state. 
TMS Output Test Mode signal from Embest PowerICE for ARM to the target JTAG port. This 

pin should be pulled up on the target so that the effect of any spurious TCKs when 
there is no connection is benign. 

TCK Output Test Clock signal from Embest PowerICE for ARM to the target JTAG port. It is 
recommended that this pin be pulled to a defined state. 

TDO Input Test Data Out from the target JTAG port to Embest PowerICE for ARM. 
nTRST Output JTAG reset. With a pull-up resistor output from Embest PowerICE for ARM to the 

Reset signal on the target JTAG port. 
nSRST Output Open collector output from Embest PowerICE for ARM to the target system reset. 

This pin should be pulled up on the target to avoid unintentional resets when there 
is no connection.  

RES - Reserved. 

 

Notes: 
1. nSRST: open collector output from Embest JTAG emulator to the target system reset signal 
(name: nRESET) on the target board. 
2. The signal nTRST pull-up with a 10K resistor on target JTAG port, then can disconnect it to 
Embest JTAG emulator. 
3. Please DON’T connect the nTRST and target system reset signal together, sine the Embest 
JTAG emulator advises OPEN between them. 

 

2. Power Supply 

Power is supplied to the Embest PowerICE for ARM via pin 1 of the 20-way (or 
14-way) IDC connector. This is normally fed by the target Vdd. Valid power supply 



voltage is form 2.7V to 5.5V. Power of Embest PowerICE for ARM also can be suppl
y by external input voltage valid 3V/5V. Connection jack of the external voltage inp
ut show as figure A-1-2 following: 

 
Figure A-1-2 connection jack of the external voltage input 

 
Note: 

 According to the way of voltage input, power supply switch of Embest PowerICE 
for ARM must place in the right position. 

 Embest PowerICE for ARM cannot work if power voltage out of range, even be 
badly damaged. 

3. Target Interface Voltage Level 

The target interface voltage level of Embest PowerICE for ARM depends on the i
nput voltage level. It is 3V/5V compatible. Normally, power supply by the external i
nput voltage will give the output single voltage provided 3.3V. 

4. LED Indicator 

There are three LED in the panel of Embest PowerICE for ARM, labeled Power, R
un and Con. 

LED Power: power indicator 

LED Run: data indicator, indicate the data transmission between host pc and tar
get CPU. 

LED Con: connection indicator 

 

A.2 Embest Emulator for ARM 

1. JTAG Interface Connections 

A standard male-to-female 25-way parallel cable connects the Embest Emulator 
for ARM to the PC's parallel port. The connection to the target board is made by a 
20-way (or 14 - way) female IDC header cable with all pins connected straight thro
ugh (1-1, 2-2, ... 20-20). There are two types of IDC interface cable: 14pin and 20
 pins. JTAG pin connections is described as figure A-2-1. 
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(a) 20 Pin JTAG Connections 
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(b) 14 Pin JTAG Connections 

Figure A-2-1 JTAG Connection 

 

Note: All GND pins should be connected to 0V on the target board. 

 

The following table shows the JTAG pinouts. 

Signal I/O Description 

Vsupply Input This is the supply voltage to Embest Emulator for ARM. It draws its supply current 
from this pin via a step-up voltage convertor. This is normally fed by the target Vdd. 
Valid power supply voltage is form 2.7V to 5.5V. 

GND - Ground. 
TDI Output Test Data In signal from Embest Emulator for ARM to the target JTAG port. It is 

recommended that this pin be pulled to a defined state. 
TMS Output Test Mode signal from Embest Emulator for ARM to the target JTAG port. This pin 

should be pulled up on the target so that the effect of any spurious TCKs when there is 
no connection is benign. 

TCK Output Test Clock signal from Embest Emulator for ARM to the target JTAG port. It is 
recommended that this pin be pulled to a defined state. 

TDO Input Test Data Out from the target JTAG port to Embest Emulator for ARM. 
nSRST Output Open collector output from Embest Emulator for ARM to the target system reset. This 

pin should be pulled up on the target to avoid unintentional resets when there is no 
connection.  

RES - Reserved. 

2. Power Supply 

Power is supplied to the Embest Emulator for ARM via pin 1 of the 20-way (or 14-way) 
IDC connector. This is normally fed by the target Vdd. Valid power supply voltage is form 
2.7V to 5.5V. 

 



Note: Emulator cannot work if power voltage out of range, even be badly damaged. 

3. Target Interface Voltage Level 

The target interface voltage level of Embest Emulator for ARM depends on the i
nput voltage level. It is 3V/5V compatible. 

4. LED Indicator 

There are three LED in the panel of Embest Emulator for ARM, labeled Power, R
un and Con. 

LED Power: power indicator 

LED Run: data indicator, indicate the data transmission between host pc and tar
get CPU. 

LED Con: connection indicator 

 

A.3 Embest UNetICE for ARM 

1. UNetICE Hardware 

Embest UNetICE emulator includes:  

-   JTAG port for connecting target board 

-   USB and Ethernet port for connecting host 

-   RESET and UPDATER buttons 

-   External power supply socket and power switch 

-   Red, green, yellow emulator state indicator 

See details in diagram below:  

  

(a) Frontal view of UNETICE (b) Rear view of UNETICE 

 

Figure A-3-1 Embest UNetICE for ARM 

 



SN Names Functions 

1 Power indicator(PWR) Indicate the state of power supply 

2 State indicator(RUN) Indicate running state of emulator 

3 Alarm indicator(ALARM) Indicate error alarm 

4 Ethernet port The telecom port connected to host in Ethernet way. 

5 USB port The telecom port connected to host in USB way. 

6 External power supply socket For connecting external power supply 

7 Power switch Switch power supply modes (USB power supply / external power supply) 

8 RESET Reset emulator 

9 JTAG port 20-pin IDC plug port 

10 UPDATE Press the button when resetting the emulator to enter updater mode 

 

2. Connections of emulator 

In the host-target machine cross development model, through debugging device the 
host is connected with target machine, and conducts download and debugging. UNetICE 
is a JTAG emulator, connected to JTAG port of target board via a 20-pin IDC 
straight-through cable (1-1, 2-2, …20-20), connected to host through USB or Ethernet 
port. User can select an appropriate connecting way according to his real condition. 

(1) USB connection type 

USB(Universal Serial Bus) is a new port technology in PC application, it provides 
power supply and high-speed telecom channels for peripheral equipment, bringing users 
a lot of convenience. 

The host can be connected to UNETIC emulator through a special USB cable. See 
figure below, the A-type male port in the left is connected with the A-type female port of 
host, the B-type male port in the right is connected with the B-type female port of target 
board. If you need to use USB as power supply device, you can adjust the power switch. 

 
Figure A-3-2 USB cable 



(2) Ethernet connection type 

There are two ways of Ethernet connection, one is standard Ethernet connection, use 
two parallel network cable (see figure below) to connect host, target board and HUB to 
constitute a LAN. The other way is using cross cable (one) to directly connect the host and 
target machine. 

3. Power supply 

User can choose 5V power supply through USB port by operating power switch; or 
alternatively choose 6/9V external power supply. In external power supply socket, the 
inside is positive, the outside is negative, see the figure below: 

 

Figure A-3-3 power supply socket 

4. Indicators 

Functions of indicators: PWR: indicate the state of power supply; RUN: indicate 
running state of emulator; ALARM: indicate error alarm. See details in the table below: 

Names of 
indicators 

Description of indicator state  

PWR Power indicator “on”: indicate normal power supply. 

RUN 

When the emulator is powered on, it enters normal mode, the indicator is 
on. 

In normal mode, when the debugging software is connected to emulator, 
the indicator blinks; 

When the emulator is powered on, while in updater mode, the indicator is 
on (ALARM indicator is also on) 

In updater mode, during the process of downloading, the indicator blinks; 

ALARM 

The indicator is on, the system enters updater mode; 

The indicator turns on, then turns off in 1 second, indicating an alarm 
message created; 

The indicator blinks for 5 seconds, turns on then turns off in 1 second, 
indicating an error message created. 

 

5. Port signal 

(1) JTAG 

The definition of ITAG port is shown in the figure below (the RES pin can be used for 
future upgraded versions, please refer to relevant specification) 



 

Figure A-3-4 Definition of 20-pin TAG port cable 

Description of pin signal 

Signal I/O Description 

GND — Power Ground. 

TDI Output The testing data input signal from Embest Emulator to JTAG port of target board, It is 

recommended to add a pull-up or pull-down.  

TMS Output The testing mode signal from Embest Emulator to JTAG port of target board, the 

signal should be pulled up in target board, to avoid possible negative impact caused 

by change in TCK pin before connecting. 

TCK Output The testing clock signal from Embest Emulator to JTAG port of target board, It is 

recommended to add a pull-up or pull-down.. 

TDO Input The testing data output signal from JTAG port of target board to Embest Emulator. 

nSRST Output The system reset signal from open collector of Embest Emulator to target board. the 

signal should be pulled up in target board, to avoid possible unexpected reset before 

connecting. 

RES — Reserved. 

 

(2) USB 

The definition of USB port is shown in the figure below: 



 

Figure A-3-5 Definition of USB port 

Description of pin signal: 

Signal Specification 

VDss USB port can be used to supply power to peripheral equipment, voltage range of USB port: 

4.4-5.25V 

D+ Telecom channel 

D- Telecom channel 

GND Grounding 

 

(3) ETH 

The definition of Ethernet port is shown in the figure below: 

 

Figure A-3-6 Definition of Ethernet port  

Description of pin signal: 

Signal Specification 

TX+ Tranceive Data+  

TX- Tranceive Data-  

RX+ Receive Data+  

RX- Receive Data-  



n/c Not connected 

 

Appendix B: Debug Output Reference 

B.1 Info Reference 

3001 CPU was in debug state before connected, register values may be 
incorrect. 

 Description: CPU was in debug state before connecting to the host, you may get 
incorrect register values. 

 Cause and 
Resolution: 

Causation: 

 IDE Disconnected with target CPU when it is in the debug state. 

Resolution: 

If you want to run the program in the target system, you should 
rectify the value of PC and related registers. 

If you are going to download new program to the target system, 
notice the values in the stack-related registers. 

3002 target running, cannot auto download. 

 Description: Target is in running state, auto download command cannot be 
executed. 

 Cause and 
Resolution: 

Causation: 

 If auto_download check box been checked in the project setting 
dialog, when connect to the target, IDE will check the target 
status. If the target is in debug state, IDE will execute the 
download command, else prompt this info massage. 

Resolution: 

No Resolution. 

 

B.2 Warning Reference 

 

2001 Breakpoint xx are not on valid lines, disabled. 

 Description: The breakpoint is invalid, and then it is forbidden. 



 Cause and 
Resolution: 

Reason of warning: 

 Breakpoint is set at invalid line. User must reset the breakpoint 
at a valid line. 

2002 invalid line, set breakpoint failed. 

 Description: Failed to set breakpoint because current line is not execute 
statement. 

 Cause and 
Resolution: 

Reason of warning: 

 Current line is not execute statement. user must set a 
breakpoint at execute line. 

2003 load symbol file failed. 

 Description: Failed loading the symbol file. 

 Cause and 
Resolution: 

Reason of warning: 

 Symbol file dos not exist. 

 Symbol file format dose not supported by IDE. 

Select correct symbol file format and recompile and then set the 
symbol file config at Project setting > Debug >general dialog. 

2004 open memory map file failed. 

 Description: Failed to open memory map file. 

 Cause and 
Resolution: 

Reason of warning: 

 Memory map file does not exist. 

 Memory map file damaged, cannot be opened. 

2005 read program counter failed. 

 Description: Failed to read program counter. 

 Cause and 
Resolution: 

Reason of warning: 

 Communication failed between Emulator and target system. 

 Target program exception. 

Reset the target CPU and/or reconnect to it. 

2006 register doesn't exist. 

 Description: Register doesn't exist. 



 Cause and 
Resolution: 

Reason of warning: 

 CPU module is incompatible with debug device module, please 
contact the provider. 

2007 target running, all breakpoints disabled. 

 Description: Target is in running state, hence all of the breakpoint is forbidden. 

 Cause and 
Resolution: 

Reason of warning: 

 Target is in running state, user must stop the target before 
enable all the breakpoint. 

2008 target running, cannot toggle breakpoint. 

 Description: Target CPU is in running state, cannot toggle breakpoint. 

 Cause and 
Resolution: 

Reason of warning: 

 Target CPU is in running state, you need stop the CPU before 
toggle breakpoint. 

2009 too many breakpoints. 

 Description: Breakpoints’ amount out of range. 

 Cause and 
Resolution: 

Reason of warning: (Embest JTAG emulator for arm7 V2001): 

 More than two hardware breakpoints. 

 More then one hardware breakpoint and 255 software 
breakpoint. 

Delete at least one breakpoint before setting a new one. 

2010 unable to compute express or variable value. 

 Description: Failed to compute express or variable value. 

 Cause and 
Resolution: 

Reason of warning: 

 Variable does not exist. 

 Express invalid. 

2011 unable to locate address. 

 Description: Unable to locate the instruction address corresponding with 
current line. 

 Cause and 
R l ti  

Reason of warning: 



Resolution:  Symbol file is not matching with execute file. 

 Symbol file format dose not supported by IDE. 

User need rebuild the project and download again. 

2012 unable to locate source file. 

 Description: Unable to locate the source file corresponding with current 
instruction.  

 Cause and 
Resolution: 

Reason of warning: 

 Symbol file is not matching with execute file. 

 Symbol file format is not supported by IDE. 

User need rebuild the project and download again. 

2013 workspace does not exist. 

 Description: Workspace does not exist. 

 Cause and 
Resolution: 

Reason of warning: 

 Current command need a workspace be opened. User must 
create a workspace and project. 

2014 write program counter failed. 

 Description: Failed to write program counter. 

 Cause and 
Resolution: 

Reason of warning: 

 Communication failed between Emulator and target system. 

 Target program exception. 

Reset the target CPU and/or reconnect to 

it. 

 

B.3 Error Reference 

1001 Can not find environment variable 'embest_ide'. 

 Description: Failed to find environment variable. 

 Cause and 
Resolution: 

Reason of error: 

 environment variable 'embest_ide' does not set in operation 
system. User must set environment variable EMBESE_IDE=[Embest 



IDE’s setup dir]. 

1002 Can not find register group, maybe device and cpu module your selected are 
not compatible. 

 Description: Failed to find register group. 

 Cause and 
Resolution: 

Reason of error: 

 CPU module is not compatible with device module. Please connect 
to the provider. 

1003 can not find download file … 

 Description: Failed to find the specified download file. 

 Cause and 
Resolution: 

Reason of error: 

 download file do not exist. User need rebuild the project. 

 download file path is not correct. 

1004 can not read register. 

 Description: Read register error. 

 Cause and 
Resolution: 

Reason of error: 

 Communication failed between Emulator and target system. 

 Target program exception. 

Reset the target CPU and/or reconnect to it. 

1005 can not initialize CPU module. 

 Description: CPU module initialize failed. 

 Cause and 
Resolution: 

Another error statement tell you the reason of error if there are two 
error statement at same time, otherwise: 

 CPU module is not compatible with current IDE version. 

1006 can not initialize emulator module. 

 Description: Failed to initialize emulator module. 

 Cause and 
Resolution: 

Another error statement tell you the reason of error if there are two 
error statement at same time, otherwise: 

 Emulator module is not compatible with current IDE version. 

 IDE do not support current emulator. 



1007 can not initialize file module. 

 Description: Failed to initialize file module. 

 Cause and 
Resolution: 

Another error statement tell you the reason of error if there are two 
error statement at same time, otherwise: 

 file module is not compatible with current IDE version. 

1008 can not open ide.ini file or specified item does not exist. 

 Description: De.ini cannot be opened or some error occur when open the file. 

 Cause and 
Resolution: 

Reason of error: 

 ide.ini do not exist. This file should in the embest_ide dir. 

 ide.ini file contain errors. User needs resetup EmbestIDE. 

1009 cursor are not positioned on valid lines. 

 Description: The line that contains cursor is invalid to the current command. 

 Cause and 
Resolution: 

Reason of error: 

 move the cursor to a valid line. 

1010 disassemble non-existent memory. 

 Description: Disassemble non-existent memory space. 

 Cause and 
Resolution: 

Reason of error: 

 memory config file does not set up all of the memory space. 

 CPU was in debug state before connecting to the host, so, IDE may 
get incorrect register values. PC point to a non-existent memory. This 
error can be ignored. 

 User program error. 

1011 download address illegal, please modify download address. 

 Description: Download address illegal. 

 Cause and 
Resolution: 

Reason of error: 

 project setting dialog specifies a download file name, but not 
specifies the download address. User need specifies a download 
address. 

 download address is not a valid value. User must modify the 



address to a valid value. 

1012 emulator not found, please check power and hardware connection. 

 Description: Failed to find the emulator. 

 Cause and 
Resolution: 

Reason of error: 

 Emulator does not connect to the host computer. 

 Emulator do not powered on. 

 Communication port config error or damaged. 

1013 failed to convert file from ELF format to BIN format. 

 Description: Failed convert file format from ELF to BIN. 

 Cause and 
Resolution: 

Reason of error: 

 file format is incorrect. 

 Current file format is not supported by IDE. 

User must rebuild the project. 

1014 find symbol failed. 

 Description: Failed to find specified symbol. 

 Cause and 
Resolution: 

Reason of error: 

 No symbol file is specified. 

 Specified symbol is not found in source file. 

1015 get target status failed. 

 Description: Failed to get target status. 

 Cause and 
Resolution: 

Reason of error: 

 Communication failed between Emulator and target system. 

 Target program exception. 

Reset the target CPU and/or reconnect to it. 

1016 internal error, please contact supplier. 

 Description: IDE internal error. 

 Cause and 
Resolution: 

Reason of error: 

 IDE internal error. Please contact the provider. 



1017 invalid command. 

 Description: Invalid command. 

 Cause and 
Resolution: 

Reason of error: 

 execute a user customized command, but this command is invalid. 
User need modify the custom command. 

1018 load script file error. 

 Description: Failed to load script file. 

 Cause and 
Resolution: 

Reason of error: 

 Specified script file do not exist. User need check the filename and 
path of the specified script file. 

 script file error, check and modify it. 

1019 out of memory. 

 Description: Failed to allocate memory space. 

 Cause and 
Resolution: 

Reason of error: 

 Failed to allocate system memory space. User need close other 
application program or restart host computer. 

 IDE internal error. Please contact the provider. 

1020 project doesn't exist. 

 Description: Project does not exist. 

 Cause and 
Resolution: 

Reason of error: 

 No workspace has been opened. User need open a workspace. 

 No active project. User need create a project and activate it. 

1021 read register group failed. 

 Description: Failed to read register group. 

 Cause and 
Resolution: 

Reason of error: 

 Communication failed between Emulator and target system. 

 Target program exception. 

Reset the target CPU and/or reconnect to it. 



1022 reset target failed.  

 Description: Failed to reset target CPU. 

 Cause and 
Resolution: 

Reason of error: 

 hardware error or target CPU is not supported by current version of 
IDE. Check hardware interface. 

1023 run target failed. 

 Description: Failed to run target program. 

 Cause and 
Resolution: 

Reason of error: 

 IDE get wrong Target state. 

 Communication failed between Emulator and target system. 

 Target program exception. 

Reset the target CPU and/or reconnect to it. 

1024 step failed, maybe symbol file incorrect. 

 Description: Source file step failed, possibly because symbol file incorrect. 

 Cause and 
Resolution: 

Reason of error: 

 Symbol file is not matching with execute file. User need rebuild the 
project and download again. 

1025 step failed. 

 Description: Step failed. 

 Cause and 
Resolution: 

Reason of error: 

 Communication failed between Emulator and target system. 

 Target program exception. 

Reset the target CPU and/or reconnect to it. 

1026 stop target failed. 

 Description: IDE cannot stop target CPU. 

 Cause and 
Resolution: 

Reason of error: 

 Communication failed between Emulator and target system. 

 Target program exception. 



Reset the target CPU and/or reconnect to it. 

1027 target CPU not found. 

 Description: IDE cannot find target CPU. 

 Cause and 
Resolution: 

Reason of error: 

 Target board JTAG interface do not match with emulator. 

 Target CPU do not work. 

 Target CPU do not support JTAG debug mode. 

 Emulator power level does not match with CPU. 

1028 unable to load CPU module. 

 Description: Failed to load CPU module. 

 Cause and 
Resolution: 

Reason of error: 

 Specified emulator module does not exist. Reset the project and 
select corresponding emulator module. 

 CPU module path error in the IDE tools-option dialog. Select Tools 
> Option menu, set CPU module path to $(EMBEST_IDE)\bin\CPU. 

1029 unable to load emulator module. 

 Description: Failed to load emulator module. 

 Cause and 
Resolution: 

Reason of error: 

 Specified emulator module does not exist. Reset the project and 
select corresponding emulator module. 

 emulator module path error in the IDE tools-option dialog. Select 
Tools > Option menu, set emulator module path to 
$(EMBEST_IDE)\bin\device. 

1030 unable to load file module. 

 Description: Failed to load file module. 

 Cause and 
Resolution: 

Reason of error: 

 Specified file module does not exist. Check the sub dir \bin\file in 
the IDE setup dir. 

 File module path error in the IDE tools-option dialog. Select Tools 
> Option menu, set file module path to $(EMBEST_IDE)\bin\file. 



1031 unable to load portcall.dll. 

 Description: Failed to load portcall.dll. 

 Cause and 
Resolution: 

 portcall.dll does not exist. Check the sub dir \bin\driver in the IDE 
setup dir. 

 Driver module path error in the IDE tools-option dialog. Select 
Tools > Option menu, set Driver module path to 
$(EMBEST_IDE)\bin\driver. 

 

Appendix C: Debug Command List 

C.1 General Option of Debug Command 

 […] Optional items. Items out of [] must be present. 

Option can be used by all command. 

 -? Display the help information of the command. 

 

C.2 Debug Command List 

1. BKPTCLEAR – clear breakpoint 

Syntax: bkptclear [breakpiont ID] 

Description: Clear one or all the point 

Parameter: breakpoint I
D 

An integer number which identify a certain breakpoi
nt 

Option: none  

Example: bkptclear 1 ;Clear the breakpoint which ID is 1 

 bkptclear ;Clear all the breakpoint 

 

2. BKPTDATA – set an data breakpoint 

Syntax: bkptdata Option address 

Description: Set an data breakpoint at the specified memory locations 

Parameter: address Memory address 

Option: W breakpoint is vaild when write memory 



 R breakpoint is vaild when read memory 

Example: bkptdata -wr 0x7f4d
fc 

;Set a data breakpoint at address 0x7f4dfc, i
t is vaild when read or write   this address. 

 

3. BKPTINST – Sets an instruction breakpoint 

Syntax: bkptinst address 

Description: Sets an instruction breakpoint at the specified memory locations 

parameter: addre
ss 

The instruction address. 

Option: none  

Example: bkptinst 0x1024 ;Set a instruction breakpoint at address 0x10
24 

 

4. BKPTLIST –List all breakpoints 

Syntax: bkptlist 

Description: List all installed breakpoints. 

parameter: none  

Option: none  

Example: bkptlist ;List all installed breakpoints. 

 

5. DISASM –Disassemble the target code 

Syntax: disassemble addr [line_num] 

Description: The Disasm command disassembles the target code beginning at a
 specified address. The Disasm command disassembles ten lines as
 a default, or you can include an Optional [line_num] parameter 

parameter: addr address in target memory to begin disassembling. 

 line_num the number of instructions you wish to disassemble. Th
e default is 10 lines. 

Option: None  

Example: Disassemble 10
0 8 

;disassemble 100 lines of code located at addres
s 8. 

 

6. DOWNLOAD –Download file 



Syntax: download [Option] filename address 

Description: Download file to the specified address. 

parameter: filename the specified download file. 

 address the specified address 

Option: v download verify 

Example: download d:\demo\ram.bi
n 0x2000000 

;Download d:\demo\ram.bin to the me
mory address at 0x2000000 

 download -v d:\demo\ra
m.bin 0x2000000 

;Download d:\demo\ram.bin to the me
mory address at 0x2000000, verify wh
en downloading. 

 

7. GO – Execute target program 

Syntax: go  

Description: Execute target program from current program counter 

Parameter: none   

Option: none  

Example: Go  

 

8. HELP – display help information 

Syntax: help  [command name] 

Description: Display the help information of the specified command or brief info
rmation of all the command. 

parameter: Command na
me 

Debug command name 

Option: none  

Example: help  Display the brief information of all the command. 

 help stop ;Display the help information of the command st
op. 

 

9. MEMREAD –Display the content of memory 

Syntax: memread address length  

Description: Displays the contents of the memory location requested. It   acces
ses the memory in word format default. 



parameter: address memory location 

 length the length of memory to be read 

Option: h specifies access the memory in half word format. 

 b specifies access the memory in byte format. 

Example: memread 0x1000
 0x200 

;Read 0x0200 words from 0x1000 

 

10. MEMWRITE –Write to memory 

Syntax: memwrite [Option] address value  

Description: Write value to the memory location requested. It accesses the me
mory in word format default. 

parameter: addr
ess 

memory location 

 value Specifies value to write. 

Option: -h Specifies access the memory in half word format. 

 -b Specifies access the memory in byte format. 

 -e Write memory by Big endian mode 

Example: Memwrite 0x1000 0x
5A 

;Write 0x5a to 0x1000 

 memwrite -e 0x2000
000 0x22334455 

;Equal to memwrite 0x2000000 0x5544332
2 

 

11. REFRESH – refresh all windows 

Syntax: refresh  

Description: refresh all windows include register, memory, stack, watch, global/l
ocal 

parameter: none  

Option: none  

Example: refresh  

 

12. REGLIST –Display all registers 

Syntax: reglist 



Description: displays the properties of all of the processor's registers 

parameter: none  

Option: none  

Example: reglist  

 

13. REGREAD –display registers 

Syntax: regread [Option] register group name or register name 

Description: displays the contents of a particular register or registers. 

Parameter: register gr
oup name 
or register 
name 

Specifies register group name or register name 

Option: g read register group 

Example: regread pc ;display PC register 

 regread –g user ;display all registers belong to 'User' group 

 

14. REGWRITE – set register 

Syntax: Regwrite register name value 

Description: Set register 

parameter: register
 name 

Specifies register name 

 value The value to write 

Option: none  

Example: regwrite pc 0x38
40 

;Set PC with the value 0x3840 

 

15. RESET –Reset the target 

Syntax: reset  

Descriptio
n: 

Reset the target device 

parameter: none  

Option: none  



Example: reset  

 

16. SCRIPT –Executes command script file 

Syntax: script filename  

Description: Executes command script file 

parameter: filena
me 

Specifies script filename 

Option: none  

Example: script d:\demo\cm
d.cs 

;Executes command script file d:\demo\cmd.c
s 

 

17. STEP –Executes one statement or instruction 

Syntax: step  

Description: single-stepping begins at the address contained in the program cou
nter. 

parameter: none  

Option: none  

Example: step ;step one instruction 

 

18. STOP –Stop the target 

Syntax: stop  

Description: Stop the target 

parameter: none   

Option: none  

Example: stop  

 

19. SYMBOL –Load symbol file 

Syntax: symbol [symbol filename]   

Description: Load symbol file 

parameter: symbol filename Specifies symbol file 

Option: none  



Example: symbol d:\demo\ram.e
lf  

;Load ram.elf symbol file in d:\demo 

 

Appendix D: Memory Map File 

D.1 Description 

By default, Embest IDE assumes that the entire address space is mapped to sta
ndard RAM, so IDE can read or write any memory address. In some cases it will ca
use exceptions, in which case you can manually create a memory map file. You sho
uld create your own memory map in the following situations: 

 Your target has read-only memory areas or non-existent memory areas that
 should cause a bus fault when accessed. 

 Your applications access non-standard memory locations. 

A memory map is created in a *.MAP file which Embest IDE automatically execu
tes when connect emulator. 

D.2 Format 

In memory map file, each line describe one memory block except for the line be
gin with ‘#’ which is comment line. One line is consisting of nine parts and each par
t separate with blank space. The format of each line is: 

name start size read-write bus-width access-size read-times write-times burst-ti
mes 

ITEM TYPE DESCRIPTION 

Name string A single word that you can use to identify the memory region. 

You can use any name. To ease readability of the memory 

access statistics, give a descriptive name such as SRAM, 

DRAM, or EPROM. 

Start hexadecimal The start address of the memory region. 

Size hexadecimal The size of the memory region. 

Read-Write string The property of read-write, R for read, W for write. 

Bus-Width decimal The width of the data bus in bytes (that is, 1 for an 8-bit bus, 2 

for a 16-bit bus, or 4 for a 32-bit bus). 



Access-Size decimal The width when access memory (that is, 1 for 8-bit, 2 for 16-bit, 

or 4 for 32-bit). 

Read-Times nanoseconds The nonsequential and sequential read times. 

Write-Times nanoseconds The nonsequential and sequential write times. 

Burst-Times nanoseconds The nonsequential and sequential burst times. 

 

Note: The beginning four items is necessary, and the others whic
h not concerned can be substituted by symbol ‘-’.  

D.3 Example 

A typical memory map looks like this: 

          

#Name Start Size Attribute notWarry 

INTERNRAM 10000000 2000 RW - - - - - 

COREINTERNALIO 78000000 8000000 RW - - - - - 

STANDARDAPBIO B0000000 8000000 RW - - - - - 

COREAPBIO B8000000 8000000 RW - - - - - 

EXTERNDRAM C0000000 800000 RW - - - - - 

EXTERNSRAM C8000000 100000 RW - - - - - 

FLASH C8100000 200000 R - - - - - 

EXTERNSRAM D0000000 80000 RW - - - - - 

EXTERNIO F0000000 8000000 RW - - - - - 

NotWarry contents of: BusWidth AccessSize ReadWait WriteWait BurstW
ait. 

Appendix E: Command Script Reference 

E.1 Description 

Command Script File is a text formatting file, is used to auto execute several co
mmands continuously, the contents of the file consist of command one by one.  

When debug software or between connect target system, often need execute se
veral fixed command lists, for instance: after connect target system, need execute t
hereinafter steps: stop target CPU—mask interrupt register—set external memory—r



emap memory or download executable file etc. If need input these command after c
onnect target system every time, do you feel boring? Just write a command script fi
le, EmbestIDE will auto execute these commands. 

The commands that used in debug command window also can be used in script 
file. Debug command and its detail reference please refer to the sect ‘Debug Comm
and Lists’.  

E.2 Executive 

Command Script File has two executive ways:  

1.In Command Input Window, input: 

script  <command script filename> 

2.Designate in project setting dialog. When input appointed script filename, the s
cript file will be auto executed after EmbestIDE successful connect target system.  

 

E.3 Example 

Example one: Atmel Eb40, command script file that will be auto executed after 
Embest IDE successful connect target system. 

; stop target CPU 
stop 
; config memory 
memwrite    0xffe00000 0x01002535  
memwrite    0xffe00004 0x02002121  
memwrite    0xffe00024 0x06  
; remap memory  



memwrite    0xffe00020 0x01  
refresh  
download -v D:\Demo\armdemo\debug\led.elf 0x2000000 
; end 

Example two: Samsung SNDS100, command script file that will be auto execute
d after Embest IDE successful connect target system. 

; stop target CPU 
stop 
; mask interrupt 
memwrite 0x3ff4008 0xffffffff 
; config system 
memwrite 0x3ff0000 0x90FFFF83 
; set data-bus width  
memwrite 0x3ff3010 0xfaffff0f 
; config external FLASH 
memwrite 0x3ff3014 0x60000412 
memwrite 0x3ff3018 0x40800414 
memwrite 0x3ff301C 0x40000516 
memwrite 0x3ff3020 0x20800518 
memwrite 0x3ff3024 0x4000061a 
memwrite 0x3ff3028 0x4080061c 
; config external DRAM 
memwrite 0x3ff302C 0x80030004 
memwrite 0x3ff3030 0x80010108 
memwrite 0x3ff3034 0x8001020c 
memwrite 0x3ff3038 0x80010310 
memwrite 0x3ff303C 0x608327ce 
; end 

Example Three:Samsung S3C44B0X, command script file that will be auto execu
ted after Embest IDE successful connect target system.  

Stop  ;stop target CPU 
Reset ;reset CPU 
Stop  
;set the system Registers 
memwrite 0x01D30000 0x00000000  ;WTCON 
memwrite 0x01E0000C 0x07ffffff   ;INTMSK 
memwrite 0x01D8000C 0x00000fff  ;LOCKTIME 
memwrite 0x01C80000 0x11110101  ;BWSCON 
memwrite 0x01C80004 0x00000600  ; BANKCON0 
memwrite 0x01C80008 0x00007FFC  ; BANKCON1 
memwrite 0x01C8000C 0x00007FFC  ; BANKCON2 
memwrite 0x01C80010 0x00007FFC  ; BANKCON3 
memwrite 0x01C80014 0x00007FFC  ; BANKCON4 
memwrite 0x01C80018 0x00007FFC  ; BANKCON5 



memwrite 0x01C8001C 0x00018000  ; BANKCON6 
memwrite 0x01C80020 0x00018000  ; BANKCON7 
memwrite 0x01C80024 0x00860459  ;REFRESH 
memwrite 0x01c80028 0x00000010  ;BANKSIZE 
memwrite 0x01C8002C 0x00000020  ;MRSRB6 
memwrite 0x01C80030 0x00000020  ;MRSRB7 
;end 

Appendix F: Additional Software Tools 

As shown in fig. F-1, click Tools in main menu to open the tool menu of Embest
 IDE. The attached tools include: Elf to Bin, Disassemble all, Symbol table, Flash Pr
ogrammer and SplitBin.  

 

Fig. 1 Interface of tool menu 

F.1 Description 

1. Elf to Bin 

The tool Elf to Bin is the generation tool of binary file format. This tool can be u
sed to change the debug information Elf file, built and generated by IDE, into the bi
nary file necessary for solidification of program.  

The user selects the sub-menu Elf to Bin under Tools menu to generate the sub
-directory Debug under program directory into a Bin file with same name as Elf file.
  

The user can also directly use command line style to complete the above proced
ure. The execution program elf2bin.exe corresponding by the command line is locat
ed at sub-directory Tools under installation directory Embest IDE. The detailed usag
e of command line can be obtained through execution of elf2bin in control table.  

2. Disassemble all 

Disassemble all is a disassembly tool. The user can use this tool to change the 
debug information file elf into the disassembly file including source file and debug s
ymbol.  



The user selects the sub-menu Disassemble all under Tools menu to generate th
e sub-directory Debug under project directory into a disassembly file with the file n
ame as objdump. 

The user can also directly use command line style to complete the above proced
ure. The execution program arm-elf-objdump.exe corresponding by the command li
ne is located at sub-directory Builds/xgcc-arm-elf/bin under installation directory Em
best IDE. The detailed usage of command line can be obtained through execution of
 arm-elf-objdump in control table.   

3. Register Editor 

 

Embest Register Editor is aided development software provided by Embest for t
hose software and hardware engineers to develop embedded systems. During the pr
ocess of circuit design testing, drive program and bottom-layer software compilatio 
debugging, embedded system developers often have to refer to register manual, ma
nually calculate the current values set for the register, and analyze the current valu
es of the register to find their meanings one by one. The Embest Register Editor ca
n automatically fulfill the functions above, and present all the details of the register 
with direct and visual graphics. As a result, it is unnecessary to resort to the registe
r’s data manual during embedded software programming and debugging, and it has
 become an indispensable tool for the development of embedded software. 

As an auxiliary tool for the embedded software Integrated Development Environ
ment Embest IDE, the Embest Register Editor is able to achieve the following functi
ons:  1) Users can view/add/modify the register, register group and process in an i
ntegrated environment; 2) Describes details of customized register.  

More detail about Embest Register Editor, Please click this item to run and open
 the online User’s Manual, also can download it from Embest website, click here.  

The install package of Embest Register Editor can download FREE here.  

4. Symbol table 

Symbol table is the generation tool of debug symbol file. The user can use this t
ool to generate the symbol table of corresponding project debug information. This s
ymbol table mainly records the entrance addresses of various functional symbols.  



The user selects the sub-menu Symbol table under Tools menu to generate the 
sub-directory Debug under project directory into a debug symbol file with file name 
as objdump. 

The user can also directly use command line style to complete the above proced
ure. The execution program arm-elf-objdump.exe corresponding by the command li
ne is located at sub-directory Builds/xgcc-arm-elf/bin under installation directory Em
best IDE. The detailed usage of command line can be obtained through execution of
 arm-elf-objdump in control table. 

5. Flash Programmer 

The tool Flash Programmer solidifies the binary file that the user finally generate
s onto the FLASH chip of circuit board of the user, support to use the programmin
g of FLASH chip in the system developed with ARM series processors, especially su
itable to the user selecting component displacement FLASH. After open, the softwa
re interface is shown in fig. F-2. For the detailed introduction, refer to Embest Onli
ne Flash Programmer User’s Manual.   

 

Fig. F-2 Software interface of Flash Programmer 

6. SplitBin 

Click SplitBin under Tools menu to open the SplitBin tool as shown in following f
ig. F-3. It can split or unite Bin file according to data width and coding manner.  



 

F-3 Split tool interface of Bin file  

Parameter>>Bus width:Select the data width of file to be split, 16bit or 32bit; 

Parameter>>Byte order:Select coding manner of data, little Endian or big Endian;
  

Parameter>>Operate:Select whether the function of tool is split or unite;  

Parameter>>Split length:Select data width of file after split;  

File>>BIN filename:Select the routine and name of Bin file to be split or united;  

Split file 1-4: If in split manner, it will automatically generate 2 or 4 split files acc
ording to data width selected in the right before and after split, for exam
ple, Bus width selects 16bit, Split length selects 8bit, and it will generate 
two files Split file 1 and Split file 2 after split; if in unite manner, select t
he route and name of Bin file to be united. 

Appendix G: Common questions 

Question 1 About gccmain 

Question:  

It appears the following error prompt while connection, why?  

.\debug\main.o: In function ‘main’:  

.\debug\main.o (.text+0xc): undefined reference to ‘__gccmain’  

Answer:  



While gcc builder is building and connecting source file, it will automatically con
nect main function to gccmain function internally provided in gcc, that is, if the pro
grammer defines main function, the execution order of program is:   

 
main() 
    {  
        gccmain() ; 
        Code compiled by customer 
    }  

 

This function is provided in the base libgcc.a, and it must connect libg.a while c
onnecting this base.  

There are three measures for solving connection errors:  

1) Settings in Embest IDE  

Select the menu Project> Settings, open project configuration box, select the lin
ker page and select the option add library searching path in drop-down box, increas
e the path:  

..\..\..\build\xgcc-arm-elf\arm-elf\lib\arm-inter  

..\..\..\build\xgcc-arm-elf\lib\gcc-lib\arm-elf\3.0.2\arm-inter  

The above path is the path relative to Embest IDE routine, and the user can set
 absolute routine:  

Select the linker page, select the drop-down option Include Object And Library 
Modules and add the base:  

-lc  

-lgcc  

When this measure is linked, the program of user will be larger.  

2) Write a gccmain assembly function or C language function by yourself 

Prepare assembly function 

 
          .global     __gccmain  
__gccmain:  
          mov    pc, lr     

 

Prepare C language function 

 
void __gccmain() 
{ 
} 

 

Re-link the program building. 



3) Use __main or directly use __gccmain() as own function entrance. 

Question 2 Connection errors of emulator 

Question: 

In general, what reasons will cause the connection emulator to appear the follo
wing error messages?  

“target cpu not found”, “stop target failed” or “run target failed” 

Answer: 

The connection errors of emulator are generally caused due to following reasons:
  

1) The connection of JTAG interface circuit is not in accordance with the regulations of 
IEEE1149.1-1990, for example TDI, TCK, TMS and other signals are not connected 
pull-up resistance; nSRST shall be connected system reset instead of reset of JTAG. 
In addition, the JTAG interfaces have been correspondingly treated in the chips of 
some processors. The user should read the manual carefully.   

2) Some chips of processors have appointed pins to control the operation of processor, 
they should be connected according to appointed style or otherwise it may cause 
CPU not to stop properly, for example nwait signal of ARM processors. The user 
should pay attention to checking whether nTRI or nWAIT is pulled up, whether the 
reset signal connection is correct, whether clock signal is proper, and referring to 
datasheet;  

3) The emulator cannot obtain power from target board, for example the power of 
target board can only meet the requirements of target board, or JTAG interface has 
not leading power;  

4) JTAG interface switch in the side of emulator has incorrect setting. The user shall 
correctly set the switch according to that the JTAG port in target board has 14 pins 
or 20 pins;   

5) Project setting in IDE environment is not correct, the drop-down box of 
Project>Settings>Remote>Remote device shall select jtagarm7 or jtagarm9 
according to CPU of target board; 

6) Some computers need to amend parallel interface setting mode.  

For user, generally check according to the following steps:  

1) Power. Include voltage and current of power source. Embest Emulator is 
compatible to 3.3V and 5V.  Emulator itself needs the current about several 
decades of mA.  

2) Reset signal. Observe whether reset signal is proper or not, whether it is pulled 
down.  

3) Clock check. Check whether crystal oscillator work normally, whether the clock 
input and output of processor is normal.  

4) NWAIT Signal. Pull up.  



5) nTRI Signal. Pull up.  

6) For some processors, there are some modes or control pin (for example JTAGSEL 
signal) that are required to connect appointed level (pull-up or pull-down) in order 
to support JTAG debugging interface. Please read the datasheet carefully.  

Question 3 To link the useful libraries 

Question:  

How to link the useful libraries provided by GNU, and what modes do they supp
ort?  

Answer:  

-lm means that linker will connect standard mathematic function base libm.a. 

-lc means that linker will connect standard C function base libc.a. 

-lg means that linker will connect the support base of standard function base lib
g.a. 

-lgcc means that linker will connect the support base of GCC libgcc.a. 

-lstdc++ means that linker will connect the support base of C++ libstdc++.a. 

While connection, the arrangement order of these bases is generally as the follo
wing: -lm -lc -lgcc  -lg 

While the cross compiler xgcc-elf-gcc-3.0.2 installed, the C base files supplied b
y Embest IDE for ARM mainly support the following modes: 

  ARM Little-Endian 

  ARM Little-Endian Interwork 

  ARM Big-Endian 

  ARM Big-Endian Interwork 

  Thumb Little-Endian 

  Thumb Little-Endian Interwork 

  Thumb Big-Endian 

  Thumb Big-Endian Interwork 

The different versions of cross compiler tool maybe provide some of above librari
es. For a real cross compiler package usually store the different type of libraries in
to different directories. 

The lists in which Newlib C exists is corresponding to the above modes, and they
 are as follows respectively(libc.a: -lc, libg.a: -lg, libstdc++: -lstdc++, libm: -lm): 

$(BuildTools_Install)\build\xgcc-arm-elf-xxx\arm-elf 

\lib ARM Little Endian 

\lib\arm-inter ARM Little Endian Interworking 

\lib\arm-big ARM Big Endian 



\lib\arm-inter-big ARM Big Endian Interworking 

\lib\thumb Thumb Little Endian 

\lib\thumb-inter Thumb Little Endian Interworking 

\lib\thumb-big Thumb Big Endian 

\lib\thumb-inter-big Thumb Big Endian Interworking 

 

The lists in which libgcc exists:  

$(BuildTools_Install)\build\xgcc-arm-elf-xxx\lib\gcc-lib\arm-elf  

\x.x.x ARM Little Endian 

\x.x.x\arm-inter ARM Little Endian Interworking 

\x.x.x\arm-big ARM Big Endian 

\x.x.x\arm-inter-big ARM Big Endian Interworking 

\x.x.x\thumb Thumb Little Endian 

\x.x.x\thumb-inter Thumb Little Endian Interworking 

\x.x.x\thumb-big Thumb Big Endian 

\x.x.x\thumb-inter-big Thumb Big Endian Interworking 

 

Notes:x.x.x – the cross compiler tool version, such as 3.0.2/3.2/3.3.6/4.0.1 etc; 
$(BuildTools_Install) – the cross compiler install directory, such as C:\EmbestIDE\. 

 

Question 4 How to download the program onto Flash ROM 

Question:  

How to download the program completed debugging in RAM onto Flash ROM?  

Answer:  

The user shall pay attention to or change the following two positions when dow
nloading the program completed debugging in RAM on target board:  

1.Startup program: in RAM, through startup program of debugging, it is not n
ecessary to copy the data section from read-only area to readable and writabl
e area. The initialization of hardware can be completed through IDE command
script or the program download onto Flash ROM. Therefore, the program comp
leted debugging in RAM is generally download onto Flash ROM after amending
startup program, for example in AT91 routine, the startup file for debugging i
n RAM is cstartup_ice.s, the startup file used in Flash ROM is cstartup_flash.s,



according to the routine organization style of AT91, the displacement of startu
p file can be completed through a assembler pre-definition.  

2.Linker script: the program passing through debugging in RAM use such linke
r script that takes RAM area as program code section address, and data sectio
n generally directly follow the code section, while the linker script used in Flas
h ROM uses ROM area as code section address, data section is in RAM area, t
herefore it shall distribute and amend linker script according to the address of
 final target board.   

There are two examples on how to amend the program completed debugging in
 RAM then it can be downloaded onto target board.  

Example 1: the program Led_blink_EB40, which lights LED in AT91EB40 evaluati
on board  

1) Click Project menu>Settings, open project configuration box, change 
“AT91_DEBUG_ICE=1” as “AT91_DEBUG_NONE=1” in Assemble 
page>Predefines options.  

2) Amend linker script file, and the linker script files before and after amendment 
are shown in following figure:  

 

In RAM                         In Flash 

Fig. G-1 The linker scripts that the program uses in RAM and Flash and their 
difference 

Comparing with original script file, the code section and read-only data section
 are put in the position starting from 0x1000000 address, that is, ROM storage a
rea of the system; and present the starting address (RAM address) of readable a
nd writable data section.  

When the above operation is completed, re-build the project, then click IDE m
enu Tools>Elf to Bin, and change elf file into binary format file (*.bin). Finally us



e Embest Flash Programmer to download bin file onto Flash ROM of target board.
  

Example 2: LedInt that NET-START evaluation board lights LED 

1) Set ROM = 1 in pre-definition options of assembler, or directly add “.equ ROM 1” 
in init.s file. 

2) In link file of linker, select flash.ld. This link file and startup file mutually complete 
the transport of data section initially downloaded onto Flash. It has the following 
difference with the script file debugged in RAM: the address of current 0X0 is 
flash storage area, while it is RAM storage area formerly; the current RAM area 
is in the position 0X0400000. The linker script files before and after amendment 
are shown in following figure: 

 

In RAM                         In Flash 

Fig. G-2  The linker scripts that the program uses in RAM and Flash and their 
difference 

When the above operation is completed, re-build the project, then click IDE m
enu Tools>Elf to Bin, change elf file into binary format file (*.bin). Finally use E
mbest Flash Programmer to download bin file onto Flash ROM of target board.  

Question 5 Command script, linker script and memory map file  

Question:  

What is command script, linker script and memory map script?  

Answer:  

Command script:  

While integrating environment and target connection, in the course of debuggin
g software and after resetting target board, sometimes the user needs to integrate 



environment to automatically finish some special functions such as resetting target 
board, clearing off watchdog, screening and interrupting register, memory map, etc.,
 these special functions can be completed through executing a group of commands.
 The text file saving a group of command sequence is called as command scripts fil
e.   

The following are the examples of command script:  

 
; stop target CPU 
stop 
; configurations of the special register  
memwrite    0xffe00000 0x01002535  
memwrite    0xffe00004 0x02002121  
memwrite    0xffe00024 0x06  
; configuration for Mapping Address  
memwrite    0xffe00020 0x01  
refresh  
download -v D:\Demo\armdemo\debug\led.elf 0x2000000 
;end 

 

 

Linker script:  

In the Embed system development, it needs to use linker position file. This f
ile describes the relevant information of code linker position, including code sect
ion, data section, address section, and the linker shall use the code of this file t
o the whole system as correct position. This file is called as linker scripts file.  

The following is an example of Linker script:  

 
SECTIONS 
{ 
 . = 0x02000000; 
 .text : { *(.text) } 
 Image_RO_Limit = .; 
 Image_RW_Base = .; 
 .data : { *(.data) } 
 .rodata : { *(.rodata) } 
 Image_ZI_Base = .; 
 .bss : { *(.bss) } 
 Image_ZI_Limit = .; 
 __bss_start__ = .; 
 __bss_end__ = .; 
 end = .; 
 .debug_info      0 : { *(.debug_info)  } 
  .debug_line    0 : { *(.debug_line)  }  



   .debug_abbrev   0 : { *(.debug_abbrev)} 
   .debug_frame    0 : { *(.debug_frame) } 
} 

 

 

Memory linker map file:  

In the course of debugging software, accessing illegal memory will occur abnor
mal in some processors and target boards. If the abnormality is not handled, it may
 cause the debugging course of software incapable to continue. In order to prevent 
the above issues and adjust the accessing speed of emulator to reach to proper lev
el, a file for describing property of each memory area is provided. Such file is called
 as memory map file.  

The following is an example of map file:  

 
ONCHIPRAM  0    8000   RW - - - - - 
EXTERNDRAM  100000  128000  RW - - - - - 
FLASH    1000000  128000  R  - - - - - 
SRAM    2000000  512000   RW - - - - - 
PERIREG   FFC00000  4000000  R  - - - - - 
 

Question 6 Definition of linker script 

Question:  

Please explain the meaning of linker scripts file?  

Answer:  

The linker script file is used in flash solidification:  
SECTIONS    
{ 
. = 0x000000;   Assign current address as 0 
.text : { *(.text) };  Code section, put program code at this place from 0 

identification code   
.rodata : { *(.rodata) }; Read-only data section, static global variable and other 

immovable values in program are put in this section   
Image_RO_Limit = .; Length of read-only area, the symbol used in the startup 

program 
. = 0x0400000;  Assign current address as 0x400000 
Image_RW_Base = .; Read-write the frame of the area, start the symbols used in 

program 
.data : { *(.data) }; Data section, the global variables initialized in the program 

are put in this section 
Image_ZI_Base = .; Frame of resetting area, the symbol used in startup program 
.bss : { *(.bss) };  Include global accessible data not initialized, for 

example not initialized global variables 



Image_ZI_Limit = .; Length of resetting area, the symbol used in startup 
program 

end = .;    Ending address    
.debug_info   0 : { *(.debug_info)  }; Output section of debugging 

information 
.debug_line   0 : { *(.debug_line)  }     
.debug_abbrev  0 : { *(.debug_abbrev)}    
.debug_frame  0 : { *(.debug_frame) }    
} 

 
 

Linker scripts file used in debugging RAM:  
 
SECTIONS    
{ 
. = 0x000000;   Assign current address as 0 
.text : { *(.text) };  Code section, put program code at this place from 0 

identification code   
Image_RO_Limit = .; Length of read-only area, the symbol used in startup 

program 
Image_RW_Base = .; Read-write the frame of the area, the symbol used in startup 

program 
.rodata : { *(.rodata) }; Read-only data section, the static global variables and 

other immovable values in the program are put in this section    
.data : { *(.data) }; Data section, the global variables initialized in the program 

are put in this section 
Image_ZI_Base = .; Frame of resetting area, the symbol used in startup program 
.bss : { *(.bss) };  Include global accessible data not initialized, for 

example not initialized global variables 
Image_ZI_Limit = .; Length of resetting area, start the symbols used in program 
end = .;    ending address    
.debug_info   0 : { *(.debug_info)  }; Output section of debugging 

information 
.debug_line   0 : { *(.debug_line)  }     
.debug_abbrev  0 : { *(.debug_abbrev)}    
.debug_frame  0 : { *(.debug_frame) }    
} 

 
 

For the section code as follows:  

 
int A1; 
int A2 =5; 
const int A3 = 10; 



 
void main() 
{ 
 int A4; 
 register int A5; 
 A4 = A3; 
} 

 

The variable A1, as not initialized variable, will be stored in the section .bss;  

The variable A2, as initialized variable, will be stored in the section .data;  

The constant A3 is stored in read-only data section .rodata;  

The code that main function is corresponding is stored in the section .text;  

The local variable A4 is stored in the corresponding function stack of main functi
on when the program executes main function;  

The register variable A5 is directly stored in a register of ARM;  

Question 7 How to migrate SDT assemble program 

Question:  

How to migrate the assembly code in the environment of ARM SDT as assembly
 code supported by free software gnu assembler integrated by Embest IDE?  

Answer:  

Migration description on SDT assembly program:  

1) The note line replaces “;” with “#” 

2) Substitution of pseudo instruction characters  

pseudo instructions characters in SDT pseudo instructions characters in 

Embest IDE 

INCLUDE .include 

TCLK2  EQU   PB25 .equ  ECLK2 , PB25 

EXPORT .global 

IMPORT .extern 

DCD .long 

IF:DEF: .ifdef 

ELSE .else 

ENDIF .endif 

:OR: | 

:SHL << 



RN .req 

GBLA .global 

BUSWIDTH SETA 16 .equ BUSWIDTH, 16 

MACRO .macro 

MEND .endm 

END .end 

AREA Word,CODE,READONLY .text 

AREA Block, DATA, READWRITE .data 

CODE32 .arm 

CODE16 .thumb 

LTORG .ltorg 

% .fill 

Entry Entry: 

3) Substitution of operand and operator 

ldr pc, [pc, #&18] ldr pc, [pc, #+0x18] 

ldr pc, [pc, #-&18] ldr pc, [pc, #-0x18] 

 “&” refers to hex 

Question 8 Register and stack of ARM processors 

Question:  

Please explain the register and stack of ARM processors?  

Answer:  

The corresponding form of registers in ARM7:   

R0 ---> R0  

.. ..  

R9 ---> R9  

R10 ---> SL  

R11 ---> FP  Frame pointer points stack bottom  

R12 ---> IP  

R13 ---> SP  The register of stack pointer points to stack top  

R14 ---> LR  

R15 ---> PC  

Legend of stack:   



ARM7 under gcc 2.95/2.97 building uses r11 register as function stack bottom p
ointer, r13 as current function stack top pointer.   

A typical function stack information structure is as follows:   

 Memory high address  

 
Parameters of current function 

Last function 
stack top (r12) 

PC value (of no use) after 
entering function  

 

Return address of current 
function  

Stack bottom 
(r11) 

Last function r13 register value  

Last function r11 register value  

Local variable of current function  

  

 

Function  

Stack 

 

 

 

 

Parameters transferred to next 
function 

Stack top (r13) 

 Memory low address  

Note: directly take r11 value to take PC value, other than function return addre
ss 

Question 9 Building error caused by GCC bug  

Question:  

Free software gcc builder integrated by Embest IDE includes a software bug. Thi
s bug causes the target code produced from building to bring collapse of stack in so
me situations while using __attribute__ ((interrupt ("IRQ"))) style statement C lang
uage common interruption function  

How to program to ensure the normal operation of common interruption?  

Answer:  

User can ensure normal operation of common interruption through the method 
of assembly programming.  

 
            .EXTERN  irq_func 
            .GLOBAL  irq_entry 
irq_entry: 
            stmdb sp!, {r0-r11, ip, lr} /* Save r0-r11, ip, lr */ 
            ldr  r0, = irq_func 
            mov lr, pc 



            bx  r0       /* Use C interruption program*/ 
            ldmia sp!, {r0-r11, ip, lr} /* Resume r0, ip, lr */ 
      subs pc, r14, #4     /* Interruption and return */ 

 

irq_entry is the entry of common interruption function. It completes the pushing
 in stack with relevant register in the common interruption mode, calls irq_func func
tion, pops out register, interrupts return function.  

irq_func is to use C language or assembly language to prepare interruption trea
tment function. This function is not necessary to use __attribute__ ((interrupt ("IRQ
"))) style statement.  

In addition, this bug of gcc software will not affect other interruption vector mo
de, and the treatment function of other vector modes can still use __attribute__ ((i
nterrupt ("FIQ"))),  __attribute__ ((interrupt ("SWI"))) style statement.   

Question 10 To debug the project of ARM SDT  

Question:  

How to use Embest IDE to debug the project in ARM SDT environment?  

Answer:  

Embest IDE can debug the file to be produced with ARM SDT project building lin
ker. 

The user needs to make the following settings in the building environment of S
DT:  

In ARM SDT main menu click Tools>Configure, 

1.Take <cc>=armcc menu, select the page Language and Debug, set Debug Ta
ble Format as dwarf 1 option, and set Optimization Level as None option;  

2.Take <asm>=armasm menu, select the page Options, and set Debug Table F
ormat as dwarf 1 option;  

3.Select armlink menu, select the page Output and set Output Formats as Arm 
Elf Image format option;  

The above setting can aim at single project and be realized through selecting Pr
oject > Tool Configuration menu. The settings are same as the above.  

The user can use the above settings, under ARM SDT environment, to build and
 produce the corresponding output file of this project prj.elf. 

In Embest IDE environment, the user selects Project > Settings menu, sets this
 output file as symbol file and download file for debugging in the Debug page of dia
log box, and sets the local directory of source file in directory page simultaneously, 
then it can perform debugging upon this file at source file level or assembly level.  

FAQ 11  FAQ for ARM compiler 

Question A 

Which versions of ARM compiler does Embest IDE support? 



Answer 

Embest IDE supports the compilers of ARM SDT V2.50 and ARM SDT V2.51, but
 does not support the compilers over ARM ADS V1.2 version. 

ARM ADS V1.2 uses the same compiler version as ARM SDT V2.51, but it scree
ns some output formats of debugging information. 

 

Question B 

Although sometimes there shows “Command(s) successfully executed.”when co
mpiling, it actually generates no target files, why? 

Answer 

Because the user’s ARM compiler hasn’t acquired authorization. 

If armcc command is executed in DOS command line, it would show the prompt
 similar to the following:  

This licence has not yet been installed. 

 

Question C 

Compiling whilst there shows “...Fail to executing above command. “C:\Bin\arm
asm” maybe not found or executed!”? 

Answer 

1, It hasn’t yet been installed or the installation is wrong in ARM compiler direct
ories. User should choose item “Tools>Options” and then install the ARM compil
er path on the directories page of Options dialog box. 

2, ARM compiler or relevant files are damaged, so execution fails. 

Question D 

When linking, it shows the prompt like: “Warning: File C:\LIB\armlib_cn.32l not 
found.”? 

 

Answer 

The prompt indicates failure to link to library file C. 

User should refer to 5.4.3, open the configurations behind SDT or ADS projects 
and then install the search path of library file; provided user has installed ARMLIB i
n the environment variable, they will have a same result as installing the search pa
th of library file in projects. 
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	About this book


	This book is user manual for Embest IDE for ARM. It describes the major features of EmbestIDE, installing Embest IDE for ARM, graphical user interface components of EmbestIDE, and provides information on debugging applications with EmbestIDE.
	This book is organized into the following chapters:
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	Read this chapter for an introduction to EmbestIDE.
	Chapter 2
	Installing Embest IDE for ARM
	Details for installing EmbestIDE, registering, files and folder structures of EmbestIDE.
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	Project examples
	Give some examples to lead users to start with EmbestIDE quickly
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	Editor
	Read this chapter for details about how to use EmbestIDE built-in text editor. It describes the basic functionality of the editor.
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	Project management
	Read this chapter for details about how to use project files to organize your project source files.
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	Project build
	Details about specify the output from compiling and linking your source. This chapter gives details about how to configure compile options and link options of a project.
	Chapter 7
	Software debug
	Introduce the debugger of EmbestIDE, details about how to debug arm-based application with EmbestIDE.
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	Customization and Options
	Read this chapter for details about customizes EmbestIDE.
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	JTAG Emulator Hardware Reference
	Appendix B
	Debug Output Reference
	Appendix C
	Debug Command List
	Appendix D
	Memory Map File
	Appendix E
	Command Script Reference
	Appendix F
	Additional Software Tools of Embest IDE
	Appendix G
	Common questions
	
	Further Reading


	This book describes all the details about Embest IDE. Refer to the following books for information on other components of developing embedded application base on ARM processors:
	ARM Architectural Reference Manual (ARM DUI 0100)
	ARM Reference Peripheral Specification (ARM DDI 0062)
	ARM Target Development System User Guide (ARM DUI 0061)
	— �you can get these papers from: www.arm.com
	Program reference of Embest IDE
	
	Typographical Convention


	The following typographical convention are used in this book:
	Menu quote
	Use > to separate the main menu and submenu
	Commands
	Highlights important notes
	Notes
	Italic denotative arguments with lines above and below
	Notes: this is an important note, and please pay attention to it.
	
	Feed Back on This Book


	If you have any problems with this book, please send email to press@embedinfo.com giving:
	the document title
	the page number(s) to which your comments apply
	a concise explanation of the problem.
	General suggestions for additions and improvements are also welcome.
	I. Overview

	This chapter introduces the Embest IDE. It contains the following sections:
	About the Embest IDE
	main characteristic of Embest IDE
	User Interface Basics
	
	1.1 About Embest IDE


	Embest IDE is an Integrated Development Environment for software cross-development. The EmbestIDE is an application that provides a simple and versatile graphical user interface and tools for developing embedded software. It is an Integrated Development
	An integrated source-code editor.
	A project management facility.
	Integrated C and ASM compilers and linker.
	a source-level debugger.
	an integrated development environment.
	an ARM simulator
	�
	Figure 1-1: EmbestIDE Tools
	EmbestIDE uses host-target cross model for developing embedded applications. EmbestIDE runs on a host computer. Your target board is connected to the host computer through debug device (BDM/JTAG Emulator). You can edit and build your projects on the ho
	When you use Embest IDE for ARM, a debug device—E
	�
	Figure 1-2 the Host-target Cross Model with Embest IDE
	
	1.2 Major Features of Embest IDE


	EmbestIDE runs under Windows 95 above and Windows NT 4.0 above. EmbestIDE supports target microprocessors debugging on the ARM-core microprocessor families, 68K, PowerPC, and Coldfire microprocessor families.  EmbestIDE provides a simple, versatile and g
	Comprehensive project management capabilities
	Code navigation routines to help you locate routines quickly.
	EmbestIDE enables you to organize source code files, library files, other files, and configuration settings into a project. Each project enables you to create and manage multiple configurations of build target settings.
	Major features of EmbestIDE:
	Support development language: ANSI C, ARM assembly language.
	User interface: consists of an integrated set of 
	Source code Editor: Standard text manipulation capabilities; C and ASM syntax-element color highlight; Debugger integration, the editor window tracks code execution; Compiler integration, the project management utility links compiler warnings and errors
	Project Management: The EmbestIDE project facility simplifies organizing, configuring, and building embedded applications. It includes graphical configuration of the build environment (including compiler flags).
	Compiler: includes the GNU compiler, as well as a collection of supporting tools that provide a complete development tool chain: cpp, C preprocessor; gcc, C compiler; make, program building automation tool; ld, programmable static linker; as, portable as
	EmbestIDE debugger: a powerful graphical debugger that enables program loading, executing, running control, and monitoring; a source-level debugger, view your application code as C, as assembly-level code, or in a mixed mode that shows both; full-feature
	
	1.3 User Interface of EmbestIDE


	The user interface is the portion of the environm
	To step into EmbestIDE, just run EmbestiDE.exe. EmbestIDE user interface consists of an integrated set of windows, tools, menus, toolbars, directories, and other elements that allow you to create, test, and refine your application. Figure 1-3 shows the m
	�
	Figure 1-3  Embest IDE Main GUI
	Title column displays current opening file name. Menus column and tool bar column are below title column. The menu bar is a special toolbar at the top of the screen that contains menus such as File, Edit, and Build. The standard tool bar appears just bel
	II. Installation
	2.1 System Requirement


	Host:
	A PC with a Pentium or higher processor
	Memory:
	More than 64M
	Disk Space:
	150M
	Monitor:
	VGA or Super VGA color monitor
	Operation System:
	Microsoft Windows 98, Windows NT with Service Pack 3 or later, Windows 2000, Windows Me, Windows XP
	Others:
	Mouse, Parallel Port, CD-ROM
	
	2.2 Install and remove Embest IDE
	2.2.1 Install main programs



	Step1: It is strongly recommended that you exit all programs under Win32;
	Step2: Place Embest IDE setup CD in CD-Rom, run the setup program (if operating system allows CD-Rom to run it automatically, a setup interface will popup when CD-Rom reads disc), user can also install setup program by running Setup.exe from CD;
	�
	Figure 2-1 Welcome dialog box
	Step3: click Next button in Welcome dialog box;
	�
	Figure 2-2 License dialog box of setup program.
	Step4: License dialog box lists the agreement of Embest IDE system user, click Yes to agree the agreement, the system goes to the next step;
	�
	Figure 2-3 Input Register User dialog box
	Step5: Enter user information in the dialog box, click next to continue;
	�
	Figure 2-4 Destination Location dialog box
	Step6: Select the destination folder of Embest IDE system in Destination Dialog Box, the default folder is C:\EmbestIDE, if user selects the default folder, click Next to continue; if users needs select another folder, click Browse button, a Choose Fold
	�
	Figure 2-5 Choose Folder Dialog Box
	Notices: To ensure normal operation of cross the installation path of Embest IDE should not contain space so as to ensure normal operation of cross compiler; this caution also apply to the undermentioned name of folders and source file.
	Step7:  Enter the name of program group in Program FolderDialog Box, choose Next to continue;
	�
	Figure 2-6 Information Dialog Box
	Step8: Information Dialog Box contains current setup information and system information, if you are satisfied with the settings, click Next to begin copying files;
	�
	Figure 2-7 Copying files of setup program
	Step9: when the copying is finished, the system indicates users to restart the computer, user must restart the computer after the setup is finished, and obtain legal License file, then Embest IDE can run normally.
	�
	Figure 2-8 Setup finished
	
	
	2.2.2 Remove Embest IDE



	Embest IDE can be removed by running setup progra
	�
	(a) Remove Embest IDE by running setup program (recommended)
	�
	\(b\) Remove Embest IDE using “Add/Delete Prog�
	Figure 2-9 Development environment of Removing Embest IDE
	Notices: if user modifies installation folder or files, or adds new folders or files during using Embest IDE, they will not be removed together with the program.
	
	
	2.2.3 Setup of compiler tool



	Embest IDE development environment can use GNU GCC compiler toolchain of different versions, toolchain of different versions can be installed in Build folder under Embest IDE installation folder.
	User can choose setup link of cross compiler in the setup wizard of Embest IDE software, or directly run setup wizard of compiler toolkit in the CD. Compiler toolchain of all versions provide a setup file like xgcc-arm-elf-xxx.exe (xxx is version No.)
	When setup wizard of compiler toolkit is run, the welcome interface below will popup.
	�
	Figure 2-10 welcome interface of setup wizard of compiler toolkit.
	Click Next, select the install directory of compiler toolkit, the setup program will create the folder Build\xgcc-arm-elf-xxx under the install directory.
	�
	Figure 2-11 Select install directory for compiler toolkit.
	Then click Next, setup program will copy compiler toolkit, STL (Standard Template Library) and GCC support library to designated folder.
	�
	Figure 2-12 Copy program files to install directory
	
	
	2.2.2 Remove compiler toolkit



	User can use “Add/Delete Program” under control p
	�
	Figure 2-13 remove compiler toolkit using “Add/De
	Notices: if user modifies the name or content of installation folder or files, or adds name or contents of new folders or files, they will not be removed together with the program.
	
	2.3 Directories & Files
	2.3.1 Directories & Files



	The files of Embest IDE release are copied to a directory and its subfolders, when the installation steps finished. For example, if the destination location is C:\EmbestIDE, several sub-directories will be created on it, and the files will be copied acc
	Table 2-3-1-1
	Folder/File
	Description
	Bin
	Folder with main application, DLL files and DLL folders
	Build
	Folder created when GNU GCC Cross-Compiler for ARM installed. Recommend installation any version of GNU GCC Cross-Compiler and library here. Every subdirectory includes one type of GCC tools. For example, C:\EmbestIDE\Build\xgcc-arm-elf-3.0.2 is the G
	Doc
	Folder with documents
	Examples
	Folder with samples
	ide.ini
	Configuration files of Embest IDE, it shows the folder of the modules and other settings in running.
	Licenses
	Folder with license files
	Peripheral
	The information library of the peripheral registers of the processors set by the system
	Target
	Folder with BSP files
	License.txt
	License file
	Readme.Txt
	Readme file
	Tools
	Folder with the tools in system application include Flash Programmer, elf2bin etc.
	Description of directory C:\EmbestIDE\Bin show at Table 2-3-1-2.
	Table 2-3-1-2
	Folder/File
	Description
	Build
	Folder with cross-compiler interface files
	CPU
	Folder with CPU interface files
	Device
	Folder with device interface files
	File
	Folder with file modules
	Description of directory C:\EmbestIDE\Examples Table 2-3-1-3
	Table 2-3-1-3
	Folder/File
	Description
	ARM
	Command examples for ARM include particular assemble examples
	SDT&ADS
	ADS 1.2 and SDT 2.51 Projects, can open and debug under Embest IDE
	
	
	2.3.2 File Types



	Table 2-3-2-1
	Name
	Description
	*.ews
	Workspace file of EmbestIDE
	*.pjf
	Project file of EmbestIDE
	*.opt
	Workspace status file
	*.ini
	Config file of EmbestIDE
	*.c
	C source file
	*.C
	C++ source file
	*.cc
	C++ source file
	*.cp
	C++ source file
	*.cxx
	C++ source file
	*.c++
	C++ source file
	*.cpp
	C++ source file
	*.s
	Assemble source file
	*.asm
	Assemble source file
	*.h
	C/C++ header file
	*.inc
	Assemble include file
	*.mac
	Macro file
	*.map
	Memory map file
	*.cs
	Command script file
	*.ld
	Link script file
	*.o
	Object file
	*.a
	Library file
	
	2.4 Product registration


	From Embest IDE Pro for ARM 2005, EMBEST INFO&TECH CORPORATION grants each Embest IDE software a 30-day full-function license (Evaluate), within these days (maximum 30 days) user can normally use all debug functions under Embest IDE development envir
	If user does not register the software before expiry (maximum 30 days), the software will not be operable unless with official license software, when the Evaluate expiries, the register notice below will popup every time Embest IDE is run.
	�
	2-4-1 Register notice window
	Notices:
	1. Users please do not attempt to modify system time of your computer, to prevent fault of Embest IDE during Evaluate period.
	2. During the Evaluate period, the software or hardware of Embest IDE has full software and hardware functions of official versions.
	The registration of authorized users include two steps: 1. generate registration information file; 2. Submit registration information file, obtain license file.
	Official license includes personal PC binding version and floating version. The license for personal PC binding version requires submission of a registration application file key.dat generated in local machine; while the license for floating version can
	
	
	2.4.1 Generate registration information file



	Every time you run EmbestIDE.exe, a dialog box wi
	When users chooses “Register”, first a user infor
	�
	2-10 Register information dialog box
	1
	User Name
	Compulsory field. Used to provide services and technical support.
	2
	Company Name
	Compulsory field. Used to provide services and technical support.
	3
	Phone Number
	Compulsory field. Used to contact users or notify users of services and upgrade
	4
	Fax Number
	Compulsory field. Used to contact users or notify users of services and upgrade
	5
	Contact E-mail
	Compulsory field. Used to contact users or notify users of services and upgrade
	6
	Emulator Number
	Compulsory field. The necessary content for license generation and premise for license grant.
	7
	Licenses Type
	User must first choose a PC Licenses, then he can enter the above data.
	When choosing Floating Licenses, he must enter Server IP of LAN.
	
	
	
	1. Apply for license for personal PC binding version




	Single user please choose PC License in the column License Type, then complete your accurate information as an end user:
	�
	Figure 2-11 Use PC Licenses registration dialog box
	
	
	
	2. Apply for license for floating version




	For Embest IDE users, if you have registered Embest Floating Licenses Server in the same LAN, you can enter the legal IP address of the PC which is installed and licensed Embest Floating Licenses Server when you choose Floating Licenses, see the figure b
	�
	Figure 2-12 Use Floating Licenses registration dialog box
	Notices:
	1. Unlike PC Licenses, for Floating Licenses computer does not have to generate license file (but the server should first be registered in the same way with that of PC Licenses).
	2. Please refer to User’s Manual of Embest Floati
	
	
	2.4.2 Acquire runtime license file



	Complete user information accurately, and submit 
	1. Email it to Licenses@embedinfo.com (it is strongly recommended you zip it first to avoid transmission error); or
	2. print it and fax it to (+86)0755-25616057; or
	3. save it in floppy disk and send it to EMBEST I
	Then user will receive the License.dat from EMBES
	Notices:
	1. Please do not modify the generated key.dat file;
	2. If users applies for Licenses file by email, generally they will receive the reply within 24 hours;
	3.Any attempt to modify Embest IDE file or modify the content of officially granted License file may result in software runtime error.
	4. Unless you replace computer HD or mainboard, the officially granted can be reused normally, so please backup Licenses file.
	5. If user has trouble acquiring license file, please feel free to contact our Market Department, so as to prevent any delay.
	
	2.5 Connecting the Emulator Hardware


	Embest Emulator is a JTAG-based debugging channel for ARM microprocessors. It provides an interface between Embest IDE and an ARM microprocessor deeply embedded.
	�
	A standard male-to-female 25-way parallel cable c
	The connection to the target board is made by a 20-way (or 14 - way) female IDC header cable (BT224 type) with all pins connected straight through (1-1, 2-2, ... 20-20).
	Note: Connecting cable dose not provide hot swap
	For further pin-out details, refer to Embest IDE JTAG interface connections on page A-2.
	III. Quick Start
	3.1 Simple Example


	This section shows users step by step how to create, compile and debug a simple project. The project described below is to create a random number.
	The project demo locates at \Examples\arm\explasm under EmbestIDE installing directory. The files to be used are:
	Random.s
	Assemble file of random number function
	Randtest.c
	Main program file
	Note:
	1. Only source files above are used. The project can only be run and debugged by simulator under EmbestIDE.
	2. The project doesn’t link to any function libra
	
	
	3.1.1 Create a Project



	1) Creating Project
	Select File > New Workspace menu, Give a project name and specify project directory as shown in Figure 3-1:
	�
	Figure 3-1 Create a New Project Dialog box
	Rantest has been used as a project name, and project directory has been specified manually as D:\EmbestIDE\Example\arm\explasm\, D:\EmbestIDE is supposed installing directory of EmbestIDE unless noted.
	After clicking OK, two files will be created in the project directory:
	Rantest.ews
	Workspace file (one or more project files.)
	Randtest.pjf
	Project file
	Note:
	1. It is normally generate both workspace and project files with the same project name under the location.
	2. Workspace and project files are maintained by EmbestIDE system itself. Users cannot edit these files manually.
	After the project has been created, files pane will appear in EmbestIDE workspace window as shown in Figure 3-2.
	�
	Figure 3-2 Workspace Window
	The Figure 3-2 shows current workspace is rantest which contains a project named rantest. Boldface indicates that rantest is an active project.
	2) Add Source Files
	Choose Project Source Files folder in rantest workspace window. Click Project > Add To Project > Files to add source files. You can also right click Project Source Files folder to add source files, See Figure 3-3:
	�
	Figure 3-3 Add Source Files In Workspace Window
	You can add the source files in the pop up dialog box. To select source files, press CTRL key and hold, click source files of random.s and randtest.c in Project directory, See Figure 3-4.
	�
	Figure 3-4 File Open Window
	After the source files added, workspace window is shown as Figure 3-5.
	�
	Figure 3-5 Workspace Window
	
	
	3.1.2 Project Settings



	After creating a project, you need to configure the project. The project settings include CPU settings, emulator settings, debug settings, directory settings, compiler settings, assembler settings and linker settings. The project settings is a critical s
	Click Project > Settings, Project Settings dialog box pops up, then Choose randtest files in the dialog.
	1. CPU Settings
	Select Processor pane from Project Settings dialog box. Define CPU module as ARM7, CPU family and CPU member as ARM7 too. Switch Endian to little endian. Build tools are GNU tools for ARM. Figure 3-5 is a Project Settings dialog.
	�
	Figure 3-5 Processor pane of Project Settings Dialog
	After build tool has been set, Project Settings dialog will show the pane of this build tool.
	2. Emulator Settings
	Select Remote pane from Project Settings dialog. 
	�
	figure 3-6 Remote Pane of Project Settings Dialog
	Device Module
	Description
	JtagARM7----- Embest Emulator for ARM debug ARM7-series CPU
	JtagARM9----- Embest Emulator for ARM debug ARM9-series CPU
	PowerICEARM7----- Embest PowerICE for ARM debug ARM7-series CPU
	PowerICEARM9----- Embest PowerICE for ARM debug ARM9-series CPU
	UnetICE----- Embest UnetICE for ARM debug ARM7/9-series CPU
	simARM7----- Embest IDE for ARM simulator (only for ARM7-series CPU)
	3. Debug Settings
	Select Debug pane from Project Settings dialog. Select General from Category, Set symbol file as ./debug/rantest.elf and Action after connected as None. See Figure 3-7.
	�
	figure3-7 Debug General Options of Project Settings Dialog
	Select Download from Category. Set Download file as ./debug/rantest.elf. set Download Verify option on. Set Download file to address 0x2000000. Execute program starting from download address. See Figure 3-8.
	�
	figure 3-8 Debug Download Options of Project Settings Dialog
	Note:
	1. Flat Binary format can be used for download files. The tool ELF2BIN provided by IDE can transfer ELF files to the files with flat binary format.
	2. Please change download address according to the project linker options setting.
	3. You must manual input the strings in the box “
	Set Memory Map to No map file. See Figure 3-9.
	�
	Figure 3-9 Debug Memory Maps Options of Project Settings
	4. Compiler Settings
	Select Compiler pane from Project Settings dialog. Set Object Files Location as ./debug and others as default. See Figure 3-10.
	�
	Figure 3-10 Compiler Pane of Project Settings Dialog
	5. Assembler Settings
	Select Assembler pane from Project Settings Dialog. Set Object Files Location as ./debug and other as default. See Figure 3-11.
	�
	Figure 3-11 Assembler Pane of Project Settings Dialog
	6. Linker Settings
	Select Linker pane from Project Settings Dialog. Select General from Category. The Output file name is the default setting as ./debug/<project_name>.elf (sometimes copy it to the Symbol file and Download file of Debug setting); Modify Linke Options inp
	-Ttext 0x2000000 (take care of the SPACE between other options, means that address of entire executive program code will start from 0x2000000.)
	Keep others as default. See Figure 3-12.
	�
	Figuer 3-12 Linker General Options of Project Settings
	Note:
	1.-T is one of the linker options to set the star
	2. You also can change the default text address b
	Select Image Entry Options from Category. Set Select Entry File as rantest.o. Select entry point as Main. See Figure 3-13.
	�
	Figure 3-13 Linker Image Entry Optios of Project Settings Dialog
	Entry File ‘Rantest.o’ means that executive code 
	Entry Point means that executive code will run starting from this label address.
	Note: The step described above can be skipped if users open workspace file explasm.ews created under the directory.
	
	
	3.1.3 Compile and Link



	Click Build > Build rantest to complete entire project building. You can view the output in the output window, the following messages show as Figure 3-14.
	�
	Figure 3-14 Build Output Window
	The message shown in the window indicates that this project building has been success.
	
	
	3.1.4 Debug



	1. Create Executive File
	Click Tools > Elf to Bin to automatically transfe
	You can also complete file transfer by running elf2bin.exe located in Bin sub-directory under install directory.
	Note: This step can be skipped if you have make a choice of downloading ELF format file directly.
	2. Active connection
	Click Debug > Remote Connect to active the connection with the target board through Embest JTAG emulator. The target board will be one of the two kinds of status:
	\( Running status: When the target board is in t
	�
	Figure 3-15 Debug Output Window
	In this case, Embest IDE Disassemble window shows nothing.
	\( Stop status \(This happens when you stopped�
	�
	Figure 3-16 Debug Output Window
	In this case, Embest IDE Disassemble window shows assemble instruction, with the instruction currently PC is pointing to beginning. See Figure 3-17.
	�
	Figure 3-17 Disassemble Window
	Note: In general, disassemble window which you see is not as same as above.
	3. Download File
	Click Debug > Stop to stop running target board if current target board is on running status. Click Debug > Download to download file if current target board is on stopping status. Downloading parameters were set through Debug pane in Project Settings di
	When download is completed, program pointer will automatically return to program starting point. Disassemble window will appear as shown in Figure 3-18.
	�
	Figure3-18 Disassemble Window
	At the same time, rantest.c source file window will appear as well as shown in Figure 3-19.
	�
	Figure 3-19 Source File Window
	4. Debug
	Click Debug > StepOver to run program to this line:
	random = randomnumber();
	Click View > Debug Windows > Variables menu to show the Variable window. Continuous to click Debug > StepOver to view the changes of function variables as shown in Figure 3-20.
	�
	Figure 3-20 Variables Window
	
	3.2 A Complete Example


	This section shows you step by step to create, compile and debug a complete project. The project demonstrates communication between PC and AT91EB40 evaluation board through parallel port. This is a complete embedded application.
	The example project locates at \Examples\AT91\ATEB40x\EB4008\ under Embest IDE installed directory after installed the examples for ATEB40x board1. The files to be used are:
	1. We have provided an accessory CD-ROM with contained software installation package.
	term.c
	Terminal Test Main Program File
	Terminal_irq.s
	Assemble Interrupt Handle Program File
	Cstartup.s
	Startup Program File for evaluation board. The file locates at the following sub-directory under installed directory ATEB40x\Targets\EB40008\.
	The differences between the project described in this section and the project described in the previous section are:
	( The project of this section contains complete target board startup codes. After the program is debugged successfully, you can change AT91_DEBUG_ICE=1 defined by project settings to AT91_DEBUG_NONE=1, replace the linker script file as flash_eb40x.ld (
	( The project of this section uses individual linker scripts. The file is
	ram_ice_extern.ld
	Linker Script file for RAM Debugging, locate the text area start address in extern SRAM.
	sram_ice.ld_inner.ld
	locate the text area start address in inner SRAM.
	flash_eb40x.ld
	Linker Script file for Flash Running, use to build the image file to program into Flash.
	Flash_ram_run.ld
	Linker Script file for RAM Running, use to build the image file to program into Flash, but copy itself to inner SRAM to run.
	( The project of this section links to standard C function library. The file of function library supports arm interwork format.
	Libc.a(-lc)
	Standard C function library, the file is located at \build\xgcc-arm-elf\arm-elf\lib\arm-inter.
	Libgcc.a(-lgcc)
	Support base of GCC library, the file is located at \build\xgcc-arm-elf-xxx\lib\gcc-lib\arm-elf\x.x.x\arm-inter.
	( The project of this section connects to peripheral driver function library and device function library of AT91 series CPU provided by ATMEL. They include:
	Lib_drv_32.lib
	Peripheral Driver Function Library,The file is located at AT91Lib\drivers\lib_drv\arm-inter\ under installed directory. The project file creating the library is located at the directory one level up. It can create THUMB instruction library or ARM Int
	R40008_lib32.lib
	Device Function Library. The file is located at AT91Lib\parts\r40008\arm-inter\ under installed directory. The project file creating the library is located at the directory one level up. It can create THUMB instruction library or ARM Interwork librar
	Note 1: Before using the project, if could not found the libraries Lib_drv_32.lib and r40008_lib32.lib:
	1. Install the software package for the ATMEL AT91 CPUs.
	2. Open workspace file lib_drv_32.ews, which located at AT91Lib\drivers\lib_drv\ directory to build peripheral driver function library named lib_drv_32.lib, and open workspace file r40807_lib32.ews, which located at AT91Lib\parts\r40008\ to build d
	Note 2:If you don’t want to use ARM Interwork, yo
	
	
	3.2.1 Create Project



	The project called EB40008UART can be created and related source files can be added by following the same procedure described in the previous section at \Examples\AT91\ATEB40x\EB4008\ under installed directory. Final workspace window will beappeared
	�
	(a) add files in project directly (only the project source files)
	�
	(b) after modify the folder names and add all files (not necessary)
	�
	(c) right click the folder name and modify the folder properties
	Figure 3-21 Workspace Window
	
	
	3.2.2 Project Settings



	The processor settings and remote settings can be done by following the same procedure described in Section 3.1.2 previously. Please refer to it. You can indicate the CPU to use by the Peripheral1 item, select the Maker as ATMEL and Chip as AT91R40807 (
	1. If could not find the chip or compatible chip want to debug, leave it empty and well.
	�
	Figure 3-22 Processor options of Project Settings Dialog
	1. Debug Settings
	Select Debug pane from Project Settings dialog. Set Symbol file settings as .\debug\EB40008.elf. Set Action after connected option to Command script and input the file ..\Targets\boot_EB40x.cs. See Figure 3-22.
	�
	Figure 3-22 Debug General Options of Project Settings Dialog
	Select Download from Category. Set download file to .\debug\EB40008.elf. Set Download Verify option on. Set download address for download file as 0x0100 (). Execute program starting from download address as shown in Figure 3-23.
	�
	Figure 3-23 Debug Download Options of Project Settings Dialog
	Memory Maps Settings is the same as the first section. Please refer to it.
	2. Directory Settings
	Select Directory pane from Project Settings Dialog. Set additional source file directory as ..\AT91Lib and ..\Targets. If you want to track the program in driver function library or device function library, you can add more source file directories here
	�
	Figure 3-24 Directory Pane of Project Settings Dialog
	3. Compiler Settings
	Select Compiler pane from Project Settings Dialog. Select General from Category. Set Object files location as .\debug and add two include directories: ..\..\AT91Lib, ..\..\AT91Lib\parts\r40008 and ..\Targets\EB40008. Select Target Specific Optio
	�
	Figure 3-25 Compiler General Options of Project Settings Dialog
	4. Assembler Settings
	Select Assembler pane from Project Settings dialog. Select general from category. Set Object file location as .\debug. Add three include directories: ..\..\AT91Lib, ..\..\AT91Lib\parts\r40008 and ..\Targets\EB40008.  Add three predefines: ATEB40
	�
	Figure 3-26 Assembler Pane of Project Settings Dialog
	5. Linker Settings
	Select Linker pane from Project Settings dialog. Select general from category. Set Output file name as .\debug\<Project_name>..elf and linker script file as ..\Targets\ram_ice_inner.ld as shown in Figure 3-27.
	�
	Figure 3-27 Linker General Options of Project Settings Dialog
	Select Image Entry Options from category. Make entry file as cstartup.o as shown in Figure 3-28.
	�
	Figure 3-28 Linker Image Entry Options of Project Settings Dialog
	Select Add Library Searching Path from category. Add the library files path: D:\EmbestIDE\Build\xgcc-arm-elf\arm-elf\lib\arm-inter (use the ARM interwork format library file libc.a) and D:\EmbestIDE\Build\xgcc-arm-elf\lib\gcc-lib\arm-elf\3
	Select Include Object and Library Modules from category. Add three library files:
	..\..\AT91Lib\drivers\lib_drv\arm-inter\lib_drv_32.lib
	..\..\AT91Lib\parts\r40008\arm-inter\r40008_lib32.lib
	-lc
	-lgcc
	See Figure below.
	�
	Figure 3-29 Linker Include Object Options of Project Settings Dialog
	Note: The step above can be skipped if you directly open workspace file term.ews created in the directory.
	
	
	3.2.3 Compile and Link



	Click Build > Build term to complete compiling, a
	
	
	3.2.4 Debug



	1. Terminal Program Settings
	Connect Serial A on ATEB40x board to COM port of PC by using a standard series port wire. Run Terminal program of windows. Click Setting > Communication and set communication parameters as shown in Figure 3-30.
	�
	Figure 3-30 Terminal Program Communication Settings Dialog
	Select port according to COM port of PC connected. Figure 3-30 above is set to COM1 Port.
	2. Debug
	Create executive file, active the connection with target board through Embest JTAG emulator, and then download the executive file. Disassemble window will pop out after downloading file. Disassemble window will show assemble code starting from address 0x
	�
	Figure 3-27 Source File Window
	Click Debug > Go again. The program starts runnin
	�
	Figure 3-27 Terminal Program Window
	Input “Hello, Embest”. Terminal program will show
	
	3.3 Example Project of S3C4510B


	The example program introduced in this part is a complete program based on S3C4510, which may be debugged in RAM, and solidification may be normally conducted in ROM. Led will be lit at interval during normal operation period, and press the button to lig
	For the convenience of users to rapidly understand S3C4510 programming and application, the whole software includes only two program source files:
	starting assembling file: init.s
	C source program file: ledint.c
	All macro definitions are included in the source files, and no other header files are used.
	The example program has integrally demonstrated the starting process of S3C4510 processor, including configuration of memory area, stack setting and interrupt vector setting, and has demonstrated the control to IO port after completion of starting and fu
	The example program is based on EV4510 EVM board of Embest Corporation, and the basic configuration includes 2M of Flash area, 16M of DRAM area, IO port P16 connected to LED1, IO port P17 connected to LED2, and IO port P9 connected to the button. If deve
	
	
	3.3.1 Interpretation of Source Program



	starting assembling file
	Starting assembling file “init.s”; starting assem
	What shall be paid attention to includes:
	1) if software is debugged in RAM, the configuration of memory area will be completed by integration environment through command  script file, therefore, it is unnecessary to use memory area configuration code in program, which can be completed through 
	2) when debugging is made in RAM, it is unnecessary to copy the content of data segment, which will be automatically selected in program through judgment whether the addresses of read only area and read-write area are overlapped;
	3) no handing to primary exception vector such as failure of prefetch has been made in the code, perfect program shall handle any of primary vectors, including saving the implementing state before entering into primary exception vector for reference and
	The source code and the detailed interpretation o
	/****************************************************
	* file name: init.s
	*  description: S3C4510 starting program
	****************************************************/
	#===================================================
	# programming register bit definition
	#===================================================
	.EQU    LOCKOUT,0xC0   @ forbid all interrupts
	.EQU    MODE_MASK,0x1F   @ processor mode bit.EQU    UDF_MODE,0x1B   @ undefined mode UDF
	.EQU    ABT_MODE,0x17   @ abnormal mode ABT
	.EQU    SUP_MODE,0x13   @ superuser mode SVC
	.EQU    IRQ_MODE,0x12   @ interrupt mode IRQ
	.EQU    FIQ_MODE,0x11   @ fast interrupt mode FIQ
	.EQU    USR_MODE,0x10   @ user mode USR
	#====================================================
	# set interrupt and primary exception vector
	#====================================================
	ENTRY:
	B       Reset_Handler@ implement from here after S3C4510 reset
	B       SystemUndefinedHandler
	B       SystemSwiHandler
	B       SystemPrefetchHandler
	B       SystemAbortHandler
	BSystemReserv
	B       SystemIrqHandler
	B       SystemFiqHandler
	#===================================================
	# reset entry point
	#===================================================
	.globalReset_Handler
	Reset_Handler:                      @ reset entry point
	#==================================================
	# set system configuration register
	#==================================================
	LDRr0, =0x3FF0000 @ address of system configuration register: 0x3FF00000
	LDRr1, =0x83FFFF90   @ value of register is set as 0x83FFFF90
	STRr1, [r0]  @ significance of register: to use synchronical DRAM, peripheral register base value 0x3FF0000, which can cache
	#==================================================
	# configuration of memory area, not define ROM when debugging the program in RAM, and define when solidified
	#==================================================
	.ifdef ROM
	LDR    r0, =SystemInitDataSDRAM@ load the setting value of memory area register to save address
	LDMIA   r0, {r1-r12}@ load 12 setting values
	LDRr0, =0x3FF0000 + 0x3010@ load the address of memory area register
	STMIA   r0, {r1-r12}@ set memory area register
	.endif
	#==================================================
	# introduce external symbol, symbol definition is in link script file
	#==================================================
	.extern  Image_RO_Limit  @ size of read only area
	.extern  Image_RW_Base   @ initial address of read-write memory area
	.extern  Image_ZI_Base   @ initial address of clear area, the area of the uninitialized variable .bss segment in code
	.extern  Image_ZI_Limit  @ size of clear area
	#==================================================
	# memory area needed to use to initialize C code
	#==================================================
	LDR  r0, =Image_RO_Limit @ obtain the size of read only area
	LDR  r1, =Image_RW_Base  @ obtain the initial address of read-write memory area
	LDR  r3, =Image_ZI_Base  @ obtain the initial address of clear area
	CMP     r0, r1               @ compare whether the read only area and the read-write area are overlapped
	BEQ     LOOP1
	LOOP0:
	CMP     r1, r3               @ copy the content o
	LDRCC   r2, [r0], #4
	STRCC   r2, [r1], #4
	BCC     LOOP0
	LOOP1:
	LDR     r1, =Image_ZI_Limit @ commence from the top of the clear area
	MOV     r2, #0
	LOOP2:
	CMP     r3, r1               @ clear
	STRCC   r2, [r3], #4
	BCC     LOOP2
	#=================================================
	# initialize stack space
	#=================================================
	INITIALIZE_STACK:
	MRSr0, cpsr
	BICr0, r0, #LOCKOUT | MODE_MASK
	ORRr2, r0, #USR_MODE
	ORRr1, r0, #LOCKOUT | FIQ_MODE
	MSRcpsr_cf, r1
	MSRspsr_cf, r2
	LDRsp, =FIQ_STACK@ set fast interrupt stack space
	ORRr1, r0, #LOCKOUT | IRQ_MODE
	MSRcpsr_cf, r1
	MSRspsr_cf, r2
	LDRsp, =IRQ_STACK@ set interrupt stack space
	ORRr1, r0, #LOCKOUT | ABT_MODE
	MSRcpsr_cf, r1
	MSRspsr_cf, r2
	LDRsp, =ABT_STACK@ set abnormal stack space
	ORRr1, r0, #LOCKOUT | UDF_MODE
	MSRcpsr_cf, r1
	MSRspsr_cf, r2
	LDRsp, =UDF_STACK@ set undefined abnormal stack space
	ORRr1, r0, #LOCKOUT | SUP_MODE
	MSRcpsr_cf, r1
	MSRspsr_cf, r2
	LDRsp, =SUP_STACK   @ set superuser stack space
	#=================================================
	# switch to user mode and set user stack space
	#=================================================
	MRS r0, cpsr
	BICr0, r0, #LOCKOUT | MODE_MASK
	ORRr1, r0, #USR_MODE
	MSRcpsr_cf, r0
	LDRsp, =USR_STACK
	#=================================================
	# enter into C language program entry
	#=================================================
	.extern __main
	BL      __main
	#=================================================
	#definition of vector function, definition of internal function in C program
	#=================================================
	SystemUndefinedHandler:B SystemUndefinedHandler
	SystemSwiHandler:B SystemSwiHandler
	MakeSVC:B MakeSVC
	SystemPrefetchHandler:B SystemPrefetchHandler
	SystemAbortHandler:B SystemAbortHandler
	SystemReserv:B SystemReserv
	SystemIrqHandler:@ interrupt vector
	.externISR_IrqHandler
	STMFDsp!, {r0-r12, lr}@ interrupt stack saving
	BLISR_IrqHandler@ interrupt C manipulation function
	LDMFDsp!, {r0-r12, lr}@ recover interrupt stack
	SUBSpc, lr, #4@ return to the program index before interrupt
	SystemFiqHandler:@ fast interrupt vector
	.externISR_FiqHandler
	STMFDsp!, {r0-r7, lr}@ fast interrupt stack saving
	BLISR_FiqHandler@ fast interrupt C manipulation function
	LDMFDsp!, {r0-r7, lr}@ fast recover interrupt stack
	SUBSpc, lr, #4@ return to the program index before fast interrupt
	#===============================================
	# memory area register setting value
	#===============================================
	SystemInitDataSDRAM:
	.long 0x00003E02@ EXTDBWTH setting value
	.long 0x02000060@ ROMCOON0 setting value, 0~0x200000
	.long 0x00000060
	.long 0x00000060
	.long 0x00000060
	.long 0x00000060
	.long 0x00000060
	.long 0x14010301@ DRAMCON0 setting value, 0x400000~0x1400000
	.long 0x00000000
	.long 0x00000000
	.long 0x00000000
	.long 0x9C298360 @ REFEXTCOM setting value
	#===============================================
	# stack space definition interval
	#===============================================
	.data
	.SPACE    1024
	USR_STACK:  .SPACE    512
	UDF_STACK:  .SPACE    512
	ABT_STACK:  .SPACE    512
	IRQ_STACK:  .SPACE    512
	FIQ_STACK:  .SPACE    512
	SUP_STACK:
	C master program file
	C master program file “led_int.c” completes the i
	The source code and detailed interpretation of “L
	/***********************************************************
	* file name: led_int.c
	* description  S3C4510control IO and interrupt demonstration program*/
	* P16/TOUT0 connected to LED1
	*P17/TOUT1 connected to LED2
	* P9/XIRQ1  connected to button
	************************************************************/
	#define VPint    *(volatile unsigned int *)
	#define Base_Addr0x3ff0000// register base address
	#define IOPMOD(VPint(Base_Addr+0x5000))// IO mode register
	#define IOPCON  (VPint(Base_Addr+0x5004))// IO control register
	#define IOPDATA (VPint(Base_Addr+0x5008))// IO data register
	#define INTMOD    (VPint(Base_Addr+0x4000))// interrupt mode register
	#define INTPEND   (VPint(Base_Addr+0x4004))// interrupt pending register
	#define INTMASK   (VPint(Base_Addr+0x4008))// interrupt mask register
	#define INTOFFSET(VPint(Base_Addr+0x4024))// interrupt shift register
	void ISR_IrqHandler(void);
	void ISR_FiqHandler(void);
	/****************************************************
	* name:__main
	* function:C language entry master function
	******************************************************/
	void __main(void)
	{
	int i, j;
	IOPMOD = 0x00030000;// set P16 and P17 as output, other IO port as input
	IOPCON = 0x320;// set P9 as external interrupt, high level advancing edge triggering
	INTMOD = 0x0;// interrupt is IRQ mode
	INTMASK = 0x3FFFFD;// mask interrupts except XIRQ
	for(;;)
	{
	IOPDATA = 0x00010000;// light LED1
	for(i=0; i < 65000; i++) ;// simple delay
	IOPDATA = 0;// put out LED1
	for(i=0; i < 65000; i++) ;
	}
	}
	/****************************************************
	* name:ISR_IrqHandler
	* function:  interrupt handling function
	******************************************************/
	void ISR_IrqHandler(void)
	{
	unsigned int IntOffSet;
	IntOffSet = (unsigned int)INTOFFSET;// obtain interrupt source
	INTPEND = 1<<(IntOffSet>>2);// remove interrupt pending symbol
	IOPDATA = 0x00020000;// light LED2
	}
	/****************************************************
	* name:ISR_FiqHandler
	* function: fastinterrupt handling function
	******************************************************/
	void ISR_FiqHandler(void)
	{
	}
	
	
	3.3.2 Creation of Project



	Select menu File > New Workspace, the system will pop up project creation dialog, as shown in Fig 3-35:
	�
	Fig 3-35 project creation dialog
	Input the project name of the newly-created proje
	Select button OK to create new project ledint, and the integration environment will create the workspace and project with the same name as the project.
	Select the right key menu to create source file folder in the window of workspace and add relevant source file, at last, the workspace is shown as Fig 3-36:
	�
	Fig 3-36 window of workspace
	
	
	3.3.3 Configuration of Project



	The processor configuration and emulator configuration in the project is the same as in the example described in Part 1 of this chapter, what needs to pay attention to is that, during the course of processor configuration, for Maker in Peripheral Registe
	�
	Fig 3-37  project configuration processor page layout
	Debugging equipment configuration
	Select project configuration dialog box to debug equipment debug page layout, as shown in Fig 3-38:
	Select General option in Category
	set debugging symbol file as./debug/ledint.elf;
	if debugged in RAM, set “Action after connected” 
	if debugged in ROM, set “Action after connected” 
	command script file is a serial commands for integration environment to implement, which will usually complete the initialization work needed by processor, including reset, memory area configuration, and disable interrupt, etc, users shall use command sc
	reset; reset processor
	stop; stop processor operation
	memwrite 0x3ff4008 0xffffffff; remove all interrupts
	memwrite 0x3ff4004 0xffffffff; mask all interrupts
	memwrite 0x3ff0000 0x83FFFF90; config. System register
	memwrite 0x3ff3010 0x00003e02; config. Access width register
	memwrite 0x3ff3014 0x1a060040; config.ROM0 (0x1800000-0x1a00000)
	memwrite 0x3ff302C 0x10000301; config.RAM0 from 0x0 to 0x1000000
	memwrite 0x3ff303C 0x9c298360; config. DRAM brush parameter register
	�
	Fig 3-38 general option of project configuration debugging page layout
	select Download option in Category, as shown in Fig 3-39:
	set download file as ./debug/ledint.elf;
	set download address as 0x0;
	other default settings used;
	�
	Fig 3-39 download option of project configuration debugging configuration page layout
	select debugging option Memory Maps in Category, as shown in Fig 3-40:
	Set Memory Map as No map file;
	�
	Fig 3-40 memory mapping option of project configuration debugging page layout
	Memory mapping file “.map” file is used for debug
	compiling configuration
	select project configuration dialog box compiling configuration (Compiler) page layout, as shown in Fig 3-41:
	select General option in Category
	set object files location as .\debug;
	other default settings used;
	�
	Fig 3-41  general option of project configuration compiling page layout
	assembly configuration
	select project configuration dialog box assembly configuration (Assembler) page layout, as shown in Fig 3-42:
	select General option in Category
	Set object files location as .\debug:
	Set predefine as ROM=1 if it needed to build binary image and debug in ROM; do not set any predefine for debugging in RAM.
	other default settings used;
	�
	Fig 3-42  general option of project configuration assembly configuration page
	link configuration
	select project configuration dialog box link configuration (Linker) page layout, as shown in Fig 3-43:
	select General option in Category
	set linker script file as flash.ld when solidifying program or debugging in ROM;
	set linker script file as ram_ice.ld when debugging program in RAM;
	set output file name as .\debug\ledint.elf;
	other default settings used;
	�
	Fig 3-43  general option of project configuration link page layout
	link location file shall be used in embed development of system level, and the file describes the relevant information of code link location, including code segment, data segment address, etc, the linker shall use the file to make correct location to the
	SECTIONS
	{
	. = 0x000000;
	.text : { *(.text) };
	.rodata : { *(.rodata) };
	Image_RO_Limit = .;
	. = 0x0400000;
	Image_RW_Base = .;
	.data : { *(.data) };
	Image_ZI_Base = .;
	.bss : { *(.bss) };
	Image_ZI_Limit = .;
	end = .;
	set the current address as 0.
	code segment, symbol lay program code here from 0.
	read only data segment, the fixed values such as static global variable in program is laid in this segment.
	read only area length, the symbol used in starting program.
	set the current address as 0x400000.
	read and write area base address, the symbol used in starting program.
	data segment, the initialized global variable in program is laid in this segment.
	clear area base address, the symbol used in starting program.
	contain uninitialized globally useable data, such as uninitialized global variable.
	clear area length, the symbol used in starting program.
	end address.
	.debug_info 0 : { *(.debug_info)  }; debugging information output segment.
	.debug_line0 : { *(.debug_line)  }
	.debug_abbrev0 : { *(.debug_abbrev)}
	.debug_frame0 : { *(.debug_frame) }
	}
	the link location file used for debugging in RAM:
	SECTIONS
	{
	. = 0x000000;
	.text : { *(.text) };
	.rodata : { *(.rodata) };
	Image_RO_Limit = .;
	Image_RW_Base = .;
	.data : { *(.data) };
	Image_ZI_Base = .;
	.bss : { *(.bss) };
	Image_ZI_Limit = .;
	end = .;
	set the current address as 0.
	code segment, symbol lay program code here from 0.
	read only data segment, the fixed values such as static global variable in program is laid in this segment.
	read only area length, the symbol used in starting program.
	read and write area base address, the symbol used in starting program.
	data segment, the initialized global variable in program is laid in this segment.
	clear area base address, the symbol used in starting program.
	contain uninitialized globally useable data, such as uninitialized global variable.
	clear area length, the symbol used in starting program.
	end address.
	.debug_info 0 : { *(.debug_info)  }; debugging information output segment.
	.debug_line0 : { *(.debug_line)  }
	.debug_abbrev0 : { *(.debug_abbrev)}
	.debug_frame0 : { *(.debug_frame) }
	}
	
	
	3.3.4 Debugging of Program in RAM



	Debugging of software may be completed in ROM area or RAM area, because it is convenient to read and write in RAM area and the access speed is high, all the debugging during the process of software development shall be completed in RAM area if only the h
	The following steps shall be completed before debugging of software: compile link project, to connect emulator and target board, and download program.
	compile link project
	Users select Build menu, compile corresponding file or project, and output relevant compiling and link information at the Build subwindow of the Output window. According to link configuration, led_int.elf file will be built under .\led_int\debug\ dire
	connect emulator and target board
	Select Remote Connect submenu on Debug menu, and the debugger in integration environment will be connected to the target system through emulator.
	download program
	After connection of target system, if automatic download option is set in the debugging configuration option, the debugger will automatically download software; or it will select Download submenu download program of the menu Debug. Now, the debugger will
	The debugging interface of Embest IDE after download of program is shown in Fig 3-44, and now the debugging of program may be started.
	�
	Fig 3-44  Embest IDE debugging interface
	Embest IDE will display the corresponding assembl
	Now it may, through setting breakpoint at the window of anti-assembly file or source file, implement the operation such as single step run to debug program and analyze the problems in program, as shown in Fig 3-45.
	�
	Fig 3-45  set breakpoint in source program
	
	
	3.3.5 Download onto the Flash ROM



	The program passed through debugging in RAM is different from the program finally programmed into Flash space, and users shall change the project settings:
	Set ROM=1 in the predefine option of assembly, the initialization code of the startup file will be included to compile. In this case, build the project to generate binary image. After programming the binary image into Flash and running, the startup file
	Select the link file flash.ld in Linker, and the link file and starting file will combine to complete the handling job of data segment downloaded onto Flash originally.
	After completion of the above modification, compile program again. Then use Elf to Bin tool to change ledint.elf file into binary format file ledint.bin.
	At last, use Embest Flash Programmer to download ledint.bin to the Flash ROM, as show in Fig 3-46.
	�
	Fig 3-46 Flash programmer interface program page layout
	Please reference to Embest online Flash Programme
	
	
	3.3.6 Debugging of Program in Flash



	When target board limited by software resources, such as the space of RAM area is less than the space of program code, which causes that debugging can not be made in RAM area, or it is needed to observe the actual operation situation of program in Flash,
	The project configuration for debugging of program in Flash is different from that of the debugging in RAM:
	it is unnecessary to implement script file in deb
	And the debugging processes are different too;
	after connecting to emulator, it unnecessary to implement Download program operation
	if it is to commence debugging program at the entry of starting program, reset command shall be implemented, and now the program will stop at the zero address;
	two hardware breakpoints may be set at most when program is debugged in Flash.
	
	
	3.3.7 Startup Program Design of S3C44B0X



	S3C44B0 starting program design is different from the starting program of S3C4510 as we describe in the above example, the major reason lies in that S3C44B0 has no memory mapping function, all the addresses of memory area are fixed, in addition, S3C44B0
	The starting program of S3C4510 represents the starting flow of processor chips of most integrate ARM, and S3C44B0 represents the rest, to understand the starting program of these two processors is helpful to the starting design of other processors.
	The following codes are the source codes and the interpretation of the starting program of S3C44B0, in order to effectively apply the space, some similar interrupt entry definitions and function macro definitions are omitted, and the omitted parts is rep
	# *****************************************************
	# file name: 44binit.s
	# description: S3c44b0x starting file
	# *****************************************************
	#==========================================
	# register definition and bit definition
	#==========================================
	.equ INTMSK,  0x01e0000c
	.equ WTCON,  0x01d30000
	.equ CLKCON, 0x01d80004
	.equ LOCKTIME,0x01d8000c
	.equ FIQMODE,0x11
	.equ IRQMODE,0x12
	.equ SVCMODE,0x13
	.equ ABORTMODE,     0x17
	.equ UNDEFMODE,     0x1b
	.equ MODEMASK,      0x1f
	.equ NOINT,0xc0
	#===========================================
	# interrupt handling macro
	#===========================================
	.macro HANDLER HandleLabel
	sub    sp, sp, #4@ stack space degression save jump address
	stmfd     sp!, {r0}@ save work register r0 to stack
	ldr    r0, =\HandleLabel @ load interrupt entry address location to r0
	ldr    r0, [r0]   @ load interrupt entry address to r0
	str    r0, [sp,#4]@ save interrupt entry address to stack
	ldmfd     sp!, {r0,pc}    @ recover work register and jump to interrupt function
	.endm
	#==========================================
	#  set ARM7 interrupt and primary exception vector
	#==========================================
	ENTRY:
	b ResetHandler@ implement from here after S3C4510 reset
	b HandlerUndef@ undefined primary exception vector
	b HandlerSWI@ soft interrupt vector
	b HandlerPabort@ obtain fetch primary exception vector
	b HandlerDabort@ obtain data primary exception vector
	b . @ keep
	b HandlerIRQ @ interrupt vector
	b HandlerFIQ@ fast interrupt vector
	#==========================================
	# set 44B0 interrupt vector table
	#==========================================
	VECTOR_BRANCH:
	ldr pc,=HandlerEINT0    @ mGA H/W interrupt vector table
	ldr pc,=HandlerEINT1    @
	……@ omit
	ldr pc,=HandlerADC@ mGKB
	……@ omit
	b .
	#==========================================
	# interrupt vector handling macro
	#==========================================
	HandlerFIQ:HANDLER HandleFIQ
	HandlerIRQ:HANDLER HandleIRQ
	HandlerUndef:   HANDLER HandleUndef
	HandlerSWI:HANDLER HandleSWI
	HandlerDabort:  HANDLER HandleDabort
	HandlerPabort:  HANDLER HandlePabort
	HandlerADC:HANDLER HandleADC
	……@ omit
	HandlerEINT1:HANDLER HandleEINT1
	HandlerEINT0:HANDLER HandleEINT0
	#==========================================
	# interrupt vector handling macro
	#==========================================
	ResetHandler:
	ldr    r0,=WTCON    @ watchdog forbidden
	ldr    r1,=0x0
	str    r1,[r0]
	ldr    r0,=INTMSK
	ldr    r1,=0x07ffffff       @ all interrupts forbidden
	str    r1,[r0]
	#===========================================
	# set clock control controller
	#===========================================
	ldrr0, =LOCKTIME
	ldrr1, =0xfff
	strr1, [r0]
	ldr    r0, =CLKCON
	ldr    r1, =0x7ff8@ clock of all modules unlocked
	str    r1, [r0]
	#===========================================
	# set memory area controller
	# If build the binary image to program into flash, and want to copy the code to RAM to run,
	# please set EXEC_FROM_RAM=1 in the predefine option of assembly
	#===========================================
	ldr    r0, =SMRDATA
	.ifdefEXEC_FROM_RAM@ if need to calculate the offset address SMRDATA
	ldr     r1, =Image_RO_Base
	sub     r0, r0, r1@ yes, subtract to the RAM start address.
	.endif
	ldmia     r0, {r1-r13}
	ldr    r0, =0x01c80000
	stmia     r0, {r1-r13}
	.ifdef      EXEC_FROM_RAM @ if need to copy code segment to RAM
	mov   r0, #0@ copy from ROM start address
	ldr   r1, =Image_RO_Base@ store to real space
	ldr   r3, =Image_ZI_Limit@ until ZI segment end address.
	LoopRw:
	cmp   r1, r3
	ldrcc     r2, [r0], #4
	strcc   r2, [r1], #4
	bcc   LoopRw
	ldr   pc,=Jump@ jump to the new address in RAM.
	Jump:
	nop
	nop
	nop
	.endif
	#===========================================
	# initialize stack space
	#===========================================
	ldr    sp, =SVCStack@ switch to supervise stack space
	bl    InitStacks
	#===========================================
	# introduce external symbol, symbol definition is in link script file
	#===========================================
	.extern  Image_RO_Limit  @ end address of read only area
	.extern  Image_RW_Base@ start address of readable-writeable memory area
	.extern  Image_ZI_Base@ start address of clear area
	.extern  Image_ZI_Limit@ end address of clear area
	#===========================================
	# initialize the memory area needed to use by C code
	#===========================================
	LDR  r0, =Image_RO_Limit @ obtain the end address of read only area
	LDR  r1, =Image_RW_Base @ obtain the start address of readable- writable memory area
	LDR  r3, =Image_ZI_Base  @ obtain the start address of clear area
	CMP     r0, r1    @ compare whether the read only area and the readable-writable area are overlapped
	BEQ     LOOP1
	LOOP0:
	CMP     r1, r3    @ copy the content of “.data” d
	LDRCC   r2, [r0], #4
	STRCC   r2, [r1], #4
	BCC     LOOP0
	LOOP1:
	LDR     r1, =Image_ZI_Limit @ commence from the top of the clear area
	MOV     r2, #0
	LOOP2:
	CMP     r3, r1             @ clear
	STRCC   r2, [r3], #4
	BCC     LOOP2
	#===========================
	# enter into C language program entry
	#===========================
	MRS    r0, CPSR
	BIC     r0, r0, #NOINT /* enable interrupt */
	MSR    CPSR_cxsf, r0
	/* jump to main() */
	.extern   Main
	bl       Main
	b        .
	#==========================================
	# initialize the function of stack space
	#==========================================
	InitStacks:
	mrs    r0, cpsr
	bic    r0, r0, #MODEMASK
	orr    r1, r0, #UNDEFMODE | NOINT
	msr    cpsr_cxsf, r1
	ldr    sp, =UndefStack@ set undefined abnormal stack space
	orr    r1, r0, #ABORTMODE|NOINT
	msr    cpsr_cxsf, r1
	ldr    sp, =AbortStack@ set abnormal stack space
	orr    r1, r0, #IRQMODE|NOINT
	msr    cpsr_cxsf, r1
	ldr    sp, =IRQStack@ set interrupt stack space
	orr    r1, r0, #FIQMODE|NOINT
	msr    cpsr_cxsf, r1
	ldr    sp, =FIQStack@ set fast interrupt stack space
	bic    r0, r0, #MODEMASK|NOINT
	orr    r1, r0, #SVCMODE
	msr    cpsr_cxsf, r1
	ldr    sp, =SVCStack@ set superuser stack space
	mov    pc,lr @ function return
	#==========================================
	# setting value of relevant register of memory area
	#==========================================
	SMRDATA:
	.long 0x11110101@ memory area access width control register
	.long 0x00000600@ BANK0 control register
	.long 0x00007FFC@ BANK1 control register
	.long 0x00007FFC@ BANK2 control register
	.long 0x00007FFC@ BANK3 control register
	.long 0x00007FFC@ BANK4 control register
	.long 0x00007FFC@ BANK5 control register
	.long 0x00018000@ BANK6 control register
	.long 0x00018000@ BANK7 control register
	.long 0x00860459@ SDRAM brush control register
	.long 0x10@ SDRAM memory area size
	.long 0x20@ BANK6 SDRAM mode register
	.long 0x20@ BANK7 SDRAM mode register
	.equSTARTADDRESS,0xc7fff00
	#==========================================
	# stack space definition
	#==========================================
	.equUserStack,STARTADDRESS-0x500      @ c1(c7)ffa00
	.equSVCStack,STARTADDRESS-0x500+256  @ c1(c7)ffb00
	.equUndefStack,STARTADDRESS-0x500+256*2 @ c1(c7)ffc00
	.equAbortStack,STARTADDRESS-0x500+256*3 @ c1(c7)ffd00
	.equIRQStack,STARTADDRESS-0x500+256*4 @ c1(c7)ffe00
	.equFIQStack,STARTADDRESS-0x500+256*5 @ c1(c7)fff00
	#==========================================
	# ARM interrupt vector entry definition
	#==========================================
	.equHandleReset,STARTADDRESS
	.equHandleUndef,STARTADDRESS+4
	.equHandleSWI,STARTADDRESS+4*2
	.equHandlePabort,STARTADDRESS+4*3
	.equHandleDabort,STARTADDRESS+4*4
	.equHandleReserved,STARTADDRESS+4*5
	.equHandleIRQ,STARTADDRESS+4*6
	.equHandleFIQ,STARTADDRESS+4*7
	#==========================================
	# S3C44B0 interrupt vector entry definition
	#==========================================
	.equHandleADC,    STARTADDRESS+4*8
	…… @ omit
	.equHandleEINT4567,STARTADDRESS+4*29
	.equHandleEINT3,STARTADDRESS+4*30
	.equHandleEINT2,STARTADDRESS+4*31
	.equHandleEINT1,STARTADDRESS+4*32
	.equHandleEINT0,STARTADDRESS+4*33 @ 0xc1(c7)fff84
	IV. Editor

	Embest development environment includes an integrated Text editor to manage, edit, and print source files.
	
	4.1 Editor Overview


	The EmbestIDE source code editor includes standard text manipulation capabilities, as well as the following specialized features:
	? C and assembly syntax color highlighting.
	? Debugger integration: the editor window tracks code execution.
	? Compiler integration: compiler messages links to the editor window.
	The EmbestIDE editor also provides features tailored to the program environment. Editor display program syntactic elements such as C keywords, preprocessor directives, and comments in color. Because the editor is integrated with the debugger, the editor
	You can work on as many files simultaneously as your computer's memory allows. This is convenient for you are working with more than one module, or want to edit both a source and header file at the same time.
	Typically, developers use the EmbestIDE editor to work with source files and header files. However, because it is a text editor, it can also be used on any text file. For example, you can view a bug report, or save a note in a text file.
	The EmbestIDE editor uses standard Windows editing commands and conventions. Most of the procedures for using the editor should seem familiar if you have used other Windows-based text editors. With the Text editor, you can:
	? Perform advanced find and replace operations in a single file or multiple files, including using regular expressions and incremental searching.
	? Use Bookmarks to mark frequently accessed lines in your source file.
	? Customize the Text editor with the selection margin, indent, and drag and drop.
	? Select lines, multiple lines, or columns.
	? Use drag-and-drop editing within one editor window, between editor windows, and between the Text editor and the debugger.
	? Manage the source window.
	While using the Text editor, in many instances you can right-click mouse  to display a shortcut menu of frequently used commands. The commands available depend on what the mouse pointer is pointing to.
	
	4.2 The Standard Toolbar


	The Standard toolbar has buttons for frequently used editing commands that are also available in the File and Edit menus. Figure 4-1 shows the Standard toolbar.
	When you first start EmbestIDE in its default configuration, the Standard toolbar appears just below. You can click View>Toolbars>Standard to show and hide the standard tool bar.
	�
	Figure4-1 Standard Tool Bar
	The following are summary descriptions of each buttons and the equivalent menu option.
	Table 4-1 Standard Tool Bar Buttons Description
	button
	menu
	description
	�
	File>New
	Create a new file
	�
	File>Open
	Open an existing file
	�
	File>Save
	Save current file
	�
	File>Save All
	Save all opening files
	�
	File>Print
	Print current file
	�
	Edit>Cut
	Delete the selection and place it into the clipboard
	�
	Edit>Copy
	Copy the selection to the clipboard
	�
	Edit>Paste
	Insert the clipboard text at the insertion point
	�
	Edit>Undo
	Undo the previous operation
	�
	Edit>Redo
	Redo the previous operation
	�
	View>Workspace
	View or hide the workspace window
	�
	View>output
	View or hide the output window
	�
	Edit>Find in Files
	Search strings in multiple files
	�
	Edit>Find Next
	Search for another instance of the same string in the same search direction
	�
	Edit>Find Previous
	Repeat the search, but in the opposite direction
	�
	Edit>Replace
	Specify both a string to find and a replacement for it
	�
	Edit>More Bookmarks>Toggle Bookmark
	Toggles an unnamed bookmark for the current line
	�
	Edit>More Bookmarks>Next Bookmark
	Moves to the line containing the next bookmark
	�
	Edit>More Bookmarks
	>Previous Bookmark
	Moves to the line containing the previous bookmark
	�
	Edit>More Bookmarks>Clear All Bookmarks
	Clears all bookmarks in the window
	
	4.3 File Management


	The following sections describe file management commands.
	
	
	4.3.1 Create a file



	Table 4-2  Operation of Create a New File
	Button
	Shortcut
	File menu
	�
	Ctrl+N
	File > New
	To create a new file, click File> New, an empty window appears, ready for input text.
	
	
	4.3.2 Open a File



	Table 4-3  Operation of Open a File
	Button
	Shortcut
	File menu
	�
	Ctrl+O
	File > Open
	To open an existing file, click File>Open. A standard Windows file browser allows you to select which file to be open.
	Recent files of the File menu (File > Recent Files) lists the most recently opened files. You can choose one of these without navigating through the open dialog box.
	
	
	4.3.3 Save and Close a File



	Table 4-4  Save and Close File Button
	Button
	Shortcut
	File menu
	�
	Ctrl+S
	File > Save
	N/a
	File > Save As
	�
	File > Save All
	N/a
	Ctrl+F4
	File > Close
	To save current file, click File>Save. If need specify a new name (or path) for current file, click Save As instead. (Save is disabled until you modify current file.)
	If you open multiple files, you can also click File>save all  to save the modification of all opening files.
	Click Close to dismiss the editor window for current file. If the file has changed since you last saved, a confirmation dialog box offers you the opportunity to save the file before closing it.
	
	
	4.3.4 Print



	Table 4-5 Print Buttons
	Button
	Shortcut
	File menu
	�
	Ctrl+P
	File > Print
	N/a
	File > Print Preview
	N/a
	File > Page Setup
	N/a
	File > Print Setup
	To print current edit window, click File>Print. A standard print dialog box (Figure 4-2) appears.
	�
	Figure 4-2  Print Dialog Box
	Click File > Print Preview, to preview the page will be printed. Click File > Page Setup to change the margin size of each page in printout.
	
	4.4 Typing and Editing


	Only one edit window in EmbestIDE is active at any time. The active window contains a text cursor, a blinking vertical line also called an insertion point. Whatever you type appears at the text location indicated by the text cursor.
	The editor is designed for edit source files. As such, it does not provide the "word wrap" feature found in many word edit software. You must press ENTER to start a new line. If a line is too long for the current width of the edit window, the text scroll
	There are two edit modes in EmbestIDE: overtype mode, which replaces the existing text under the cursor as you type, and insert mode (the default), which displaces text to the right while adding the characters you type. Use the INSERT key on your keybo
	NOTE: If you cannot type inside an editor window, check for a READ indicator on the status bar at the bottom of EmbestIDE window. If that indicator appears, the editor is displaying as a read-only file. To enable type in that window, click Edit>Read Only
	
	
	4.4.1 Edit Text



	Table 4-6  Edit Button
	Button
	Shortcut
	Edit menu
	�
	Ctrl+Z
	Edit > Undo Typing
	�
	Ctrl+Z
	Edit > Redo
	�
	Ctrl+X
	Edit > Cut
	�
	Ctrl+C
	Edit > Copy
	�
	Ctrl+V
	Edit > Paste
	Del
	Edit > Delete
	Ctrl+A
	Edit > Select All
	The edit menu supports the Windows standard edit functions: Undo, Cut, Copy, Paste, Delete, and Select All, with standard shortcuts. With the text editor, you can cut, copy, and paste selected text using menu commands or drag-and-drop operation. You can
	The editor uses the standard Windows keys and mouse actions for moving throughout the file. For example, the following specialized keys have the standard effects:
	Table 4-7  The Standard Windows Edit Keys
	Page Up
	Display the previous portion of text.
	Page Down
	Display the next portion of text.
	End
	Move the cursor to the end of the line.
	Ctrl+End
	Display the end of the document.
	Home
	Move the cursor to the beginning of the line.
	Ctrl+Home
	Display the start of the document.
	( ( ( (
	Move the cursor into the direction of the arrow, one character or line at a time.
	Ctrl + (
	Ctrl + (
	Move the cursor one word at a time, in the direction of the arrow.
	Ctrl + (
	Ctrl + (
	Scroll the window by one line, in the direction of the arrow, without changing cursor position.
	You can set bookmarks to mark source lines that need frequently access in your source file. Once a bookmark is set, you can use menu or keyboard commands to move to it. You can remove a bookmark when you no longer need it.
	
	
	4.4.2 Find and Replace Text



	Table 4-8 Find and Replace Button
	Button
	Shortcut
	Menu
	N/a
	Ctrl+F
	Edit > Find
	�
	F3
	Edit > Find Next
	�
	Shift+F3
	Edit > Find Previous
	�
	Edit > Find in Files
	�
	Ctrl+H
	Edit > Replace
	The text editor supports string searching. You can search text in a single source file or in multiple files.
	Click Edit>Find to search for a string in the current active file window. Figure 4-4 shows the Find dialog box. Enter the string you are looking for, set the options, and click find next. The option buttons under Direction determine whether the editor se
	�
	Figure 4-4 Find Dialog Box
	Click Edit > Replace to specify both a string to find and a replacement for it. Figure 4-5 shows the Replace dialog box. The buttons in the Replace dialog box allow you to replace all occurrences of a string, or examine each individual occurrence before
	�
	Figure 4-5 Replace Dialog Box
	You can also find text in multiple files. Just click Edit > Find in Files to do this search. The Find in Files command supports two output panes. This allows you to conduct a second search through multiple files without losing the results from your first
	The Output window displays the list of file locations where the text string appears. Each occurrence lists the fully qualified filename, followed by the line number of the occurrence and the line containing the match. To open a file that contains a match
	An editor window contains the file opens with the line contain the match selected. You can jump to other occurrences of the text string by double-clicking the specific entries in the Output window.
	When you jump to a found string location specified in the Output window, the corresponding source file is loaded if it is not already open in the editor.
	�
	Figure 4-6 Find in Files Dialog Box
	
	
	4.4.3 Hex file Editor



	Embest IDE Hex file editor can open the HEX or  Bin format files, and read, modify and save.
	Open file: when you open file with the menu File Open, drop down file type select box and select Hex Files (*.hex,*.bin) to open the file.
	�
	Fig. 4-7 Open Hex file dialog box
	Edit file: after open Hex file, the display in Source Program Window is shown in fig. 4-8. The user can directly modify the content of file in left Hex area. The editor will automatically identify ASCII characters and display in the right. As the same, t
	�
	Fig. 4-8 Hex file Editor in Source Program Window
	
	
	4.4.4 Find in Hex file



	Hex file editor supports the forward and back finding of ASCII character string and Hex code. The user highlights Find in menu option to activate Find Dialog Box with right key of mouse in Source Program Window, or activates it through Find option in Edi
	�
	Fig. 4-9 Hex file finding interface
	The user can input Hex code while finding:
	�
	Fig. 4-10 Hex file finding input dialog box
	The user can also input ASCII code while finding, and highlight Find ASCII option:
	�
	Fig. 4-11 Hex binary file finding input dialog box
	Hex file editor also supports copy, stick, cancel, print and print interview so that the user is easy to view Hex file.
	
	4.5 Function List Window of Source Program


	When users open C language or C ++ source file in editing window, source file function listing window will dynamically display the function contained in the current source file, and user can select the display format of function through menu.
	Users can self-define the display mode of function in list:
	display detailed information of function
	only display function name
	do not display function return style
	do not display function call parameter
	
	
	4.5.1 Introduction



	Click the menu Tools > Options, select Extra Function Prototype in the ejected dialog box; the window Func can be found in workspace window; the function list currently opening C/C++ program is shown in the window; double click the position of function n
	�
	Fig 4-12  Dynamic list window of source program function
	Click right key in list window to select the display style of function. The ejected right key menu is shown in fig. 4-13.
	�
	Fig 4-13  Right key menu in dynamic list window of functions
	Introduction to main options of right key menu in dynamic list window of functions
	Whole Prototype: display all information concerning definition of function, including return type, function name, and parameter
	Func Name Only: Only display function name
	No Return Type: display function name, parameter of function definition
	No Parameters: display return type, function name of function definition
	V. Project Management
	5.1 Introduction


	The project facility is a key element of EmbestIDE. It provides graphical and automated mechanisms for create applications that can be downloaded to target. A project consists of the source code files, build settings, and binary codes that are used to cr
	In EmbestIDE, the Project Workspace is a container for your development projects. When you create a new project, a workspace is created at the same time. You can use the Project Workspace window to view and access the various elements of your projects. A
	The workspace directory is the root directory for the project workspace. The projects you add to the project workspace can be located on other paths, even on a different drive.
	The project facility provides mechanisms for:
	? Organize the files that make up of a project. A project is a collection of source files, library files, and other input files. You can organize the files in a project in various ways to provide a logical structure to your source files.
	? Group related projects into a workspace.
	? Define varied sets of build options. The project facility provides a simpler mean for configuration and building, a project settings dialog box enable you define target processor, debug device, debug information, output file, compiling option, assemble
	? Build applications. A build toolbar is provided, which provides access to all the major build commands.
	? Download application objects to the target.
	This chapter describes many of the basic tasks involving projects, such as:
	? create projects
	? open projects
	? add files to projects
	? save projects
	? move files in the project window
	? configure projects
	
	5.2 GUI


	Figure 5-1 and figure 5-2 shows the operation menu about project management in file menu and project menu of EmbestIDE.
	Figure 5-1 File Menu                  Figure 5-2 Project Menu
	Operation about project management in file menu describes below:
	Table 5-1 Project Management in File Menu
	File menu
	Describe
	New Workspace…
	Create a new project, a workspace
	Open Workspace…
	Open a workspace and the projects in the workspace
	Save Workspace
	Save workspace and the projects in the workspace
	Close Workspace
	Close a workspace and the projects in the workspace
	Recent Workspace
	Open a recently used project workspace
	Table 5-2 describes the project menu.
	Table 5-2 Project Menus
	Project menu
	Describe
	Set Active Project
	Active a project
	Add To Project
	Insert file or folder into a project
	Settings…
	Configure the active project
	Workspace window is the project management window, click View>Workspace (shortcut: Alt+0) to hide or show workspace window. The workspace window shows information about the projects and the files in that project. The workspace window provides an outlin
	You can highlight every level folder in the Workspace window then right-click to invoke its pop-up menu. We will describe these menus following.
	To navigate the workspace window, use the vertical scroll bar on the right side of the window, or the Up and Down Arrow keys on your keyboard. If the workspace window contains many files, use the Home key to scroll to the top of the list, or use the End
	Workspace directory is the root directory of project workspace. Every project consists of several relative folders such as C Source Files, Assembly Source files, Link Files, Include Files. You can create new folder in the project. To do this, highlight t
	
	5.3 Operations
	5.3.1 Create a New Project



	When you first create a new project, a workspace is created at the same time.
	Click File>New Workspace, a dialog box pops up.
	�
	Figure 5-3 Create a New Project
	Enter the new Project name and its path, and click � to browse the path.
	Click Ok button, a new project will be created, and a same name workspace will be created too.
	You can insert a new project into an existing project workspace too:
	Open the project workspace that you want to add a new project to.
	Highlight the root directory of the project works
	Enter a new project name and its path on the dialog box.
	Click ok button.
	The new project that you just created becomes the default active project in the workspace.
	Notes: when a new workspace and project is created, two files with the same main file name and .ews and .pjf extend file name is created in the project saved path. The file with .ews extend file name is the workspace file. This file saved the workspace i
	
	
	5.3.2 Open a Project



	To open an existing project workspace:
	On the File menu, click Open Workspace.
	Select the driver and directory that contain the project workspace that you want to open.
	Select the .ews or .prj file for the project workspace from the File Name list and click OK.
	�
	Figure 5-4 Opening a Project
	To reopen a recently used project workspace:
	On the File menu, click recent workspaces, and then click the name of the recently used workspace.
	
	
	5.3.3 Workspace Operation



	Workspace window displays and manages the files and projects in workspace window. All source files in projects and all projects in workspace can be browsed intuitively in workspace window. The top level catalogue of workspace displays current workspace n
	Each catalogue in workspace corresponds to different right mouse menu.
	The top level catalogue’s right mouse menu is wor
	�
	Figure5-5 Workspace Right Mouse Menu
	The operation of workspace right mouse menu is:
	Table5-3 Operation of The Top Level Catalogue’s R
	Menu Item
	Operation
	Add New Project to workspace…
	Create a new project into current workspace
	Insert Project into Workspace…
	Insert a existent project into current workspace
	Docking View
	Switch display mode of workspace window
	Hide
	Hide workspace window
	Properties
	Popup workspace’s property dialog box
	The second level catalogue’s right mouse menu is 
	�
	Figure5-6 Project Right Mouse Menu
	The operation of project right mouse menu is:
	Table5-4 Operation of The Second Level Catalogue’
	Menu Item
	Operation
	Build
	Compile current active project
	New Folder…
	Create a new group into current project
	Add Files to Project…
	Add a file into current project
	Set as Active Project
	Set current project as active project
	Setting…
	Project setting management, detail see sect 3.3
	Docking View
	Switch display mode of workspace window
	Hide
	Hide workspace window
	Properties
	Popup workspace’s property dialog box
	The third level catalogue’s right mouse menu is f
	�
	Figure5-7 File Group Right Mouse Menu
	The operation of file group right mouse menu is:
	Table5-5 Operation of The Third Level Catalogue’s
	Menu Item
	Operation
	Add Files to Folder…
	Add a file into current file group
	Docking View
	Switch display mode of workspace window
	Hide
	Hide workspace window
	Properties
	Popup workspace’s property dialog box
	The fourth level catalogue’s right mouse menu is 
	�
	Figure5-8 File Right Mouse Menu
	The operation of file right mouse menu is:
	Table5-6 Operation Of The Fourth Level Catalogue’
	Menu Item
	Operation
	Open
	Open current file
	Compile
	Compile current file
	Docking View
	Switch display mode of workspace window
	Hide
	Hide workspace window
	Properties
	Popup workspace’s property dialog box
	User can convenient manage projects in workspace 
	
	
	5.3.4 Save and Close Workspace



	If user want to save the change of workspace, just click menu 'File > Save Workspace'. Save a workspace or project is not save concrete files in project or workspace, it saves correlative file management information.
	Click menu 'File > Close Workspace' can close current workspace, EmbestIDE will auto check whether or not exist change after last workspace saves when closing workspace, if exist change, EmbestIDE will popup a hint dialog box to hint user whether save ch
	Notes:When close workspace, just hide workspace window, not actual close workspace window.
	
	
	5.3.5 Set Active Project



	One workspace can contain several projects, but o
	�
	Figure 5-9  right key set as current active proje
	If want to set a project as active project, select that project, right click mouse and click 'Save as Active Project' in popup menu, show as in figure 5-9; or click menu 'Project > Set Active Project', then select the project want to set active, show as
	�
	Figure 5-10  set as current active project from menu bar
	
	5.4 Project Basic Configuration
	5.4.1 Processor Configuration



	Select menu 'Project > Settings…' will popup proj�
	�
	Figure5-11 Processor Configuration Dialog Box
	CPU Module: select current CPU module, different CPU module will sustain different CPU series. Embest IDE has supported the core of ARM7 and ARM9 series processor.
	CPU Family: select CPU series which user’s CPU be
	CPU Member: select detail CPU type.
	Endian: set memory area byte order of user’s CPU 
	Peripheral Maker: select the Maker of processor on the target board.
	Peripheral Chip: select the processor name on the target board.
	Build Tools: set compiler and linker which accord
	
	
	5.4.2 Configure Emulator



	Select menu 'Project>Settings…' will popup projec�
	�
	Figure5-12 Emulator Configuration Dialog Box
	Remote device: select debug device, Embest Emulator for ARM is according to 'jtagarm7', and Embest PowerICE for ARM is according to 'PowerICEARM7'. Series of ARM9 CPU, Embest Emulator for ARM is according to 'jtagarm9', and Embest PowerICE for ARM is acc
	Speed: setting the Emulator work speed. Embest Emulator for ARM was worked at constant speed 25Kbyte per second, and Embest PowerICE for ARM was support to change the working speed valid: Full Speed(120Kbyte/s), High Speed, Medium Speed, Low Speed. The
	�
	Figure 5-13 Embest PowerICE for ARM work speed
	Communication type: select connect communication 
	Parallel Port: set according to actual connect.
	Note:Usually, Embest Emulator for ARM use parallel port mode, would be set EPP(0x278/0x378).
	
	5.5 ARM SDT and ADS project operation
	5.5.1 SDT software project opening



	Click menu item File > Open Workspace, and a dialog box will pop up for opening workspace. Select file type ARM SDT Project, with the suffix for the software project file of SDT as apj, as shown in the following figure.
	�
	Fig. 5-13 Open SDT project
	Select the SDT project file to be opened, press the open button to open the project. At the same time opening the SDT project, the integrated environment will automatically generate the Embest IDE workspace and project file corresponding to the project,
	�
	Fig. 5-14  Automatic generation of Embest IDE workspace and project file
	When the user opens the SDT project for the second time, the integrated environment will present a dialog box as shown in the following figure:
	�
	Fig. 5-15  Prompt dialog box for the second time of opening the SDT project
	The user can select “Yes” to directly open the Em
	Note: In opening the SDT project of Embest IDE, the user is in fact finally opening the automatically generated Embest IDE workspace after conversion. The follow-up configurations of the user will be directly saved in  the Embest IDE workspace and projec
	The project interface opened by the ARM SDT software is illustrated in the following figure:
	�
	Fig. 5-16  Project interface opened by the ARM SDT
	After conversion, the workspace interface of the project opened by the Embest IDE is illustrated in the following figure:
	�
	Fig. 5-17  Project interface opened by the ARM SDT
	During opening, the Embest IDE automatically deletes file folders that do not contain any files in the SDT project.
	
	
	5.5.2 ADS software project opening



	Click menu item File > Open Workspace, and a dialog box will pop up for opening workspace. Select file opening type ARM ADS Project, with the suffix for the software project file of ADS as mcp, as shown in the following figure.
	�
	Fig. 5-18 Open ADS project
	Select the ADS project file to be opened, press the open button to open the project. At the same time opening the ADS project, the integrated environment will automatically generate the Embest IDE workspace and project file corresponding to the project,
	�
	Fig. 5-19  Automatic generation of Embest IDE workspace and project file
	When the user opens the ADS project for the second time, the integrated environment will present a dialog box as shown in the following figure:
	�
	Fig. 5-20  Prompt dialog box for the second time of opening the ADS project
	The user can select “Yes” to directly open the Em
	Note: In opening the ADS project of Embest IDE, the user is in fact finally opening the automatically generated Embest IDE workspace after conversion. The follow-up configurations of the user will be directly saved in the Embest IDE workspace and project
	The project interface opened under the ARM ADS software is illustrated in the following figure:
	�
	Fig. 5-21  Project interface opened by ARM ADS
	The workspace interface opened by the Embest IDE after conversion is illustrated in the following figure:
	�
	Fig. 5-22  ADS project interface opened by Embest IDE
	
	
	5.5.3 Configuration after opening SDT or ADS project



	Default setting is applied to the processor and debugging equipment after the ARM SDT or ADS project is opened by the Embest IDE, and users have to perform adjustment according to the specific conditions.
	Adjusting processor configuration
	Select menu item Project > Settings… or use short�
	�
	Fig. 5-23  Adjusting processor configuration in project setting dialog box
	Adjusting emulator configuration
	Select menu item Project > Settings…, and a dialo�
	�
	Fig. 5-24  Adjusting emulator configuration in project setting dialog box
	Library file path setting
	After the Embest IDE opens the SDT or ADS project, the default complier will be ARM complier. If the user links library files in the software project, he has to manually set the library file path.
	Select menu item Project>Settings…, and a dialog �
	�
	Fig. 5-25 Setting searching path for object file
	VI. Project Configuring & Building
	6.1 Build Tools Introduction(by Embest IDE)


	The build module is a visual interface to conFigure  a project and build the target program. The following Project Settings dialog box handles settings that affect how the EmbestIDE builds a specific target file within a project.
	Because several cross-compilers can integrate with the plug-in technique, you must select a compiler for each project before build the target. Show as Figure  6-1, in the Processor page of Project Settings dialog box, the Build Tools should be selected b
	Build Tools that Embest IDE project sets up selects and includes GNU Tools for ARM or ARM Build Tools, namely can compatible GNU compiling Tools and ARM compiling Tools.
	�
	Figure  6-1-1 Project Settings Dialog
	Figure  6-1-1 shows an example of project settings. The selected Build Tools for project led_swing is GNU Tools for ARM.
	Note:If the Build Tools is not conFigure d for a 
	
	6.2 GNU Tools for ARM


	It is one that GNU Tools for ARM compiles and selects the compiling device is set up GCC cross-compiler of ARM processor specially; GNU Tools for ARM is the free software; GNU Tools for ARM is a dedicative cross-compiler for ARM processor, created from G
	
	
	6.2.1 Files Type and Compiler



	Which application of the cross-compiler will be invoked by EmbestIDE to handle a source file lies on its postfix. Table 6-2-1 shows each postfix and its relevant application.
	Table 6-2-1
	Postfix
	Application of Cross-Compiler
	*.c
	C Compiler
	*.C, *.S
	C++ Compiler
	*.cpp
	C++ Compiler
	*.cc
	C++ Compiler
	*.cp
	C++ Compiler
	*.c++
	C++ Compiler
	*.cxx
	C++ Compiler
	*.s
	Assembler
	*.asm
	Assembler
	Files type of GNU tools chain shows as Table 6-2-2.
	Table 6-2-2
	Files
	Files Type
	file.stuf
	source files of GNU
	file.h/.inc/.a
	head file
	file.o
	ELF formation target file
	file.elf
	ELF formation debugging file
	stuf stand for *.c/C, *.cpp/C++, *.s/asm, are the source files which can compiling or assembling by GNU tools chain(Note: it is permitted that there is the blank within the filename or directory.)
	
	
	6.2.2 Options for Compiler



	The Compiler property page, as in the Figure  6-3, is used to conFigure  the compile options for C/C++ compiler of GNU Tools for ARM cross-compiler, All the options user selected are displayed in the Compile Options edit box with the following format:
	[Opt-1] [Opt-2] … $\(SOURCE_FILE\) … [Opt-n] … -�
	Note: You can input or modify the options manually in the edit box, but the blank character between each option must be reserved, and the macros $(SOURCE_FILE), $(OBJ_FILE) should not be deleted or modified. $(SOURCE_FILE) means the source file to 
	Note: When you conFigure a project setting, you should consider that the location of the project file (*.pjf) is the current directory.
	�
	Figure  6-2-1 Compiler General Settings
	Show in Figure  6-3, compiler options are divided into five Categories:
	General
	Warning Options
	Debug/Optimization
	Target Specific Options
	Code Generation Options
	Note: All this compiler options are also compiled
	General  Cluster
	Description
	Include Directories
	Add <dir> to the end of the main include paths
	Object file location
	The location of the compile outcome will be placed, and no blank character can be included.
	If not exist, EmbestIDE create it automatically.
	Preprocessor Definitions
	Define macros, each macro separated by comma and with blank character.
	
	
	
	1. Warning Options




	�
	Figure  6-2-2 Compiler Warning Options
	Warning Options  Cluster
	Description
	Suppress Warnings
	-w, Inhibit warning messages
	A variable is unused
	-Wunused, Warn when a variable is unused
	Unqualified pointer cast
	-Wcast-qual, Warn about cast which discard qualifiers
	Incompatible func cast
	-Wbad-function-cast, Warn about casting functions to incompatible types
	Confusing type conversions
	-Wconversion, Warn about possibly confusing type conversions
	Inlined function cannot be inlined
	-Winline, Warn when an inlined function cannot be inlined
	One local variable shadows another
	-Wshadow, Warn when one local variable shadows another
	Automatic variables are uninitialized
	-Wuninitialized, Warn about uninitialized automatic variables
	Alignment increased when pointer cast
	-Wcast-align, Warn about pointer casts which increase alignment
	Trigraphs encountered
	-Wtrigraphs, Warn when trigraphs are encountered
	Missing Declarations
	-Wmissing-declarations, Warn about global functions without previous declarations
	ANSI C extension
	-pedantic, Issue warnings needed by strict compliance to ANSI C
	
	
	
	2. Debug/Optimization




	�
	Figure  6-2-3 Compiler Debug/Optimization
	Debug/Optimization  Cluster
	Description
	Generate default debug format output
	-g
	Generate DWARF-1 format debug output
	-gdwarf
	Generate DWARF-2 debug output
	-gdwarf-2
	Generate extended DWARF-1 format debug output
	-gdwarf+
	Optimization Options
	-O[number]/-Os, Set Optimization level to [number]/Optimize for space rather than speed
	
	
	
	3. Target Specific Options




	�
	Figure  6-2-4 Compiler Target Specific Options
	Target Specific Options  Cluster
	Description
	ARM only(Default)
	Generate ARM instructions
	ARM interworking
	-mthumb-interwork, Generate ARM instructions supporting calls between THUMB and ARM instructions sets
	Thumb only
	-mthumb, Generate THUMB Instructions
	Thumb interwork
	-mthumb –mthumb-interwork, Generate THUMB instruc
	Little endian mode(Default)
	-mlittle-endian, Assume target CPU is conFigure d as little endian
	Big endian mode
	-mbig-endian, Assume target CPU is conFigure d as big endian
	Hardware FP instructions
	-mhard-float, Use hardware floating point instructions
	Lib call for FP operations
	-msoft-float, Use library calls to perform FP operations
	Use the 26bit version of APCS
	-mapcs-26, Use the 26bit version of APCS
	Generate APCS conformant stack frames
	-mapcs-frame, Generate APCS conformant stack frames
	Specify the name of the target CPU
	Specify the name of the target CPU
	
	
	
	4. Code Generation Options




	�
	Figure  6-2-5 Compiler Code Generation Options
	Code Generation Options  Cluster
	Description
	Compile just for ANSI C
	-ansi, Compile just for ANSI C
	Use the same size for double as for float
	-fshort-double, Use the same size for double as for float
	Use the smallist fitting integer to hold enums
	-fshort-enums, Use the smallest fitting integer to hold enums
	Pretend that host and target use the same FP format
	-fpretend-float, Pretend that host and target use the same FP format
	Do not recognize any built-in functions
	-fno-builtin, Do not recognize any built in functions
	Do not search the system include directories
	-nostdinc, Do not search the system include directories
	Do not put uninitialized globals in the common section
	-fcommon, Do not put uninitialised globals in the common section
	
	
	6.2.3 Options for Assembler



	The Assembler property page, as in the Figure  6-8, is used to conFigure  the assembling options for assembler of GNU Tools for ARM cross-compiler, All the options user select are displayed in the Assemble Options edit box with the following format:
	[Opt-1] [Opt-2] … $\(SOURCE_FILE\) … [Opt-n] … –�
	Note: You can input or modify the options manually in the edit box, but the blank character between each option must be reserved, and the macros $(SOURCE_FILE), $(OBJ_FILE) should not be deleted or modified. $(SOURCE_FILE) means the source file to 
	�
	Figure  6-2-6 Assembler General Settings
	Show in Figure  6-2-6, assembler options are divided into four Categories:
	General
	Code Generation
	Target Specific Options
	Warning Options
	Note: All this assembler options are also compile
	General  Cluster
	Description
	Include Directories
	-I<dir>, Add dir to search list for include directories
	Object file location
	The location of the assembling outcome will be placed, and no blank character can be included.
	If not exist, Embest IDE create it automatically.
	Preprocessor Definitions
	Define macros, each macro separated by comma and with blank character.
	
	
	
	1. Code Generation Options




	�
	Figure  6-2-7 Assembler Code Generation Options
	Code Generation  Cluster
	Description
	Generate DWARF-2 debugging information
	-gdwarf2
	Generate listing file
	-a
	Keep local symbols
	-L
	Assemble in MRI compatibility
	-M
	Strip local absolute symbols
	--strip-local-absolute
	
	
	
	2. Target Specific Options




	�
	Figure  6-2-8 Assembler Target Specific Options
	Target Specific Options  Cluster
	Description
	Allow any instruction(Default)
	-mall
	Only allow thumb instructions
	-mthumb
	Make the assembled code as support interworking
	-mthumb-interwork
	Little endian mode(Default)
	-EL, Assemble code for a little endian cpu
	Big endian mode
	-EB, Assemble code for a big endian CPU
	Use the 32bit APCS
	-mapcs-32
	Use the 26bit APCS
	-mapcs-26
	Fpa10 FP architecture
	-mfpa10
	Fpa11 FP architecture
	-mfpa11
	No FP multiple instructions
	-mfpe-old
	No FP instructions
	-mno-fpu
	The code is position independent or reentrant
	-mapcs-reentrant
	
	
	
	3. Warning Options




	�
	Figure  6-2-9 Assembler Warning Options
	Warning Options  Cluster
	Description
	Suppress Warnings
	-W
	Do not warn about signed overflow
	-J
	Warn when differences altered for long displacements
	-K
	
	
	6.2.4 Options for Linker



	The linker property page, as in the Figure 6-12, is used to configure the link options for linker of GNU Tools for ARM cross-compiler, All the options user select are displayed in the Link Options edit box with the following format as the output file is
	[Opt-1] … –o[Path]$\(TARGET_NAME\) $\(OBJ_FILE
	The $(TARGET_NAME) is a macro for executable file name, $(OBJ_FILES) is also a macro for the collection of all object files to be linked.
	As the target file is a library, the format of the options is:
	[Opt-1] … $\(TARGET_NAME\) $\(OBJ_FILES\) [Li
	The $(TARGET_NAME) is a macro for library name.
	Note: You can input or modify the options manually in the edit box, but the blank character between each option must be reserved, and the macros $(TARGET_NAME), $(OBJ_FILES) should not be deleted or modified. There will be replaced with the actual fi
	Note: $(TARGET_NAME) will be replaced with the default that consists of project name and postfix, elf or lib.
	Note:Macro $(<entry.o>OBJ_FILES), for example, means that the file entry.o is the first object file in the collection of all object files to be linked.
	Show in Figure  6-2-10, linker options are divided into five Categories:
	General
	Image Entry Options
	Code Generation Options
	Include Object and Library Modules
	Add Library Searching Path
	
	
	
	1. Linker General Settings




	�
	Figure  6-2-10 Linker General Settings
	General  Cluster
	Description
	Executable file
	The output file is an executable file
	Library
	The output file is a library
	Linker script file
	The link script file
	Output file name
	The file name of output file
	
	
	
	2. Image Entry Options




	�
	Figure  6-2-11 Linker Image Entry Options
	Image Entry Options  Cluster
	Description
	Select entry file
	The collection of all object files to be linked is displayed in a list box, and you can select one as the first object file to be linked.
	Image entry point
	-e<address/symbol>, The entry point of the executable target.
	Note: Image Entry Options  Cluster can be set while the output file is executable.
	
	
	
	3. Code Generation Options




	�
	Figure  6-2-12  Linker Code Generation Options
	Code Generation Options  Cluster
	Description
	Generate relocateable output
	-r, Generate relocateable output
	Optimize output file
	-O1, Optimize output file
	Do not link against shared libraries
	-static, Do not link against shared libraries
	Output lots of information during link
	-verbose, Output lots of information during link
	Warn about common symbols
	--warn-common, Warn about duplicate common symbols
	Warn only once per undefined symbol
	--warn-once, Warn only once per undefined symbol
	Link little-endian object
	-EL, Link little-endian objects
	Link big-endian object
	-EB, Link big-endian objects
	Strip all symbols
	-s
	Strip debugging symbols
	-S
	Discard all local symbols
	-x
	Note: Code Generation Options  Cluster can be set while the output file is executable.
	
	
	
	4. Include Object and Library Modules




	�
	Figure  6-2-13  Linker Include Object and Library Modules
	Include Object and Library Modules
	Description
	Library or Object Modules
	The libraries that should be linked against
	
	
	
	5. Add Library Searching Path




	�
	Figure  6-2-14 Linker Add Library Searching Path
	Add Library Searching Path
	Description
	Library Searching Directories
	-L<Directory>, Add directory to library search path
	Note: Add Library Searching Path can be set while the output file is executable.
	Note: The detailed descriptions of all the options of GNU Tools for ARM cross-compiler can be found in <<Embest IDE Program Reference>>
	
	6.3 ARM Build Tools


	ARM Build Tools is a dedicative cross-compiler for ARM processor, created from ARM source code. It mainly includes C/C++ compiler, assembler, linker, standard libraries for embedded system and other tools.
	Compiling device supported in Embest IDE compatible SDT 2.51 edition at present, this edition compiles and chains tools including ARM C/C ++ compiling device Abbreviated as ARMCC , ARM collecting device ( abbreviated as ARMASM ) and ARM chaining device
	
	
	6.3.1 ARM Build Tools and Files



	Which application of the cross-compiler will be invoked by EmbestIDE to handle a source file lies on its postfix. Table 6-3-1 shows each postfix and its relevant application.
	Table 6-3-1
	Postfix
	Application of Cross-Compiler
	*.c
	C Compiler
	*.C
	C++ Compiler
	*.cpp
	C++ Compiler
	*.cc
	C++ Compiler
	*.cp
	C++ Compiler
	*.c++
	C++ Compiler
	*.cxx
	C++ Compiler
	*.s
	Assembler
	*.asm
	Assembler
	Files type of ARM tools chain shows as Table 6-3-2.
	Table 6-3-2
	Files
	Files Type
	file.stuf
	source files of ARM
	file.h/.inc/.alf
	head file
	file.o
	ELF formation target file
	file.elf
	ELF formation debugging file
	stuf stand for *.c/C, *.cpp/C++, *.s/asm, are the source files which can compiling or assembling by ARM tools chain(Note: it is permitted that there is the blank within the filename or directory.)
	
	
	6.3.2 ARM Complier options setting



	The complier attribute tab of the ARM Build Tools complier is illustrated in Fig. 6-3. There are altogether 7 categories of list (namely, setting option), namely, General, Target Specific, Warning Options, Error Handling, Debug & Optimization, Code Gen
	�
	Fig. 6-3-1  Project complier setting and category options list
	
	
	
	General




	�
	Figure 6-3-2   settings of General
	shows as Figure 6-3-1, in the Compiler dialog window, click the Category drawing menu, select the option in the Source dialog window, the definition as following:
	General  Cluster
	Description
	Compiler
	instruction format of the Target file
	ARM      supports ARM code
	Thumb  supports Thumb code
	Source
	source fiiles type
	Portable C compiler C
	-pcc, Compiles (BSD 4.2) Portable C compiler C. This dialect is based on the
	original Kernighan and Ritchie definition of C, and is the one used to build UNIX systems. The -pcc option alters the language accepted by the compiler, however the built-in ANSI C headers are still used. See also, the -zc option in Controlling code gene
	char is signed
	sizeof is signed
	an approximation of early UNIX-style C preprocessing is used.
	Strict Portable C compiler C[BSD4.2]
	-pcc –strict, is extra strict about enforcing con
	static struct T {int i; };
	Because no object is declared, the static is spurious. In a strict reading of the C++ Draft Standard, it is illegal.
	ANSI/ISO standard C
	-ansi, Compiles ANSI standard C. This is the default for armcc
	Strict ANSI/ISO standard C[ANSI X3.159]
	-ansi –strict
	Object file locations
	settings the directory to store object file(s)
	Preprocessor Definitions
	Defines symbol as a preprocessor macro, as if the following line were at
	the head of the source file: #define symbol [value] This option can be repeated.
	
	
	
	Target Specific




	�
	Figure 6-3-3  settings of Target Specific
	shows as Figure 6-3-1, in the Compiler dialog window, click the Category drawing menu, select Target Specific, the definition of compile as following:
	Target Specific Cluster
	Description
	Little Endian
	-li, instructs suitable for Little Endian ARM
	Big Endian
	-bi, instructs suitable for Big Endian ARM
	Processor
	instruction code support by processor
	Architecture
	-arch, sets the target architecture. Some processor-specific instructions produce either errors or warnings if assembled for the wrong target architecture. See also the -unsafe assembler option. Valid values for architecture
	are 3, 3m, 4, 4T, 4TxM.
	Float point processor
	-fpu, select the target FPU, where name is one of:
	none  No FPU. Use software floating point library. This option implies /softfp.
	fpa  Floating Point Accelerator. This option implies /hardfp.
	Software stack check
	-apcs /swst, specifies that the code in inputfile carries out software
	stack checking.
	Frame pointer
	-apcs /fp, specifies that the code in inputfile uses a frame pointer.
	This option is obsolete and is provided for backwards
	compatibility only.
	FP arguments passed in FP register
	(selected) specifies that the code in inputfile does not use a frame pointer. This is the default.
	ARM/Thumb interworking
	-apcs /inter, specifies that the code is suitable for ARM/Thumb interworking. This option has the same effect as specifying the INTERWORK attribute for all code areas in the source files to be assembled. Refer to the ARM Software Development Toolkit User
	
	
	
	Warning Options




	�
	Figure 6-3-4  settings of Warning Options
	shows as Figure 6-3-1, in the Compiler dialog windows, click the Category drawing menu to set the warning information of the compile.
	The compiler issues warnings to indicate potential portability problems or other hazards. The compiler options described below allow you to turn specific warnings off.
	For example, you may wish to turn warnings off if you are in the early stages of porting a program written in old-style C. The options are on by default, unless specified otherwise. See also Specifying additional checks on page 2-32 for descriptions of a
	The general form of the -W compiler option is:
	-W[ options][+][ options]
	where options are one or more characters.
	If the + character is included in the characters following the -W, the warnings corresponding to any following letters are enabled rather than suppressed.
	You can specify multiple options. For example:
	-Wad+fg
	turns off the warning messages specified by a, d, and turns on the warning message specified by f and g.
	Following description for the Warning Options shows in Figure  6-3-4:
	Warning Options  Cluster
	Description
	No Warnings
	-W, suppresses all warnings. If one or more letters follow the option, only the warnings controlled by those letters are suppressed.
	Implicit narrowing cast
	-W+n Suppresses the warning message:
	implicit narrow cast
	This warning is issued when the compiler detects the implicit narrowing of a long expression in an int or char context, or the implicit narrowing of a floating-point expression in an integer or narrower floating-point context.
	Such implicit narrowing casts are almost always a source of problems when moving code that has been developed on a fully 32-bit system (such as ARM C++) to a system in which integers occupy 16 bits and longs occupy 32 bits. This is suppressed by defaul
	Header file not guarded
	-W+g, Suppresses the warning given if an unguarded header file is #included.
	This warning is off by default. It can be enabled with -W+g. An unguarded header file is a header file not wrapped in a declaration such as:
	#ifdef foo_h
	#define foo_h
	/* body of include file */
	#endif
	Non-ANSI header
	-W+p, Suppresses the warning message:
	non-ANSI #include <…>
	The ANSI C standard requires that you use #includ
	headers only. However, it is useful to disable this warning when compiling code not conforming to this aspect of the standard. This option is suppressed by default, unless the -fussy option is specified.
	C++ incompatibility
	-W+u, For C code, suppresses warnings about future compatibility with C++ for both armcpp and tcpp. This option is off by default. It can be enabled with -W+u.
	Char/short bitfields
	-Wb, Suppresses the warning message:
	ANSI C forbids bit field type ’type’ where ’type’
	Lower precision in wider content
	-W+l, Lower precision in wider context. This warning arises in cases like:
	long x; int y, z; x = y*z
	where the multiplication yields an int result that is then widened to long. This warns in cases where the destination is long long, or where the target system defines 16-bit integers or 64-bit longs. This option is off by default. It can be enabled with
	Padding inserted in struct
	-Ws, Warns when the compiler inserts padding in a struct. This warning is off by default. It can be enabled with -W+s.
	‘=’ in condition
	-Wa, Suppresses the warning message:
	Use of the assignment operator in a condition context
	This warning is given when the compiler encounters a statement such as:
	if (a = b) {...
	where it is possible that:
	if ((a = b) != 0) {...
	was intended, or that:
	if (a == b) {...
	was intended. This warning is suppressed by default in PCC mode.
	Multiple character read as int
	-Wm
	Unused declaration
	-Wx, Disables not used warnings such as:
	Warning: function ‘foo’ declared but not used
	Note: User can input the warning switch(s) directly in  Compiler options
	
	
	
	Error Handling




	�
	Figure 6-3-5  settings of Error Handling
	shows as Figure 6-3-1, in the Compiler dialog window, click the Category drawing menu, select Error Handling, the definition of close and down lever in the compile error information compiler as following:
	The compiler issues errors to indicate that serious problems exist in the code it is attempting to compile.
	The compiler options described below allow you to:
	turn specific recoverable errors off
	downgrade specific errors to warnings.
	The general form of the -e compiler option is:
	-e[ options][+][ options]
	where options are one or more of the letters described below.
	If the + character is included in the characters following the -e, the errors corresponding to any following letters are enabled rather than suppressed.
	You can specify multiple options. For example:
	-eac
	turns off the error messages specified by a and c
	Following description for the Warning Options shows in Figure 6-3-5:
	Error Handling Cluster
	Description
	Junk at end of #end/#else/#undef
	-Ep, Suppresses the error that occurs if there are extraneous characters at the
	end of a preprocessor line. This error is suppressed by default in PCC mode.
	Implicit pointer cast
	-Ec, Suppresses all implicit cast errors, such as implicit casts of a non-zero
	int to pointer.
	Other doblous cast
	-Ef, Suppresses errors for unclean casts, such as short to pointer.
	Linkage conflict
	-El, Suppresses errors about linkage disagreements where functions are
	implicitly declared extern and later defined as static. This option
	applies to C++ only.
	Zero-length array
	-Ez, Suppresses the error that occurs if a zero-length array is used.
	Access control violation
	-E+a, This option applies to C++ only. Downgrades access control errors to
	warnings. For example:
	class A { void f() {}; }; // private member A a;
	void g() { a.f(); } // erroneous access
	Implicit “int” type
	-E+I, Downgrades constructs of the following kind from errors to warnings.
	For example:
	const i;
	Error: declaration lacks type/storage-class \(as
	This option applies to C++ only.
	
	
	
	Debug & Optimization




	�
	Figure 6-3-6    settings of Debug & Optimization
	shows as Figure 6-3-1, in the Compiler dialog window, click the Category drawing menu, select Debug * Optimization, the definition as following:
	Debug & Optimization Cluster
	Description
	dwarf 1
	-dwarf1, Use DWARF1 debug table format. This option is not recommended for C++.
	If DWARF1 debug tables are generated and a procedure call standard that does not use a frame-pointer register is used (always the case with Thumb, and the default with ARM), local variables that have been allocated to the stack cannot be displayed by t
	dwarf 2
	-dwarf2, to select DWARF2 debug tables. This is the default and is selected if -g with no dwarf option is specified. This is the default.
	asd (obsolete)
	-asd, Use ASD debug table format. This option is obsolete and is provided for
	backwards compatibility only.
	Enable debug table generation
	-g, instructs the assembler to generate debug tables. Use the following command-line options to control the behavior of -g:
	-dwarf to select DWARF1 debug tables. This option is obsolete. Use
	-dwarf2 or -dwarf1.
	-dwarf1 to select DWARF1 debug tables. This option is not
	recommended for C++.
	-dwarf2 to select DWARF2 debug tables. This is the default and is
	selected if -g with no dwarf option is specified.
	Include preprocessor symbol
	Not use
	Default balance
	If neither -Otime or -Ospace is specified, the co
	For space
	-Ospace, Optimize to reduce image size at the expense of increased execution time.
	For example, large structure copies are done by out-of-line function calls
	instead of inline code.
	For time None
	-Otime, Optimize to reduce execution time at the expense of a larger image. For
	example, compile:
	while \( expression\) body…;
	as:
	if ( expression) {
	do body…;
	while ( expression);
	}
	None(best debug view)
	-O0, Turn off all optimization, except some simple source transformations. This is the default optimization level if debug tables are generated with -g+. It gives the best debug view and the lowest level of optimization.
	Most (good debug view good code)
	-O1, Turn off the following optimizations:
	structure splitting
	range splitting
	cross-jumping
	conditional execution.
	If this option is specified and debug tables are generated with -g+ it gives a satisfactory debug view with good code density.
	All (poor debug view best code)
	-O2, Generate fully optimized code. If used with -g+, this option
	produces fully optimized code that is acceptable to the
	debugger, though the mapping of object code to source code is
	not always clear.
	This is the default optimization level if debug tables are not
	generated.
	
	
	
	Code Generation




	�
	Figure 6-3-7  settings of Code Generation
	shows as Figure 6-3-1, in the Compiler dialog window, click the Category drawing menu, select Code Generation, the definition of the compiler output target files as following:
	Code Generation Cluster
	Description
	Read-only literal string
	-fw, Allows string literals to be writable, as expected by some UNIX code, by allocating them in the program data area rather than the notionally read-only code area. This also stops the compiler reusing a multiply occurring string literal.
	Play char always signed
	-zc, Make char signed. It is normally unsigned in C++ and ANSI C modes,
	and signed in PCC mode. The sign of char is set by the last option
	specified that would normally affect it. For example, if you specify both
	the -ansic and -zc options and you want to make char signed in ANSI
	C mode, you must specify the -zc option after the -ansic option.
	One AOF area per function
	-zo, Generates one AOF area for each function. This can result in increased
	code size. Normally the compiler generates one AOF function for each C
	compilation unit, and at least one AOF function for each C++ compilation unit.
	This option enables the linker to remove unused functions when the
	-remove linker option is specified.
	Enum container always int
	-fy, Treats enumerations as signed integers. This option is off by default (no forced integers).
	Inline SWIs may overwrite the Link
	-fz, Instructs the compiler that an inline SWI may overwrite the contents of the link register. This option is usually used for modules that run in
	Supervisor mode, and that contain inline SWIs. You must use this option
	when compiling code that contains inline SWIs.
	Access word only from word aligned
	-za0/1, Specifies whether LDR may only access word-aligned addresses. Valid values are:
	-za0  LDR is not restricted to accessing word-aligned addresses. This
	is the default.
	-za1 LDR may only access word-aligned addresses.
	Max integer load
	-zi2, The compiler selects a value for the maximum number of instructions allowed to generate an integer literal inline before using LDR rx,= value on the basis of the -Otime, -Ospace, and -processor options.
	You can alter this behavior by setting Number to an integer between 1 and
	4. Lower numbers generate less code at the possible expense of speed, depending on your memory system. The effect of altering this value is small, and is usually not significant.
	Max LDM regs
	-zr16, Limits the number of register values transferred by load multiple and
	store multiple instructions generated by the compiler to Number. Valid values for Number are 3 to 16 inclusively. The default value is 16.
	You can use this option to reduce interrupt latency. Note that the inline
	assembler is not subject to the limit imposed by the -zr option.
	The Thumb compiler does not support this option.
	Top-level static object
	-zat4, Specifies the minimum byte alignment for top-level static objects, suchas global variables. Valid values for Number are:1, 2, 4, 8
	The default is 4 for the ARM compilers and 1 for the Thumb compilers.
	Min. struct
	-zas4, Specifies the minimum byte alignment for structures. Valid values for Number are: 1, 2, 4, 8
	The default is 4 for both ARM and Thumb compilers. This allows structure copying to be implemented more efficiently by copying in units of words, rather than bytes. Setting a lower value reduces the amount of padding required, at the expense of the speed
	Pointer to structs aligned to minimum struct alignment
	Specifies whether pointers to structures are assumed to be aligned on at least the minimum byte alignment boundaries, as set by the -zas option. Valid values are:
	-zap1 Pointers to structures are assumed to be aligned on at least the minimum byte alignment boundaries set by -zas. This is the default.
	-zap0  Pointers to structures are not assumed to be aligned on at least the minimum byte alignment boundaries set by -zas. Casting short[ ] to struct {short, short,...} does not cause a problem.
	
	
	
	Include Paths




	�
	Figure 6-3-8  settings of Include Paths
	shows as Figure 6-3-1, in the Compiler dialog window, click the Category drawing menu, set the search folder of the user define head files and the ANSI lib head files compiler, definition as following:
	Include Paths Cluster
	Description
	Include Directories
	-i<dir> , adds directories to the source file search path so that arguments to GET/INCLUDE directives do not need to be fully qualified.
	ANSI Header
	-j,  Adds the specified comma-separated list of directories to the end of the search path, after all directories specified by -I options. Use -j- to search the in-memory file system.
	
	
	
	Compile Options Window




	The Compiler property page, as in the figure 6-3-1, is used to configure the compile options for C/C++ compiler of ARM Build Tools cross-compiler, All the options user selected are displayed in the Compile Options edit box with the following format:
	[Opt-1] [Opt-2] …–o[Path]$\(OBJ_FILE\) … [Opt-n]
	Note: You can input or modify the options manually in the edit box, but the blank character between each option must be reserved, and the macros $(SOURCE_FILE), $(OBJ_FILE) should not be deleted or modified. $(SOURCE_FILE) means the source file to 
	Note: When you configure a project setting, you should consider that the location of the project file (*.pjf) is the current directory.
	shows as Figure 6-3-1, the Switch and meaning of the command in the Compile Options Window:
	Switch
	Description
	-O0
	Turn off all optimization, except some simple source transformations.
	-dwarf1
	Compile output file by dwarf1 format
	-g+
	The target file include debug information figure�
	-l..\common
	Use the common file folder which in the project base forward folder as the search catalog of head files
	-o .\Debug\$(OBJ_FILE)
	Compile output target file to the Debug folder
	-c
	Only compile C language program without link
	$(SOURCE_FILE)
	Compile all source files of the active project
	
	
	6.3.3 ARM Assembler options setting



	The Assembler attribute tab of the ARM Build Tools complier is illustrated in Fig. 6-3-9. There are altogether 6 categories of list (namely, setting option), namely, General, Target Specific, Call Standard Options, Debug Options, Predefines and Listing
	�
	Fig. 6-3-9  Project complier setting and category options list
	
	
	
	General




	�
	Figure 6-3-10 settings of General
	shows as Figure 6-3-9, In the Assembler dialog window, click the Category  drawing menu, choose General, the search and assembler output file folder of  the head source files, definition as following:
	General  Cluster
	Description
	Include Directories
	-i<dir> , adds directories to the source file search path so that arguments to GET/INCLUDE directives do not need to be fully qualified.
	Object files location
	settings the directory to store object file(s)
	
	
	
	Target Specific




	�
	Figure 6-3-11 settings of Target Specific
	shows as Figure 6-3-9, In the Assembler dialog window, click the Category  drawing menu, choose Target Specific, the definition  of the assembler target file, definition as following:
	Target Specific Cluster
	Description
	Little Endian
	-li, instructs suitable for Little Endian ARM
	Big Endian
	-bi, instructs suitable for Big Endian ARM
	Processor
	instruction code support by processor
	Architecture
	-arch, sets the target architecture. Some processor-specific instructions produce either errors or warnings if assembled for the wrong target architecture. See also the -unsafe assembler option. Valid values for architecture
	are 3, 3m, 4, 4T, 4TxM.
	Float point processor
	-fpu, select the target FPU, where name is one of:
	none  No FPU. Use software floating point library. This option implies /softfp.
	fpa  Floating Point Accelerator. This option implies /hardfp.
	Initial State
	instruction format of the Target file
	ARM      supports ARM code
	Thumb  supports Thumb code
	
	
	
	Call standard Options




	�
	Figure 6-3-12 settings of Call standard Options
	shows as Figure 6-3-9, In the Assembler dialog window, click the Category  drawing menu, choose Call Standard Options, the attributes of  the procedure calling in cross compile ,definition as following:
	Call Standard Options  Cluster
	Description
	Call Standard
	-apcs none/3, specifies whether you are using the ARM Procedure Call Standard or not, and may specify some attributes of code areas. User Guide for more information.
	none specifies that inputfile does not use APCS. APCS registers
	are not set up. Qualifiers are not allowed.
	3 specifies that inputfile uses APCS version 3. APCS registers are set up. This is the default.
	Predeclared Register Names
	APCS register name in the rule:
	PCS   --   PCS rule
	None --   no rule
	Software stack check
	-apcs /swst, specifies that the code in inputfile carries out software
	stack checking.
	Frame pointer
	-apcs /fp, specifies that the code in inputfile uses a frame pointer.
	This option is obsolete and is provided for backwards
	compatibility only.
	FP arguments passed in FP register
	(selected) specifies that the code in inputfile does not use a frame pointer. This is the default.
	ARM/Thumb interworking
	-apcs /inter, specifies that the code is suitable for ARM/Thumb interworking. This option has the same effect as specifying the INTERWORK attribute for all code areas in the source files to be assembled. Refer to the ARM Software Development Toolkit User
	
	
	
	Debug Options




	�
	Figure 6-3-13 settings of Debug Options
	shows as Figure 6-3-9, In the Assembler dialog window, click the Category  drawing menu, choose Debug Options, the attributes of  assemble output target files ,definition as following:
	Debug Options Cluster
	Description
	dwarf 1
	-dwarf1, Use DWARF1 debug table format. This option is not recommended for C++.
	If DWARF1 debug tables are generated and a procedure call standard that does not use a frame-pointer register is used (always the case with Thumb, and the default with ARM), local variables that have been allocated to the stack cannot be displayed by t
	dwarf 2
	-dwarf2, to select DWARF2 debug tables. This is the default and is selected if -g with no dwarf option is specified. This is the default.
	asd (obsolete)
	-asd, Use ASD debug table format. This option is obsolete and is provided for
	backwards compatibility only.
	Check register lists
	-checkreglist, instructs the assembler to check RLIST, LDM, and STM register lists to ensure that all registers are provided in increasing register number order.
	If this is not the case, a warning is given.
	No warnings
	-nowarn, turns off warning messages.
	Source line debug
	-g, instructs the assembler to generate debug tables. Use the following command-line options to control the behavior of -g:
	-dwarf to select DWARF1 debug tables. This option is obsolete. Use -dwarf2 or -dwarf1.
	-dwarf1 to select DWARF1 debug tables. This option is not recommended for C++.
	-dwarf2 to select DWARF2 debug tables. This is the default and is selected if -g with no dwarf option is specified.
	Keep symbols
	-keep, instructs the assembler to keep local labels in the symbol table of the object file, for use by the debugger.
	
	
	
	Predefines




	�
	Figure 6-3-14 settings of Predefines
	shows as Figure 6-3-9, In the Assembler dialog window, click the Category  drawing menu, choose Predefines, the attributes of  predefined macro, definition as following:
	Predefines  Cluster
	Description
	Listing of predefines
	The list of the active predefined
	Variable, Directive, Value
	-PD, instructs the assembler to pre-execute one of the SET directives. You must
	enclose directive in double quotes. See:
	SETA directive on page 5-82.
	SETL directive on page 5-83.
	SETS directive on page 5-84.
	The assembler executes a corresponding GBLL, GBLS, or GBLA directive
	to define the variable before setting its value. Arguments to SETS must be
	enclosed in escaped double quotation marks, for example:
	-pd "Version SETS \"beta-4\""
	-pd "VersionNum SETA 4"
	
	
	
	Listing Options




	�
	Figure 6-3-15 settings of symbol list file
	shows as Figure 6-3-9, In the Assembler dialog window, click the Category  drawing menu, choose Listing Options, the attributes of  the assemble output files, definition as following:
	Listing Options  Cluster
	Description
	Listing on
	-liston, list generation is on.
	Terse
	-noterse, turns the terse flag off. When this option is on, lines skipped due to conditional assembly do not appear in the listing. If the terse option is off, these lines do appear in the listing. The default is on.
	XRef
	-xref, instructs the assembler to list cross-referencing information on symbols, including where they were defined and where they were used, both inside and outside macros. The default is off.
	Page width
	-width, sets the listing page width. The default is 79 characters.
	Page length
	-length n(>0), sets the listing page length. Length zero means an unpaged listing. The default is 66 lines.
	Continuous page
	This a synonym for -length 0.
	
	
	
	Assemble Options Window




	The Assembler property page, as in the figure 6-8, is used to configure the assembling options for assembler of ARM Build Tools cross-compiler, All the options user select are displayed in the Assemble Options edit box with the following format:
	[Opt-1] [Opt-2] …–o[Path]$\(OBJ_FILE\) … [Opt-n]
	Note: You can input or modify the options manually in the edit box, but the blank character between each option must be reserved, and the macros $(SOURCE_FILE), $(OBJ_FILE) should not be deleted or modified. $(SOURCE_FILE) means the source file to 
	shows as Figure 6-3-9, Assemble Options Window indicates:
	Switch
	Description
	-dwarf 1
	-dwarf1, Use DWARF1 debug table format.
	-g
	Include debug information.
	-l..\common
	Use the common folder which in the project last layer catalog as the head files search folder.
	-o .\Debug\$(OBJ_FILE)
	Set the assemble target files output to Debug folder.
	$(SOURCE_FILE)
	Assemble all the source files in the project.
	
	
	6.3.4 ARM Linker options setting



	The linker attribute tab of the ARM Build Tools linker is illustrated in Fig.  6-3-16-16. If the various option configurations in the figure are used for the linker, all the settings of the user will be displayed in the Link Options edit box in the form
	In the Linker attribute tab, change the pull-down window of the Category, and respectively set the various category options for the ARM Build Tools linker.
	�
	Figure 6-3-16  settings of General
	
	
	
	General




	�
	Figure 6-3-17  settings of General
	shows as Figure 6-3-16, In the Linker dialog window, click the Category  drawing menu, choose General, the attributes of  ARM linker definition as following:
	General  Cluster
	Description
	Executable file
	The output file is an executable file
	Library
	The output file is a library
	Output formats
	select  linker output file formation
	-elf generates the image in ELF format. This is the default. Future versions of the ARM linker will output images in ELF file format only. You can use the fromELF utility to convert an ELF
	file to another format.
	-aof generates the consolidated object in AOF. Because AOF can only be used to represent an object, this option is interpreted by the
	linker as a request for partial linking of the input objects into a consolidated object.
	-aif generates the image in executable AIF format. Because -aif will not be supported in future releases, you are recommended to use
	-elf to produce the output file, then run the fromELF utility to convert to AIF format.
	-aif –bin generates the image in non-executable A
	recommended to use -elf to produce the output file, then run the fromELF utility to convert to AIF BIN.
	-bin generates the image in plain binary format. 
	Output file
	-o, The file name of output file (with the project file name and the stuff .elf or .lib/.alf )
	
	
	
	Information Options




	�
	Figure 6-3-18 settings of Information Options
	shows as Figure 6-3-16, In the Linker dialog window, click the Category  drawing menu, choose Information Options, the definition of  the ARM linker debug target files as following:
	Information Options Cluster
	Description
	Include debugging infomation
	-nodebug, turns off the inclusion of debug information in the output file. The image is then smaller, but you cannot debug it at source level.
	Give progress information while
	-verbose, prints messages indicating progress of the link operation.
	Search standard library
	-noscanlib, prevents the scanning of default libraries in a link step. This is the opposite of -scanlib. (See also -libpath above).
	Give information on
	-info < topic >, prints information about specified topics, where topic-list is a comma-separated list of topic keywords. A topic keyword may be one of the following:
	Totals reports the total code and data sizes in the
	image. The totals are broken down into
	separate totals for object and library files.
	Sizes gives a detailed breakdown of the code and data sizes for each input object and interworking veneers. Interwork is ignored in this release of the linker.
	Unused lists all unused areas, when used with the -remove option.
	Note that spaces are not allowed between keywords in a list. For example, you can enter:
	-info sizes,totals but not:
	-info sizes, totals
	Search path for libraries
	-libpath, specifies a path that is used to search for libraries. This path overrides the path specified by the ARMLIB environment variable.
	If you do not specify a path using -libpath, the linker searches in the path specified by ARMLIB, else searches the libraries defined in the file Lib$$Request$$library$$ variant.
	
	
	
	Listings Options




	�
	Figure 6-3-19 settings of Listings Options
	shows as Figure 6-3-16, In the Linker dialog window, click the Category  drawing menu, choose Listings Options, the setting of the listing file attributes , definition as following:
	Listings Options Cluster
	Description
	Produce a list of symbol definition
	-symb, lists each symbol used in the link step (including linker-generated
	symbols) and its value, in the named file. A filename of minus (-) names the standard output stream instead of a file.
	Produce an area map
	-map, creates an image map listing the base and size of each constituent
	area.
	Produce an area xref
	-xref, lists cross-references between input areas.
	List file
	-list, redirects the standard output stream to file. This is useful in conjunction with -map, -xref, and -symbols.
	
	
	
	Entry Point & Image Base




	�
	Figure 6-3-20 settings of Entry Point & Image Base
	shows as Figure 6-3-16, In the Linker dialog window, click the Category  drawing menu, choose Entry Point & Image Base, definition as following:
	Entry Point & Image Base Cluster
	Description
	Entry Point
	-entry, specifies the entry point of the image. The entrypoint may be given as either.
	Base of image
	-ro-base, instructs the linker to place the Read-Only section at exec_address (for example, the address of the first location in ROM), set in  Read-Only
	-rw-base, instructs the linker to place the Read-Write section at exec_address, set in  Read-Write
	
	
	
	Image Layout




	�
	Figure 6-3-21 settings of Image Layout
	shows as Figure 6-3-16, In the Linker dialog window, click the Category  drawing menu, choose Image Layout, definition of the start image and end image in the ARM linker target files as following:
	Image Layout Cluster
	Description
	Place at beginning of image
	-first, places area from object first in the RO section of the image if it is a non ZI area. If it is a ZI area, it is placed first in the ZI section. This can be used to force an area that maps low addresses to be placed first (typically the reset and 
	When using scatter loading, use +FIRST instead.
	Object file  assemble object files
	Area Name a certain Area name
	Place at end of image
	-last, places area from object last in the RW or RO section of the
	image if it is a non-ZI area. If it is a ZI area, it is placed last in the ZI section. For example, this can be used to force an area that contains a checksum to be placed last in the RW section. There must be no space between object and the following op
	When using scatter loading, use +LAST instead.
	Object file  assemble object files
	Area Name a certain Area name
	Note: Object file must include Area Name in it.
	
	
	
	Areas Options




	�
	Figure 6-3-22 settings of Areas Options
	shows as Figure 6-3-16, In the Linker dialog window, click the Category  drawing menu, choose Areas Options, definition of the label  segment in the ARM linker target files as following:
	Areas Options Cluster
	Description
	Unrearch Areas
	-remove, removes unused areas from the image. An area is considered to be used if it contains the image entry point, or if it is referred to from a used area. You must take care not to remove interrupt handlers when using -remove.
	Don’t remove  do not remove
	Remove all  remove unused areas
	Ignore case for symbol matching
	-case, uses case-sensitive symbol name matching. This is the default.
	Allow duplicate symbols
	-dupok, allows duplicate symbols so that an area can be included more than once in the image. However, if -noremove is also specified, the image must not contain multiple copies of the area.
	Refer unresolved
	-unresolved, matches each reference to an undefined symbol to the global
	definition of symbol. Note that symbol must be both defined and global, otherwise it will appear in the list of undefined symbols, and the link step will fail. This option is particularly useful during top-down development, when it may be possible to tes
	
	6.4 Project Settings & Folder Settings


	More than one source file is included in a single project at the most time, and each file maybe has its own compile options different from the others. Thus, we used to add the files that have the same compile options into a folder of the project, and set
	Show as Figure  6-2-1, GNU Tools for ARM, project led_swing has three folders --- C Source, ASM Source and Link Script. The files in folder C Source have their own compile options different from the project settings.
	There is the same settings while selecting the ARM Build Tools which SDT or ADS project folds.
	Note:For example, a project for ARM based application includes a list  source files, part of them should be compiled to generate thumb  object files, and the others should result with arm object files. Here, the source files can be divided into two parts
	�
	Figure  6-4-1 Folder Settings Dialog
	Show as Figure  6-4-1, select Always Use Custom Compile Options check box, the relevant Compiler property page will displayed, in this property page, you can set the compile options for the folder. Otherwise, the folder has the same compile settings with
	If select Always Use Custom assemble Options check box, the relevant assembler property page will displayed, in this property page, you can set the assemble options for the folder. Otherwise, the folder has the same assemble settings with the project.
	Click Reset buttons, valid when the matched check box is selected, to reshuffle the relevant settings to be as same as the project.
	
	6.5 Project Building


	Do one of the following to build project:
	1. Click on Build button on Build toolbar.
	2. Click on Build item on Project menu.
	3. Click on Rebuild All item on Project menu to rebuild the project.
	If build succeeds, a target file will be generated in the output directory specified in the Project Settings dialog.
	The output information is displayed in the following build pane. If any error occurs, the building operation will be terminated, and the error(s) will be displayed in the build pane.
	�
	Figure  6-5-1 Build Menu and Toolbar
	
	
	6.5.1 Project File Compiling and Assembling



	Do one of the following to compile or assemble file:
	1. Click on Compile button on Build toolbar.
	2. Click on Compile item on Project menu.
	3. Click on Compile item on Workspace popup menu (show as Figure  6-18).
	The compiler can handle what kind of file or assembler that is described in File type chapter.
	Menu Item
	Description
	Compile
	Before compile or assemble the active document, EmbestIDE will check several dependence relationship, if the following assumptions are true, the active document will not be handled:
	1.the object file are more up-to-the-minute than the source file;
	2.the object file are more up-to-the-minute than the all dependence files of the source file;
	3.No compiling or assembling options are modified, since the last building or rebuilding all operation.
	�
	Figure  6-5-2 Compiling Menu Item
	
	
	6.5.2 Project Build



	The menu items----Build, Rebuild All, Batch build, Clean and Stop Build----are all used to handle the active project:
	Menu Item
	Description
	Build
	Compile all the source files that need to be compiled (as the description in Files type chapter), and link the object files to generate the target file.
	Before build the active project, EmbestIDE will check several dependence relationship, if the following assumptions are true, the active project will not be handled:
	1.No source file need to be compiled;
	2.The target file are more up-to-the-minute than the dependence files of linking operation;
	3.No linking options are modified, since the last building or rebuilding all operation.
	Rebuild All
	EmbestIDE deletes the existing object files and target file first and then generates them again, suggest use this operation if there more than one project in current workspace.
	Batch Build
	Batch Build the Projects and order the building sequence in current workspace.
	Clean
	Delete all the intermediate files include the object files and target files
	Stop Build
	Stop the building or rebuilding all operation
	�
	Figure  6-5-3  Build Pop Menu in Workspace Pane
	
	
	6.5.3 Projects batch build



	The user can simultaneously carry out batch build upon several projects in current workspace. Click the menu Build > Batch Build to pop out the dialogue box as shown in fig. 6-5-4.
	�
	Fig 6-5-4  Batch Build operating window
	Introduction to options of Batch Build operating window:
	Project Name: select the project to be built by the user; the project not be selected will not be built.
	Move Up: move the highlighted project up a step.
	Move Down: move the highlighted project down a step.
	Select All: select all projects in workspace.
	Build: Build the selected projects in the workspace. The regulated rule of building is same as the definition of Build menu of the system.
	Rebuild All: Re-build the selected projects in the workspace. The regulated rule of building is same as the definition of Build menu of the system.
	Clean: completely delete the files produced in building.
	Note: for several projects, if it is set that the file folder with same name store building output result, it is suggested using the operation of Rebuild All so that it may not occur any error while building and connecting files with same name.
	
	6.6 Building Information in Output window


	At the beginning of compiling or building operation, the build pane will be set active to display the output information. In the Figure  6-21, the first line in this window prompt you which project or file is handled now.
	If all the command execute successfully, EmbestIDE will print line ---Command(s) successfully executed, otherwise, line---Error executing above command.
	If fail to complete the compiling operation, error will displayed in build pane. To locate to the corresponding source quickly for those syntax errors, simply double click on the line or press key F4 (shift + F4).
	Building output information shows as Figure  6-5-5 to Figure  6-5-8:
	�
	Figure  6-5-5 Build Pane
	�
	(a) not use list file output
	�
	(b) use list file output
	Figure  6-5-6 GNU Tools for ARM (success)
	�
	Figure  6-5-7 GNU Tools for ARM (failure)
	�
	Figure  6-5-8 ARM Build Tools (failure)
	VII. Program Debugging
	7.1 Overview


	The Embest IDE debugger combines the best features of graphical debug and command-line debug, provides multifarious debug ways.
	The most common debugging activities, such as setting breakpoints and controlling program execution, are available through convenient point-and-click interfaces. Similarly, program listings and data-inspection windows provide an immediate visual context
	Embest IDE provides much advanced features as follows:
	Supports assemble language debugging and source code debugging; supports many program windows (include source program window, disassemble program window and mix-mode window).
	Many emulational debug methods: Go, Reset, Stop, Step, Step into, Step over, Step out, Goto Cursor, Goto Source and Goto Address etc.
	Supports Unconditional Breakpoint, Conditional Breakpoint and Watchpoint.
	Register value display and modification.
	Memory content according can be desplayed with byte, half-word or word length and Hexdecimal or Ascii mode.
	Supports global and local variables display and modification, and also supports expression value compute.
	When value-change occurs in memory, variables, registers , corresponding interface content will be displayed with red color.
	Supports function stack display.
	Saves debugging environment information with each project.
	
	7.2 Debugger GUI


	Figure 7-1 illustrates the GUI elements you can use to interact with Embest IDE debugger.
	�
	Figure 7-1  Embest IDE debugger interface
	The Debug menu provides a complete list of Embest IDE GUI debugger commands, as well as their keyboard shortcuts.
	The Debug toolbar provides buttons for the most common debugger commands, as well as for opening and closing all kind of windows and program compile and link etc.
	The Debug status bar displays system status and d
	
	
	7.2.1 Debugger Toolbar, Buttons, Menu and Shortcut



	The debug toolbar has many buttons for the most common debugging commands, as well as display auxiliary debugger windows. The toolbar shown as a floating palette interface as figure 7-2.
	�
	�
	Figure7-2  debugger toolbar
	The commands in the debug menu include alternatives to the buttons in the debug toolbar, as well as additional debugger functions. Keyboard shortcuts are also available for all graphical debugger commands.
	The debugger buttons and menu commands are described in following table 7-1.
	Table 7-1  debug button and menu command
	Button
	Menu Command
	Description
	Connect/
	Disconnect
	Connect or Disconnect target system
	Download
	Download debug file to target system
	�
	Restart
	Restart the program from entry point
	�
	Go
	Run debug file on the target under debugger control
	Stop
	Stop target system
	Reset
	Reset target system
	Step into
	Step to the next line of code, in order of execution (not necessarily the next line displayed in the editor)
	Step over
	Step to the next line displayed on the screen. If there is a subroutine call on the current line, the button executes that subroutine in its entirety, then stops at the line after the subroutine call
	Step out
	Finish the current subroutine. Execution continues until the current subroutine returns to its caller.
	Run to Cursor
	Run to the line where cursor staying
	Show Next Statement
	Show next code line which will be execute
	Toggle Breakpoint
	Set or remove a task-level breakpoint on the current line of the editor window
	Enable All Breakpoints
	Enable all breakpoints
	Disable All Breakpoints
	Disable all breakpoints
	�
	Delete All Breakpoints
	Delete all breakpoints
	Breakpoint type
	There are three choices of Type of breakpoint:
	Auto: the default and recommendation breakpoint type. If choosing this breakpoint type, Embest debugger will automatically treat it as software breakpoint or hardware breakpoint;
	Hardware: change the default breakpoint type and set it as hardware breakpoint;
	Software: change the default breakpoint type and set it as software breakpoint.
	Breakpoints…
	Show the breakpoints management dialog
	Watch
	Open or close the Watch window, which displays the values of specified variables throughout the execution of the program
	Variables
	Open or close the Variables window, which displays the values of local and global variables
	Registers
	Open or close the Registers window, which displays values of the target registers
	Memory
	Open or close the Memory window, which displays target memory information
	Call Stack
	Open or close the Call Trace window, which displays stack information
	Disassembly
	Open or close the Disassembly window, which displays disassemble code
	
	7.3 Debug Setting


	Debug setting window, which is used to configure debug software, locates at the setting dialog window of project. The configurations is divided to three categories:
	General
	Download
	Memory Maps
	General debug setting page interface show as following figure7-3:
	�
	Figure7-3  General Debug Setting Page
	Symbol file column specifies the debug symbol file name and directory, debug symbol file contains debug information for debugger, usually symbol file has Elf-format or Coff-format.
	Auto Download option item is used for whether or not auto download file after the target system is resetted or debugger connects target. If be selected, debugger will finish the download operation automaticly.
	Command Script option item specifies the command script file, if selected, the debugger will auto execute the commands listed in this file after system connects target board.
	Download debug setting page interface show as following figure7-4:
	�
	Figure7-4  Download Setting Page
	Download file column specifies the executable file to be downloaded, this  file is the program which will run on a target system.
	Download Verift option item is used for whether or not auto checksum download file. If selected, debugger will auto compare the target memory file with the download file.
	Download address column specifies the start memory address of download file, the download file will ordinally be stored from this address.
	Execute until column specifies a symbol to which program will run, after it is downloaded.
	Download address option item means debugger will 
	Program entry point option item means debugger wi
	Memory maps setting page interface show as following figure7-5:
	�
	Figure7-5  Memory Maps Setting Page
	Use map file option item means the range of memory access should be specified when users debug program, and the range is descripted in the memory map file assigned in the following editbox.
	
	7.4 Start to Debug the program


	When a project is compiled and linked successfully, and you have correctly filled debug setting dialog, you can debug the project now with the following steps --- 1, connect debug emulator device; 2, download program.
	
	
	7.4.1 Connect Emulator



	Before connect emulator device, please read Appendix A JTAG Emulator Connect.
	Connect computer’s parallel port and the Embest E
	Click Debug menu, select ‘Remote Connect’ menu it
	�
	Figure7-6  Debug Menu before Connection
	If connection is failed to set up, debugger will show possible reason in debug pane of the Output Window. Please refer to Appendix A, and check whether power and cable connection are correct or not. If the connection established successfully, Debug menu
	�
	Figure7-7  Debug Menu after Remote Connect
	
	
	7.4.2 Program download



	After connection between host and target system set up, we can download executable file to target system now. If Auto Download option is set in Debug Setting Dialog, debugger will auto progress this step. If not, please click Debug menu, and select Downl
	�
	Figure 7-8  Status Bar as Program Downloading
	If download succeed, status bar displays “Downloa
	�
	Figure 7-9  Status Bar as Program Download completed
	�
	Figure 7-10  Status Bar as Program Download failed
	
	7.5 Control Program Executing


	Debuger can control target program as it execute, and disassemble binary code in the target system, and also can control target program by set breakpoint to help user faster debugging program.
	
	
	7.5.1 Program Running



	Executing program state includes run-state, stop-state, reset-state mainly. Run-state expresses program is executing according to code order; Stop-state expresses it is stopped at certain code and waiting for debugger to read needed information; Reset-st
	Click ‘Debug’ menu and select ‘Go’ menu item, or 
	�
	Figure 7-11  Program Running Interface
	Click ‘Debug’ menu and select ‘Stop’ menu item, o
	�
	Figure 7-12  Program Stop Interface
	When program stoped, if stop at certain source code, corresponding source code line will be highlight, and set a current-line flag in front of the line ( current-line flag is yellow rightward arrow), source code interface is shown as following figure7-
	�
	Fgure 7-13  Program Stop Interface with Source Code
	Click ‘Debug’ menu and select ‘Reset’ menu item, 
	�
	Figure 7-14  Program Reset Interface
	Source program also can be executed step by step. Step execute include Step Into, Step Over and Step Out mode.
	1.Step Into mode: If there is a subroutine call in the current line, Step Into takes program to the first line of that subroutine, not to the next line currently displayed on your screen.
	2.Step Over mode: Step Over steps program to the next line display on the screen.
	3.Step Out mode: program execution continues until the current subroutine completes, then the debugger regains control in the calling statement.
	An example for step execute is shown as follows figure 7-15:( suppose system run into the position as the following figure, current subroutine is OSTaskCreate)
	�
	Figure 7-15  Step Execute Start Position
	If execute Step into, because the source line have a subroutine call, so system will run into the first line of OSTaskCreateHook subroutine, source window interface will changed as the following figure 7-16:
	�
	Figure 7-16  Source Code Window Interface after Step Into
	If execute Step over, system will stop at next line displayed on the screen, source code window will changed as the figure 7-17:
	�
	Figure7-17  Source Code Window Interface after Step Over
	If execute Step out, system will continues until the current subroutine completes, and stop at calling statement, source code window will changed as the following figure 7-18:
	�
	Figure 7-18  Source Code Window Interface after Step Out
	
	
	7.5.2 Disassemble Window



	Disassemble window provides display of assemble code disassembled from binary machine code, and provides blend display between assemble code, source code, and binary code. Disassemble window can set and clear assemble breakpoint, and also can disassemble
	The buttons, shortcuts and menu commands, correlative with disassemble window, are described in following table.
	Table 7-2  Buttons, Shortcuts and Menu Commands
	Button
	Shortcut Key
	Menu command
	�
	ALT+8
	View > Debug Windows > Call Stack
	Disassemble window is shown as following figure 7-19:
	�
	Figure 7-19  Disassemble Window Interface
	Disassemble window blend source code and assemble code as the following figure 7-20:
	�
	Figure 7-20  Disassemble Window Interface
	Disassemble window blend binary code and assemble code as the following figure 7-21:
	�
	Figure 7-21  Disassemble Window Interface
	The right mouse menu of disassemble window is shown as following figure 7-22.
	�
	Figure 7-22 Disassemble Window Right Menu
	Go To Source: show the source code line which in according with current assemble line, if the source line exists, debugger will show the source code window.
	Go To Address: set start address of assemble code, and start disassembling binary code from that address.
	Show Next Statement: show assemble code which will execute next step.
	Insert Breakpoint: set a breakpoint at current assemble code line.
	Enable Breakpoint: enable the breakpoint at current assemble code line.
	Disable Breakpoint: disable the breakpoint at current assemble code line.
	Delete Breakpoint: delete the breakpoint at current assemble code line.
	Run to Cursor: run program to the line where the cursor is staying.
	Set Next Statement: set the assemble code line, where the cursor is staying, as the line which will execute by system next.
	Disassembly Mode: set disassemble mode ---- ARM or THUMB mode.
	Source Annotation: display assemble code blend with source code.
	Code Byte: display assemble code blend with binary code.
	Close: close the disassembe window.
	
	
	7.5.3 Breakpoint



	The buttons.shortcut keys and menu items which relate with breakpoint is shown as following table 7-3:
	Table7-3  Buttons.Shortcut keys and Menu items
	Button
	Shortcut
	Key
	Debug menu command
	Right mouse menu
	�
	F9
	Toggle Breakpoints
	Insert Breakpoint/
	Delete Breakpoint
	n/a
	n/a
	Enable All Breakpoints
	n/a
	n/a
	Enable Breakpoint
	n/a
	n/a
	Disable All Breakpoints
	n/a
	n/a
	Disable Breakpoint
	�
	n/a
	Delete All Breakpoints
	n/a
	n/a
	Breakpoints…
	Before setting a breakpoint, symbol file must has been fiiled in debug setting dialog. Embest IDE debugger can set and clear breakpoints in source code window.assemble window.disassemble window and code blend display window.
	Several way, hereinafter, to set breakpoint:
	1. Moving mouse to left grey margin of the source code window, mouse will change to hand shape, then click the left mouse button, a red-circle breakpoint flag will displays in the left grey margin and a yellow backgrounf bar will be shown at correspondin
	2. Set cursor to the line which need a breakpoint
	3. Set cursor to the line which need a breakpoint
	The breakpoint, which is set first time, is a enable breakpoint, shown as following figure 7-23. The flag which is around by cyan circle is a enable breakpoint flag:
	�
	Figure 7-23  a Disable Breakpoint Flag
	In a source code window, if a breakpoint is set at a invalid source line, Embest IDE will have none response.
	Breakpoint state includes enable state and disable state, program will not auto stop at the disable breakpoints. Shown as the following figure 7-24, the flag around by cyan circle is a disable breakpoint flag:
	Figure 7-24  Disable Breakpoint Flag
	When running into a enable breakpoint line, program will stop at the breakpoint, shown as the following figure 7-25:
	�
	Figure 7-25  Program Stop at Breakpoint
	Right click the flag of Breakpoint, the dialog box below will popup, through this dialog box you can disable or enable breakpoint, define the properties of breakpoint.
	User can query all breakpoint information and sta
	�
	Figure 7-26  Breakpoints List Dialog
	Double click left mouse button at a line of the breakpoint list or click Modify button, user can modify the breakpoint information in a dialog, shown as the following figure 7-27:
	�
	Figure 7-27  Breakpoint Modify Dialog
	As figure 7-27 shows, there are three choices of Type of breakpoint, please check one:
	Auto: the default type. If choosing this breakpoint type, Embest debugger will automatically treat it as software breakpoint or hardware breakpoint.
	Hardware: set current breakpoint as hardware breakpoint; hardware breakpoint can be set in RAM area or ROM area; the number of hardware breakpoints is limited by CPU hardware resources, e,g. maximum 2 hardware can be set breakpoints ARM7TDMI kernel.
	Software: set current breakpoint as software breakpoint. Software breakpoint can only be set in RAM area; so when debugging the programs in Flash, only hardware breakpoint can be chosen; theoretically, any number of software breakpoints are allowed.
	Notices:
	1. Setup of Breakpoint Type through Debug menu can change the default breakpoint type, see section 7.2.1;
	2. Setup of Breakpoint Type through breakpoint information window is valid to current breakpoint.
	Count: set times of breakpoint trigger.
	If want to set a conditional breakpoint, click ‘A
	�
	Figure 7-28  Conditional Breakpoint Modify Dialog
	Enter “5” in the column “Count” in the above figu
	
	7.6 Debug Information


	When users want to debug a program, they need much debug information to make sure the correctness of program and data, so can faster find the origin of  errors. Embest IDE has visual debug information windows to display and modify debug information when
	
	
	7.6.1 Register Window



	Register window can display and modify values of processor core registers and peripheral chip registers on the target system. Registers name and num depend on the type of target system processor, when debug different target system, the content of the reg
	The buttons, shortcut and menu commands which is correlative  with register window are described in following table7-4.
	table7-4  register window’s buttons, shortcut and
	Button
	Shortcut Key
	Menu command
	�
	ALT+5
	View > Debug Windows > Register
	Register window show as following figure 7-29:
	�
	Figure7-29  register window interface
	Click one register, the name and value of the register will display in input column which is on top of register window. User can modify the value in input column, the input column show as following figure7-30:
	�
	Figure 7-30  register value modify column
	When register value modified, register window will show the value in red color, the interface of register window show as following figure7-31:
	�
	Figure 7-31  Register Window interface
	Right click mouse on register window will show the register window menu, the register window menu show as following figure7-32, the meanings of menu item is:
	�
	Figure 7-32  Register Window Popup Menu
	Refresh: handly refresh registers value to keep consistent with target system.
	Auto Refresh: auto refresh option, if be set, register group name will in deep green, and register window will auto refresh registers value base on every operation of user to keep consistent with target system.
	Hex Format: display registers value base on hexadecimal format.
	Binary Format: display registers value base on binary mode.
	Decimal Format: display registers value base on decimal format.
	Expand …: expand all register groups\(…=All\) or
	Collapse …: collpase all register groups\(…=All\�
	Docking View: window auto arrange option, if set, window will auto keep to the side and ordinal arrange.
	Hide: hide register window.
	Note: Setting the data display format, please attention by following:
	1) right key on the register name, settings will effect on the appointed register.
	2) right key on the register group name, settings will effect on the appointed register group.
	3) right key on the blank of the register window, settings will effect on the all register group and registers.
	
	
	7.6.2 Peripheral register window



	Peripheral register window provides status display and operation of peripheral register of target processor. It can view and amend the content of peripheral register in this window. The relevant buttons, shortcut keys and menu commands of peripheral regi
	Form 7-5 Buttons, shortcut keys and menu commands in storage area window
	Button
	Shortcut key
	Menu command
	�
	ALT+5
	View > Debug Windows > Registers
	�
	Fig. 7-33 Peripheral register window
	As shown in the above figure, peripheral register window shows the peripheral register groups of current target processor with a list. The register group can be separately carried out refresh setting, data display format setting. Click � to view the list
	
	
	
	1. View peripheral register




	Click � to view the list of peripheral registers of register group in peripheral register window. The display format of peripheral register is:
	Name of register: current content or property of register
	The readable register will directly display the current content; for write-only register, it will display the character string WriteOnly in the back of register.
	When the mouse stops above register, the screen will prompt the description of register that the mouse currently points out, and the meanings of each part are:
	Name of register (register mapping address): register description (accessing property)
	As shown in Fig. 7-34:
	�
	Fig. 7-34 Value display of peripheral register
	
	
	
	2. Operation of peripheral register




	In name of register group, click � or click righ�
	�
	Fig. 7-35 Amendment and input column of register’
	The value of register will be shown in red after being amended, as shown in fig. 7-36:
	�
	Fig. 7-36 Show corresponding register in red after the value of register is amended
	While clicking right key in the window of peripheral register, it will pop out the menu as shown in fig. 7-37.
	�
	Fig. 7-37 Right key menu in window of peripheral register
	Menu
	Function
	Refresh …
	Manually refresh all value of registered groups �
	Auto Refresh
	Set automatic refresh. While setting, the window of register will automatically keep consistent with target system according to the operation of user in each step. While using this setting, the corresponding all names of register groups (All) or appoin
	Properties
	Display detailed window of peripheral register
	Hex Format
	Display register’s value according to hex format
	Binary Format
	Display register’s value according to binary form
	Decimal Format
	Display register’s value according to decimal for
	Expand …
	Expand all register groups\(…=All\) or appointe�
	Collapse …
	Collapse all register groups\(…=All\) or appoin�
	Docking View
	Whether the window is automatically arranged to the side. When selection, the window will be automatically arranged to the side.
	Hide
	Hide register window
	When the user uses the setting Auto Refresh to all register groups, the system will automatically pop out dialog box as shown in fig. 7-38. When the user executes a debugging operation, the integrated environment must read all values of peripheral regist
	�
	Fig. 7-38 Prompt when peripheral registers use the setting Auto Refresh
	Notes:
	While using refresh and automatic refresh of right key menu, it shall pay attention to the position where the mouse points:
	1) The setting that is carried out with right key above name of special register group is effective against this register group;
	2) The setting that is carried out with right key in other blank of register is effective against all register groups.
	While using data display format of right key menu, it shall pay attention to the position where the mouse points:
	1) The setting that is carried out with right key above name of special register group is effective against this register group;
	2) The setting that is carried out with right key in special register group is effective against this register group;
	3) The setting that is carried out with right key in other blank of register is effective against all register groups.
	The user shall be careful when he uses right key to operate.
	
	
	
	3. Detailed dialog box of peripheral register




	The dialog box of peripheral register provides for user the visual viewing measures of peripheral register of detailed register and flexible and convenient amendment methods to the value of peripheral register.
	The detailed dialog box provides for user the detailed information about peripheral register, including the actual meaning of content, address and bit; the user can amend the value of peripheral register through directly inputting hex value or binary val
	After selecting register, select sub-menu Properties in right key menu of mouse, or double click left key of mouse in register to pop out detailed dialog box of register as shown in fig. 7-39:
	�
	Fig. 7-39 Detailed dialog box of peripheral register
	The detailed dialog box of register includes the following:
	Heading of dialog box: display the name of register.
	Blue letterform above dialog box: display the full description of current register.
	Hex edit box(HEX Value): Display hex value of register, can also be used for amending the value of register.
	Binary edit box(Binary Value): Display binary value of register, can also be used for amending the value of register.
	Register Field:
	Select drop-down box(Select Option):Selectable value and the meaning that the register field currently selected is corresponding.
	Bit: The bit group of register.
	Name of field(Name): Short name of bit group of register.
	Binary value of field(Bin):Binary value of bit group of register.
	Description of field(Desc): Description character string of current set of bit group of register.
	Screen prompt: display short name of bit group of register, full name of bit group of register,all selectable values that the bit group of register is corresponding to, and the meaning when the value is set. The value of the bit group of register current
	If the user wants to amend the content of peripheral register, he can directly amend in hex and binary edit box, or amend the value in this field in Select Option or Edit Box after selection of register field. The drop-down select box of detailed window
	�
	Fig. 7-40 Drop-down select box of detailed window of peripheral register
	
	
	7.6.3 Memory Window



	Memory window can display and modify memory content of target system. Memory window show memory content from the address which can be input by user, content length auto match the size of memory window. Memory content can display on byte:half-word or word
	The buttons,shortcut,and menu commands which is correlative  with memory window are described in following table7-5.
	Table 7-5  memory window’s buttons, shortcut and 
	Button
	Shortcut key
	Menu command
	�
	ALT+6
	View > Debug Windows > Memory
	Memory window display base on byte length mode show as following figure 7-41:
	�
	Figure 7-41  Memory Window Base on Byte Length Mode
	User can modify original address of memory conten
	�
	Figure 7-42  Original Memory Address Input Column
	If need modify memory content, user can directly modify the content on hexadecimal digit part or ASCII char part, and new content will immediately write into corresponding memory, and show new content on red color. The interface which memory content modi
	�
	Figure 7-43  Memory Window with content change
	Right click mouse on memory window will show the memory window menu, the memory window menu show as following figure7-44, the meanings of menu item is:
	�
	Figure 7-44  Memory Window Popup Menu
	Menu
	Description
	Refresh
	handly refresh memory content to keep consistent with target system.
	Auto Refresh
	auto refresh option, if be set, memory window will auto memory content base on every operation of user to keep consistent with target system.
	Byte Format
	display memory content base on byte length mode.
	Short Hex Format
	display memory content base on half-word length mode.
	Long Hex Format
	display memory content base on word length mode.
	Memory Access Size
	Set the access size of memory
	Byte      ---- by byte
	Half Word ---- by half word
	Word     ---- by word
	Docking View
	window auto arrange option, if set, window will auto keep to the side and ordinal arrange.
	Hide
	hide memory window.
	Note: with Memory Window1for illustration above, so as Memory Window2 can be able to operate. But their options are independency.
	
	
	7.6.4 Watch Window



	Watch window can display variables value or compute expression result which user input for watch, user can add a new watch data or delete a watch data. Watch data value can display base on hexadecimal or decimal format. With every operation of user, watc
	The buttons,shortcut,and menu commands which is correlative  with watch window are described in following table7-6.
	Table7-6  watch windows’s buttons,shortcut,and me
	Button
	Shortcut key
	Menu command
	�
	ALT+3
	View > Debug Windows > Watch
	Watch window default display base on hexadecimal format, window interface show as following figure7-45:
	�
	Figure 7-45  Watch Window Base on Hex Format
	Watch window interface base on decimal format show as following figure 7-46:
	�
	Figure 7-46  Watch Window Base on Decimal Format
	User can use two kinds of ways to add new watch data:
	1.Double click the name column of the blank line in watch window,then will put a input box into the line, user can input new data in that box, carriage return or click other line, watch window will auto compute data value and show it on corresponding val
	�
	Figure 7-47  Watch Data Input Column
	2.Right click on watch window, select ‘Add’ menu 
	�
	Figure 7-48 Watch Data Input Dialog
	User can look over detail data property, select c
	�
	Figure 7-49 Watch Data Properties Dialog
	Right click mouse on watch window will show the watch window menu, the watch window menu show as following figure7-50, the meanings of menu item is:
	�
	Figure 7-50  Watch Window Popup Menu
	Add: add a new watch data.
	Delete: delete current selected watch data.
	Hexadecimal Display: data value format option, if set will show data value on hexadecimal format, if not set will show data value on decimal format.
	Docking View: window auto arrange option, if set, window will auto keep to the side and ordinal arrange.
	Hide: hide watch window.
	Properties: current selected watch data property.
	
	
	7.6.5 Variables Window



	Variables window can display global and local var
	The buttons,shortcut,and menu commands which is correlative  with variables window are described in following table 7-7.
	Table 7-7  variables windows’s buttons,shortcut a
	Button
	Shortcut key
	Menu command
	�
	ALT+4
	View > Debug Windows > Variables
	Variables window default display base on hexadecimal format, window interface show as following figure 7-51:
	�
	Figure 7-51 Variables Window Base on Hex Format
	Variables window interface base on decimal format show as following figure 7-52:
	�
	Figure 7-52 Variables Window Base on Adecimal Format
	User can look over detail variables property incl
	�
	Figure 7-53 Variables Property Dialog
	User can modify variable value. The way is double click the value column of the variable which need to be modified, and input new value in input box, interface show as following figure 7-54:
	�
	Figure 7-54 Variables modify
	When new variable value is legal, watch window wi
	�
	Figure 7-55 Variables Window after a variable value change
	Right click mouse on variables window will show the variables window menu, the variables window menu show as following figure 7-56, the meanings of menu item is:
	�
	Figure 7-56 Variables Window Popup Menu
	Hexadecimal Display: variable value format option, if set will show variable value on hexadecimal format, if not set will show variable value on decimal format.
	Docking View: window auto arrange option, if set, window will auto keep to the side and ordinal arrange.
	Hide: hide variables window.
	Properties: current selected variable property.
	
	
	7.6.6 Call Stack Window



	Call stack window can display runtime relation of functions which be calling and called. Function parameter value can display base on hexadecimal or decimal format. The last called function(current running function) display on top line of the window, a
	The buttons, shortcut and menu commands which is correlative  with call stack window are described in following table7-8.
	Table7-8  call stack window’s buttons,shortcut,an
	Button
	Shortcut key
	Menu command
	�
	ALT+7
	View > Debug Windows > Call Stack
	Call stack window interface show as following figure 7-57 (have been set all function parameter display property):
	�
	Figure7-57  Call Stack Window
	Function Parameter’s name or type or value can be
	�
	Figure 7-58 Call Stack Window with Function Parameter value
	If close all function parameter display property will only show function name and its return type. Call stack window interface show as following figure 7-59 (Close all function parameter display property)
	�
	Figure7-59 Call Stack Window without Function Parameter
	Double click one function line of call stack window, source window will show next code to be execute after the code which the function call above function, and put a blue rightward arrow on front of the source line, call stack window will also show the f
	�
	Figure 7-60 Debugger Interface as Double-Click Function Line
	Right click mouse on call stack window will show the call stack window menu, the call stack window menu show as following figure, the meanings of menu item is:
	�
	Figure 7-61  Call Stack Window Popup Menu
	Parameter Values: parameter values display option, if set will show parameter values.
	Parameter Types: parameter types display option, if set will show parameter types.
	Parameter Names: parameter names display option, if set will show parameter names.
	Hexadecimal Display: parameter values format option, if set will show parameter values on hexadecimal format, if not set will show parameter values on decimal format.
	Docking View: window auto arrange option, if set, window will auto keep to the side and ordinal arrange.
	Hide: hide call stack window.
	VIII. Customization and Options
	8.1 Introduction


	Embest IDE not only allows you to customize the appearance of the display to match your preferences, but it also allows you to add menu entries for other tools you may wish to use. The Options entry in the Tools menu displays commands that change the edi
	Table 8-1 Customization and Options Menu
	Button
	Menu
	Description
	Customize…
	Open the Customize dialog box
	Options…
	Open the Option dialog box
	
	8.2 Tools Menu Customization


	Select Tools > Customize… menu, open the Customiz�
	�
	Figure 8-1 Tools Menu Customize Dialog Box
	Menu Contents List Box lists commands you have added to the Tools menu. To add a command, click the New button above the Menu Contents list, type the text for the menu item in the box at the end of the Menu Contents list, and provide the necessary inform
	Command Edit Box displays the path and filename of the tool currently selected in the Menu Contents list. Click the button at the right of the edit box opens a dialog box where you can browse and select a file.
	Arguments Edit Box Specifies additional arguments for the tool each time you start it. You can use several macros in custom menu commands, see 8.4 Use Macros for explanations of these macros.
	Workiing directory Edit Box specifies where (in what directory) to run the custom command. You can edit the directory name in place, or click the button at the right of this field to bring up a directory browser where you can search for the right direc
	Prompt for arguments Checked Box When selected, displays a dialog box which prompts for command-line arguments each time you run the tool. You can specify additional arguments for each particular instance of the tool.
	OK Button Applies your changes to the Tools menu.
	CANCEL Button Discards your changes without modifying the Tools menu.
	
	8.3 IDE Options
	8.3.1 Editor Preferences



	Select Tools > Options… menu, then click the Edit�
	�
	Figure 8-2 Editor Page
	The following choices are available on the Editor Settings:
	Disable backspace at start of line, prevents joining of lines by using the BACKSPACE key.
	Disable drag-and-drop text editing, select this checkbox to disable drag-and-drop text editing so you can not move or copy selected text with the mouse..
	Disable show selection margin, select this checkbox to disable display a margin to the left of each line of text. This margin display information about source lines, including breakpoints, instruction points, and tag pointers.
	Disable automatic indent, select this checkbox to disable indent source code automatically.
	Reload last workspace at startup, when selected, automatically loads the workspace you last worked on.
	Tab Size, provides a place for you to specify the number of space characters that equal one tab character. The defaults is four space characters..
	The following choices are available on the Window Settings:
	Reset the positions of all docking bars & remove all recent info, all docking windows display at same position and size as you lase worked on. When select, all docking windows display with the deault position provided by the IDE and all history informati
	Set the main menu and edit popup menus without icons, when selected, disable display icons corresponding with menu items. This function suits some operation system which limited GUI resources, such as WINDOWS 98.
	
	
	8.3.2 Directory Options



	Select Tools > Options… menu, then click the Dire�
	�
	Figure 8-3 Directories Page
	Plug_in Module Directory:
	Table 8-2 is a description of the Embest IDE Plug_in Module Directories.
	Table 8-2 Directory Description
	Function
	Default Directory
	CPU Support
	$(EMBEST_IDE)\bin\cpu
	Debug Device Support
	$(EMBEST_IDE)\bin\device
	File Support
	$(EMBEST_IDE)\bin\file
	Build Tools Support
	$(EMBEST_IDE)\bin\build
	Driver
	$(EMBEST_IDE)\bin\driver
	In the Show Directories For list box, user select the type of module for the directory, then the edit box below the list box display directory for modules. You can edit the directory or click the button at the right of the edit box opens a dialog box whe
	Note:Plug_in Module Directories Use Default, general user do not change it.
	Build Executable Files Directory:
	IDE support some different compiler at the same time. You can setting Build Executable Files Directory corresponding with compiler. In the Show Directories For list box, user select compiler, then directory corresponding with compiler is displayed in the
	Note:The default directory specilized by IDE, general user do not change it.
	
	8.4 Use Macro


	You can use argument macros to specify arguments for a Tools menu command. Embest IDE provides the argument macros shown in the following table:
	Table 8-3 Macro Description
	No.
	Macro Name
	Expands to a string containing
	Examples
	1
	$(DOWNLOAD_PATHFILE)
	The directory and Name of symbol file(.elf)
	D:\test\debug\test.elf
	2
	$(EMBEST_IDE)
	Installation directory of The Embest IDE.
	D:\EmbestIDE
	3
	$(LINK_FILE)
	Name of the output file(.elf)
	test.elf
	4
	$(LINK_DIR)
	The directory of the output file(.elf)
	D:\test\debug
	5
	$(LINK_PATHFILE)
	The directory and Name of output file(.elf)
	D:\test\debug\test.elf
	6
	$(PROJECT_PATH)
	The directory of the current project.
	D:\test
	7
	$(PROJECT_NAME)
	The name of the current project.
	test
	8
	$(SYMBOL_PATHFILE)
	The directory and Name of Symbol file(.elf)
	D:\test\debug\test.elf
	To click menu Tools>Options, there is the template to use Macro.
	IX. Customer Service

	Get support on demand. Connect Customer Service f
	Web Site
	Get the latest information and docs about Embest’
	You may have noticed some trouble issues at the support forums. In the meantime, you can get help by subscribing to the following forum:
	http://www.embedinfo.com/cforum/login.asp
	E-Mail
	If you have any question, comments, feedback or suggestions as to how our products could be improved, let us know at support@embedinfo.com
	Telephone Number
	You can also call 86-755-25635626 with the extension to the Customer Service Center.
	Fax Number
	Our fax number is 86-755-25616057.
	Appendix A: Hardware Reference of Embest JTAG Emulator

	Embest JTAG Emulator contents two types of product: Standard JTAG Emulator (Embest Emulator for ARM), and Enhanced JTAG Emulator (Embest PowerICE for ARM).
	Standard Emulator (Embest Emulator for ARM) was the standard JTAG emulator for development series of ARM core CPU, early product of Embest Info&Tech Co., LTD. It works at 25Kbyte per second by transmission, and capability stabilization.
	Enhanced Emulator \(Embest PowerICE for ARM\) �
	Embest JTAG Emulator has a Parallel port connecti
	There are 3 LEDs on the panel, indicating the Emu
	Note: Cable connection must not hot swap!
	
	A.1 Embest PowerICE for ARM
	1. JTAG Interface Connections



	A standard male-to-female 25-way parallel cable connects the Embest PowerICE for ARM to the PC's parallel port. The connection to the target board is made by a 20-way (or 14 - way) female IDC header cable with all pins connected straight through (1-1,
	�
	(a) 20 Pin JTAG Connections
	�
	(b) 14 Pin JTAG Connections
	Figure A-1-1 JTAG Connection
	Note: All GND pins should be connected to 0V on the target board.
	The following table shows the JTAG pinouts.
	Signal
	I/O
	Description
	Vref
	Input
	This is the target reference voltage. It indicates that target has power and also controls the output logic levels to the target. It is normally fed from Vdd on target board.
	Vsupply
	Input
	This is the supply voltage to Embest PowerICE for ARM. It draws its supply current from this pin via a step-up voltage convertor. This is normally fed by the target Vdd. Valid power supply voltage is form 2.7V to 5.5V.
	GND
	-
	Ground.
	TDI
	Output
	Test Data In signal from Embest PowerICE for ARM to the target JTAG port. It is recommended that this pin be pulled to a defined state.
	TMS
	Output
	Test Mode signal from Embest PowerICE for ARM to the target JTAG port. This pin should be pulled up on the target so that the effect of any spurious TCKs when there is no connection is benign.
	TCK
	Output
	Test Clock signal from Embest PowerICE for ARM to the target JTAG port. It is recommended that this pin be pulled to a defined state.
	TDO
	Input
	Test Data Out from the target JTAG port to Embest PowerICE for ARM.
	nTRST
	Output
	JTAG reset. With a pull-up resistor output from Embest PowerICE for ARM to the Reset signal on the target JTAG port.
	nSRST
	Output
	Open collector output from Embest PowerICE for ARM to the target system reset. This pin should be pulled up on the target to avoid unintentional resets when there is no connection.
	RES
	-
	Reserved.
	Notes:
	1. nSRST: open collector output from Embest JTAG emulator to the target system reset signal (name: nRESET) on the target board.
	2. The signal nTRST pull-up with a 10K resistor on target JTAG port, then can disconnect it to Embest JTAG emulator.
	3. Please DON’T connect the nTRST and target syst
	
	
	2. Power Supply



	Power is supplied to the Embest PowerICE for ARM via pin 1 of the 20-way (or 14-way) IDC connector. This is normally fed by the target Vdd. Valid power supply voltage is form 2.7V to 5.5V. Power of Embest PowerICE for ARM also can be supply by external
	�
	Figure A-1-2 connection jack of the external voltage input
	Note:
	According to the way of voltage input, power supply switch of Embest PowerICE for ARM must place in the right position.
	Embest PowerICE for ARM cannot work if power voltage out of range, even be badly damaged.
	
	
	3. Target Interface Voltage Level



	The target interface voltage level of Embest PowerICE for ARM depends on the input voltage level. It is 3V/5V compatible. Normally, power supply by the external input voltage will give the output single voltage provided 3.3V.
	
	
	4. LED Indicator



	There are three LED in the panel of Embest PowerICE for ARM, labeled Power, Run and Con.
	LED Power: power indicator
	LED Run: data indicator, indicate the data transmission between host pc and target CPU.
	LED Con: connection indicator
	
	A.2 Embest Emulator for ARM
	1. JTAG Interface Connections



	A standard male-to-female 25-way parallel cable connects the Embest Emulator for ARM to the PC's parallel port. The connection to the target board is made by a 20-way (or 14 - way) female IDC header cable with all pins connected straight through (1-1,
	�
	(a) 20 Pin JTAG Connections
	�
	(b) 14 Pin JTAG Connections
	Figure A-2-1 JTAG Connection
	Note: All GND pins should be connected to 0V on the target board.
	The following table shows the JTAG pinouts.
	Signal
	I/O
	Description
	Vsupply
	Input
	This is the supply voltage to Embest Emulator for ARM. It draws its supply current from this pin via a step-up voltage convertor. This is normally fed by the target Vdd. Valid power supply voltage is form 2.7V to 5.5V.
	GND
	-
	Ground.
	TDI
	Output
	Test Data In signal from Embest Emulator for ARM to the target JTAG port. It is recommended that this pin be pulled to a defined state.
	TMS
	Output
	Test Mode signal from Embest Emulator for ARM to the target JTAG port. This pin should be pulled up on the target so that the effect of any spurious TCKs when there is no connection is benign.
	TCK
	Output
	Test Clock signal from Embest Emulator for ARM to the target JTAG port. It is recommended that this pin be pulled to a defined state.
	TDO
	Input
	Test Data Out from the target JTAG port to Embest Emulator for ARM.
	nSRST
	Output
	Open collector output from Embest Emulator for ARM to the target system reset. This pin should be pulled up on the target to avoid unintentional resets when there is no connection.
	RES
	-
	Reserved.
	
	
	2. Power Supply



	Power is supplied to the Embest Emulator for ARM via pin 1 of the 20-way (or 14-way) IDC connector. This is normally fed by the target Vdd. Valid power supply voltage is form 2.7V to 5.5V.
	Note: Emulator cannot work if power voltage out of range, even be badly damaged.
	
	
	3. Target Interface Voltage Level



	The target interface voltage level of Embest Emulator for ARM depends on the input voltage level. It is 3V/5V compatible.
	
	
	4. LED Indicator



	There are three LED in the panel of Embest Emulator for ARM, labeled Power, Run and Con.
	LED Power: power indicator
	LED Run: data indicator, indicate the data transmission between host pc and target CPU.
	LED Con: connection indicator
	
	A.3 Embest UNetICE for ARM
	1. UNetICE Hardware



	Embest UNetICE emulator includes:
	-   JTAG port for connecting target board
	-   USB and Ethernet port for connecting host
	-   RESET and UPDATER buttons
	-   External power supply socket and power switch
	-   Red, green, yellow emulator state indicator
	See details in diagram below:
	�
	(a) Frontal view of UNETICE
	�
	(b) Rear view of UNETICE
	Figure A-3-1 Embest UNetICE for ARM
	SN
	Names
	Functions
	1
	Power indicator(PWR)
	Indicate the state of power supply
	2
	State indicator(RUN)
	Indicate running state of emulator
	3
	Alarm indicator(ALARM)
	Indicate error alarm
	4
	Ethernet port
	The telecom port connected to host in Ethernet way.
	5
	USB port
	The telecom port connected to host in USB way.
	6
	External power supply socket
	For connecting external power supply
	7
	Power switch
	Switch power supply modes (USB power supply / external power supply)
	8
	RESET
	Reset emulator
	9
	JTAG port
	20-pin IDC plug port
	10
	UPDATE
	Press the button when resetting the emulator to enter updater mode
	
	
	2. Connections of emulator



	In the host-target machine cross development model, through debugging device the host is connected with target machine, and conducts download and debugging. UNetICE is a JTAG emulator, connected to JTAG port of target board via a 20-pin IDC straight-thro
	(1) USB connection type
	USB(Universal Serial Bus) is a new port technology in PC application, it provides power supply and high-speed telecom channels for peripheral equipment, bringing users a lot of convenience.
	The host can be connected to UNETIC emulator through a special USB cable. See figure below, the A-type male port in the left is connected with the A-type female port of host, the B-type male port in the right is connected with the B-type female port of t
	�
	Figure A-3-2 USB cable
	(2) Ethernet connection type
	There are two ways of Ethernet connection, one is standard Ethernet connection, use two parallel network cable (see figure below) to connect host, target board and HUB to constitute a LAN. The other way is using cross cable (one) to directly connect 
	
	
	3. Power supply



	User can choose 5V power supply through USB port by operating power switch; or alternatively choose 6/9V external power supply. In external power supply socket, the inside is positive, the outside is negative, see the figure below:
	�
	Figure A-3-3 power supply socket
	
	
	4. Indicators



	Functions of indicators: PWR: indicate the state of power supply; RUN: indicate running state of emulator; ALARM: indicate error alarm. See details in the table below:
	Names of indicators
	Description of indicator state
	PWR
	Power indicator “on”: indicate normal power suppl
	RUN
	When the emulator is powered on, it enters normal mode, the indicator is on.
	In normal mode, when the debugging software is connected to emulator, the indicator blinks;
	When the emulator is powered on, while in updater mode, the indicator is on (ALARM indicator is also on)
	In updater mode, during the process of downloading, the indicator blinks;
	ALARM
	The indicator is on, the system enters updater mode;
	The indicator turns on, then turns off in 1 second, indicating an alarm message created;
	The indicator blinks for 5 seconds, turns on then turns off in 1 second, indicating an error message created.
	
	
	5. Port signal



	(1) JTAG
	The definition of ITAG port is shown in the figure below (the RES pin can be used for future upgraded versions, please refer to relevant specification)
	�
	Figure A-3-4 Definition of 20-pin TAG port cable
	Description of pin signal
	Signal
	I/O
	Description
	GND
	—
	Power Ground.
	TDI
	Output
	The testing data input signal from Embest Emulator to JTAG port of target board, It is recommended to add a pull-up or pull-down.
	TMS
	Output
	The testing mode signal from Embest Emulator to JTAG port of target board, the signal should be pulled up in target board, to avoid possible negative impact caused by change in TCK pin before connecting.
	TCK
	Output
	The testing clock signal from Embest Emulator to JTAG port of target board, It is recommended to add a pull-up or pull-down..
	TDO
	Input
	The testing data output signal from JTAG port of target board to Embest Emulator.
	nSRST
	Output
	The system reset signal from open collector of Embest Emulator to target board. the signal should be pulled up in target board, to avoid possible unexpected reset before connecting.
	RES
	—
	Reserved.
	(2) USB
	The definition of USB port is shown in the figure below:
	�
	Figure A-3-5 Definition of USB port
	Description of pin signal:
	Signal
	Specification
	VDss
	USB port can be used to supply power to peripheral equipment, voltage range of USB port: 4.4-5.25V
	D+
	Telecom channel
	D-
	Telecom channel
	GND
	Grounding
	(3) ETH
	The definition of Ethernet port is shown in the figure below:
	�
	Figure A-3-6 Definition of Ethernet port
	Description of pin signal:
	Signal
	Specification
	TX+
	Tranceive Data+
	TX-
	Tranceive Data-
	RX+
	Receive Data+
	RX-
	Receive Data-
	n/c
	Not connected
	Appendix B: Debug Output Reference
	B.1 Info Reference


	3001
	CPU was in debug state before connected, register values may be incorrect.
	Description:
	CPU was in debug state before connecting to the host, you may get incorrect register values.
	Cause and Resolution:
	Causation:
	( IDE Disconnected with target CPU when it is in the debug state.
	Resolution:
	If you want to run the program in the target system, you should rectify the value of PC and related registers.
	If you are going to download new program to the target system, notice the values in the stack-related registers.
	3002
	target running, cannot auto download.
	Description:
	Target is in running state, auto download command cannot be executed.
	Cause and Resolution:
	Causation:
	( If auto_download check box been checked in the project setting dialog, when connect to the target, IDE will check the target status. If the target is in debug state, IDE will execute the download command, else prompt this info massage.
	Resolution:
	No Resolution.
	
	B.2 Warning Reference


	2001
	Breakpoint xx are not on valid lines, disabled.
	Description:
	The breakpoint is invalid, and then it is forbidden.
	Cause and Resolution:
	Reason of warning:
	( Breakpoint is set at invalid line. User must reset the breakpoint at a valid line.
	2002
	invalid line, set breakpoint failed.
	Description:
	Failed to set breakpoint because current line is not execute statement.
	Cause and Resolution:
	Reason of warning:
	( Current line is not execute statement. user must set a breakpoint at execute line.
	2003
	load symbol file failed.
	Description:
	Failed loading the symbol file.
	Cause and Resolution:
	Reason of warning:
	( Symbol file dos not exist.
	( Symbol file format dose not supported by IDE.
	Select correct symbol file format and recompile and then set the symbol file config at Project setting > Debug >general dialog.
	2004
	open memory map file failed.
	Description:
	Failed to open memory map file.
	Cause and Resolution:
	Reason of warning:
	( Memory map file does not exist.
	( Memory map file damaged, cannot be opened.
	2005
	read program counter failed.
	Description:
	Failed to read program counter.
	Cause and Resolution:
	Reason of warning:
	( Communication failed between Emulator and target system.
	( Target program exception.
	Reset the target CPU and/or reconnect to it.
	2006
	register doesn't exist.
	Description:
	Register doesn't exist.
	Cause and Resolution:
	Reason of warning:
	( CPU module is incompatible with debug device module, please contact the provider.
	2007
	target running, all breakpoints disabled.
	Description:
	Target is in running state, hence all of the breakpoint is forbidden.
	Cause and Resolution:
	Reason of warning:
	( Target is in running state, user must stop the target before enable all the breakpoint.
	2008
	target running, cannot toggle breakpoint.
	Description:
	Target CPU is in running state, cannot toggle breakpoint.
	Cause and Resolution:
	Reason of warning:
	( Target CPU is in running state, you need stop the CPU before toggle breakpoint.
	2009
	too many breakpoints.
	Description:
	Breakpoints’ amount out of range.
	Cause and Resolution:
	Reason of warning: (Embest JTAG emulator for arm7 V2001):
	( More than two hardware breakpoints.
	( More then one hardware breakpoint and 255 software breakpoint.
	Delete at least one breakpoint before setting a new one.
	2010
	unable to compute express or variable value.
	Description:
	Failed to compute express or variable value.
	Cause and Resolution:
	Reason of warning:
	( Variable does not exist.
	( Express invalid.
	2011
	unable to locate address.
	Description:
	Unable to locate the instruction address corresponding with current line.
	Cause and Resolution:
	Reason of warning:
	( Symbol file is not matching with execute file.
	( Symbol file format dose not supported by IDE.
	User need rebuild the project and download again.
	2012
	unable to locate source file.
	Description:
	Unable to locate the source file corresponding with current instruction.
	Cause and Resolution:
	Reason of warning:
	( Symbol file is not matching with execute file.
	( Symbol file format is not supported by IDE.
	User need rebuild the project and download again.
	2013
	workspace does not exist.
	Description:
	Workspace does not exist.
	Cause and Resolution:
	Reason of warning:
	( Current command need a workspace be opened. User must create a workspace and project.
	2014
	write program counter failed.
	Description:
	Failed to write program counter.
	Cause and Resolution:
	Reason of warning:
	( Communication failed between Emulator and target system.
	( Target program exception.
	Reset the target CPU and/or reconnect to
	it.
	
	B.3 Error Reference


	1001
	Can not find environment variable 'embest_ide'.
	Description:
	Failed to find environment variable.
	Cause and Resolution:
	Reason of error:
	\( environment variable 'embest_ide' does not se
	1002
	Can not find register group, maybe device and cpu module your selected are not compatible.
	Description:
	Failed to find register group.
	Cause and Resolution:
	Reason of error:
	( CPU module is not compatible with device module. Please connect to the provider.
	1003
	can not find download file …
	Description:
	Failed to find the specified download file.
	Cause and Resolution:
	Reason of error:
	( download file do not exist. User need rebuild the project.
	( download file path is not correct.
	1004
	can not read register.
	Description:
	Read register error.
	Cause and Resolution:
	Reason of error:
	( Communication failed between Emulator and target system.
	( Target program exception.
	Reset the target CPU and/or reconnect to it.
	1005
	can not initialize CPU module.
	Description:
	CPU module initialize failed.
	Cause and Resolution:
	Another error statement tell you the reason of error if there are two error statement at same time, otherwise:
	( CPU module is not compatible with current IDE version.
	1006
	can not initialize emulator module.
	Description:
	Failed to initialize emulator module.
	Cause and Resolution:
	Another error statement tell you the reason of error if there are two error statement at same time, otherwise:
	( Emulator module is not compatible with current IDE version.
	( IDE do not support current emulator.
	1007
	can not initialize file module.
	Description:
	Failed to initialize file module.
	Cause and Resolution:
	Another error statement tell you the reason of error if there are two error statement at same time, otherwise:
	( file module is not compatible with current IDE version.
	1008
	can not open ide.ini file or specified item does not exist.
	Description:
	De.ini cannot be opened or some error occur when open the file.
	Cause and Resolution:
	Reason of error:
	( ide.ini do not exist. This file should in the embest_ide dir.
	( ide.ini file contain errors. User needs resetup EmbestIDE.
	1009
	cursor are not positioned on valid lines.
	Description:
	The line that contains cursor is invalid to the current command.
	Cause and Resolution:
	Reason of error:
	( move the cursor to a valid line.
	1010
	disassemble non-existent memory.
	Description:
	Disassemble non-existent memory space.
	Cause and Resolution:
	Reason of error:
	( memory config file does not set up all of the memory space.
	( CPU was in debug state before connecting to the host, so, IDE may get incorrect register values. PC point to a non-existent memory. This error can be ignored.
	( User program error.
	1011
	download address illegal, please modify download address.
	Description:
	Download address illegal.
	Cause and Resolution:
	Reason of error:
	( project setting dialog specifies a download file name, but not specifies the download address. User need specifies a download address.
	( download address is not a valid value. User must modify the address to a valid value.
	1012
	emulator not found, please check power and hardware connection.
	Description:
	Failed to find the emulator.
	Cause and Resolution:
	Reason of error:
	( Emulator does not connect to the host computer.
	( Emulator do not powered on.
	( Communication port config error or damaged.
	1013
	failed to convert file from ELF format to BIN format.
	Description:
	Failed convert file format from ELF to BIN.
	Cause and Resolution:
	Reason of error:
	( file format is incorrect.
	( Current file format is not supported by IDE.
	User must rebuild the project.
	1014
	find symbol failed.
	Description:
	Failed to find specified symbol.
	Cause and Resolution:
	Reason of error:
	( No symbol file is specified.
	( Specified symbol is not found in source file.
	1015
	get target status failed.
	Description:
	Failed to get target status.
	Cause and Resolution:
	Reason of error:
	( Communication failed between Emulator and target system.
	( Target program exception.
	Reset the target CPU and/or reconnect to it.
	1016
	internal error, please contact supplier.
	Description:
	IDE internal error.
	Cause and Resolution:
	Reason of error:
	( IDE internal error. Please contact the provider.
	1017
	invalid command.
	Description:
	Invalid command.
	Cause and Resolution:
	Reason of error:
	( execute a user customized command, but this command is invalid. User need modify the custom command.
	1018
	load script file error.
	Description:
	Failed to load script file.
	Cause and Resolution:
	Reason of error:
	( Specified script file do not exist. User need check the filename and path of the specified script file.
	( script file error, check and modify it.
	1019
	out of memory.
	Description:
	Failed to allocate memory space.
	Cause and Resolution:
	Reason of error:
	( Failed to allocate system memory space. User need close other application program or restart host computer.
	( IDE internal error. Please contact the provider.
	1020
	project doesn't exist.
	Description:
	Project does not exist.
	Cause and Resolution:
	Reason of error:
	( No workspace has been opened. User need open a workspace.
	( No active project. User need create a project and activate it.
	1021
	read register group failed.
	Description:
	Failed to read register group.
	Cause and Resolution:
	Reason of error:
	( Communication failed between Emulator and target system.
	( Target program exception.
	Reset the target CPU and/or reconnect to it.
	1022
	reset target failed.
	Description:
	Failed to reset target CPU.
	Cause and Resolution:
	Reason of error:
	( hardware error or target CPU is not supported by current version of IDE. Check hardware interface.
	1023
	run target failed.
	Description:
	Failed to run target program.
	Cause and Resolution:
	Reason of error:
	( IDE get wrong Target state.
	( Communication failed between Emulator and target system.
	( Target program exception.
	Reset the target CPU and/or reconnect to it.
	1024
	step failed, maybe symbol file incorrect.
	Description:
	Source file step failed, possibly because symbol file incorrect.
	Cause and Resolution:
	Reason of error:
	( Symbol file is not matching with execute file. User need rebuild the project and download again.
	1025
	step failed.
	Description:
	Step failed.
	Cause and Resolution:
	Reason of error:
	( Communication failed between Emulator and target system.
	( Target program exception.
	Reset the target CPU and/or reconnect to it.
	1026
	stop target failed.
	Description:
	IDE cannot stop target CPU.
	Cause and Resolution:
	Reason of error:
	( Communication failed between Emulator and target system.
	( Target program exception.
	Reset the target CPU and/or reconnect to it.
	1027
	target CPU not found.
	Description:
	IDE cannot find target CPU.
	Cause and Resolution:
	Reason of error:
	( Target board JTAG interface do not match with emulator.
	( Target CPU do not work.
	( Target CPU do not support JTAG debug mode.
	( Emulator power level does not match with CPU.
	1028
	unable to load CPU module.
	Description:
	Failed to load CPU module.
	Cause and Resolution:
	Reason of error:
	( Specified emulator module does not exist. Reset the project and select corresponding emulator module.
	( CPU module path error in the IDE tools-option dialog. Select Tools > Option menu, set CPU module path to $(EMBEST_IDE)\bin\CPU.
	1029
	unable to load emulator module.
	Description:
	Failed to load emulator module.
	Cause and Resolution:
	Reason of error:
	( Specified emulator module does not exist. Reset the project and select corresponding emulator module.
	( emulator module path error in the IDE tools-option dialog. Select Tools > Option menu, set emulator module path to $(EMBEST_IDE)\bin\device.
	1030
	unable to load file module.
	Description:
	Failed to load file module.
	Cause and Resolution:
	Reason of error:
	( Specified file module does not exist. Check the sub dir \bin\file in the IDE setup dir.
	( File module path error in the IDE tools-option dialog. Select Tools > Option menu, set file module path to $(EMBEST_IDE)\bin\file.
	1031
	unable to load portcall.dll.
	Description:
	Failed to load portcall.dll.
	Cause and Resolution:
	( portcall.dll does not exist. Check the sub dir \bin\driver in the IDE setup dir.
	( Driver module path error in the IDE tools-option dialog. Select Tools > Option menu, set Driver module path to $(EMBEST_IDE)\bin\driver.
	Appendix C: Debug Command List
	C.1 General Option of Debug Command


	[…]
	Optional items. Items out of [] must be present.
	Option can be used by all command.
	-?
	Display the help information of the command.
	
	C.2 Debug Command List


	1. BKPTCLEAR – clear breakpoint
	Syntax:
	bkptclear [breakpiont ID]
	Description:
	Clear one or all the point
	Parameter:
	breakpoint ID
	An integer number which identify a certain breakpoint
	Option:
	none
	Example:
	bkptclear 1
	;Clear the breakpoint which ID is 1
	bkptclear
	;Clear all the breakpoint
	2. BKPTDATA – set an data breakpoint
	Syntax:
	bkptdata Option address
	Description:
	Set an data breakpoint at the specified memory locations
	Parameter:
	address
	Memory address
	Option:
	W
	breakpoint is vaild when write memory
	R
	breakpoint is vaild when read memory
	Example:
	bkptdata -wr 0x7f4dfc
	;Set a data breakpoint at address 0x7f4dfc, it is vaild when read or write   this address.
	3. BKPTINST – Sets an instruction breakpoint
	Syntax:
	bkptinst address
	Description:
	Sets an instruction breakpoint at the specified memory locations
	parameter:
	address
	The instruction address.
	Option:
	none
	Example:
	bkptinst 0x1024
	;Set a instruction breakpoint at address 0x1024
	4. BKPTLIST –List all breakpoints
	Syntax:
	bkptlist
	Description:
	List all installed breakpoints.
	parameter:
	none
	Option:
	none
	Example:
	bkptlist
	;List all installed breakpoints.
	5. DISASM –Disassemble the target code
	Syntax:
	disassemble addr [line_num]
	Description:
	The Disasm command disassembles the target code beginning at a specified address. The Disasm command disassembles ten lines as a default, or you can include an Optional [line_num] parameter
	parameter:
	addr
	address in target memory to begin disassembling.
	line_num
	the number of instructions you wish to disassemble. The default is 10 lines.
	Option:
	None
	Example:
	Disassemble 100 8
	;disassemble 100 lines of code located at address 8.
	6. DOWNLOAD –Download file
	Syntax:
	download [Option] filename address
	Description:
	Download file to the specified address.
	parameter:
	filename
	the specified download file.
	address
	the specified address
	Option:
	v
	download verify
	Example:
	download d:\demo\ram.bin 0x2000000
	;Download d:\demo\ram.bin to the memory address at 0x2000000
	download -v d:\demo\ram.bin 0x2000000
	;Download d:\demo\ram.bin to the memory address at 0x2000000, verify when downloading.
	7. GO – Execute target program
	Syntax:
	go
	Description:
	Execute target program from current program counter
	Parameter:
	none
	Option:
	none
	Example:
	Go
	8. HELP – display help information
	Syntax:
	help  [command name]
	Description:
	Display the help information of the specified command or brief information of all the command.
	parameter:
	Command name
	Debug command name
	Option:
	none
	Example:
	help
	Display the brief information of all the command.
	help stop
	;Display the help information of the command stop.
	9. MEMREAD –Display the content of memory
	Syntax:
	memread address length
	Description:
	Displays the contents of the memory location requested. It   accesses the memory in word format default.
	parameter:
	address
	memory location
	length
	the length of memory to be read
	Option:
	h
	specifies access the memory in half word format.
	b
	specifies access the memory in byte format.
	Example:
	memread0x1000 0x200
	;Read 0x0200 words from 0x1000
	10. MEMWRITE –Write to memory
	Syntax:
	memwrite [Option] address value
	Description:
	Write value to the memory location requested. It accesses the memory in word format default.
	parameter:
	address
	memory location
	value
	Specifies value to write.
	Option:
	-h
	Specifies access the memory in half word format.
	-b
	Specifies access the memory in byte format.
	-e
	Write memory by Big endian mode
	Example:
	Memwrite 0x1000 0x5A
	;Write 0x5a to 0x1000
	memwrite -e 0x2000000 0x22334455
	;Equal to memwrite 0x2000000 0x55443322
	11. REFRESH – refresh all windows
	Syntax:
	refresh
	Description:
	refresh all windows include register, memory, stack, watch, global/local
	parameter:
	none
	Option:
	none
	Example:
	refresh
	12. REGLIST –Display all registers
	Syntax:
	reglist
	Description:
	displays the properties of all of the processor's registers
	parameter:
	none
	Option:
	none
	Example:
	reglist
	13. REGREAD –display registers
	Syntax:
	regread [Option] register group name or register name
	Description:
	displays the contents of a particular register or registers.
	Parameter:
	register group name or register name
	Specifies register group name or register name
	Option:
	g
	read register group
	Example:
	regread pc
	;display PC register
	regread –g user
	;display all registers belong to 'User' group
	14. REGWRITE – set register
	Syntax:
	Regwrite register name value
	Description:
	Set register
	parameter:
	register name
	Specifies register name
	value
	The value to write
	Option:
	none
	Example:
	regwrite pc 0x3840
	;Set PC with the value 0x3840
	15. RESET –Reset the target
	Syntax:
	reset
	Description:
	Reset the target device
	parameter:
	none
	Option:
	none
	Example:
	reset
	16. SCRIPT –Executes command script file
	Syntax:
	script filename
	Description:
	Executes command script file
	parameter:
	filename
	Specifies script filename
	Option:
	none
	Example:
	script d:\demo\cmd.cs
	;Executes command script file d:\demo\cmd.cs
	17. STEP –Executes one statement or instruction
	Syntax:
	step
	Description:
	single-stepping begins at the address contained in the program counter.
	parameter:
	none
	Option:
	none
	Example:
	step
	;step one instruction
	18. STOP –Stop the target
	Syntax:
	stop
	Description:
	Stop the target
	parameter:
	none
	Option:
	none
	Example:
	stop
	19. SYMBOL –Load symbol file
	Syntax:
	symbol [symbol filename]
	Description:
	Load symbol file
	parameter:
	symbol filename
	Specifies symbol file
	Option:
	none
	Example:
	symbol d:\demo\ram.elf
	;Load ram.elf symbol file in d:\demo
	Appendix D: Memory Map File
	D.1 Description


	By default, Embest IDE assumes that the entire address space is mapped to standard RAM, so IDE can read or write any memory address. In some cases it will cause exceptions, in which case you can manually create a memory map file. You should create your o
	Your target has read-only memory areas or non-existent memory areas that should cause a bus fault when accessed.
	Your applications access non-standard memory locations.
	A memory map is created in a *.MAP file which Embest IDE automatically executes when connect emulator.
	
	D.2 Format


	In memory map file, each line describe one memory
	name start size read-write bus-width access-size read-times write-times burst-times
	ITEM
	TYPE
	DESCRIPTION
	Name
	string
	A single word that you can use to identify the memory region. You can use any name. To ease readability of the memory access statistics, give a descriptive name such as SRAM, DRAM, or EPROM.
	Start
	hexadecimal
	The start address of the memory region.
	Size
	hexadecimal
	The size of the memory region.
	Read-Write
	string
	The property of read-write, R for read, W for write.
	Bus-Width
	decimal
	The width of the data bus in bytes (that is, 1 for an 8-bit bus, 2 for a 16-bit bus, or 4 for a 32-bit bus).
	Access-Size
	decimal
	The width when access memory (that is, 1 for 8-bit, 2 for 16-bit, or 4 for 32-bit).
	Read-Times
	nanoseconds
	The nonsequential and sequential read times.
	Write-Times
	nanoseconds
	The nonsequential and sequential write times.
	Burst-Times
	nanoseconds
	The nonsequential and sequential burst times.
	Note: The beginning four items is necessary, and 
	
	D.3 Example


	A typical memory map looks like this:
	 
	 
	 
	 
	 
	#Name
	Start
	Size
	Attribute
	notWarry
	INTERNRAM
	10000000
	2000
	RW
	- - - - -
	COREINTERNALIO
	78000000
	8000000
	RW
	- - - - -
	STANDARDAPBIO
	B0000000
	8000000
	RW
	- - - - -
	COREAPBIO
	B8000000
	8000000
	RW
	- - - - -
	EXTERNDRAM
	C0000000
	800000
	RW
	- - - - -
	EXTERNSRAM
	C8000000
	100000
	RW
	- - - - -
	FLASH
	C8100000
	200000
	R
	- - - - -
	EXTERNSRAM
	D0000000
	80000
	RW
	- - - - -
	EXTERNIO
	F0000000
	8000000
	RW
	- - - - -
	NotWarry contents of: BusWidth AccessSize ReadWait WriteWait BurstWait.
	Appendix E: Command Script Reference
	E.1 Description


	Command Script File is a text formatting file, is used to auto execute several commands continuously, the contents of the file consist of command one by one.
	When debug software or between connect target sys
	The commands that used in debug command window al
	
	E.2 Executive


	Command Script File has two executive ways:
	1.In Command Input Window, input:
	script  <command script filename>
	2.Designate in project setting dialog. When input appointed script filename, the script file will be auto executed after EmbestIDE successful connect target system.
	�
	
	E.3 Example


	Example one: Atmel Eb40, command script file that will be auto executed after Embest IDE successful connect target system.
	; stop target CPU
	stop
	; config memory
	memwrite    0xffe00000 0x01002535
	memwrite    0xffe00004 0x02002121
	memwrite    0xffe00024 0x06
	; remap memory
	memwrite    0xffe00020 0x01
	refresh
	download -v D:\Demo\armdemo\debug\led.elf 0x2000000
	; end
	Example two: Samsung SNDS100, command script file that will be auto executed after Embest IDE successful connect target system.
	; stop target CPU
	stop
	; mask interrupt
	memwrite 0x3ff4008 0xffffffff
	; config system
	memwrite 0x3ff0000 0x90FFFF83
	; set data-bus width
	memwrite 0x3ff3010 0xfaffff0f
	; config external FLASH
	memwrite 0x3ff3014 0x60000412
	memwrite 0x3ff3018 0x40800414
	memwrite 0x3ff301C 0x40000516
	memwrite 0x3ff3020 0x20800518
	memwrite 0x3ff3024 0x4000061a
	memwrite 0x3ff3028 0x4080061c
	; config external DRAM
	memwrite 0x3ff302C 0x80030004
	memwrite 0x3ff3030 0x80010108
	memwrite 0x3ff3034 0x8001020c
	memwrite 0x3ff3038 0x80010310
	memwrite 0x3ff303C 0x608327ce
	; end
	Example Three:Samsung S3C44B0X, command script file that will be auto executed after Embest IDE successful connect target system.
	Stop;stop target CPU
	Reset;reset CPU
	Stop
	;set the system Registers
	memwrite 0x01D30000 0x00000000;WTCON
	memwrite 0x01E0000C 0x07ffffff ;INTMSK
	memwrite 0x01D8000C 0x00000fff;LOCKTIME
	memwrite 0x01C80000 0x11110101;BWSCON
	memwrite 0x01C80004 0x00000600; BANKCON0
	memwrite 0x01C80008 0x00007FFC; BANKCON1
	memwrite 0x01C8000C 0x00007FFC; BANKCON2
	memwrite 0x01C80010 0x00007FFC; BANKCON3
	memwrite 0x01C80014 0x00007FFC; BANKCON4
	memwrite 0x01C80018 0x00007FFC; BANKCON5
	memwrite 0x01C8001C 0x00018000; BANKCON6
	memwrite 0x01C80020 0x00018000; BANKCON7
	memwrite 0x01C80024 0x00860459;REFRESH
	memwrite 0x01c80028 0x00000010;BANKSIZE
	memwrite 0x01C8002C 0x00000020;MRSRB6
	memwrite 0x01C80030 0x00000020;MRSRB7
	;end
	Appendix F: Additional Software Tools

	As shown in fig. F-1, click Tools in main menu to open the tool menu of Embest IDE. The attached tools include: Elf to Bin, Disassemble all, Symbol table, Flash Programmer and SplitBin.
	�
	Fig. 1 Interface of tool menu
	
	F.1 Description
	1. Elf to Bin



	The tool Elf to Bin is the generation tool of binary file format. This tool can be used to change the debug information Elf file, built and generated by IDE, into the binary file necessary for solidification of program.
	The user selects the sub-menu Elf to Bin under Tools menu to generate the sub-directory Debug under program directory into a Bin file with same name as Elf file.
	The user can also directly use command line style to complete the above procedure. The execution program elf2bin.exe corresponding by the command line is located at sub-directory Tools under installation directory Embest IDE. The detailed usage of comman
	
	
	2. Disassemble all



	Disassemble all is a disassembly tool. The user can use this tool to change the debug information file elf into the disassembly file including source file and debug symbol.
	The user selects the sub-menu Disassemble all under Tools menu to generate the sub-directory Debug under project directory into a disassembly file with the file name as objdump.
	The user can also directly use command line style to complete the above procedure. The execution program arm-elf-objdump.exe corresponding by the command line is located at sub-directory Builds/xgcc-arm-elf/bin under installation directory Embest IDE. Th
	
	
	3. Register Editor



	�
	Embest Register Editor is aided development software provided by Embest for those software and hardware engineers to develop embedded systems. During the process of circuit design testing, drive program and bottom-layer software compilatio debugging, emb
	As an auxiliary tool for the embedded software Integrated Development Environment Embest IDE, the Embest Register Editor is able to achieve the following functions:  1) Users can view/add/modify the register, register group and process in an integrated 
	More detail about Embest Register Editor, Please 
	The install package of Embest Register Editor can download FREE here.
	
	
	4. Symbol table



	Symbol table is the generation tool of debug symbol file. The user can use this tool to generate the symbol table of corresponding project debug information. This symbol table mainly records the entrance addresses of various functional symbols.
	The user selects the sub-menu Symbol table under Tools menu to generate the sub-directory Debug under project directory into a debug symbol file with file name as objdump.
	The user can also directly use command line style to complete the above procedure. The execution program arm-elf-objdump.exe corresponding by the command line is located at sub-directory Builds/xgcc-arm-elf/bin under installation directory Embest IDE. Th
	
	
	5. Flash Programmer



	The tool Flash Programmer solidifies the binary file that the user finally generates onto the FLASH chip of circuit board of the user, support to use the programming of FLASH chip in the system developed with ARM series processors, especially suitable to
	�
	Fig. F-2 Software interface of Flash Programmer
	
	
	6. SplitBin



	Click SplitBin under Tools menu to open the SplitBin tool as shown in following fig. F-3. It can split or unite Bin file according to data width and coding manner.
	�
	F-3 Split tool interface of Bin file
	Parameter>>Bus width:Select the data width of file to be split, 16bit or 32bit;
	Parameter>>Byte order:Select coding manner of data, little Endian or big Endian;
	Parameter>>Operate:Select whether the function of tool is split or unite;
	Parameter>>Split length:Select data width of file after split;
	File>>BIN filename:Select the routine and name of Bin file to be split or united;
	Split file 1-4: If in split manner, it will automatically generate 2 or 4 split files according to data width selected in the right before and after split, for example, Bus width selects 16bit, Split length selects 8bit, and it will generate two files Sp
	Appendix G: Common questions
	
	Question 1 About gccmain



	Question:
	It appears the following error prompt while connection, why?
	.\\debug\\main.o: In function ‘main’:
	.\\debug\\main.o \(.text+0xc\): undefined re�
	Answer:
	While gcc builder is building and connecting source file, it will automatically connect main function to gccmain function internally provided in gcc, that is, if the programmer defines main function, the execution order of program is:
	main()
	{
	gccmain() ;
	Code compiled by customer
	}
	This function is provided in the base libgcc.a, and it must connect libg.a while connecting this base.
	There are three measures for solving connection errors:
	1) Settings in Embest IDE
	Select the menu Project> Settings, open project configuration box, select the linker page and select the option add library searching path in drop-down box, increase the path:
	..\..\..\build\xgcc-arm-elf\arm-elf\lib\arm-inter
	..\..\..\build\xgcc-arm-elf\lib\gcc-lib\arm-elf\3.0.2\arm-inter
	The above path is the path relative to Embest IDE routine, and the user can set absolute routine:
	Select the linker page, select the drop-down option Include Object And Library Modules and add the base:
	-lc
	-lgcc
	When this measure is linked, the program of user will be larger.
	2) Write a gccmain assembly function or C language function by yourself
	Prepare assembly function
	.global     __gccmain
	__gccmain:
	mov    pc, lr
	Prepare C language function
	void __gccmain()
	{
	}
	Re-link the program building.
	3) Use __main or directly use __gccmain() as own function entrance.
	
	
	Question 2 Connection errors of emulator



	Question:
	In general, what reasons will cause the connection emulator to appear the following error messages?
	“target cpu not found”, “stop target failed” or “
	Answer:
	The connection errors of emulator are generally caused due to following reasons:
	1) The connection of JTAG interface circuit is not in accordance with the regulations of IEEE1149.1-1990, for example TDI, TCK, TMS and other signals are not connected pull-up resistance; nSRST shall be connected system reset instead of reset of JTAG. I
	2) Some chips of processors have appointed pins to control the operation of processor, they should be connected according to appointed style or otherwise it may cause CPU not to stop properly, for example nwait signal of ARM processors. The user should 
	3) The emulator cannot obtain power from target board, for example the power of target board can only meet the requirements of target board, or JTAG interface has not leading power;
	4) JTAG interface switch in the side of emulator has incorrect setting. The user shall correctly set the switch according to that the JTAG port in target board has 14 pins or 20 pins;
	5) Project setting in IDE environment is not correct, the drop-down box of Project>Settings>Remote>Remote device shall select jtagarm7 or jtagarm9 according to CPU of target board;
	6) Some computers need to amend parallel interface setting mode.
	For user, generally check according to the following steps:
	1) Power. Include voltage and current of power source. Embest Emulator is compatible to 3.3V and 5V.  Emulator itself needs the current about several decades of mA.
	2) Reset signal. Observe whether reset signal is proper or not, whether it is pulled down.
	3) Clock check. Check whether crystal oscillator work normally, whether the clock input and output of processor is normal.
	4) NWAIT Signal. Pull up.
	5) nTRI Signal. Pull up.
	6) For some processors, there are some modes or control pin (for example JTAGSEL signal) that are required to connect appointed level (pull-up or pull-down) in order to support JTAG debugging interface. Please read the datasheet carefully.
	
	
	Question 3 To link the useful libraries



	Question:
	How to link the useful libraries provided by GNU, and what modes do they support?
	Answer:
	-lm means that linker will connect standard math�
	-lc means that linker will connect standard C fu�
	-lg means that linker will connect the support base of standard function base libg.a.
	-lgcc means that linker will connect the support�
	-lstdc++ means that linker will connect the support base of C++ libstdc++.a.
	While connection, the arrangement order of these 
	While the cross compiler xgcc-elf-gcc-3.0.2 insta
	ARM Little-Endian
	ARM Little-Endian Interwork
	ARM Big-Endian
	ARM Big-Endian Interwork
	Thumb Little-Endian
	Thumb Little-Endian Interwork
	Thumb Big-Endian
	Thumb Big-Endian Interwork
	The different versions of cross compiler tool maybe provide some of above libraries. For a real cross compiler package usually store the different type of libraries into different directories.
	The lists in which Newlib C exists is correspond�
	$(BuildTools_Install)\build\xgcc-arm-elf-xxx\arm-elf
	\lib
	ARM Little Endian
	\lib\arm-inter
	ARM Little Endian Interworking
	\lib\arm-big
	ARM Big Endian
	\lib\arm-inter-big
	ARM Big Endian Interworking
	\lib\thumb
	Thumb Little Endian
	\lib\thumb-inter
	Thumb Little Endian Interworking
	\lib\thumb-big
	Thumb Big Endian
	\lib\thumb-inter-big
	Thumb Big Endian Interworking
	The lists in which libgcc exists:
	$(BuildTools_Install)\build\xgcc-arm-elf-xxx\lib\gcc-lib\arm-elf
	\x.x.x
	ARM Little Endian
	\x.x.x\arm-inter
	ARM Little Endian Interworking
	\x.x.x\arm-big
	ARM Big Endian
	\x.x.x\arm-inter-big
	ARM Big Endian Interworking
	\x.x.x\thumb
	Thumb Little Endian
	\x.x.x\thumb-inter
	Thumb Little Endian Interworking
	\x.x.x\thumb-big
	Thumb Big Endian
	\x.x.x\thumb-inter-big
	Thumb Big Endian Interworking
	Notes:x.x.x – the cross compiler tool version, su
	$\(BuildTools_Install\) – the cross compiler i�
	
	
	Question 4 How to download the program onto Flash ROM



	Question:
	How to download the program completed debugging in RAM onto Flash ROM?
	Answer:
	The user shall pay attention to or change the following two positions when downloading the program completed debugging in RAM on target board:
	1.Startup program: in RAM, through startup program of debugging, it is not necessary to copy the data section from read-only area to readable and writable area. The initialization of hardware can be completed through IDE commandscript or the program down
	2.Linker script: the program passing through debugging in RAM use such linker script that takes RAM area as program code section address, and data section generally directly follow the code section, while the linker script used in Flash ROM uses ROM area
	There are two examples on how to amend the program completed debugging in RAM then it can be downloaded onto target board.
	Example 1: the program Led_blink_EB40, which lights LED in AT91EB40 evaluation board
	Click Project menu>Settings, open project configu
	Amend linker script file, and the linker script files before and after amendment are shown in following figure:
	�
	In RAM                         In Flash
	Fig. G-1 The linker scripts that the program uses in RAM and Flash and their difference
	Comparing with original script file, the code section and read-only data section are put in the position starting from 0x1000000 address, that is, ROM storage area of the system; and present the starting address (RAM address) of readable and writable d
	When the above operation is completed, re-build the project, then click IDE menu Tools>Elf to Bin, and change elf file into binary format file (*.bin). Finally use Embest Flash Programmer to download bin file onto Flash ROM of target board.
	Example 2: LedInt that NET-START evaluation board lights LED
	Set ROM = 1 in pre-definition options of assemble
	In link file of linker, select flash.ld. This link file and startup file mutually complete the transport of data section initially downloaded onto Flash. It has the following difference with the script file debugged in RAM: the address of current 0X0 is
	�
	In RAM                         In Flash
	Fig. G-2  The linker scripts that the program uses in RAM and Flash and their difference
	When the above operation is completed, re-build the project, then click IDE menu Tools>Elf to Bin, change elf file into binary format file (*.bin). Finally use Embest Flash Programmer to download bin file onto Flash ROM of target board.
	
	
	Question 5 Command script, linker script and memory map file



	Question:
	What is command script, linker script and memory map script?
	Answer:
	Command script:
	While integrating environment and target connection, in the course of debugging software and after resetting target board, sometimes the user needs to integrate environment to automatically finish some special functions such as resetting target board, cl
	The following are the examples of command script:
	; stop target CPU
	stop
	; configurations of the special register
	memwrite    0xffe00000 0x01002535
	memwrite    0xffe00004 0x02002121
	memwrite    0xffe00024 0x06
	; configuration for Mapping Address
	memwrite    0xffe00020 0x01
	refresh
	download -v D:\Demo\armdemo\debug\led.elf 0x2000000
	;end
	Linker script:
	In the Embed system development, it needs to use linker position file. This file describes the relevant information of code linker position, including code section, data section, address section, and the linker shall use the code of this file to the whol
	The following is an example of Linker script:
	SECTIONS
	{
	. = 0x02000000;
	.text : { *(.text) }
	Image_RO_Limit = .;
	Image_RW_Base = .;
	.data : { *(.data) }
	.rodata : { *(.rodata) }
	Image_ZI_Base = .;
	.bss : { *(.bss) }
	Image_ZI_Limit = .;
	__bss_start__ = .;
	__bss_end__ = .;
	end = .;
	.debug_info      0 : { *(.debug_info)  }
	.debug_line  0 : { *(.debug_line)  }
	.debug_abbrev   0 : { *(.debug_abbrev)}
	.debug_frame    0 : { *(.debug_frame) }
	}
	Memory linker map file:
	In the course of debugging software, accessing illegal memory will occur abnormal in some processors and target boards. If the abnormality is not handled, it may cause the debugging course of software incapable to continue. In order to prevent the above
	The following is an example of map file:
	ONCHIPRAM 0 8000 RW - - - - -
	EXTERNDRAM 100000 128000 RW - - - - -
	FLASH 1000000 128000 R - - - - -
	SRAM 2000000 512000 RW - - - - -
	PERIREG FFC00000 4000000 R - - - - -
	
	
	Question 6 Definition of linker script



	Question:
	Please explain the meaning of linker scripts file?
	Answer:
	The linker script file is used in flash solidification:
	SECTIONS
	{
	. = 0x000000;Assign current address as 0
	.text : { *(.text) };Code section, put program code at this place from 0 identification code
	.rodata : { *(.rodata) }; Read-only data section, static global variable and other immovable values in program are put in this section
	Image_RO_Limit = .;Length of read-only area, the
	. = 0x0400000;Assign current address as 0x400000
	Image_RW_Base = .;Read-write the frame of the area, start the symbols used in program
	.data : { *(.data) };Data section, the global variables initialized in the program are put in this section
	Image_ZI_Base = .;Frame of resetting area, the symbol used in startup program
	.bss : { *(.bss) };Include global accessible data not initialized, for example not initialized global variables
	Image_ZI_Limit = .;Length of resetting area, the symbol used in startup program
	end = .;Ending address
	.debug_info0 : { *(.debug_info)  };Output section of debugging information
	.debug_line0 : { *(.debug_line)  }
	.debug_abbrev0 : { *(.debug_abbrev)}
	.debug_frame0 : { *(.debug_frame) }
	}
	Linker scripts file used in debugging RAM:
	SECTIONS
	{
	. = 0x000000;Assign current address as 0
	.text : { *(.text) };Code section, put program code at this place from 0 identification code
	Image_RO_Limit = .;Length of read-only area, the
	Image_RW_Base = .;Read-write the frame of the area, the symbol used in startup program
	.rodata : { *(.rodata) }; Read-only data section, the static global variables and other immovable values in the program are put in this section
	.data : { *(.data) };Data section, the global variables initialized in the program are put in this section
	Image_ZI_Base = .;Frame of resetting area, the symbol used in startup program
	.bss : { *(.bss) };Include global accessible data not initialized, for example not initialized global variables
	Image_ZI_Limit = .;Length of resetting area, start the symbols used in program
	end = .;ending address
	.debug_info0 : { *(.debug_info)  };Output section of debugging information
	.debug_line0 : { *(.debug_line)  }
	.debug_abbrev0 : { *(.debug_abbrev)}
	.debug_frame0 : { *(.debug_frame) }
	}
	For the section code as follows:
	int A1;
	int A2 =5;
	const int A3 = 10;
	void main()
	{
	int A4;
	register int A5;
	A4 = A3;
	}
	The variable A1, as not initialized variable, will be stored in the section .bss;
	The variable A2, as initialized variable, will be stored in the section .data;
	The constant A3 is stored in read-only data section .rodata;
	The code that main function is corresponding is stored in the section .text;
	The local variable A4 is stored in the corresponding function stack of main function when the program executes main function;
	The register variable A5 is directly stored in a register of ARM;
	
	
	Question 7 How to migrate SDT assemble program



	Question:
	How to migrate the assembly code in the environment of ARM SDT as assembly code supported by free software gnu assembler integrated by Embest IDE?
	Answer:
	Migration description on SDT assembly program:
	The note line replaces “;” with “#”
	Substitution of pseudo instruction characters
	pseudo instructions characters in SDT
	pseudo instructions characters in Embest IDE
	INCLUDE
	.include
	TCLK2  EQU   PB25
	.equ  ECLK2 , PB25
	EXPORT
	.global
	IMPORT
	.extern
	DCD
	.long
	IF:DEF:
	.ifdef
	ELSE
	.else
	ENDIF
	.endif
	:OR:
	|
	:SHL
	<<
	RN
	.req
	GBLA
	.global
	BUSWIDTH SETA 16
	.equ BUSWIDTH, 16
	MACRO
	.macro
	MEND
	.endm
	END
	.end
	AREA Word,CODE,READONLY
	.text
	AREA Block, DATA, READWRITE
	.data
	CODE32
	.arm
	CODE16
	.thumb
	LTORG
	.ltorg
	%
	.fill
	Entry
	Entry:
	Substitution of operand and operator
	ldr pc, [pc, #&18]
	ldr pc, [pc, #+0x18]
	ldr pc, [pc, #-&18]
	ldr pc, [pc, #-0x18]
	“&” refers to hex
	
	
	Question 8 Register and stack of ARM processors



	Question:
	Please explain the register and stack of ARM processors?
	Answer:
	The corresponding form of registers in ARM7:
	R0 ---> R0
	.. ..
	R9 ---> R9
	R10 ---> SL
	R11 ---> FPFrame pointer points stack bottom
	R12 ---> IP
	R13 ---> SPThe register of stack pointer points to stack top
	R14 ---> LR
	R15 ---> PC
	Legend of stack:
	ARM7 under gcc 2.95/2.97 building uses r11 register as function stack bottom pointer, r13 as current function stack top pointer.
	A typical function stack information structure is as follows:
	Memory high address
	Parameters of current function
	Last function stack top (r12)
	Function
	Stack
	PC value (of no use) after entering function
	Return address of current function
	Stack bottom (r11)
	Last function r13 register value
	Last function r11 register value
	Local variable of current function
	Parameters transferred to next function
	Stack top (r13)
	Memory low address
	Note: directly take r11 value to take PC value, other than function return address
	
	
	Question 9 Building error caused by GCC bug



	Question:
	Free software gcc builder integrated by Embest IDE includes a software bug. This bug causes the target code produced from building to bring collapse of stack in some situations while using __attribute__ ((interrupt ("IRQ"))) style statement C langu
	How to program to ensure the normal operation of common interruption?
	Answer:
	User can ensure normal operation of common interruption through the method of assembly programming.
	.EXTERN  irq_func
	.GLOBAL  irq_entry
	irq_entry:
	stmdbsp!, {r0-r11, ip, lr}/* Save r0-r11, ip, lr */
	ldrr0, = irq_func
	movlr, pc
	bxr0   /* Use C interruption program*/
	ldmiasp!, {r0-r11, ip, lr}/* Resume r0, ip, lr */
	subspc, r14, #4   /* Interruption and return */
	irq_entry is the entry of common interruption function. It completes the pushing in stack with relevant register in the common interruption mode, calls irq_func function, pops out register, interrupts return function.
	irq_func is to use C language or assembly language to prepare interruption treatment function. This function is not necessary to use __attribute__ ((interrupt ("IRQ"))) style statement.
	In addition, this bug of gcc software will not affect other interruption vector mode, and the treatment function of other vector modes can still use __attribute__ ((interrupt ("FIQ"))),  __attribute__ ((interrupt ("SWI"))) style statement.
	
	
	Question 10 To debug the project of ARM SDT



	Question:
	How to use Embest IDE to debug the project in ARM SDT environment?
	Answer:
	Embest IDE can debug the file to be produced with ARM SDT project building linker.
	The user needs to make the following settings in the building environment of SDT:
	In ARM SDT main menu click Tools>Configure,
	1.Take <cc>=armcc menu, select the page Language and Debug, set Debug Table Format as dwarf 1 option, and set Optimization Level as None option;
	2.Take <asm>=armasm menu, select the page Options, and set Debug Table Format as dwarf 1 option;
	3.Select armlink menu, select the page Output and set Output Formats as Arm Elf Image format option;
	The above setting can aim at single project and be realized through selecting Project > Tool Configuration menu. The settings are same as the above.
	The user can use the above settings, under ARM SDT environment, to build and produce the corresponding output file of this project prj.elf.
	In Embest IDE environment, the user selects Project > Settings menu, sets this output file as symbol file and download file for debugging in the Debug page of dialog box, and sets the local directory of source file in directory page simultaneously, then
	
	
	FAQ 11  FAQ for ARM compiler



	Question A
	Which versions of ARM compiler does Embest IDE support?
	Answer
	Embest IDE supports the compilers of ARM SDT V2.50 and ARM SDT V2.51, but does not support the compilers over ARM ADS V1.2 version.
	ARM ADS V1.2 uses the same compiler version as ARM SDT V2.51, but it screens some output formats of debugging information.
	Question B
	Although sometimes there shows “Command\(s\) s�
	Answer
	Because the user’s ARM compiler hasn’t acquired a
	If armcc command is executed in DOS command line, it would show the prompt similar to the following:
	This licence has not yet been installed.
	Question C
	Compiling whilst there shows “...Fail to executin
	Answer
	1, It hasn’t yet been installed or the installati
	2, ARM compiler or relevant files are damaged, so execution fails.
	Question D
	When linking, it shows the prompt like: “Warning:
	Answer
	The prompt indicates failure to link to library file C.
	User should refer to 5.4.3, open the configurations behind SDT or ADS projects and then install the search path of library file; provided user has installed ARMLIB in the environment variable, they will have a same result as installing the search path of

